Impossible d'ajouter des pièce-jointes

Ce forum est consacré aux versions stables de Firefox OS

Modérateurs : Monique, genma

Répondre
dud
Arias
Messages : 7
Enregistré le : 12 janv. 2015, 14:55

Impossible d'ajouter des pièce-jointes

Message par dud » 20 juil. 2015, 22:16

Bonjour

je viens de compiler Firefox OS en version 2.2 et je l'ai installé sur mon ZTE Open C. Malheureusement je constate qu'il m'est impossible de partager des images :
  • l'icône visible dans l'application Messages ne produit aucun effet
  • une photo sélectionnée dans l'application Galerie affiche le message suivant :
    Impossible de partager ce type d'image.
Je n'ai pas vu beaucoup de gens signaler ce bug, hormis celui-ci resté sans réponse.

Est-ce quelqu'un a déjà constaté ce problème ? Existe-t-il un moyen de faire fonctionner cette fonctionalité en 2.2 ?

dud

ren0
Lézard à collerette
Messages : 407
Enregistré le : 08 févr. 2015, 12:56

Re: Impossible d'ajouter des pièce-jointes

Message par ren0 » 20 juil. 2015, 23:51

Bonjour dud ,
Le message d'erreur indique : impossible de partager "ce type d'image".
Vos images sont en quel(s) format(s) ?
Quelles en sont les résolutions, la taille des fichiers ?
Debian GNU/Linux && Firefox OS (B2G 2.5 prerelease / Flame + Builds communautaires 2.2 / Open_C EU)

dud
Arias
Messages : 7
Enregistré le : 12 janv. 2015, 14:55

Re: Impossible d'ajouter des pièce-jointes

Message par dud » 21 juil. 2015, 08:22

Bonjour ren0

il s'agit de photos prises avec l'appareil photo de l'Open C, c'est-à-dire des JPEG 1536x2048 de taille inférieure à 500 Ko. En version 2.1 cela fonctionnait correctement.

ren0
Lézard à collerette
Messages : 407
Enregistré le : 08 févr. 2015, 12:56

Re: Impossible d'ajouter des pièce-jointes

Message par ren0 » 21 juil. 2015, 08:37

Donc aucun souci au niveau du format d'image.
Je n'ai rencontré aucune difficulté particulière concernant le partage.
À voir s'il n'y aurait pas eu une complication au niveau de la compilation...

Pour voir si le problème est lié à l'application Galerie (ou pas) : installez une application comme "Mes fichiers" (https://marketplace.firefox.com/app/file-manager/), et voyez si elle vous permet le partage.
dud a écrit :...
il s'agit de photos prises avec l'appareil photo de l'Open C, c'est-à-dire des JPEG 1536x2048 de taille inférieure à 500 Ko.
Debian GNU/Linux && Firefox OS (B2G 2.5 prerelease / Flame + Builds communautaires 2.2 / Open_C EU)

dud
Arias
Messages : 7
Enregistré le : 12 janv. 2015, 14:55

Re: Impossible d'ajouter des pièce-jointes

Message par dud » 21 juil. 2015, 10:40

ren0 a écrit : Pour voir si le problème est lié à l'application Galerie (ou pas) : installez une application comme "Mes fichiers" (https://marketplace.firefox.com/app/file-manager/), et voyez si elle vous permet le partage.
Je n'arrive pas à naviguer dans l'arborescence des fichiers, l'application ne réagit pas lorsque je sélectionne un dossier.

Par ailleurs j'ai aussi été affecté par ce problème. Comme indiqué je l'ai corrigé en déplaçant le fichier /etc/volume.cfg. Cela a peut être un lien avec le problème décrit dans ce post.

Je vais retester une nouvelle compilation.

ren0
Lézard à collerette
Messages : 407
Enregistré le : 08 févr. 2015, 12:56

Re: Impossible d'ajouter des pièce-jointes

Message par ren0 » 21 juil. 2015, 11:39

Peut-être regarder du côté des droits d'accès aux fichiers... (http://lea-linux.org/documentations/Adm ... ermissions)
[ commande : "adb shell ls -al /storage/sdcard" -- résultat pour le répertoire DCIM : "drwxrwxr-x root sdcard_rw" ]
Debian GNU/Linux && Firefox OS (B2G 2.5 prerelease / Flame + Builds communautaires 2.2 / Open_C EU)

dud
Arias
Messages : 7
Enregistré le : 12 janv. 2015, 14:55

Re: Impossible d'ajouter des pièce-jointes

Message par dud » 21 juil. 2015, 12:28

Les droits sont bons (ils sont même à 777 ! ).
Je retente une compilation et je vous tiens informé.

dud
Arias
Messages : 7
Enregistré le : 12 janv. 2015, 14:55

Re: Impossible d'ajouter des pièce-jointes

Message par dud » 21 juil. 2015, 14:11

Je viens de recompiler FFOS 2.2 et je constate toujours le même problème. J'ai remis le fichier volume.cfg comme à l'origine, en vain.
Dans le processus de compilation il y a pas mal d'erreurs, mais je n'arrive pas à savoir si elles sont pertinentes ou non. Voici mon log de compilation.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités