[Résolu]Pb : Fichier SWF ouvert par défaut avec le compose

Vous cherchez une solution complète et libre ? La curiosité vous presse de poser des questions sur SeaMonkey (successeur de la suite Mozilla), et vous ne parvenez pas à trouver de réponses ? Venez ici, et trouvez votre bonheur.

Modérateur : Mori

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

[Résolu]Pb : Fichier SWF ouvert par défaut avec le compose

Message par nitrofoliz » 12 sept. 2004, 14:43

Salut tout le monde, donc en fait, je demande que les fichier flash SWF soit ouvert avec Mozilla.

Donc je vais dans Options des dossiers dans le panneau de configuration, lje sélectionne swf et je demande à l'ouvrir avec Mozilla par défaut.

Or, quand je clique sur un fichier Swf, ça me l'ouvre avec le Composeur, et j'ai le message " Ce type de page ne peut être édité"; et ça ne veut pas me l'ouvrir avec le navigateur Mozilla.

Mais si je glisse mon fichier Swf dans le navigateur, c'est bon ça marche, mais bon, j'aimerais bien cliquer dessus et que ça me l'ouvre avce le navigateur et pas le composeur.

Pour infos, j'ai Mozilla 1.7.2 + Win Xp Pro Sp1.

Merci pour votre aide.
Modifié en dernier par nitrofoliz le 25 sept. 2004, 16:34, modifié 1 fois.
Quand tu polishe ta caisse, elle brille !!!

Avatar du membre
Mori
Animal mythique
Messages : 13306
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 12 sept. 2004, 16:02

edit > preferences > navigateur > aide application (3° niveau) > spécifier comment manipuler chaque type de fichier > effacer "application/swf"
fermer mozilla le rouvrir
à la prochaine manip, il t'ouvrira une fenêtre de ce que tu veux faire...

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 12 sept. 2004, 18:27

J'ai rien avec swf ou shockwave dans Applications/Type de fichiers.

Pour infos aussi, mon fichier SWF est sur mon disque dur, doncquand je double clique dessus, j'aimerais qu'il me l'ouvre dans le navigateur.

Donc bon, j'en suis toujours au même point, il me l'ouvre toujours avec le composeur. :cry:

Mais merci quand même pour ta réponse. Quelqu'un d'autre aurait une soluce ?
Quand tu polishe ta caisse, elle brille !!!

Avatar du membre
Mori
Animal mythique
Messages : 13306
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 12 sept. 2004, 18:31

Pour infos aussi, mon fichier SWF est sur mon disque dur, doncquand je double clique dessus, j'aimerais qu'il me l'ouvre dans le navigateur.
mets le dans ff...
about:plugins tapé dans la barre de saisie
as-tu Macromedia Flash movie swf > enabled > yes
dans Shockwave Flash ?
passe par http://plugindoc.mozdev.org/fr-FR/windows.html
pour qu'il te l'installe proprement dans le moz 1.7.x.
Linux Lubuntu 20.04 (x86_64) Focal Fossa

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 12 sept. 2004, 23:36

Shockwave Flash

Nom de fichier : NPSWF32.dll
Shockwave Flash 7.0 r19

Type MIME Description Suffixes Autorisé
application/x-shockwave-flash Macromedia Flash movie swf Oui
application/futuresplash FutureSplash movie spl Oui

Bah ouai, le plugin est bien installé et autorisé, c'est bien pour ça que j'y compren rien à ce bug moi.

T'orais une soluce par hasard ?
Quand tu polishe ta caisse, elle brille !!!

Avatar du membre
Mori
Animal mythique
Messages : 13306
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 13 sept. 2004, 00:01

ben oui... c'est ce que j'ai aussi... et ça marche quand je rencontre une animation flash sur une page web... sur mon dd, je n'ai pas eu l'occasion de le faire...
on va creuser... tu arrives à ouvrir avec ton navigateur... donc moz le reconnaît...
en fait quand c'est sur ton dd, tu quittes la zone moz pour rentrer sur la zone de xp... il faut demander à le faire reconnaître par moz dans windows (je te donne pour win 98, tu adaptes pour xp)
paramètres > options des dossiers > type de fichiers > tu recherches la ligne "Shockwave Flash Object" > ouvrir avec et là tu dois avoir "composer <ou ce qui correspond à mozilla composer>"
supprime cette commande pour que windows quand tu cliqueras sur un fichier *.swf te demande avec quoi l'ouvrir et là tu choisis le navigateur.
Linux Lubuntu 20.04 (x86_64) Focal Fossa

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 13 sept. 2004, 23:48

Je viens de faire ta manip, je sélectionne Mozilla, mais ça veut toujours pas se lancé avec le navigateur mais toujours avec le composeur.

J'arrive aussi a lire les SWF qui st sur le net, mais sur mon DD, ça se lance toujorus pasavec Mozilla, sauf si jle glisse dedans.

Merci qd mm a toi pr ton aide.

Quelqu'un d'autre à une soluce plz ?
Quand tu polishe ta caisse, elle brille !!!

jv2759
Tyrannosaurus Rex
Messages : 4161
Enregistré le : 12 févr. 2004, 14:29

Message par jv2759 » 13 sept. 2004, 23:50

Je suis pas sur que ce soit possible. Car swf il ne connais pas, il ne sais pas qu'il peux ouvrire cela tout seul... J'ai comme l'impretion que c'est un comportement normale...
Inscrit sur la liste des abonner absent...

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 14 sept. 2004, 08:08

Bah malgré avoir remis a zéro les SWF ds Windows, pr moi toujours rien.

J'ai un pote qui a aussi la suite 1.7.2 avec XPSP1, et chez lui, ça l'ouvre ds le navigateur.

Comment faire pr ke mes SWF s'ouvre avec le navigateur au lieu du composeur, qqn d'autre à une soluce SVP ?
Quand tu polishe ta caisse, elle brille !!!

Avatar du membre
Mori
Animal mythique
Messages : 13306
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 14 sept. 2004, 09:15

on va tenter autre chose : supprime le composeur (soit tu peux le faire, soit tu désinstalles moz 1.7.x et tu le réinstalles en mode personnalisé en ne mettant pas le composeur)... tu ouvres les *.swf... tu attends que moz l'ouvre avec le navigateur... si ça marche... eureka... si tu as besoin du composeur, tu refais la manip désinstall / réinstall...

si ça ne marche pas, on regardera du côté de about:config

si ça marche, merci de regarder ma signature. merci. :wink:
Linux Lubuntu 20.04 (x86_64) Focal Fossa

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 14 sept. 2004, 10:55

Pour savoir, comment je peux faire pour désinstaller uniquement le composeur ??

Parce que si je peux éviter la désinstall et réinstall complète, ça serait cool, sinon tant pis je le ferais mais bon, tu sais comment faire Mori svp ?
Quand tu polishe ta caisse, elle brille !!!

Avatar du membre
Mori
Animal mythique
Messages : 13306
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 14 sept. 2004, 13:08

nitrofoliz a écrit :Pour savoir, comment je peux faire pour désinstaller uniquement le composeur ??

Parce que si je peux éviter la désinstall et réinstall complète, ça serait cool, sinon tant pis je le ferais mais bon, tu sais comment faire Mori svp ?
note bien que désinstaller par le programme uninstall intégré à moz 1.7.x
C:\Program Files\mozilla.org\Mozilla\uninstall
ne modifie pas ton profil... donc ne touche pas à tes extensions ni tes thèmes... si tu as quand même des craintes, sauvegarde ton profil entier sur une autre partie de ton disque...
tu désinstalles et tu réinstalles en option "personnaliser"... décocher "composeur".

c'est la solution la plus simple... d'ailleurs, je ne sais pas s'il y en a une autre.
Linux Lubuntu 20.04 (x86_64) Focal Fossa

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 14 sept. 2004, 13:32

Lol c 'est vrai, j'avais oublié ça, chui encore au boulot la, donc dans qqes heures je tente, et je te tien au courant de toute façon. :wink:
Quand tu polishe ta caisse, elle brille !!!

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 14 sept. 2004, 18:14

URGENT !!! PLZ

Je viens de désintaller la suite Mozilla, jusqu'ici tout va bien.

Je veux réinstaller, et là, je fais Install Personalisé, j'ai tous ces choix :
-Courriers & Forums
-Correcteur orthographique
-Chatzilla
-Débogueur
-Inspecteur
-Agent de rapport qualité.

Le composeur, il est où celui là ??? Je fais comment si je ne veux pas l'installer ???
Merci pour vos réponses
Quand tu polishe ta caisse, elle brille !!!

nitrofoliz
Lézard vert
Messages : 134
Enregistré le : 13 avr. 2004, 18:18

Message par nitrofoliz » 14 sept. 2004, 18:26

Je crois avoir ma réponse, le composeur est aussi utilisé pour la rédaction des emails, donc si je ne veux pas le composeur, pas de courriers :cry:
Quand tu polishe ta caisse, elle brille !!!

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités