Geckozone ne valide pas

Toutes remarques, tout intérêt, toutes choses à dire ou à demander à propos de Geckozone... Vous voulez participer à ce projet ? C'est par là qu'ça se passe...
Orbite
Salamandre
Messages : 31
Inscription : 29 juil. 2003, 03:03

Geckozone ne valide pas

Message par Orbite »

:cry: Dommage que fr.geckozine.org ne passe pas les tests élémentaires de validation.

Les pages HTML contiennent du code XTHML. :oops:
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

Tu as parfaitement raison, je suis d'ailleurs occupé à tester un template en XHTML ( http://www.forumimages.com/ ) en attendant d'en avoir un plus spécifique.
Bouiaw
Gecko
Messages : 68
Inscription : 29 juil. 2003, 09:03

Message par Bouiaw »

En plus, si je peux me permettre, le template de Forum Image est bien plus beau que l'actuel :!:
Orbite
Salamandre
Messages : 31
Inscription : 29 juil. 2003, 03:03

Message par Orbite »

Si je peux me permettre aussi, je préfère l'apparence de http://www.forumimages.com/
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

Bouiaw a écrit :En plus, si je peux me permettre, le template de Forum Image est bien plus beau que l'actuel :!:
L'actuel c'est celui de phpbb par défaut. Tu peux déjà choisir l'autre dans ton profil mais je dois encore faire les adaptations nécessaires.
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

Voilà après avoir réfléchi pendant deux heures sur la façon de faire passer la variable S_CONTENT_DIRECTION en minuscules, ce qui empêchait le site de valider, j'ai réalisé qu'il suffisait de l'enlever :roll:

Je passe tout le monde en FIsubsilver, prévenez-moi si ça pose des problèmes.
Orbite
Salamandre
Messages : 31
Inscription : 29 juil. 2003, 03:03

Message par Orbite »

Toujours pas du XHTML valide.

De plus, l'horrible couleur orange est toujours là et elle jure plus que jamais avec le reste du site.
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

La page principale EST valide. Pour l'affichage des sujets il ya juste un problème dès qu'il y au une liste (c'est phpbb qui produit du code invalide).

Remarque: ce forum-ci devrait être valide également (je suppose que c'est celui sur lequel tu as testé), mais il requiert une indentification, donc le validateur est redirigé vers la page de login qui elle n'est pas valide. Reste le problème des listes pour lequel il faudra attendre la prochaine version de phpbb.

P.S. J'en ai profité pour changer les smilies aussi ;)
Orbite
Salamandre
Messages : 31
Inscription : 29 juil. 2003, 03:03

Message par Orbite »

Pas besoin de reconfigurer le serveur.

Il manque seulement quelques urlencode dans le code phpBB.
PHP supporte le remplacement de séparateur d'arguments par un point-virgule, comme recommandé par le W3C, grâce à la directive arg_separator .ini. Malheureusement, la plupart des clients web n'envoient pas leurs données de formulaire avec des points-virgules. Une solution plus portable est d'utiliser & à la place de & comme séparateur. Vous n'avez alors pas à changer la directive arg_separator. Laissez-la à &, mais encodez vos URL avec htmlentities().

Code : Tout sélectionner

<?php
  echo '<A HREF="moncgi?foo=', htmlentities (urlencode ($userinput) ), '">';
?>
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

Orbite a écrit :Pas besoin de reconfigurer le serveur.

Il manque seulement quelques urlencode dans le code phpBB.
Comme je l'ai corrigé ci-dessus après avoir lu attentivement le rapport d'erreur du validateur, c'est simplement la page de login qui est invalide, je ne pense pas que ce soit très important :arrow: je regarderai ça un autre jour.
Bobe
Iguane
Messages : 742
Inscription : 28 juil. 2003, 21:29

Message par Bobe »

Benoit a écrit : Voilà après avoir réfléchi pendant deux heures sur la façon de faire passer la variable S_CONTENT_DIRECTION en minuscules,
fichier lang_main.php :wink:
Orbite
Salamandre
Messages : 31
Inscription : 29 juil. 2003, 03:03

Message par Orbite »

Benoit a écrit :je regarderai ça un autre jour.
Prenez le temps de dormir de temps en temps. On est déjà tellement heureux que GeckOzone existe. On peut bien attendre un peu pour les détails sans conséquence immédiates.

Merci pour tout le boulot déjà fait.
LezeuS
Lézard vert
Messages : 158
Inscription : 29 juil. 2003, 19:00

Message par LezeuS »

Benoit a écrit :P.S. J'en ai profité pour changer les smilies aussi ;)
:!: *newbie*
Je comprends pas tout au niveau du code... Mais pour les smileys je peux reagir ;)

Je prefere ca
Image à ca :lol:
ou encore ca Image à ca :D

J'en ai d'autre encore si ca plait... :roll:
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59

Message par Benoit »

J'ai pris une série qui allait avec le thème : http://www.forumimages.com/misc/smilies ... /#yellow_a
(pense à faire un Maj+Reload, tu as peut-être encore les anciens dans ton cache)

Si ce que tu veux dire c'est que tu préfères les plus grands il y a ceux-ci : http://www.forumimages.com/misc/smilies/#19px mais qui m'ont moins convaincu. Enfin si tu arrives à trouver la source de tes préférés et s'il ne faut par pour ça respecter une licence supplémentaire inappliquable je veux bien :)
Bouiaw
Gecko
Messages : 68
Inscription : 29 juil. 2003, 09:03

Message par Bouiaw »

Le bleu sur fond marron clair, c'est temporaire ou c'est définitif ?
Je trouve que ça va pas très bien ensemble, le tout-en-bleu du theme d'origine ça fait mieux, même si c'est moins original.

Mais bon, c'est juste mon avis, les gouts et les couleurs ...
Pis merci pour m'avoir fait découvrir les template XHTML pour phpbb, je connaissais pas, je vais pouvoir modifier le forum que j'administre pour qu'il soit compatible XMTML :P
Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité