Problème d'affichage des pages [Résolu]

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

djodjo567

Problème d'affichage des pages [Résolu]

Message par djodjo567 » 09 mai 2008, 03:12

Boujour,

J'ai un problème d'affichage de mes pages...
Par défaut ma page est en plein écran (comme tt le monde!!)
J'ai une page perso où le bloc principal est centrée dans la page web.
Si je réduit la taille d'affichage de la fenetre web en augmentant la taille de ma sidebar, ma page web reste toujours centrée (c'est normal!!)
Par contre ce qui ne l'est pas, c'est que quand je réduit la fenetre de firefox, ma page web reste positionnée comme elle était quand firefox était en plein écran. Elle ne se centre pas automatiquement!
Ce qui fait qu'il y a un moment ou je ne vois plus ma page web et il y a un grand espace vide sur la gauche!!!!

:oops:

Mon profil firefox est tout neuf, j'ai meme pas 20 extensions et ca tourne déjà pas correctement.
Je ne sais pas quoi faire. Si vous pouvez me filler un coup de main. Merci beaucoup
Djo

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Avatar du membre
jpj
Animal mythique
Messages : 25241
Enregistré le : 01 août 2005, 15:38

Message par jpj » 09 mai 2008, 04:13

Bonjour,

Si cela ne le fait qu'avec ta page perso, c'est probablement le code qui est en cause. Pourrais-tu donner l'adresse et confirmer que c'est bien ça. On déplacera alors dans "Développement web".

A+
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 09 mai 2008, 05:16

Whaou on a les mêmes horaires!!! J'pensais pas avoir de réponse avant 8h00... Bonne nuit

Non ça le fait avec toutes les pages qui sont censée être centrées!!
Je viens de réessayer à l'instant

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Avatar du membre
jpj
Animal mythique
Messages : 25241
Enregistré le : 01 août 2005, 15:38

Message par jpj » 09 mai 2008, 15:28

Bonjour,

Essaie déjà en mode sans échec de Firefox (sans rien réinitialiser) et, si c'est pareil, avec un nouveau profil (sans supprimer l'actuel). Si nécessaire, plus d'explications ici: http://www.geckozone.org/forum/viewtopi ... 044#326044 (suivre les liens dans le message).

Pourrais-tu donner quand même des adresses de site afin que l'on puisse vérifier comment ils sont affichés. Si ça vient des sites, il est inutile de chercher dans la configuration de Firefox.
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 09 mai 2008, 21:12

Bon en mode sans échec ca fonctionne!
Je vais essayez en déactivant les modules un par un!

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 09 mai 2008, 21:39

Je reprend tout...

Le probleme vient de l'affichage d'une page web qui est centrée par défaut et qui ne reste pas centrée si je redimensionne firefox.

Bon alors plusieurs choses à noter :
- La page s'affiche correctement sur un autre profil
- La page s'affiche correctement en mode sans échecs...
- La page s'affiche correctement si je modifie sa taille en redimensionnant le panneau latéral
- La page s'affiche correctement au redémarrage après avoir fermé Firefox (s'il n'est pas en mode plein écran / fenêtre firefox plus petite que le bureau windows)

- La page ne s'affiche pas correctement au redémarrage après avoir fermé Firefox (s'il est en mode plein écran)

Le problème intervient donc parce que quand je quitte firefox je suis en mode plein écran!!!! :?

L'activation ou la désactivation des modules ne change rien au problème.



Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Modifié en dernier par djodjolyon le 09 mai 2008, 22:02, modifié 1 fois.

nico@nc
Animal mythique
Messages : 8038
Enregistré le : 21 août 2005, 08:04

Message par nico@nc » 09 mai 2008, 21:59

Bonjour,

Tu n'aurais pas FasterFox ou FireTune ?
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 09 mai 2008, 22:04

Non j'ai pas ça. Mais apparemment ça ne vient pas d'une extension...
Si je les désactives toutes, ça ne change rien au probleme.

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 09 mai 2008, 22:36

Bon après une autre batterie test, voila ce qu'il en est.
En fait ce n'est pas la page web qui ne s'affiche pas bien, c'est firefox en entier!!
Comme je l'ai dit tout a l'heure, si j'ouvre firefox et qu'il était en mode plein écran lors de la fermeture, j'ai le problème d'affichage.
En fait Firefox ne redimmensionne rien. Meme pas ma barre d'adresse. Ce qui fait que ma barre de recherche qui est juste à coté disparait si je réduit la fenetre firefox.

L'affichage est bien par contre si j'ouvre firefox et qu'il n'était pas en mode plein écran lors de la fermeture. Il redimensionne les élément de la fenetre comme il faut!!

Je ne pourrais pas faire mieux comme explication.

J'aimerai bien garder ce profil quand meme s'il y a une solution pour éviter de refaire tous les parametrages des extensions, etc

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Avatar du membre
jpj
Animal mythique
Messages : 25241
Enregistré le : 01 août 2005, 15:38

Message par jpj » 09 mai 2008, 22:59

Sans aucune garantie, essaie déjà ceci : http://www.geckozone.org/forum/viewtopi ... 896#341896
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 10 mai 2008, 19:00

J'ai fais ce que tu m'as dit jpj mais pas de changements!!
D'autres idées?

Sinon j'ai trouver une astuce pour ouvrir 2 profils en meme temps...
Du coup, je peux faire mon nouveau profil sans me prendre la tete sur les options de chaque extensions...
J'ouvre mes deux profils et affiches les extensions sur les 2 fenêtres et je reproduit...

Soluce :
- Allez dans le panneau de configuration et choisir "système".
- Cliquer sur l'onglet avancé, puis sur le bouton "variables d'environnements".
- Dans la boîte de dialogue qui apparait, rajoutez MOZ_NO_REMOTE avec une valeur à 1.


Je le met ici parce c'est pas mis sur beaucoup de sites!! je l'ai pas vu sur geckozone...

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Avatar du membre
jpj
Animal mythique
Messages : 25241
Enregistré le : 01 août 2005, 15:38

Message par jpj » 10 mai 2008, 20:03

Bonsoir,

L'astuce se trouve, entre autres, ici : http://xulfr.org/wiki/ConfigurerMozillaPourDevelopper. Comme cela peut poser des problèmes d'avoir la variable fixée une fois pour toute, il vaudra mieux la virer quand tu aura fini.

Tu as la possibilité de faire la même chose avec un fichier batch (cf. xulfr.org) ou avec l'extension ProfileSwitcher, ce qui a l'avantage de ne pas fixer la variable d'environnement.
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

djodjo

Message par djodjo » 10 mai 2008, 23:00

ok...
Est-ce que par hasard, ca peut planter un ordi completement?
Windows était à zéro ce matin... Comme quand on vient de faire une install...
J'ai galeré toute la journée pour reconfigurer...
J'ai posté sur un autre forum pour ça mais si tu me dis que ca peut poser des problemes peut etre que tu sais...

Une autre question avant que nous revenions au sujet principal... Je viens de regarder rapidement le lien. C'est expliquer pour faire le fichier batch dans cette page? Si oui je regarderai plus en détail et si non c'est quoi le code a insérer?

Pour ce qui est de mon problème, j'ai trouvé le coupable... C'est moi!!!
Mais le problème n'est pas encore règlé.
J'explique :
En fait j'ai ma barre personnelle avec mes liens. Je l'ai configuré avec userchrome pour pouvoir avoir plusieurs lignes.
Je met le code ici :

#bookmarks-ptf
{
display: block;
border: 0 !important;
padding: 5px 0 5px 0 !important;
}

Ce qui est mal configuré, c'est display. Je l'avais comme ca dans le fichier userchrome.
J'ai fait tous les essais en mettant à la place de block : line, inline-block, moz-inline-box, none, marker, compact. Soit ça n'affiche pas les marques pages, soit sur une seule ligne.
J'ai essayé aussi avec list-item mais c'est pareil que block.
Qu'est-ce qu'il faut que je fasse?

Je met le code complet si jamais il y a un problème d'incompatibilité avec deux propriétés :

#bookmarks-ptf
{
display: compact;
border: 0 !important;
padding: 5px 0 5px 0 !important;
}
#bookmarks-ptf toolbarseparator
{
display: block;
}
#PersonalToolbar {
max-height:80px !important;
}
# #overflow-padder {
width: auto !important;
}
/* this controls the # length of the bookmarks */
#bookmarks-chevron {
display: none !important;
}
#bookmarks-ptf .bookmark-item {
visibility: visible !important;
}
/* souligne les marque-pages simples au passage souris */
#bookmarks-stack > .bookmarks-toolbar-overflow-items {
display: none !important;
}
#bookmarks-stack {
overflow: visible !important;
}
#bookmarks-ptf toolbarbutton {
font-size: 11px !important; color: #5D6469 !important;
margin : 50 !important;
border: 0 !important;
}
#bookmarks-ptf .bookmark-item .toolbarbutton-icon {
margin-top: 0px !important;
padding: 0 0px 0 0px !important;
margin : 0 !important;
border: 0 !important;
}
#bookmarks-ptf .bookmark-item .toolbarbutton-text {
margin-top: 0px !important;
padding: 0 0px 0px 0px !important;
font-size: 11px !important;
font-weight: 500 !important;
}
@namespace url("http://www.mozilla.org/keymaster/gateke ... s.only.xul");

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Avatar du membre
jpj
Animal mythique
Messages : 25241
Enregistré le : 01 août 2005, 15:38

Message par jpj » 11 mai 2008, 00:12

Non, en aucun cas un plantage complet de Windows à ce point là. Les seuls problèmes possibles sont au niveau des profil et éventuellement de la mémoire puisque tu lances plusieurs fois Firefox. Ce que tu décris ressemble à la création d'une nouvelle session Windows (nouveau compte utilisateur).

Pour créer un fichier batch, il suffit du bloc-notes de Windows. Il faut seulement vérifier que le fichier est bien enregistré avec l'extension .bat et non .bat.txt. Tu peux par exemple avoir:

Lance le profil default

Code : Tout sélectionner

SET MOZ_NO_REMOTE=1
"C:\Program Files\Mozilla Firefox\firefox.exe" -p default
Lance le profil test

Code : Tout sélectionner

SET MOZ_NO_REMOTE=1
"C:\Program Files\Mozilla Firefox\firefox.exe" -p test
Les guillemets sont impératifs s'il y a des espaces dans le chemin. Idem pour le nom du profil ("mon profil" à cause de l'espace). Ne pas oublier l'espace avant et après -p.

Mais cette solution est surtout utile pour lancer des version différentes de Firefox, par exemple la version 2.0.0.14 et la version 3.0pre. Quand il s'agit de la même version de Firefox, l'extension ProfileSwitcher est plus simple à utiliser et le lancement est un peu plus rapide que par le batch (bien qu'elle utilise en fait aussi la modification de la variable d'environnement).

Pour la barre personnelle sur plusieurs niveau, voir &11 Barre personnelle sur plusieurs lignes dans ce message: http://www.geckozone.org/forum/viewtopic.php?t=28965, ainsi que ce message: http://www.geckozone.org/forum/viewtopi ... 286#297286 (hi-han 2). Pour plus d'aide, comme je n'ai jamais vraiment bidouillé le userChrome.css, poste plutôt dans personnaliser Firefox avec le userChrome.css (même si ce fil est un peu en sommeil :( ).
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 17 mai 2008, 16:53

XP m'avais virer mon profil effectivement... L'enfoi**. Mais je sais pas pourquoi... C'est la vie avec un pc!

Sinon j'ai fait le fichier .bat. Ca fonctionne nikel... Merci

Pour mon problème de barre personnelle sur 3 ligne j'ai eu zéro réponse en 5 jours!!!!!!
Help me please

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot], gererd24 et 26 invités