Très gros souci avec les icones dans les menulist sous Vist

Vous vous penchez sur le développement d'applications ou d'extensions pour Mozilla ? C'est alors vers ce forum que se dirigeront naturellement vos requêtes...

Modérateur : chBok

Répondre
christophe charron
Gecko
Messages : 73
Enregistré le : 02 févr. 2006, 19:36

Très gros souci avec les icones dans les menulist sous Vist

Message par christophe charron » 28 janv. 2009, 13:51

Bonjour,
presque tout est dit dans le titre ... et la description très très mal aisée car le comportement n'est pas tout le temps le même.

Parfois le contenu de la menupopup n'apparait pas du tout et il faut cliquer sur une barre d'ascenceur qui se crèe alors que cela ne se justifie pas !!!
Parfois le contenu du menupopup apparait mais disparait après avoir été survolé !!!
Parfois les icones apparaissent puis disparaissent après une sélection!!!
Parfois il n'y a aucun problème !!!

Et il n'y a absolument aucun problème sous XP, Ubuntu.
Donc 2 questions :
1 -> utilisateurs de vista pouvez-vous me dire si vous constatez le problème sur cette page http://test03.christophe-charron.org/pu ... ems_00.xul ?

2-> est-ce un bug connu et connaissez-vous la solution ? un moyen de contournement ??

D'avance merci d'avance pour vos suggestions car je suis fort embêté ... pour rester poli !!


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Cordialement,
Christophe Charron
http://xsoftware.fr

christophe charron
Gecko
Messages : 73
Enregistré le : 02 févr. 2006, 19:36

Message par christophe charron » 18 févr. 2009, 18:47

And the winner is ... still Martin, pour m'avoir mis, dans une autre conversation sur la bonne piste :
il "suffit" de remplacer dans la feuille de style :

Code : Tout sélectionner

menulist > menupopup > menuitem > .menu-iconic-left {
  display: block;
}
par

Code : Tout sélectionner

menulist > menupopup > menuitem > .menu-iconic-left {
  display: -moz-box;
}
Pourquoi ? Je ne sais pas ...
si quelqu'un peut m'expliquer, ça m'arrangerait bien quand même
Ici http://test03.christophe-charron.org/pu ... ems_00.xul la fenêtre normalement correctement visible partout, enfin j'espère.

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Cordialement,
Christophe Charron
http://xsoftware.fr

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités