ma première extension, Boox

Vous vous penchez sur le développement d'applications ou d'extensions pour Mozilla ? C'est alors vers ce forum que se dirigeront naturellement vos requêtes...

Modérateur : chBok

Humpfff
Tyrannosaurus Rex
Messages : 2451
Enregistré le : 05 avr. 2004, 13:23

Message par Humpfff » 27 févr. 2010, 09:38

Bonjour la Zone,

Jusqu'à présent tout allait bien avec Minefield, en incrémentant le maxVersion de Boox 2.6beta1.
Depuis la Build 20100225xxxxxx (Mozilla-Central-l10n) : (testé sur un profil tout frais)
  • Les flux ne sont plus graissés dans la barre latérale des marque-pages.
  • Par contre, les flux sont bien graissés dans la barre personnelle.
Je ne sais pas si c'est un bug ou une feature de Minefield.
Je n'ai pas constaté d'autres bizarreries.

jason2005
Lézard à collerette
Messages : 337
Enregistré le : 05 nov. 2006, 22:53

Re: ma première extension, Boox

Message par jason2005 » 28 févr. 2010, 13:49

bonjour

je suis en train de tester cette extension, elle fonctionne tres bien sous ff 3.6, par contre n'ayant pas lu les 17 pages
du post (je ne sais donc pas si ca a deja eté signalé ou pas), j'ai, a chaque fermeture de ff, Xmarks qui fait
une synchronisation des marques pages alors que rien n'a eté ajouté ou modifié par mes soins ... si je desactive boox
ca ne se produit plus ... bug ou pas j'en sais rien mais de toute façon je garde cette extension, c'est pas mal du tout
ces infobulles detaillées :wink:
@+++

martin
Varan
Messages : 1074
Enregistré le : 21 janv. 2004, 16:23

Re: ma première extension, Boox

Message par martin » 27 mai 2010, 12:03

Bon, c'est la honte, il n'y a toujours pas de version Boox stable compatible Firefox 3.6...

voici (enfin) une nouvelle version 2.6 beta2, à tester.
personnellement je n'ai plus de problème, c'est peut être la bonne ;)

En principe ceux qui sont sur la beta 1 devraient avoir la mise à jour automatique.

martin
Varan
Messages : 1074
Enregistré le : 21 janv. 2004, 16:23

Re: ma première extension, Boox

Message par martin » 27 mai 2010, 12:29

rognodutju, comprend pas, j'ai pas vu vos messages et donc j'ai pas répondu (j'ai pourtant souscrit au fil :s)

Donc, en retard, mais tant pis, je vous répond quand même:
The RedBurn a écrit :Sinon, il y a deux choses plus ou moins gênantes (déjà avec les anciennes versions) :

Un problème de décalage des infobulles difficile à reproduire. J'ai déjà essayé avec deux fichiers de test comme pour l'autre fois, mais ça ne fonctionne pas, même si je laisse le navigateur actualiser le flux par lui-même (en utilisant browser.bookmarks.livemark_refresh_seconds pour diminuer le délai).

Et lorsqu'un flux vient d'être mis à jour, il faut parfois un certain temps pour que la première infobulle s'affiche (d'où le throbber, mais ce serait pas mal s'il y avait moyen de s'en passer).
Le problème de décalage m'a déjà été signalé, mais effectivement je ne l'ai pas vu, je n'arrive pas à reproduire... Difficile de corriger donc.

Le temps pour l'infobulle, je ne peux également pas faire grand chose. En principe Boox tente de charger l'info via le cache si possible. Donc si le flux vient d'être mis à jour, il devrait s'y trouver... Ne s'agirait 'il pas d'un flux "redirigé" ? C'est à dire que l'adresse du Marque-page dynamique (clic-droit -> propriétés, adresse du flux) ne correspond pas à celle du flux affiché (clic-droit -> Voir le Flux, adresse dans la barre d'adresse).
Si le problème est plus présent pour certains flux, je veux bien une url, que j'y regarde par moi même.
Humpfff a écrit :Je ne sais pas si c'est un bug ou une feature de Minefield.
Je n'ai pas constaté d'autres bizarreries.
M'étonne pas qu'elle ne fonctionne pas sur le tronc (Minefield). Il y a à chaque des changements dans Firefox en ce qui concerne les Marque-pages, à chaque version majeure, y compris sur l'UI.
On va d'abord finir une version stable de Boox, avant de se pencher sur Firefox 3.7/4. Et je pense que j'attendrai les alpha, voir les beta, qu'ils stabilisent cette partie ;) .
jason2005 a écrit :j'ai, a chaque fermeture de ff, Xmarks qui fait
une synchronisation des marques pages alors que rien n'a eté ajouté ou modifié par mes soins ... si je desactive boox
ca ne se produit plus
Arf, j'ai pas trop envie de souscrire à XMark pour pister çà. Mais je le ferai peut être. En principe, le seul changement que je vois avec Boox, c'est qu'il enregistre une visite sur une entrée de flux lorsque tu la marques comme lue, de la même manière que si tu visites directement celle-ci. Çà ne devrait pas posé de problème.

As tu essayé d'utiliser l'historique propre à Boox ? (dans les préférences de Boox). Celà résoudrait peut être ton problème.

Et sinon, personnellement je conseillerai plutôt Weave pour cette fonctionnalité ;) .


Je vais surveiller si les nouveaux messages de ce fil me sont bien notifié ;) .

The RedBurn
Iguane
Messages : 515
Enregistré le : 28 janv. 2005, 16:39

Re: ma première extension, Boox

Message par The RedBurn » 27 mai 2010, 15:54

martin a écrit :Le temps pour l'infobulle, je ne peux également pas faire grand chose. En principe Boox tente de charger l'info via le cache si possible. Donc si le flux vient d'être mis à jour, il devrait s'y trouver... Ne s'agirait 'il pas d'un flux "redirigé" ? C'est à dire que l'adresse du Marque-page dynamique (clic-droit -> propriétés, adresse du flux) ne correspond pas à celle du flux affiché (clic-droit -> Voir le Flux, adresse dans la barre d'adresse).
En effet, je pense que c'est lié à ça. Je n'ai plus eu ce problème depuis que j'ai corrigé l'adresse de certains flux.
martin a écrit :Le problème de décalage m'a déjà été signalé, mais effectivement je ne l'ai pas vu, je n'arrive pas à reproduire... Difficile de corriger donc.
La prochaine fois que je le remarquerai sur un flux, je te donnerais son adresse, au cas où tu voudrais tester.
martin a écrit :Et sinon, personnellement je conseillerai plutôt Weave pour cette fonctionnalité ;).
J'utilise aussi xmarks car Weave ne conserve pas l'ordre des marque-pages non classés. :(
Par contre je n'ai pas remarqué ce problème.
Venez traduire des extensions sur BabelZilla

martin
Varan
Messages : 1074
Enregistré le : 21 janv. 2004, 16:23

Re: ma première extension, Boox

Message par martin » 27 mai 2010, 16:32

The RedBurn a écrit :
martin a écrit :Le temps pour l'infobulle...
En effet, je pense que c'est lié à ça. Je n'ai plus eu ce problème depuis que j'ai corrigé l'adresse de certains flux.
Cool. Faudra que je pense à mettre çà dans la FAQ.
Et çà me fait penser que ce doit aussi être la cause d'un autre problème signalé (des infobulles pas en adéquation avec leur item)
The RedBurn a écrit :
martin a écrit :Le problème de décalage m'a déjà été signalé, mais effectivement je ne l'ai pas vu, je n'arrive pas à reproduire... Difficile de corriger donc.
La prochaine fois que je le remarquerai sur un flux, je te donnerais son adresse, au cas où tu voudrais tester.
Merci d'avance. Néanmoins je ne suis sûr que ce soit un problème de flux, plutôt que quand un flux est entièrement lu, le "gras" disparait et modifie un poil l'interface. Mais je suis pas sûr, ne le reproduisant pas.
The RedBurn a écrit :
martin a écrit :Et sinon, personnellement je conseillerai plutôt Weave pour cette fonctionnalité ;).
J'utilise aussi xmarks car Weave ne conserve pas l'ordre des marque-pages non classés. :(
Par contre je n'ai pas remarqué ce problème.
Cool pour "pas de problème" :) . Par curiosité, tu utilise l'historique de Boox, ou le natif de Firefox ?
Crotte pour weave, parce qu'il a quand même d'autres avantages.

merci pour le retour The RedBurn ;)

The RedBurn
Iguane
Messages : 515
Enregistré le : 28 janv. 2005, 16:39

Re: ma première extension, Boox

Message par The RedBurn » 27 mai 2010, 17:12

martin a écrit :
The RedBurn a écrit : En effet, je pense que c'est lié à ça. Je n'ai plus eu ce problème depuis que j'ai corrigé l'adresse de certains flux.
Et çà me fait penser que ce doit aussi être la cause d'un autre problème signalé (des infobulles pas en adéquation avec leur item)
Je ne parierais pas là-dessus, car je pense l'avoir remarqué sur des flux dont l'adresse est correcte, mais on verra.
martin a écrit :
The RedBurn a écrit :
martin a écrit :Le problème de décalage m'a déjà été signalé, mais effectivement je ne l'ai pas vu, je n'arrive pas à reproduire... Difficile de corriger donc.
La prochaine fois que je le remarquerai sur un flux, je te donnerais son adresse, au cas où tu voudrais tester.
Merci d'avance. Néanmoins je ne suis sûr que ce soit un problème de flux, plutôt que quand un flux est entièrement lu, le "gras" disparait et modifie un poil l'interface. Mais je suis pas sûr, ne le reproduisant pas.
Je n'utilise pas le stylage des marque-pages, donc ça m'étonnerait que ce soit ça. Et le problème apparaît après la mise à jour automatique d'un flux.
martin a écrit :
The RedBurn a écrit :
martin a écrit :Et sinon, personnellement je conseillerai plutôt Weave pour cette fonctionnalité ;).
J'utilise aussi xmarks car Weave ne conserve pas l'ordre des marque-pages non classés. :(
Par contre je n'ai pas remarqué ce problème.
Cool pour "pas de problème" :) . Par curiosité, tu utilise l'historique de Boox, ou le natif de Firefox ?
Crotte pour weave, parce qu'il a quand même d'autres avantages.
L'historique natif.
J'utilise aussi weave, mais pas pour les marque-pages. Un autre avantage de xmarks, c'est qu'on peut consulter ses marque-pages via une page web, ce qui n'est pas encore le cas de weave.
martin a écrit :merci pour le retour The RedBurn ;)
De rien, et merci encore pour cette extension ! :)
Venez traduire des extensions sur BabelZilla

The RedBurn
Iguane
Messages : 515
Enregistré le : 28 janv. 2005, 16:39

Re: ma première extension, Boox

Message par The RedBurn » 07 juin 2010, 10:35

The RedBurn a écrit :
martin a écrit :
The RedBurn a écrit : En effet, je pense que c'est lié à ça. Je n'ai plus eu ce problème depuis que j'ai corrigé l'adresse de certains flux.
Et çà me fait penser que ce doit aussi être la cause d'un autre problème signalé (des infobulles pas en adéquation avec leur item)
Je ne parierais pas là-dessus, car je pense l'avoir remarqué sur des flux dont l'adresse est correcte, mais on verra.
Je viens d'avoir le problème avec le flux http://www.zdnet.fr/feeds/rss/actualites/, dont l'adresse était correcte. :?
Venez traduire des extensions sur BabelZilla

martin
Varan
Messages : 1074
Enregistré le : 21 janv. 2004, 16:23

Re: ma première extension, Boox

Message par martin » 18 juin 2010, 17:23

hop, c'est parti,version 2.6 pour Firefox 3.6 publiée à l'instant, disponible sur monsite, en mise à jour automatique, et en phase d'approbation sur AMO.

Le bug des infobulles parfois pas en adéquation est toujours présent. C'est pas bloquant, j'essaierai de corriger quand je trouverai le pourquoi...

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 1 invité