[trad] Forecastfox l10n 0.7 (prévisions et jours inclus!)

Vous vous penchez sur le développement d'applications ou d'extensions pour Mozilla ? C'est alors vers ce forum que se dirigeront naturellement vos requêtes...

Modérateur : chBok

Michael Stipe

Message par Michael Stipe » 23 févr. 2006, 13:45

En ce qui me concerne, j'utilise cette version plus pour retrouver les prévisions de weather.com (bien meilleures que celles d'AccuWeather dans mon cas) plutôt que pour la traduction.
Je me suis monté une version "personnalisée" en faisant coller les traductions au plus près de l'américain et surtout en mettant les nouvelles icônes utilisées par ForecastFox, qui à mon goût sont bien plus claires que les moches icônes de weather.com.
Le .jar "personnalisé" tourne comme un charme.
En tout cas, merci pour le boulot de traduction et de maintenance.

Michael Stipe

Message par Michael Stipe » 23 févr. 2006, 15:16

Un bug tant que j'y suis : vers la mi-journée et jusqu'avant 15 heures, l'affichage des prévisions du jour est décalé. Nous sommes jeudi, et au lieu d'avoir les prévisions de jeudi (journée), j'ai les prévisions de vendredi (journée) qui s'affichent.
A 15 heures, ça passe aux prévisions de la soirée, et là c'est bien jeudi (soirée) qui s'affiche.

cedvincent

Message par cedvincent » 05 mars 2006, 11:49

Désolé, je n'ai pas ce problème

Avatar du membre
wiroth
Gecko
Messages : 77
Enregistré le : 04 mars 2005, 14:38

Message par wiroth » 05 mars 2006, 12:02

bonjour,
oui c'est déjà arrivé chez moi,
mais tout rentre dans l'ordre à la mise à jour de l'observation suivante.
:wink:
Se connecter à internet, c'est y rencontrer des centaines de gens avec qui vous n'auriez jamais eu envie d'avoir quelque rapport que ce soit.

cedvincent

Message par cedvincent » 05 mars 2006, 14:50

Je viens d'avoir ce problème lors du chargement de Firefox vers 14h45 alors que ce matin l'extension fonctionnait très bien.

En allant voir sur le site les prévisions du jour ne sont plus possible. Je pense que ça vient de là et l'extension décale tout d'un jour. Il n'affiche plus les prévisions de ce jour ni pour la nuit.

Faut attendre lors de ca prochaine mise à jour pour moi à 15h environ.

cedvincent

Message par cedvincent » 05 mars 2006, 21:19

Je viens de constater un problème de traduction avec le vent:
Il affiche ONW, ca devrait être ONO à la place pour les prévisions de cette nuit.

Avatar du membre
wiroth
Gecko
Messages : 77
Enregistré le : 04 mars 2005, 14:38

Message par wiroth » 07 mars 2006, 18:30

Bonsoir,
exact je l'ai actuellement aussi sur Marseille pour mercredi et jeudi = ONW,
bien vu Cedvincent.
:wink:
Se connecter à internet, c'est y rencontrer des centaines de gens avec qui vous n'auriez jamais eu envie d'avoir quelque rapport que ce soit.

cedvincent

Message par cedvincent » 07 mars 2006, 19:18

Merci.

De même pour OSW qui devrait être OSO.
D'où deux erreurs.

TheRedBurn, il y a é corrections à faire:
ONW -> ONO
OSW -> OSO

Autant aussi vérifier avec les autres directions de vents.

Merci

The RedBurn
Iguane
Messages : 515
Enregistré le : 28 janv. 2005, 16:39

Message par The RedBurn » 07 mars 2006, 22:06

Tiens, tiens, je vois que tu n'utilises pas ton pavé numérique, cedvincent. :wink:
L'erreur de traduction concernant le vent est très simple : le remplacement des directions du vent n'est effectuée que pour une seule occurence de chaque direction. Ils suffit d'effectuer ce remplacement pour deux occurences de chaque direction pour régler ce problème.

À propos du bug de 15 heures, il est très possible que ce soit bien dû au fait que la prévision de la journée n'est plus envoyée par weather.com à partir d'une certaine heure. C'était déjà le cas à partir de 15h, mais ils l'ont peut-être modifié à 14h45 juste pour nous embêter. :evil:
L'idéal serait que le premier qui remarque à nouveau ce bug m'envoie le fichier forecastcache-(suffixe du profil Firefox).xml se trouvant dans le répertoire forecastfox de son profil Firefox.
Venez traduire des extensions sur BabelZilla

Avatar du membre
wiroth
Gecko
Messages : 77
Enregistré le : 04 mars 2005, 14:38

Message par wiroth » 08 mars 2006, 17:35

The RedBurn a écrit :Tiens, tiens, je vois que tu n'utilises pas ton pavé numérique, cedvincent. :wink:
L'erreur de traduction concernant le vent est très simple : le remplacement des directions du vent n'est effectuée que pour une seule occurence de chaque direction. Ils suffit d'effectuer ce remplacement pour deux occurences de chaque direction pour régler ce problème.
là j'ai pas bien compris les élements que je devais gérer pour régler cette affichage, je donne ma langue au chat
:oops:
Se connecter à internet, c'est y rencontrer des centaines de gens avec qui vous n'auriez jamais eu envie d'avoir quelque rapport que ce soit.

cedvincent

Message par cedvincent » 08 mars 2006, 19:00

Pavé Numérique? Que vient-il faire celui-là? :!:

J'ai émis la même hytpthèse concernant le bug juste avant 15H.
Mais tu apportes plus de précisions.

Concernant le vent, j'ai compris la traduction à faire mais je ne vois rein dans les options comme Wiroth.
Je penses que ca doit être réalisé dans le fichier de traduction!

The RedBurn
Iguane
Messages : 515
Enregistré le : 28 janv. 2005, 16:39

Message par The RedBurn » 08 mars 2006, 21:45

Le 2 se trouve sur la même touche que le é

Je ne faisais que confirmer ton hypothèse, tu n'as pas dû remarquer le "bien". :wink:

Je ne comprend pas ce que vous avez tous les deux à comprendre que c'est vous qui devez changer quelque paramètre obscur.
C'est l'extension qui n'effectue qu'une seule boucle de traduction des directions du vent, donc il ne peut y avoir qu'un seul remplacement par lettre de l'alphabet, ce qui explique que la deuxième occurence de W n'est pas remplacée.
Venez traduire des extensions sur BabelZilla

cedvincent

Message par cedvincent » 08 mars 2006, 21:50

Désolé. Tu as raison dans les deux cas.

Avatar du membre
wiroth
Gecko
Messages : 77
Enregistré le : 04 mars 2005, 14:38

Message par wiroth » 08 mars 2006, 22:38

The RedBurn a écrit :Le 2 se trouve sur la même touche que le é


Je ne comprend pas ce que vous avez tous les deux à comprendre que c'est vous qui devez changer quelque paramètre obscur.
C'est l'extension qui n'effectue qu'une seule boucle de traduction des directions du vent, donc il ne peut y avoir qu'un seul remplacement par lettre de l'alphabet, ce qui explique que la deuxième occurence de W n'est pas remplacée.
Ho, Bonne Mère, tu as raison,
je vais aller faire bruler un cierge pour me faire pardonner.
:oops:
Se connecter à internet, c'est y rencontrer des centaines de gens avec qui vous n'auriez jamais eu envie d'avoir quelque rapport que ce soit.

Ririck

Message par Ririck » 12 mars 2006, 20:44

Bon deja je préviens ke je ne suis pa un boss en informatique, mais apré avoir télécharger cette extension, avoir fait les réglages (villes...) et bien il n'y a toujours rien qui s'affiche sur mozilla!!
Qu'est que je n'ai pas bien fait??? :cry:

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité