migration addon de TB38 vers TB45

Vous vous penchez sur le développement d'applications ou d'extensions pour Mozilla ? C'est alors vers ce forum que se dirigeront naturellement vos requêtes...

Modérateur : chBok

pewpew2001
Arias
Messages : 5
Inscription : 26 avr. 2016, 10:22

migration addon de TB38 vers TB45

Message par pewpew2001 » 26 avr. 2016, 10:31

Bonjour,

J'ai récupéré un projet pour lequel je doit faire évoluer un addon fonctionnant avec TB38 pour qu'il fonctionne avec TB45.


Dans cet addon il y a une partie javascript qui fait référence aux composants xpcom dont voici un extrait

Code : Tout sélectionner

	var configService = Components.classes['@asip-sante.fr/mssConfig;1']
                    .createInstance(Components.interfaces.IMssConfig);


Ce code fonctionne sous TB38 mais pas sous TB45, j'ai une erreur :

Code : Tout sélectionner

TypeError: Components.classes['@asip-sante/mssConfig;1'] is undefined
Il semble que les composants xpcom ne soient pas enregistrés.

Y-a-t'il des modification a effectuer sur mon plugin pour TB 45 ?


Cordialement
Laurent
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Avatar de l’utilisateur
J2m06
Administrateur
Messages : 20079
Inscription : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: migration addon de TB38 vers TB45

Message par J2m06 » 28 avr. 2016, 17:26

Bonjour

Je déplace dans un autre forum ou tu auras peut etre plus de chance d'avoir une réponse :wink:


.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 1800 captures écran )

pewpew2001
Arias
Messages : 5
Inscription : 26 avr. 2016, 10:22

Re: migration addon de TB38 vers TB45

Message par pewpew2001 » 17 mai 2016, 16:53

Bonjour,

Pas de réponse sur ce post, personne n'a eu le même problème que moi ?

Peut être que c'est en lien avec le xulrunner sdk, qui s’arrête a la version 41 ?

Cordialement
Laurent
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités