[Résolu] Pb de locale

Vous vous penchez sur le développement d'applications ou d'extensions pour Mozilla ? C'est alors vers ce forum que se dirigeront naturellement vos requêtes...

Modérateur : chBok

dmganges
Gecko
Messages : 63
Inscription : 25 juin 2013, 20:35
Localisation : Hérault

[Résolu] Pb de locale

Message par dmganges » 11 oct. 2013, 10:24

Bonjour,

[Edit 24/10]:
Ce n'était qu'un copier intempestif dans chrome.manifest.
Ctrl_F Findbar_1.0.0 validé Windows & Linux est disponible https://addons.mozilla.org/fr/firefox/addon/ctrlf/
[/Edit]

J'arrive au bout, mais j'ai un problème de locale :
Dans le répertoire des locales j'ai
ar
ar-MA
en-US
es-ES
fr-FR

En fait je n'ai fait qu'une mauvaise traduction en anglais...
les autres ne sont que des copies de fr-FR pour tester.

- fr-FR pas de pb
- en-US pas de pb
- es-ES pas de pb même si en fait tout est en français...

par contre en ar et ar-MA :
1) si je conserve en-US, il y a basculement vers en-US, je ne passe jamais en ar ni ar-MA
2) si je renomme en-US en SAVen-US, bien sûr il n'y a plus basculement automatique vers en-US et j'ai une erreur sur la console debug :
Le premier libellé nécessaire à l'application n'est pas trouvé.

j'écris en dur le libellé dans le .xul,
c'est le deuxième libellé nécessaire à l'appli qui n'est pas trouvé.........

J'en déduis que mes locales ar et ar-MA ne sont pas vu de l'appli !

Si je fais une locale bidon it dans laquelle je mets du français c'est OK !!!

En fait l'appli ne voit pas les locales arabes et seulement celle-là !
Y aurait-il un subtilité avec les locales concernant les langues qui s'écrivent de droite à gauche ?
J'ai donné un coup d’œil au code de Adblock qui prend en compte l'arabe ar, je n'ai rien trouvé de spécifique.

Bien sûr TOUT est en UTF8.

Auriez-vous une idée ?
D'avance MERCI !
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité