Page 1 sur 2

extension traducteur (gb2fr)

Posté : 09 août 2003, 15:38
par Chadom
Bonjour,
ce post n'est pas lié directement à mozilla mais à une extension (j'espère ne pas être hors sujet ?)

J'ai écris une petite extension (en m'inspirant de l'extension textLink) qui permet de sélectionner un mot (ou une phrase) et d'ouvrir une fenêtre qui va sur le site reverso.com pour en faire la traduction.

Vous pouvez récupere ce xpi sur :
http://qsdqsd.free.fr/xpi_gb2fr/gb2fr(0.1).xpi

Tous commentaires bienvenus, merci.

Re: extension traducteur (gb2fr)

Posté : 09 août 2003, 16:23
par Shogix
Chadom a écrit :Bonjour,
ce post n'est pas lié directement à mozilla mais à une extension (j'espère ne pas être hors sujet ?)

J'ai écris une petite extension (en m'inspirant de l'extension textLink) qui permet de sélectionner un mot (ou une phrase) et d'ouvrir une fenêtre qui va sur le site reverso.com pour en faire la traduction.

Vous pouvez récupere ce xpi sur :
http://qsdqsd.free.fr/xpi_gb2fr/gb2fr(0.1).xpi

Tous commentaires bienvenus, merci.
Je crois que tu devrais faire une page de présentation pour ton extension et fournir quelques renseignements et peut-être une capture d'écran. Est-ce que ça marche avec Firebird? Netscape 7.x? Ça se désinstalle facilement?

Je termine avec une suggestion pour les admins du forum: il faudrait une section "Extensions" parce que c'est pas très parlant la catégorie "Autres".

Posté : 09 août 2003, 17:32
par Benoit
Est-ce que ça n'aurait pas sa place dans "Développement d'applications" ?

Posté : 09 août 2003, 18:23
par ericj
En résumé :
- on ne pourra pas ouvrir indéfiniment des forums (trop d'infos tue l'info);
- "Développement d'applications spécial Gecko" est le forum idoine dans ce cas;
- "Développement d'applications spécial Gecko" devrait se situer non pas dans le chapitre "Spécial webmestre" mais sous "Applications de base gecko".

Il faudrait modifier l'agencement actuel pour le corriger, si vous en êtes d'accord. (ce message est par nature biodégradable :wink: )

Posté : 09 août 2003, 21:47
par Benoit
Voilà, le sujet et le forum sont déplacés et la description a été modifiée pour clarifier que c'est pour parler des extensions également.

Page de description

Posté : 10 août 2003, 01:31
par Chadom
J'ai eu un peu de temps et j'ai fait une page de présentation :
http://qsdqsd.free.fr/xpi_gb2fr/

Sinon je l'ai testé sur Firebird, ça a l'aire bon.
Sous Mozilla je ne l'ai testé que sans avoir installé le package de langue fr, et je sais pas si ça peut poser problème (car j'ai fait le gros gore en métant les libélés dans chrome/gb2fr.jar!/locale/en-US/gb2fr/ :roll:). Si quelqu'un peut me dire si ça fonctionne...

Je suis assez contant de moi même si ça manque de finitions, je trouve cette petite extension bien pratique ! 8)

Posté : 10 août 2003, 02:00
par Douglas
si tu pouvais faire ton liens sur ta page pour que l'install se fasse en auto (comme sur http://texturizer.net/firebird/extensions.html ) parce que la moi ca le l'ouvre en texte j'ai du fiare enregistrer sous

j'ai cru voir qu'ils utilisent un js pour le faire ;)

Posté : 10 août 2003, 02:01
par Douglas
parcontre l'extension en elle meme elle fonctione bien :)

si tu veux des idées de features a ajouter demande :D

Posté : 10 août 2003, 07:54
par Shogix
Bah moi j'ai le message "Package non-valide" quand j'essaye d'installer :(

Je sais pas si tu peux créer un fichier .htaccess sur Free, si oui ajoute la ligne suivante:

AddType application/x-xpinstall .xpi

Ça va permettre l'installation directe.

installation automatique

Posté : 10 août 2003, 12:25
par Chadom
free.fr gère les .htaccess (du moins pour les droits), mais j'en ai fait un juste avec la ligne
AddType application/x-xpinstall .xpi
et ça n'a pas l'air d'avoir d'éffet... ?

Par contre j'ai rajouté du javascript pour permettre l'install direct. Pour info il suffit de rajouter :

var xpi={'Traducteur gb2fr v0.1':'gb2fr(0.1).xpi'};
InstallTrigger.install(xpi);

(cf. http://devedge.netscape.com/library/man ... Chap3.html)

Posté : 10 août 2003, 13:15
par Douglas
il lance maintenant automatiquement l'install quand on clique mais pdt l'install on a droit a une erreur "install failed : code error:999"

"install failed : code error:999"

Posté : 10 août 2003, 15:36
par Chadom
Douglas : peux-tu stp me dire qu'elle est ta platforme (navigateur/version et OS) ? car ici sous Mozilla 1.5 et Firebird 0.6 windows je n'ai pas de problème.

Y-a-t-il d'autres personnes qui ont cette erreur ?
merci

Posté : 10 août 2003, 16:10
par Shogix
J'ai encore le message "Package à installer non-valide" (mozilla 1.4 fr-FR windows 2000) :(

Pour ce qui est du .htaccess, chez moi j'ai:
AddType application/x-xpinstall .xpi
AddType application/vnd.mozilla.xul+xml .xul

Et ça marche.

C'est peut-être Free qui ne permet pas l'ajout de types MIME dans la config globale d'Apache?

Posté : 10 août 2003, 16:10
par Douglas
je n'ia plus l'erreur en fait il etait deja installé il ne dois pas aimer :lol:
une fois viré du profile je l'install parfaitment :)

Code : Tout sélectionner

Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.5b) Gecko/20030809 Mozilla Firebird/0.6.1+

Posté : 11 août 2003, 12:48
par Snap
Code 999: impossible d'installer parce que..
Ca aurait été un patch francais pour Mozilla, j'aurais dit qu'il fallait passer en anglais avant d'installer le patch francais.

Bonne idée Chadom, ton extension est bien pratique en effet =)