CSS et XML, une obligation ?

HTML5, CSS3, Javascript, support des mobiles... Que penser de votre site ? Vous manquez d'informations pour la construction d'un site qui puisse s'afficher correctement partout ? C'est un problème simple, un peu complexe ? Venez ici !

Modérateur : Asumbaa

Répondre
eric

CSS et XML, une obligation ?

Message par eric » 21 oct. 2003, 00:03

J'obtiens ce message avec Validator Css, ma page étant validée xhtml
1.0 strict, lorsque je veux valider ma feuille de style :

Invalid byte 2 of 3-byte UTF-8 sequence.
Je précise que je n'ai pas mis dans mon code source avant la déclaration doctype la balise portant <? xml encoding= ?> vu que je considère que ma feuille de style ne constitue pas un fichier xml.
Par contre quand je mets cette balise, le validator CSS me demande de valider tout d'abord mon xml ce que je suis bien incapable de faire, n'ayant de mon point de vue rien de spécifique en xml.
Avez vous déjà été confronté à ce pb ? ( j'en suis donc à vouloir valider ma page en CSS après l'avoir fait en xhtml 1.0 strict )

eric

xml et css, une obligation ?

Message par eric » 21 oct. 2003, 00:06

j'oubliais la page de mon site en question :
http://perso.wanadoo.fr/sed_lex/francais.html

SIBELIUS
Lézard vert
Messages : 146
Enregistré le : 09 sept. 2003, 23:21

Message par SIBELIUS » 21 oct. 2003, 10:39

Le xhtml fait partie des recommendations xml, il faut laisser la doctype entière.

Mais dans ton cas il s'agit d'un problème de charset, tu as défini ton encodage en utf 8, et certains caractères de ta page n'en font pas partie
Tutoriels et blog (X)HTML / CSS : css.alsacreations.com
Forum Standards / CSS : forum.alsacreations.com

mat
g3ck0m4st3r
Messages : 57
Enregistré le : 31 juil. 2003, 04:02

Message par mat » 22 oct. 2003, 16:17


eric

xhtml et css

Message par eric » 22 oct. 2003, 17:44

c'est bon çà marche, j'ai remplacé dans le code source le é par &eacute; et fait de même pour les autres caractères et c'est bon çà a validé.
Merci à tous :lol:

Nucleos
Lézard à collerette
Messages : 282
Enregistré le : 04 juil. 2003, 17:04

Message par Nucleos » 01 nov. 2003, 03:24

je ne vois pas l'intérêt d'utiliser utf-8 si tu as des problèmes d'encodage...
utilise iconv (en php ou console linux) pour transformer tes fichiers d'un encodage à l'autre, ou utilise uniquement iso-8559-15 partout :p
« La clarté est la politesse des professeurs. » (E. Gerurez)
... Posons de bonnes questions !

Bobe
Iguane
Messages : 741
Enregistré le : 28 juil. 2003, 21:29

Message par Bobe » 01 nov. 2003, 05:52

C'est parce que les documents xml utilisent utf-8 comme jeu de caractère par défaut. Si tu veux en utiliser un autre, il faut que tu le spécifies avec le prologue xml ou dans l'entête http Content-Type (avec la fonction header() de php par exemple)
« La vie d’un geek est un combat perpétuel contre l’imperfection »

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités