[Résolu] Problème d'affichage firefox

HTML5, CSS3, Javascript, support des mobiles... Que penser de votre site ? Vous manquez d'informations pour la construction d'un site qui puisse s'afficher correctement partout ? C'est un problème simple, un peu complexe ? Venez ici !

Modérateur : Asumbaa

Répondre
djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

[Résolu] Problème d'affichage firefox

Message par djodjolyon » 09 mai 2008, 05:23

Bonjour,

Je viens de faire un en tete mail mais firefox ne respecte pas la mise en page que je lui ai mis. Ca s'affiche bien sur IE.
Je vous envoi le lien si vous pouvez jeter un oeil!
Merci

http://howelljonathan.free.fr/Forum/email_francais.html

Mes contacts sont censés se trouver juste en dessous du bandeau d'image mais sur FF, il s'affiche en bas dans le cadre noir (décalage de 15px à peu près).
C'est pas beaucoup je sais mais c'est pas terrible quand même!

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Modifié en dernier par djodjolyon le 18 mai 2008, 13:43, modifié 1 fois.

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 17 mai 2008, 15:51

Aucune idée?

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 17 mai 2008, 16:18

Euh... à vrai dire j'ai beau y regarder de près, comparer avec Opera ou Konqueror, je ne vois pas ce qui ne va pas... peut-être faudrait-il préciser un peu ta requête :wink:

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 17 mai 2008, 16:30

J'envoi les capture d'écran sous IE et sous Firefox.
Ca sera plus clair comme ça!!!!

Sous FF
Image

Sous IE
Image

il y a un décalage des paragraphe!

IE affiche correctement du moins comme je veux!

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Benoit
Administrateur
Messages : 4894
Enregistré le : 19 juil. 2003, 10:59

Message par Benoit » 17 mai 2008, 19:32

Ah je comprends maintenant !

Ajoute simplement un

Code : Tout sélectionner

margin-top: 0;
au style de ton paragraphe :

Code : Tout sélectionner

<p style="padding-top:130px; padding-right:10px; margin-top:0;">
Deux remarques sinon : ce serait plus pratique d'externaliser les styles avec des classes.

Et d'autre part, mais ça c'est propre à ta machine, il me semble que le lissage des polices ClearType est activé dans Internet Explorer et non pour le système entier. Je te conseille d'aller changer ça dans tes propriétés d'affichage, panneau Apparence, bouton Effets, et choisir ClearType comme méthode de lissage des polices.
♫ Li tens s'en veit, je n'ai riens fais ;
Li tens revient, je ne fais riens. ♪

Invité

Message par Invité » 17 mai 2008, 21:00

Merci benoit,

J'ai cherché pendant trop longtemps... C'était tout simple!!!!!!!
Ca m'énerve...

Mais bon maintenant ça fait plaisir que ce soit tout beau...

Quand tu dis externaliser les styles avec des classes tu veux dire que je fasse des feuilles de style externes?
Si c'est ça, j'ai peu d'intérêt à faire ça juste pour un email non?

J'ai activé Cleartype. C'est parfait. Le seul pb c'est que si l'autre utilisateur est comme moi et qu'il n'a pas activé cleartype, ça s'affichera pas bien!
J'allais justement te poser la question pour les polices... Bien anticipé!

Je viens de voir mon xp il a tout changé au niveau des polices!!! Titres des fenetres, Bloc note (il est super class maintenant et beaucoup mieu à lire maintenant.... )
Merci encore


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 18 mai 2008, 02:52

Bon je pose ma dernière question...
Il y a aussi un décalage entre IE et FF au niveau du "Bonjour"
C'est pas grave du tout mais je vais me mettre à faire un site internet. Donc ça m'évitera peut-être de vous reposer les mêmes questions...

Il il a plus d'espace avant le mot bonjour sur firefox que sur internet explorer...
J'ai essayer un margin-top:0 et aussi un margin-bottom mais ça n'a rien changé!

Capture IE
Image

Capture Firefox
Image

Je remet le lien de l'email :
http://howelljonathan.free.fr/Forum/email_francais.html

Il me semble que tu gère plutôt bien Benoit....
Tu as une idée cette fois-ci?

Merci

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Thomas
Varan
Messages : 1907
Enregistré le : 07 janv. 2004, 17:29

Message par Thomas » 18 mai 2008, 10:11

http://dowebsitesneedtolookexactlythesa ... owser.com/

TU n'y arriveras jamais (ou à force de trop de persévérances et bidouilles). Chaque moteur d'affichage ets différent, il faut accepter les petites différences :)

Message envoyé avec : Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9) Gecko/2008051202 Firefox/3.0
Anciennement Toto.

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 18 mai 2008, 11:55

C'est probablement de nouveau un problème de marges/paddings qui ne sont pas définis, et dont les valeurs par défaut des différents navigateurs sont différentes.

Ce genre de problème se résout très bien en appliquant un

Code : Tout sélectionner

* {
margin:0;
padding:0;
}
Pour le reste, effectivement, il y aura toujours des différences entre navigateurs. Mais n'oublie pas, il y a encore plus de différences d'un système d'exploitation à un autre, d'une personne qui a modifié des préférences à une autre, et il y a des navigateurs dont tu n'as probablement même pas idée (citons lynx si tu veux voir ton site d'un autre oeil) :wink:

Ce qui compte c'est que ton site soit suffisemment souple pour que tout le monde puisse le lire :wink:

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

djodjolyon
Gecko
Messages : 61
Enregistré le : 15 avr. 2008, 03:09

Message par djodjolyon » 18 mai 2008, 13:42

Merci pour vos réponses...
J'avais précisé que ça n'était pas grave...
C'était juste pour info! Pour savoir si c'était faisable simplement ou pas!


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités