[RESOLU] CSS HELP HELP !!!!!!

HTML5, CSS3, Javascript, support des mobiles... Que penser de votre site ? Vous manquez d'informations pour la construction d'un site qui puisse s'afficher correctement partout ? C'est un problème simple, un peu complexe ? Venez ici !

Modérateur : Asumbaa

Répondre
yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

[RESOLU] CSS HELP HELP !!!!!!

Message par yvancoyaud » 18 mars 2007, 01:56

Bonjour a tous

AU SECOURS
Je galère avec un CSS sous mozilla depui plusieurs jours !!!!!
Votre aide me serait vraiment précieuse !!!!

La feuille de style incriminée
----------------------------------------

Code : Tout sélectionner

@charset "windows-1252";

@media print {
	@page {
		size:21.0cm 29.70cm;
        margin-top:10cm;
        margin-bottom:2cm;
        margin-left:10cm;
        margin-right:2cm
		}

	#MessageImp {
		display: none
		}

	.TarifLibEntete {
		color: navy;
		font-size: 12pt;
		font-family: Arial;
		font-weight: normal;
		font-style: normal;
		}
	.TarifSocEntete {
		color: navy;
		font-size: 12pt;
		font-family: Arial;
		font-weight: normal;
		font-style: normal;
		}
}

@media screen {

#idEnteteSup {display: none}
body { margin: 0em; padding: 0em }

.TarifLibEntete {color: navy; font-size: 14px; font-family: Arial; font-weight: normal; font-style: normal; cursor: default}
.TarifSocEntete {color: navy; font-size: 14px; font-family: Arial; font-weight: normal; font-style: normal; cursor: default}
.........
----------------------------------------

Pourquoi la partie média print de ce CSS ne fonctionne pas.
Tout ce passe comme si cette partie n'existait pas !!
Pas de mise en page,
Le display none ne fonctionne pas
Aucun style n'est pris en compte

Alors que la partie media screen fonctionne parfaitement

Le problème est sous mozilla
Si quelqu'un à une idée, une piste de recherche, un exemple de CSS print qui fonctionne sous mozilla à me soumettre, tout cela serait vraiment bienvenu

Merci de vos réponses....
YC



Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)
Modifié en dernier par yvancoyaud le 19 mars 2007, 22:57, modifié 1 fois.

nico@nc
Animal mythique
Messages : 8038
Enregistré le : 21 août 2005, 08:04

Message par nico@nc » 18 mars 2007, 03:28

Jette un coup d'œil ici : W3C CSS Validation Service

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

Message par yvancoyaud » 18 mars 2007, 06:32

Merci pour cette adresse que je connaissais pas....

J'ai corrigé mes css, mais malheureusement j'ai toujours le meme problème !!!!!!!!!!!!!!

Est-ce que cela vient d'un prametrage de mon navigateur ???
Est-ce que mozilla accepte les css avec media print ????

Bizarre pour un navigateur qui semble plus près de la norme que IE ???

Qu'en pensez-vous ??
YC

Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)

nico@nc
Animal mythique
Messages : 8038
Enregistré le : 21 août 2005, 08:04

Message par nico@nc » 18 mars 2007, 08:01

Et si tu fait une feuille de style séparée par média ? C'est peut-être plus simple et pratique à gérer ;).
yvancoyaud a écrit :Bizarre pour un navigateur qui semble plus près de la norme que IE ???
C'est justement qu'IE à tendance à essayer de lire un peu tout, en déchiffrant tant bien que mal (surtout mal)...

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

Message par yvancoyaud » 18 mars 2007, 08:10

Ce sont deux feuilles de style séparées !!!!
Dans le head j'ai
<link rel="stylesheet" media="screen" type="text/css" title="CSS Bg" href="Bg.css" />
<link rel="stylesheet" media="print" type="text/css" title="CSS print Bg" href="Bg_Imp.css" />

Toutes les deux maintenant verifiees par le validateur de W3C.

Y a t-il autre chose à rajouter ???
YC

Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)

nico@nc
Animal mythique
Messages : 8038
Enregistré le : 21 août 2005, 08:04

Message par nico@nc » 18 mars 2007, 08:14

yvancoyaud a écrit :Y a t-il autre chose à rajouter ???
Oui : si possible l'adresse du site.

Et si ce sont deux feuilles séparées, pourquoi n'y en-t'il qu'une en haut de cette page ?

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

Message par yvancoyaud » 18 mars 2007, 08:28

Pas facile pour le site car il n'est pas encore en ligne, je teste en local avec easyPhp et un navigateur mozilla.

Si au debut de mon message il n'y a qu'un css, cétait pour plus de simplicité sur ce forum.
Je vais essayer de mettre qquechose en ligne et donner l'url ici.

YC

Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 18 mars 2007, 10:07

Il y a tellement de possibilités que c'est difficile de dire...

Comment insères-tu ta CSS ? Est-ce que ça marche si elle est insérée directement dans la page ?
Y a-t-il des erreurs dans la console d'erreurs ?

Sans pouvoir le voir, ça risque d'être difficile :?

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.2) Gecko/20070220 Firemarsupilami Firefox/2.0.0.2

yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

Message par yvancoyaud » 18 mars 2007, 12:06

Oui je sais Je vais essayer de mettre qqchose en ligne.

Mais avant je vais essayer de mettre mon CSS dans la page pour voir si ça marche.
Merci pour cette piste ...
YC

Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)

Flore
Administratrice
Messages : 3563
Enregistré le : 19 nov. 2003, 23:04

Message par Flore » 18 mars 2007, 15:06

Size : propriété de CSS2 retirée de CSS2.1
Donc à ne pas utiliser !
Du coup, utiliser width et height

Message envoyé avec : Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Flore
Mac OSX + Nightly / Laptop Linux Mint + Nightly / Nightly sur Android

Asumbaa
Tyrannosaurus Rex
Messages : 2411
Enregistré le : 08 déc. 2004, 20:07

Message par Asumbaa » 19 mars 2007, 11:17

Salut,

Et ne pas utiliser d'attribut title pour tes feuilles de style (sert uniquement pour les styles alternatifs)

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

yvancoyaud
Arias
Messages : 11
Enregistré le : 13 mars 2007, 07:43

[RESOLU] CSS HELP HELP !!!!!!

Message par yvancoyaud » 19 mars 2007, 14:09

Bien vu !!!!!!!!!!

Il m'a suffit de retirer l'attribut title de mes lignes link pour que tout rentre dans l'ordre :D

Mille fois merci

YC

Message envoyé avec : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; SV1; .NET CLR 2.0.50727)

carolinepp

css media="print" sous FF 2.0 OK

Message par carolinepp » 04 juil. 2007, 14:38

OUI sans les attributs title, ça va mieux!!!!
ça fait un jour que je cherche WOUAHOU


MERCI MERCI




Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061025 BonEcho/2.0

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités