Le script de geckozone et FF 1.5

HTML5, CSS3, Javascript, support des mobiles... Que penser de votre site ? Vous manquez d'informations pour la construction d'un site qui puisse s'afficher correctement partout ? C'est un problème simple, un peu complexe ? Venez ici !

Modérateur : Asumbaa

Répondre
Hoaxyde
Lézard à collerette
Messages : 207
Enregistré le : 27 févr. 2004, 21:24

Le script de geckozone et FF 1.5

Message par Hoaxyde » 11 nov. 2005, 17:43

Le script "Nice titles" de geckozone rencontre un bug très gênant avec Firefox 1.5 : les "bulles" se mettent à clignoter une fois avant de se stabiliser...
Je viens de vérifier ; je n'ai ce problème qu'en utilisant la version 1.5 (RC 1 parce que la 2 pas encore dispo en fr, mais avec cette dernière c'est la même chose).

Très embêtant n'est-ce pas :?

Si quelqu'un connaît un brin le JS...

a+
Hoaxyde :lol:

Dessin de l'avatar par L.L. de Mars . Colorisation, arrangements et tout le reste par moi...

chBok
Iguane
Messages : 990
Enregistré le : 17 oct. 2003, 19:17

Message par chBok » 11 nov. 2005, 18:49

+1
Je viens de tester sous FF1.5RC1 - Mandrake 10.1, et je confirme.

Bizarre.

Hoaxyde
Lézard à collerette
Messages : 207
Enregistré le : 27 févr. 2004, 21:24

Message par Hoaxyde » 11 nov. 2005, 20:36

Le plus intriguant c'est que chez moi si j'approche la souris tout doucement, FF est pris par surprise :lol: , et pas de clignotement :shock:
Hoaxyde :lol:

Dessin de l'avatar par L.L. de Mars . Colorisation, arrangements et tout le reste par moi...

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 11 nov. 2005, 21:08

On notera que ça ne clignotte pas (en tous cas chez moi) dans la 1.0.7 :wink:

Hoaxyde
Lézard à collerette
Messages : 207
Enregistré le : 27 févr. 2004, 21:24

Message par Hoaxyde » 11 nov. 2005, 21:15

calimo a écrit :On notera que ça ne clignotte pas (en tous cas chez moi) dans la 1.0.7 :wink:
Moi pareil, ça ne fait ça qu'avec la 1.5 :(
Hoaxyde :lol:

Dessin de l'avatar par L.L. de Mars . Colorisation, arrangements et tout le reste par moi...

Kristal_be
Salamandre
Messages : 41
Enregistré le : 28 avr. 2005, 18:07

Message par Kristal_be » 11 nov. 2005, 22:54

C'est quoi ce script ? :roll:

chBok
Iguane
Messages : 990
Enregistré le : 17 oct. 2003, 19:17

Message par chBok » 12 nov. 2005, 10:31

Kristal_be a écrit :C'est quoi ce script ? :roll:
C'est le script des "nicetitle" : http://www.geckozone.org/squelettes/nicetitle.js
Il gère les attributs class="nicetitle" sur les balises <a href="" title="" /> en transformant l'infobulle classique du title en nicetitle !

:idea: Si le clignotement ne se produit pas lorsque la souris s'avance doucement, il faudrait peut être ajouter un délai supplémentaire sur la ligne de création ici :

Code : Tout sélectionner

NiceTitles.autoCreated.anchors = new NiceTitles("<p class="titletext">attr(nicetitle)</p>", 100, 600);
en augmentant la valeur du 100 (millisecondes).

Hoaxyde
Lézard à collerette
Messages : 207
Enregistré le : 27 févr. 2004, 21:24

Message par Hoaxyde » 12 nov. 2005, 12:42

Quand on monte cette valeur à 500 par exemple, le nt s'affiche pendant une milliseconde puis se réaffiche au bout des 500 mls qu'on a spécifié : le problème est donc que le nicetitle s'affiche quelle que soit la valeur au bout du quel il doit se montrer, puis il se cache immédiatement pour se rafficher au du temps spécifié...
Hoaxyde :lol:

Dessin de l'avatar par L.L. de Mars . Colorisation, arrangements et tout le reste par moi...

HP
Tyrannosaurus Rex
Messages : 2196
Enregistré le : 21 oct. 2004, 10:25

Re: Le script de geckozone et FF 1.5

Message par HP » 12 nov. 2005, 16:41

Hoaxyde a écrit :Le script "Nice titles" de geckozone rencontre un bug très gênant avec Firefox 1.5
ne serait ce pas un bug de FF 1.5 ?
parce que sous Flock (Fork issu de 1.5, si je ne me trompe)
ainsi que sous Opera, je ne rencontre aucun bug !

par contre ce que je trouve "gênant", c'est que l'attribut title soit utilisé de la sorte (afficher beaucoup de contenu),
en effet, l'attribut title n'aurait peu (voire aucun) poids en référencement,
cela ferait donc beaucoup de contenu qui échappe aux divers moteurs de recherche ! :(

dommage.

“La médiocrité obtiendra immanquablement la préséance en se travestissant des oripeaux de la bienséance.”

Hoaxyde
Lézard à collerette
Messages : 207
Enregistré le : 27 févr. 2004, 21:24

Message par Hoaxyde » 12 nov. 2005, 19:09

Non non, avec Flock, même problème !
Sinon ce n'est pas un obstacle au référencement vu que le contenu est accessible pour les moteurs sur la page en lien. Il ne s'agit qu'une prévisualisation de la page qu'on va visiter.
Hoaxyde :lol:

Dessin de l'avatar par L.L. de Mars . Colorisation, arrangements et tout le reste par moi...

Benoit
Administrateur
Messages : 4894
Enregistré le : 19 juil. 2003, 10:59

Message par Benoit » 13 nov. 2005, 11:05

Je ne vois absolument pas de problème avec la RC1 Windows, si c'est une régression au niveau de Linux je ne vois pas trop ce qu'on peut faire en JavaScript pour la réparer de toute façon.
♫ Li tens s'en veit, je n'ai riens fais ;
Li tens revient, je ne fais riens. ♪

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités