Problèmes de DIV

HTML5, CSS3, Javascript, support des mobiles... Que penser de votre site ? Vous manquez d'informations pour la construction d'un site qui puisse s'afficher correctement partout ? C'est un problème simple, un peu complexe ? Venez ici !

Modérateur : Asumbaa

Répondre
ziguezig
Arias
Messages : 8
Enregistré le : 01 nov. 2003, 22:07

Problèmes de DIV

Message par ziguezig » 07 janv. 2004, 17:46

J'ai un souci pour créer ma page web.

Pour l'instant j'ai ça: http://cefos.free.fr
Ca s'affiche bien sous IE (tiens donc !?!) mais j'arrive pas à le faire afficher correctement sous firebird.

Ma feuille de style est là: http://cefos.free.fr/styles/classic.css.

Si il ya une bonne âme qui pourrait me dire comment résoudre ce pb!
merci d'avance

LezeuS
Lézard vert
Messages : 158
Enregistré le : 29 juil. 2003, 19:00

Message par LezeuS » 07 janv. 2004, 19:26

Bon, je vais essayer ( je n'ai que des connaissances maigres )
Ton bloc texte est en float: right .
Si tu veux qu'il soit à droite du bloc lien, il faudrait réduire un peu sa largeur étant donné qu'en cet état, tu ne peux pas mettre le bloc lien et le bloc texte sur une même ligne à cause d'une trop grosse largeur quand tu sommes les deux par rapport à la largeur du conteneur.
Il n'y a pas ce probleme sous IE car pour lui, les marges et padding que tu as mis sont contenus dans la largeur initial donnée ( width ), ce qui n'est pas le cas dans les normes ( et donc pour Mozilla ;) )ou là, ca s'ajoute à la largeur initiale donnée ( un bloc de 250 px et de 25 px de marge à droite et à gauche fera 300 px sous moz et 250 px sous IE )...

Je me rends compte que je ne suis pas très clair, désolé. Enfin, essaye avec ca, et puis dis-nous si ca marche pas. ;)

bobo
Iguane
Messages : 764
Enregistré le : 18 août 2003, 11:04

Message par bobo » 07 janv. 2004, 22:49

LezeuS a écrit :Il n'y a pas ce probleme sous IE car pour lui, les marges et padding que tu as mis sont contenus dans la largeur initial donnée ( width ), ce qui n'est pas le cas dans les normes ( et donc pour Mozilla ;) )ou là, ca s'ajoute à la largeur initiale donnée.
Rappelons au passage l'excellent article d'OpenWeb : Gérer les modèles de boîtes CSS standard et Microsoft
Les standards c'est bon, mangez en !
Flore & Sébastien
Unité dans la diversité.

-Nicolas-

Message par -Nicolas- » 11 janv. 2004, 17:55

Ca ressemble quand même énormément à l'un des styles sur CSSZenGarden :?
http://www.csszengarden.com/?cssfile=/0 ... css&page=3
Change au moins les couleurs :wink:

ziguezig
Arias
Messages : 8
Enregistré le : 01 nov. 2003, 22:07

Message par ziguezig » 11 janv. 2004, 22:47

je sais c'etait fait exprès!

c'était juste pour m'entraîner et j'avais pris ce site comme modèle.

:?

ziguezig
Arias
Messages : 8
Enregistré le : 01 nov. 2003, 22:07

Message par ziguezig » 12 janv. 2004, 14:35

C'est encore moi!

Cette fois ci j'ai deux problèmes sous firebird 0.7-en:

1. Sur http://cefos.free.fr/index.html l'image ne s'affiche pas chez moi (en local ca marche :? )

2. sur http://cefos.free.fr/index.php les liens du menu ne sont plus clickable.
feuille de style: http://cefos.free.fr/themes/cefos/style.css

ps: dans les deux cas ca marche tres bien sous IE6 (tiens donc ?!?)

encore merci de m'aider

bobo
Iguane
Messages : 764
Enregistré le : 18 août 2003, 11:04

Message par bobo » 12 janv. 2004, 16:17

ziguezig a écrit :1. Sur http://cefos.free.fr/index.html l'image ne s'affiche pas chez moi (en local ca marche :? )
Attention à la confusion entre \ et / dans les chemins des fichiers...
ziguezig a écrit :2. sur http://cefos.free.fr/index.php les liens du menu ne sont plus clickable.
feuille de style: http://cefos.free.fr/themes/cefos/style.css
Je n'ai rien remarqué de tel (Mozilla 1.5 fr), peut-être que tu as une mauvaise version d'un des fichiers dans ton cache (ça arrive quand on fait plein de modifs de suite sur une page ou une CSS)
Les standards c'est bon, mangez en !
Flore & Sébastien
Unité dans la diversité.

Romuald
Gecko
Messages : 88
Enregistré le : 03 sept. 2003, 23:55

Message par Romuald » 13 janv. 2004, 23:07

Les zones non cliquable ça arrive quand on code mal, j'ai souvent eu ses problèmes au début.
Il faut bien placer les blocs dans le code html puis bien les positionner en css.
Nul besoin d'être comme son voisin pour l'apprécier, c'est la différence qui fait que le monde est intéressant.
Voyons plus loin que le bout de notre nez.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité