extension : Delete Icons 0.1.2

Vous pouvez discuter dans cette catégorie des logiciels et extensions tiers créés à partir des technologies Mozilla.
Répondre
rawbrol
Arias
Messages : 8
Enregistré le : 09 oct. 2004, 23:54

extension : Delete Icons 0.1.2

Message par rawbrol » 13 nov. 2005, 15:36

Bonjour,

Je viens d'installer Delete Icons 0.1.2, provenant de ce site, croyant que cette extension allait me réinitialiser mes icones de bookmark une par une, mais (O malheur !), c'est toutes les icones de tous mes bookmarks qui ont disparus....
J'ai alors supprimé cette extension, et même installé Favicon Picker 0.2.5, mais aucune icone provenant d'un site ne veut plus s'afficher dans mes bookmarks, grrrrrrrrrr.... :oops:

J'ai cherché sur le web si quelqu'un connaissait le problème, mais ça n'a rien donné, alors si une bonne âme à la solution pour pouvoir revoir des icones dans les bookmarks, je suis preneur :D

ma config :
User Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Avatar du membre
Mori
Animal mythique
Messages : 13310
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 14 nov. 2005, 17:00

salut,
ferme éventuellement la barre latérale (ctrl B), ferme le fox; supprime les dossiers chrome et extensions dans ton profil, et pas ailleurs et réinstalle tes extensions et thèmes.
Linux openSUSE Leap 15.2 (Gnome)

rawbrol
Arias
Messages : 8
Enregistré le : 09 oct. 2004, 23:54

Message par rawbrol » 15 nov. 2005, 17:59

Merci Mori de me répondre :)
Ton conseil est judicieux, mais j'ai posté ma demande pour éviter d'en arriver là....j'ai 32 extensions installées (pas de thème), et aurait voulu éviter de tout réinstaller....cela dit, j'ai malheureusement l'impression que si je veux revoir des icones dans mes bookmarks, je vais devoir en passer par là.
Je vais cependant encore attendre un peu, histoire de voir si quelqu'un aurait pas une solution plus "pointue", genre micro-chirurgie quoi.

Avatar du membre
Mori
Animal mythique
Messages : 13310
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 15 nov. 2005, 18:18

de la micro-chirurgie ? ok
dans ton profil :
a) dossier extension
tu supprimes le fichier qui correspond à ton extension; facile, elle a un nom du genre {1a333147-8720-4f31-948e-b790af516d49}
tu ouvres (avec un éditeur genre wordpad, notepad) Extensions.rdf tu supprimes les lignes correspondant à {1a333147-8720-4f31-948e-b790af516d49} ainsi que la totalité des lignes nommant ton extension et enchassées entre <RDF:Description> et </RDF:Description> (y compris ces deux balises)
tu enregistres bien sûr.

b) dossier chrome
tu édites chrome.rdf et tu fais la même chose pour le coup du <RDF:Description> et </RDF:Description>

c) voilàààà :P
Linux openSUSE Leap 15.2 (Gnome)

rawbrol
Arias
Messages : 8
Enregistré le : 09 oct. 2004, 23:54

Message par rawbrol » 16 nov. 2005, 19:50

Mori, ton scapel est bien affuté :) malheureusement, il n'y a rien qu'il ne puisse enlever....
L'extension Delete Icons rajoute le rep d'install suivant :
C:\WINDOWS\Application Data\Mozilla\Firefox\Profiles\xxx.default\extensions\{44895a48-6ac9-4b70-9f57-23346497132e}
(précision (un peu inutile) je suis en 98, donc mon profil est dans C:\Windows, pas dans C:\Documents and Settings)
Or, après déinstallation de l'extension, si je fais une recherche de de la chaine 44895a, dans n'importe quel fichiers de mon profil, le résultat est nada, walou, zerg....donc à fortiori, les .rdf (chrome et extension) dont tu parles ne contiennent pas cette chaine. Ni d'ailleurs malheureusement d'infos enchassées dans des balises <RDF> concernant cette extension. Idem pour le contenu de mon C:\Program Files\Mozilla Firefox
J'ai poussé la recherche sur la chaine deleteicons ou même delete tout court, pour voir, mais aucun résultat non plus.
Cette extension à bien fait le ménage lors de sa désinstallation, et je suppose que, quand je l'ai utilisé, elle m'a simplement viré une ligne de mon about:config , ou bien qu'elle a passé une valeur de true à false (ou l'inverse).
Ou alors, elle a crée un bug avec une de mes extensions installées (cela dit, tout fonctionne, navigateur et extensions présentes).

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité