Empecher telechargement fichier

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

Répondre
loicB
Arias
Messages : 4
Enregistré le : 14 oct. 2008, 15:16

Empecher telechargement fichier

Message par loicB » 15 oct. 2008, 09:24

Bonjour!!

Je suis actuellement en entreprise et j'ai besoin de bloquer le telechargement de fichier pdf sur Mozilla.
En effet, j'utilise un logiciel internet permettant la gestion de document pdf. Cependant, les document present ne doivent pas etre telechargés par l'utilisateur (consigne de la direction...). Bref, J'ai bloqué tous les telechargement sur IE, et sur firefox, j'ai enlevé l'onglet "enregistrer sous". Cependant, losqu'un utilisateur clique sur un document, cela ouvre une fenetre et 2 choix lui sont proposés:

"ouvrir" et "telecharger". Comment enlevé le choix telecharger ou alors comment directement ouvrir le fichier pdf sans avoir a passé par cette etape??

Si quelqu'un à une idée!! Merci d'avance

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

hibou57
Gecko
Messages : 52
Enregistré le : 13 juin 2005, 16:55

Message par hibou57 » 15 oct. 2008, 09:57

Good morning, sba7 nnour,

Il existe effectivement dans le plugin PDF, une barre d'outil qui permet d'enregistrer le document. Ce qui signifie logiquement que c'est au niveau du document PDF que tu dois maintenant traiter le cas, puisque tu l'as déjà traité au niveau de FireFox, qui n'a d'ailleurs pas la possibilité de manipuler le comportement du plugin PDF (on ne peut pas attendre d'un navigateur qu'il fasse ce qu'il n'est pas censé avoir en charge).

Les documents PDF intègrent une notion de droit d'utilisation. Par exemple, un document PDF peut être marqué comme non-modifiable.

Je ne suis pas spécialiste en matière de production de document PDF, mais je pense qu'il faudrait plutôt que tu t'oriente du côté de la gestion des droits propres au document.

Sans en être certain, je pense qu'il est trés probable qu'il existe un « flag » de ce type (interdisant la copie depuis le plugin de lecture).

Si c'est pour une entreprise, ton entreprise a peut-être un contrat avec Adobe.... si c'est le cas, il ne faut pas se priver de contacter le support Adobe : c'est à ça que ça sert les licences avec support ;)


Message envoyé avec : Opera/9.60 (Windows NT 5.1; U; fr) Presto/2.1.1

jpj
Animal mythique
Messages : 25238
Enregistré le : 01 août 2005, 15:38

Message par jpj » 15 oct. 2008, 11:20

Bonjour,

Dans Acrobat, il faut sélectionner pour les options internet "Afficher dans le navigateur".

Dans Firefox, Outils > Options > Applications. Pour Adobe Acrobat Document, choisir "Utiliser Adobe Acrobat (dans Firefox).

Le document est alors ouvert dans un nouvel onglet ou dans une nouvelle fenêtre de Fierfox selon sa configuration. Cependant, le document est quand même téléchargé dans \Local Settings\Temp\. Le fichier temporaire est cependant verrouillé et effacé à la fermeture du document. Il reste néanmoins la possibilité d'enregistrer le pdf avec un Ctrl+S ou avec les outils de la barre d'outils d'Acrobat. Il faut donc configurer Acrobat ou les autorisations dans le document pour que l'enregistrement soit interdit.
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

loicB
Arias
Messages : 4
Enregistré le : 14 oct. 2008, 15:16

Message par loicB » 15 oct. 2008, 11:52

Re bonjour!!!

Tout d'abord, merci de vos reponse, cependant, je n'ai pas du etre très clair, je veux juste griser ou cacher l'option "enregistrer sur le disque".
J'ai deja enlevé l'option dans la barre d'outils. Je sais que je pourrais toujours l'enregistrer avec ctrl+s ou le trouver dans local Settings/temp mais bon, ma hierarchie me demande de supprimer cette petite option. Si ce n'est pas possible bien sur, j'essairais de leur faire comprendre mais bon.

Merci d'avace


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

jpj
Animal mythique
Messages : 25238
Enregistré le : 01 août 2005, 15:38

Message par jpj » 15 oct. 2008, 12:14

Je n'ai rien trouvé comme réglage dans about:config qui permette de faire ça. Tout ce que j'ai pu voir, c'est l'option browser.helperApps.neverAsk.saveToDisk qui fait exactement le contraire (enregistrement sans boîte de dialogue). Normalement, avec les réglages que j'ai indiqué, la fenêtre de choix n'est pas affiché et le pdf est ouvert directement dans la fenêtre de Firefox.

Il faut cependant vérifier que le type MIME envoyé par le serveur pour les fichier PDF est correct, sinon, il doit être impossible d'éviter la boîte de dialogue.
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

loicB
Arias
Messages : 4
Enregistré le : 14 oct. 2008, 15:16

Message par loicB » 15 oct. 2008, 13:12

re bonjour!!

Euh, je ne trouve pas l'onglet application dans les outils. Lorsque je clique sur outils, j'ai 7 onglets qui sont :
general, onglets, contenu, flux, vie privée, sécurité, avancé.

Les options de telechargement se trouve dans general mais il n'y a que:
[checkbox] Afficher la fenetre des telechargements...
[checkbox] fermer la fenetre après telechargement

enregistrer les fichier dans ...
toujours me demander ou enregistrer

Que faire??

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

loicB
Arias
Messages : 4
Enregistré le : 14 oct. 2008, 15:16

[resolu]Empecher telechargement fishier

Message par loicB » 15 oct. 2008, 13:40

Re bonjour

Bon, alors en fait c'est bon, j'ai trouvé une solution, j'ai telecharger l'adn pdf download et j'ai mis comme action obligatoire lors de la lecture d'un pdf k'il l'ouvre dans adobe et non qu'il le telecharge!!

Tout ca pour ca!!!!!!!!

Merci beaucoup de vous etre penché sur le sujet

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17

jpj
Animal mythique
Messages : 25238
Enregistré le : 01 août 2005, 15:38

Message par jpj » 15 oct. 2008, 15:33

Excuse-moi, je n'ai pas fais attention que tu étais sous Firefox 2. Dans la version 2, c'est Outils > Options > Contenu / Types de fichiers > Gérer mais je ne suis pas certain que ce soit plus efficace ou plus simple que la solution que tu as trouvé.
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : doubleton et 8 invités