Impossible de me connecter à localhost

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : jpj, myahoo, nico@nc, Mori

Répondre
prfabio

Impossible de me connecter à localhost

Message par prfabio »

Bonjour à tous,

J'ai effectué une recherche et lu le guide pour les débutants mais je n'arrive pas à résoudre mon soucis.

Quand je tape bêtement "localhost" dans la barre de navigation il me la transforme de cette manière "http://www.localhost.com/".
J'ai ouvert au cas ou le port 80 dans ma neuf box, mais le soucis est toujours là!
J'ai peut etre activé une fonction, mais laquelle?

Merci pour votre aide

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Nuxi@
Varan
Messages : 1411
Inscription : 21 févr. 2004, 22:18

Message par Nuxi@ »

Pas clair ... Que souhaite-tu faire exactement ?

Si je ne m'abuse, on ne peut pas se connecter à sa propre machine locale via une barre d'adresse.


Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Image
Image
Invité

Message par Invité »

On peut accéder à http://localhost:80 si un serveur HTTP écoute sur le port 80.
Invité

Message par Invité »

Alors n'étant pas très doué dans le webmastering, j'ai installé apache, et on peut se connecter en tapant 127.0.0.1 ou sur l'adresse http://localhost/ dans la barre de navigation pour le php.

Mon soucis est que je peux bien me connecter sur 127.0.0.1 par contre quand je tape http://localhost/, il cherche http://www.localhost.com

Donc j'aimerai connaitre le moyen d'éviter à FF de chercher www mais de chercher juste l'adresse que j'indique.

J'espere que j'ai été clair! :D



Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Invité

Message par Invité »

Normalement c'est le système d'exploitation qui s'occupe de ça. Un autre navigateur donne-t-il la même chose ?
prfabio

Message par prfabio »

Anonymous a écrit :On peut accéder à http://localhost:80 si un serveur HTTP écoute sur le port 80.
J'ai essayé et hop il me modifie l'adresse en http://www.localhost.com/

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Noz
Varan
Messages : 1387
Inscription : 23 sept. 2008, 17:24

Message par Noz »

Salut,

Vérifie dans C:\WINDOWS\system32\drivers\etc que le fichier hosts contient bien la ligne "127.0.0.1 localhost"

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
prfabio

Message par prfabio »

J'aurai du vous le dire au moment du message, pas de soucis j'ai bien cette ligne.

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Invité

Message par Invité »

Personne ne sait comment je pourrai virer cette option?
Merci et désolé de relancer le post

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
PMLux
Arias
Messages : 6
Inscription : 15 oct. 2008, 19:38

Message par PMLux »

Hello

Il y a une différence entre accéder a 127.0.0.0 et accéder a localhost.
Car pour que l'ordinateur comprenne OU aller pour afficher le contenu de localhost, il faut qu'il sache a quelle adresse correspond localhost...

Hors cette "translation" entre le nom et les chiffres est effectué par un serveur DNS (ou serveur de noms en francais), qui fait la corrélation entre lettres compréhensibles et adresse ip qui l'est moins.

Je suppose que si tu poses la question tu as installé un système de serveur local genre WAMP par exemple? Cette option DNS "locale" est elle active?

Car si elle ne l'est pas... le navigateur utilise les données qu'il a concernant la connexion réseau (que ce soit wifi, cable réseau ou usb) il va chercher le paramètre serveur DNS, et lui pose la question (oh, localhost c'est qui?) comme le serveur DNS en question est dans la partie WAN (a l'extérieur de chez toi), la recherche se fait sur une base d'extensions diverses...

Donc vérifie les paramètre de ton serveur local et le cas échéant active le dns local. Sinon parcours la doc pour savoir comment associer des noms aux ip ;)


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
prfabio

Message par prfabio »

Merci pour ta réponse PMLux!
En fait je suis en train de régler ce soucis de connexion à localhost sur un autre forum.
Par contre mon soucis est vraiment cette ajout de www, dans FF, quand je tape tout bêtement localhost dans la barre de navigation!

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Nuxi@
Varan
Messages : 1411
Inscription : 21 févr. 2004, 22:18

Message par Nuxi@ »

Le seul moyen via la barre d'adresse-> taper file://localhost/

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Image
Image
calimo
Animal mythique
Messages : 14118
Inscription : 26 déc. 2003, 11:51

Message par calimo »

Nuxi@ a écrit :Le seul moyen via la barre d'adresse-> taper file://localhost/
Euh... je pense que c'est plutôt http://localhost/ :wink:
Nuxi@
Varan
Messages : 1411
Inscription : 21 févr. 2004, 22:18

Message par Nuxi@ »

Bah non justement, le sujet montre que cela ne marche pas chez prfabio (ni chez moi, d'ailleurs) ... alors que file://localhost/, mène bien au fichier hôte local.


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Image
Image
Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 16 invités