[RÉSOLU] Erreur à l'ouverture de lien à partir de T-bird

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : jpj, myahoo, nico@nc, Mori

manu.p
Salamandre
Messages : 48
Inscription : 03 juil. 2014, 16:12

[RÉSOLU] Erreur à l'ouverture de lien à partir de T-bird

Message par manu.p »

Bonjour,

Ubuntu 18.04.2, Thunderbird 60.6.1 (64 bits) et Firefox 67.0 (64 bits)

Je lance T-Bird avec les options --no-remote -P pour choisir un profil au démarrage (perso ou pro) et lorsque sur un profil j'ai un mail avec un lien/URL sur lequel je clique, alors que Firefox est déjà lancé (pas de profils sur FF, il n'y a que default), j'ai l'erreur :
Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.
Si FF n'est pas lancé au moment où je clique dans le lien du mail, il se lance et un nouvel onglet affiche la page correspondante à l'URL. OK.

J'ai touché les paramètres de T-Bird pour être en mesure de choisir le navigateur pour des liens http(s), et lorsque je choisis Brave : pas de pb, un nouvel onglet est ouvert qui affiche la page demandée dans Brave.

Seul FF me pose ce soucis. Comment le corriger ? Merci.
Dernière modification par manu.p le 03 juin 2019, 19:33, modifié 1 fois.
manu'
Gloops
Tyrannosaurus Rex
Messages : 2769
Inscription : 22 mai 2006, 11:55

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par Gloops »

Bonjour,
Si des fois les réponses tardaient à venir ici, je suggère de poser la question dans un forum Ubuntu.
Par exemple là on explique comment arrêter un programme planté :
https://www.pcastuces.com/pratique/astuces/2894.htm
(C'est sur Google que j'ai trouvé ça, sur la recherche "Ubuntu forcer l'arrêt d'un programme".)
Mais si le problème se pose fréquemment, probablement faudra-t-il réinstaller Firefox.
On peut commencer par ouvrir Firefox sans extensions : si ça marche mieux, c'est que c'est une extension qui pose problème, il faut en réactiver une moitié, puis l'autre, pour savoir dans quelle moitié est l'extension à problème. Et continuer avec une moitié plus petite ...
manu.p
Salamandre
Messages : 48
Inscription : 03 juil. 2014, 16:12

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par manu.p »

Merci @Gloops, je pose la question sur ubuntu-fr.org.

Je ne pense pas que ce soit lié spécifiquement à Ubuntu, plutôt au fait que depuis récemment j'utilise des profils T-Bird. Je ne cherche par à killer FF, mais simplement à ce qu'un lien cliqué dans T-Bird s'ouvre dans FF, comme ce fut toujours le cas avant que je n'utilise des profils T-Bird.

Je suppose que le problème vient des profils T-Bird, le changement de comportement étant apparemment lié au moment où j'ai commencé à les utiliser.

Sans aucune extension active dans FF, le comportement est identique.
manu'
Gloops
Tyrannosaurus Rex
Messages : 2769
Inscription : 22 mai 2006, 11:55

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par Gloops »

Ah mais j'aurais cru que T-Bird était une abréviation de Thunderbird ?
D'ailleurs je n'ai rien trouvé là-dessus, ou plutôt trop, car le nom est tellement répandu qu'on dépasse une page de résultats de recherche avant de tomber sur quelque chose qui concerne Thunderbird.
Ayant lu "Seul FF me pose ce soucis" j'ai plutôt cherché du côté de Firefox. D'ailleurs, classiquement, si un lien ne s'ouvre pas dans le navigateur par défaut, ça ne serait pas la première fois que ça serait un symptôme d'un souci du côté du navigateur par défaut. Parfois le lien ne s'ouvre pas du tout, parfois il ne s'ouvre que si le navigateur est déjà ouvert, parfois il ne s'ouvre que si ce n'est pas le cas.
Apparemment, il va falloir faire attention de fournir des référentiels suffisamment explicites, sinon ça risque de ralentir la résolution.
manu.p
Salamandre
Messages : 48
Inscription : 03 juil. 2014, 16:12

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par manu.p »

OK @Gloops, je ne suis pas le premier à écrire T-Bird pour Thunderbird, mais TB ira pour la suite.

J'ai mentionné : Ubuntu 18.04.2, Thunderbird 60.6.1 (64 bits) et Firefox 67.0 (64 bits)

"Seul FF me pose soucis" par rapport à tous les autres navigateurs à disposition, dont Brave, comme indiqué.

Là, en l'occurrence TB passe bien l'URL à FF (ou autre), mais FF répond qu'il est déjà running, au lieu d'ouvrir un nouvel onglet pour afficher la page du lien passé. C'est confirmé par le test d'arrêter FF avant de cliquer dans le lien du mail dans TB, FF est alors lancé et un nouvel onglet est ouvert avec la page demandée.

Je pense qu'une réponse est ici, je vais tester dès que j'ai une minute pour ça.
manu'
Gloops
Tyrannosaurus Rex
Messages : 2769
Inscription : 22 mai 2006, 11:55

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par Gloops »

manu.p a écrit : 03 juin 2019, 14:52 OK @Gloops, je ne suis pas le premier à écrire T-Bird pour Thunderbird, mais TB ira pour la suite.
Tu as dit :
Je suppose que le problème vient des profils T-Bird, le changement de comportement étant apparemment lié au moment où j'ai commencé à les utiliser.
Or, Thunderbird ne peut fonctionner qu'avec un profil défini, donc j'étais perdu ...
Si je comprends bien, tu en as créé un autre mais qui comporterait une erreur ?
J'ai mentionné : Ubuntu 18.04.2, Thunderbird 60.6.1 (64 bits) et Firefox 67.0 (64 bits)

"Seul FF me pose soucis" par rapport à tous les autres navigateurs à disposition, dont Brave, comme indiqué.
OK OK.
Là, en l'occurrence TB passe bien l'URL à FF (ou autre), mais FF répond qu'il est déjà running, au lieu d'ouvrir un nouvel onglet pour afficher la page du lien passé. C'est confirmé par le test d'arrêter FF avant de cliquer dans le lien du mail dans TB, FF est alors lancé et un nouvel onglet est ouvert avec la page demandée.
Oui il semblerait bien que ça soit un dysfonctionnement de Firefox, car il est supposé pouvoir ouvrir un onglet en étant déjà ouvert.
Je pense qu'une réponse est ici, je vais tester dès que j'ai une minute pour ça.
Ça a effectivement l'air de parler du même sujet ...
manu.p
Salamandre
Messages : 48
Inscription : 03 juil. 2014, 16:12

Re: Erreur à l'ouverture de lien à partir de T-bird

Message par manu.p »

manu'
Gloops
Tyrannosaurus Rex
Messages : 2769
Inscription : 22 mai 2006, 11:55

Re: [RÉSOLU] Erreur à l'ouverture de lien à partir de T-bird

Message par Gloops »

Bonne nouvelle.
D'après ce que je comprends tu ajoutais l'option -no-remote à la ligne de commande de Thunderbird, ce qui n'est plus nécessaire depuis la version 60.7
Je n'ai jamais utilisé cette option jusque là, donc maintenant qu'il ne faut plus s'en servir c'est probablement un peu tard pour que j'essaie de savoir à quoi ça sert.
Mais si jamais quelqu'un utilise ça sur un autre système ça peut être bon qu'il sache.
Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 17 invités