Modules complémentaires désactivés

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

Markco
Iguane
Messages : 509
Enregistré le : 15 juil. 2005, 09:03

Re: Modules complémentaires désactivés

Message par Markco » 07 mai 2019, 16:35

Ce que je n'arrive pas à comprendre dans ce dysfonctionnement, c'est pourquoi les fixes xpi n'ont pas été mis à disposition par Mozilla pour un téléchargement direct. Ca aurait été une bonne solution pour des utilisateurs comme moi qui n'ont jamais eu les fixes par l'intermédiaire de cette fameuse étude, encore un beau raté de la part de Mozilla.
OS: Windows 10_64bits - 2004 / Linux Mint 19.3 - kernel : 5.0.0-37_64Bits /--/ Profil FireFox : 78.3.1 ESR /--/ Profil WaterFox : 2019.12 /--/ Profil ThunderBird : 60.9.1

Avatar du membre
Cucurbitacé
Tyrannosaurus Rex
Messages : 4957
Enregistré le : 22 juil. 2012, 05:27

Re: Modules complémentaires désactivés

Message par Cucurbitacé » 07 mai 2019, 16:53

Robert Mitchum a écrit :
06 mai 2019, 16:03
[...]

Ils en font un métier maintenant : sommelier en cannabis ; c’est que je viens de voir chez Celine Galipeau !




Pour les autres :
Putain les solutions qui fonctionnent à 100 % ont été données, alors faites un effort pour lire.
En bon français de France : Wallah la vie ta mère ?!

1° => https://ftp.mozilla.org/pub/firefox/releases/66.0.4/ <=

2° => viewtopic.php?f=5&t=134941&p=850452#p850452 <=

3° => https://www.mozilla.org/en-US/firefox/releases/ <=


Bob49 a écrit :
06 mai 2019, 15:04
Pour les personnes qui ont fait des modifications dans about:config, il sera plutôt utile de remettre les choses en ordre, a fin d'éviter d'avoir des modules qui s'installeraient à votre insu.
Sur le Firefox grand public, il me semble que la ligne de commande : xpinstall.signatures.required, n’apparaît pas fonctionner pour installer des extensions non-signées.

Elle ne fonctionnerais qu’avec le Firefox développeur pour tester les extensions en programmation qui de fait n’ont pas reçu une validation, signature, de Mozilla.

MAXLAM
Arias
Messages : 17
Enregistré le : 18 oct. 2014, 00:57

Re: Modules complémentaires désactivés

Message par MAXLAM » 07 mai 2019, 17:49

Cucurbitacé

Si tu lisais ça t'éviterais de beugler et tu aurais vu que 3° Ne fonctionne pas pour moi parce que je n'ai pas intl.locale.requested dans about: config
De plus 1° Semble n'être qu'un autre moyen de télécharge FF (Voir https://www.mozilla.org/fr/firefox/all/)
2°Ne nous apprend rien de plus.


xpinstall.signatures.required figure dans mon about: config. Alors on le met a true ou false?

Chafpa
Lézard à collerette
Messages : 228
Enregistré le : 07 janv. 2007, 19:22

Re: Modules complémentaires désactivés

Message par Chafpa » 07 mai 2019, 17:54

False
La vie est un long fleuve tranquille.......Quoique.....

Chafpa
Lézard à collerette
Messages : 228
Enregistré le : 07 janv. 2007, 19:22

Re: Modules complémentaires désactivés

Message par Chafpa » 07 mai 2019, 17:56

Cucurbitacé a écrit :
07 mai 2019, 16:53

Sur le Firefox grand public, il me semble que la ligne de commande : xpinstall.signatures.required, n’apparaît pas fonctionner pour installer des extensions non-signées.
Si, la ligne apparait et j'ai une version de Firefox lambda
La vie est un long fleuve tranquille.......Quoique.....

lilas ter
Salamandre
Messages : 21
Enregistré le : 11 nov. 2017, 22:12

Re: Modules complémentaires désactivés

Message par lilas ter » 07 mai 2019, 21:07

Bonsoir,

Firefox a fait sa mise à jour et a réactivé toutes mes extensions sans qu'il soit nécessaire que je fasses quoi que ce soit. Merci Firefox. :D

Avatar du membre
Cucurbitacé
Tyrannosaurus Rex
Messages : 4957
Enregistré le : 22 juil. 2012, 05:27

Re: Modules complémentaires désactivés

Message par Cucurbitacé » 08 mai 2019, 01:06

MAXLAM a écrit :
07 mai 2019, 17:49
Cucurbitacé

Si tu lisais ça t'éviterais de beugler et tu aurais vu que 3° Ne fonctionne pas pour moi parce que je n'ai pas intl.locale.requested dans about: config
De plus 1° Semble n'être qu'un autre moyen de télécharge FF (Voir https://www.mozilla.org/fr/firefox/all/)
2°Ne nous apprend rien de plus.
Vous racontez des conneries !
J’ai essayé la 66.0.4 avec 23 extensions, dont plusieurs que j'ai attrapé au hasard, que j’ai mis uniquement pour vérifier, toutes les extensions ont été activée et ont fonctionnée.

Y compris avec la version 66.0.5 !
MAXLAM a écrit :
07 mai 2019, 17:49
xpinstall.signatures.required figure dans mon about:config. Alors on le met a true ou false?
À false, mais cela ne fonctionne pas si les extensions ne sont pas signées !
Modifié en dernier par Cucurbitacé le 08 mai 2019, 09:05, modifié 1 fois.

Avatar du membre
Cucurbitacé
Tyrannosaurus Rex
Messages : 4957
Enregistré le : 22 juil. 2012, 05:27

Re: Modules complémentaires désactivés

Message par Cucurbitacé » 08 mai 2019, 01:10

Chafpa a écrit :
07 mai 2019, 17:56
Si, la ligne apparait et j'ai une version de Firefox lambda
Cucurbitacé a écrit :
07 mai 2019, 16:53

Sur le Firefox grand public, il me semble que la ligne de commande : xpinstall.signatures.required, n’apparaît pas fonctionner pour installer des extensions non-signées.
En somme, il suffisait de lire : pas fonctionner, extension non signée !
Et de lire le commentaire de l'intervenant à qui je répondais :
Bob49 a écrit :
06 mai 2019, 15:04
Pour les personnes qui ont fait des modifications dans about:config, il sera plutôt utile de remettre les choses en ordre, a fin d'éviter d'avoir des modules qui s'installeraient à votre insu.

MAXLAM
Arias
Messages : 17
Enregistré le : 18 oct. 2014, 00:57

Re: Modules complémentaires désactivés

Message par MAXLAM » 08 mai 2019, 02:15

"Vous racontez des conneries !"
Il n'y a pas de modérateur pour censurer de tels propos de ce malotru?

"J’ai essayé la 66.0.4 avec 23 extensions, dont plusieurs que j'ai attrapé au hasard, que j’ai mis uniquement pour vérifier, toutes les extensions ont été activée et ont fonctionnée."

Pour moi la 66.0.4
- s'est installée automatiquement
- puis je l'ai je l'ai téléchargée à https://www.mozilla.org/fr/firefox/all/ et installée une nouvelle fois
- puis encore téléchargée et rèinstallée avec 1° => https://ftp.mozilla.org/pub/firefox/releases/66.0.4/ <= en utilisant .exe et non .msi

Alrors quand je dis au mal élevé, - qui se prend pour la merveille du monde parce qu'il saurait mieux que moi ce qui se passe dans mon ordi -, que ça ne fonctionne pas, c'est que ça ne fonctioone pas.

Encore à cette heure-ci
- j'ai dans about:studies => en Etudes en cours: hotfix-update-xpi-signing-intermediate-bug-v1.0.3-1548973•Active
- quand après Outils> Modules complémentaires le gestionnaire affiche parmi les choix mis en avant Ghostery et que je veux l'ajouter j'ai
"Échec du téléchargement. Veuillez vérifier votre connexion.
Fermer"
Si dans le cadre en question je clique sur le lien Ghostery par Ghostery j'arrive à
https://addons.mozilla.org/fr/firefox/a ... nk&src=api

où,à la première tentive de "Ajouter à Firefox", un message annonce que le téléchatgemenyt n'a pu ce faire car le fichier semblait corrompu; la 2ème fois j'ai eu le traditionnel "Échec du téléchargement. Veuillez vérifier votre connexion."
Voilà pour les conneries.

Agent virtuel
Tyrannosaurus Rex
Messages : 3101
Enregistré le : 29 janv. 2018, 12:06

Re: Modules complémentaires désactivés

Message par Agent virtuel » 08 mai 2019, 07:26

Bonjour

Simplement à titre pour voir

Mozilla Firefox, Portable Edition
https://portableapps.com/apps/internet/firefox_portable
Éventuellement essayer Firefox ESR (Extended Support Release)

Simplement à titre pour voir

https://www.mozilla.org/fr/firefox/all
https://support.mozilla.org/fr/kb/desin ... ordinateur
+ Supprimer les données utilisateur et les paramètres
Arrêt ordinateur
Démarrer ordinateur
Installation Firefox

Avatar du membre
Cucurbitacé
Tyrannosaurus Rex
Messages : 4957
Enregistré le : 22 juil. 2012, 05:27

Re: Modules complémentaires désactivés

Message par Cucurbitacé » 08 mai 2019, 09:34

MAXLAM a écrit :
08 mai 2019, 02:15
Il n'y a pas de modérateur pour censurer de tels propos de ce malotru?

Pour moi la 66.0.4
- s'est installée automatiquement
- puis je l'ai je l'ai téléchargée à https://www.mozilla.org/fr/firefox/all/ et installée une nouvelle fois
- puis encore téléchargée et rèinstallée avec 1° => https://ftp.mozilla.org/pub/firefox/releases/66.0.4/ <= en utilisant .exe et non .msi

Alrors quand je dis au mal élevé, - qui se prend pour la merveille du monde parce qu'il saurait mieux que moi ce qui se passe dans mon ordi -, que ça ne fonctionne pas, c'est que ça ne fonctioone pas.

Encore à cette heure-ci
- j'ai dans about:studies => en Etudes en cours: hotfix-update-xpi-signing-intermediate-bug-v1.0.3-1548973•Active
- quand après Outils> Modules complémentaires le gestionnaire affiche parmi les choix mis en avant Ghostery et que je veux l'ajouter j'ai
"Échec du téléchargement. Veuillez vérifier votre connexion.
Fermer"
Si dans le cadre en question je clique sur le lien Ghostery par Ghostery j'arrive à
https://addons.mozilla.org/fr/firefox/a ... nk&src=api

où,à la première tentive de "Ajouter à Firefox", un message annonce que le téléchatgemenyt n'a pu ce faire car le fichier semblait corrompu; la 2ème fois j'ai eu le traditionnel "Échec du téléchargement. Veuillez vérifier votre connexion."
Voilà pour les conneries.

Tu m’étonnes Ghostery, l’extension espionne par excellence ?!
Cette extension est faites pour tuer la concurrence, elle lute contre les traqueurs des autres firmes, pour être la seule sur le marché et récupérer toutes vos données.
=> viewtopic.php?f=5&t=137405&p=862959#p862787 <=



Le bon-otru, sans nombril et sans monde que vous êtes, a forcément fait une connerie, parce que Firefox 66.0.4 et 66.0.5 fonctionnent !
Essayé sur plusieurs systèmes avec plusieurs profils.

Voici les fichiers importants dans votre profil, lisez tout !


Sauvegardez vos marque-pages et les fichiers qui vous intéressent, le dossier extensions, dans un dossier que vous appellerez sauvegarde.
Surtout : places.sqlite et favicons.sqlite, ce sont tous vos marque-pages et favicons.
key4.db et logins.json, ce sont vos logins et mots de passe.

Ne sauvegarder pas : cert9.db , pkcs11, ce sont eux qui posent problème ; supprimez aussi : prefs.js.

Désinstallez Firefox avec un désinstallateur qui va tout nettoyer.
Il y a plusieurs logiciels dont deux excellents, vous pouvez les avoir en version portable, qui ne s’installe pas, juste un fichier zip à décompresser.

Gardez votre profil ouvert pendant la désinstallation.

- BCUninstaller.

- RevoUninstaller


Une fois désinstallé supprimez le profil.


Installez le nouveau Firefox => https://ftp.mozilla.org/pub/firefox/releases/66.0.5/ <= ouvrez le répertoire correspondant à votre système Win32 ou Win64, puis fr, prendre le fichier exe.

Une fois installé le nouveau Firefox, ouvrez-le, il va créer un nouveau profil, tout neuf.
Puis ouvrez le nouveau profil, fermez Firefox, pas le profil, et remplacez par un copier/coller les fichiers par tous vos fichiers de sauvegarde.

Pour les extensions, il suffira d’ouvrir dans Firefox la partie extensions, puis par un simple glisser/déposer déplacer les extensions de votre sauvegarde du dossier extensions.

Si vous avez un logiciel de sécurité, lui aussi contrôle les certificats, si un certificat de sécurité a expiré, lui aussi peut bloquer.

ff
Lézard à collerette
Messages : 223
Enregistré le : 05 avr. 2006, 23:58

Re: Modules complémentaires désactivés

Message par ff » 08 mai 2019, 09:56

Bonjour,

Selon moi l'idée est de contraindre ceux restés sous ff56 à passer à quantum (peut-être pour de sombres raisons statistiques, quelle misère !).
En effet, les développeurs des modules tournant sous l'ancien firefox qui n'ont pas signé leur travail à l'époque ne vont pas le faire aujourd'hui, sachant qu'évidemment mozilla leur refusera l'agrément.

Par ailleurs le patch ne concerne que quantum (mes extensions sous quantum 66.0.5 que je teste de temps en temps fonctionnent toutes).

Je suis donc redescendu à la plus récente esr de l'ancienne ère, la 52.8.1esr+about:config xpinstall.signatures.required passé à fasle , en attendant de trouver un autre navigateur car en effet, certains modules important n'ont été proposés qu'après la 52 et ne fonctionnent plus (UblockOrigin, Dark Reader, Grammalecte, Cookie-AutoDelete etc.).

J'ai installé hier opera 60. Je suis très très loin de la personnalisation à laquelle j'étais parvenu avec ff56 mais je découvre.
De base la navigation est aussi pourrie que sous quantum qui écrase les onglets à tout bout de champ (sauf à devoir bidouiller par about:config ce qui est un comble ou installer Open Link with New Tab qui n'est pas franchement abouti). Mais bon, je vais essayer de m'investir.
Si vous connaissez un navigateur aussi abouti, aussi personnalisable et respectueux de la vie privée que ff56, je suis preneur.

Merci.

Agent virtuel
Tyrannosaurus Rex
Messages : 3101
Enregistré le : 29 janv. 2018, 12:06

Re: Modules complémentaires désactivés

Message par Agent virtuel » 08 mai 2019, 10:10

Bonjour ff

En complément

https://wiki.mozilla.org/Add-ons/Extension_Signing

Prêtez attention

Avatar du membre
Cucurbitacé
Tyrannosaurus Rex
Messages : 4957
Enregistré le : 22 juil. 2012, 05:27

Re: Modules complémentaires désactivés

Message par Cucurbitacé » 08 mai 2019, 10:11

ff a écrit :
08 mai 2019, 09:56
Je suis donc redescendu à la plus récente esr de l'ancienne ère, la 52.8.1esr+about:config xpinstall.signatures.required passé à fasle , en attendant de trouver un autre navigateur car en effet, certains modules important n'ont été proposés qu'après la 52 et ne fonctionnent plus (UblockOrigin, Dark Reader, Grammalecte, Cookie-AutoDelete etc.).
Bonjour ff,

Essayez Vivaldi dans ce cas, c’est l’un des inventeurs de Opera.
Ils étaient deux, l’un est décédé des suites d’un cancer, l’autre lui a été volé son bébé, il a donc quitté Opera, pour fonder Vivaldi, avec énormément de possibilités.


Je ne pense pas, que, ce que vous affirmez sur Mozilla, forçant les internautes à utiliser 66 à la place de 56, soit exacte, dans ce cas pourquoi, selon votre théorie, Mozilla emmerderait tout le monde y compris ceux qui utilisent la 66.

Pour le reste, je ne comprends pas ce que vous dites, votre phrase affirme que ces extensions ne fonctionnent plus : UblockOrigin, Dark Reader, Grammalecte, Cookie-AutoDelete etc.

Ce qui serait inexacte !

uBlock Origin

Cookie autoDelete

Grammalect

Vous pouvez utiliser un Firefox pour les développeurs d'extension, il ne demande pas de signature pour les extensions, sinon, ils ne pourrait rien développer. => viewtopic.php?f=5&t=134941&p=850452#p850452 <=


Bien à vous.
Modifié en dernier par Cucurbitacé le 08 mai 2019, 17:31, modifié 1 fois.

Avatar du membre
Bob49
Animal mythique
Messages : 20745
Enregistré le : 10 mars 2006, 17:25

Re: Modules complémentaires désactivés

Message par Bob49 » 08 mai 2019, 11:28

Salut

Comme je l'ai dit hier, si l'on veut rester sur une vieille version de Firefox et garder ses extensions, il faut changer ses habitudes... et effectuer régulièrement des sauvegardes, dont effectuer des sauvegardes des fichiers des extensions... Bref, il faut savoir ce que l'on veut !!..

Contrairement à ce qui est dit, uBlock Origin est toujours disponible pour Firefox à partir de la version ESR 52... Testé et approuvé. Donc doit fonctionner avec la version 56 de Firefox.

Cookie AutoDelete fonctionne avec Firefox 50. Voir l'historique des versions de l'extension.

Grammalecte n'est plus que disponible qu'à partir de Fx 57... C'est là qu'il faut avoir effectué la sauvegarde d'une version antérieure de l'extension. (si des personnes la veulent, je pourrai la mettre à disposition... Quoi qu'elle se trouve sans doute sur le web, en la 0.5.18, par exemple...)

Bien sûr, les vieilles versions des extensions n'auront pas certaines améliorations de celles-ci. Mais bon elles fonctionnent.
Sauvegardez le profil de votre Firefox , avant d'y faire des modifications(install, etc..) ;-)
"Le bonheur est souvent la seule chose qu'on puisse donner sans l'avoir, et c'est en le donnant qu'on l'acquiert." Voltaire
Image

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 16 invités