Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

evr
Arias
Messages : 5
Inscription : 05 oct. 2014, 17:51

Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par evr » 09 janv. 2019, 16:13

Bonjour à tous,

Je sais que ce genre de problème est redondant mais je n'ai pas trouvé de solution pour mon cas, aussi je me permets de le décrire ici en espérant trouver une solution !

J'ai du matériel embarqué intégrant un certificat HTTPS auto-signé que je ne peux pas modifier ; ce dernier n'intègre pas de CN ni de nom alternatif. Firefox m'affiche l'alerte de sécurité suivante :
La connexion n’est pas sécurisée
Ce site a recours à HTTP Strict Transport Security (HSTS) pour indiquer à Firefox de n’établir qu’une connexion sécurisée. Ainsi il n’est pas possible d’ajouter d’exception pour ce certificat.
Le message d'erreur avancé est :
"monmachin.mondomain.fr" utilise un certificat de sécurité invalide. Le certificat n’est pas sûr car il est auto-signé. Le certificat n’est valide que pour . Code d’erreur : MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT
Avant, j'avais le bouton "Ajouter une exception" mais depuis la version 64 de Firefox il ne s'affiche plus. Si je passe par les Préférences > Vie privée et sécurité > Afficher les certificats > Serveurs > Ajouter une exception, je peux l'ajouter manuellement : il s'ajoute bien à la liste des exceptions, mais cela ne change rien, je n'ai toujours pas accès au site avec la même erreur.
En revanche lorsque j'accède à mon équipement via son adresse IP, là Firefox me propose d'ajouter une exception de sécurité et affiche bien la page !

Je n'ai pas trouvé d’occurrence de l'URL du site dans le fichier SiteSecurityServiceState.txt , et j'ai déjà déplacé cert9.db pour que Firefox réinitialise la base, mais sans succès. Je ne sait plus trop où chercher :|

Je suis sous CentOS 7.3 et Firefox 64 (64 bits).

Merci pour votre aide !

Avatar de l’utilisateur
Cucurbitacé
Tyrannosaurus Rex
Messages : 3298
Inscription : 22 juil. 2012, 05:27

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par Cucurbitacé » 11 janv. 2019, 08:15

Bonjour,

Est-ce la méthode que vous avez effectué ? => https://support.mozilla.org/fr/kb/que-f ... to-signaes

Bien à vous.

evr
Arias
Messages : 5
Inscription : 05 oct. 2014, 17:51

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par evr » 11 janv. 2019, 16:19

Bonjour Cucurbitacé,

J'ai essayé mais impossible car le bouton pour ajouter une exception ne s'affiche même pas.
Pour créer une exception je suis passé par les paramètres Firefox > Afficher les Certificats > etc.. mais malgré l'ajout, le site reste en erreur...

Avatar de l’utilisateur
Bob49
Animal mythique
Messages : 19082
Inscription : 10 mars 2006, 17:25
Localisation : L'Anjou en France ;-)

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par Bob49 » 11 janv. 2019, 18:42

Bonjour

A tout hasard, tu n'utiliserais pas un routeur ? Diférents problèmes similaires sur le web, résolus par mise à jour du pilote de celui-ci...
Sauvegardez le profil de votre Firefox , avant d'y faire des modifications(install, etc..) ;-)
"Le bonheur est souvent la seule chose qu'on puisse donner sans l'avoir, et c'est en le donnant qu'on l'acquiert." Voltaire
Image

evr
Arias
Messages : 5
Inscription : 05 oct. 2014, 17:51

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par evr » 13 janv. 2019, 18:29

Bonjour Bob49,

Il y a bien un routeur entre moi et mon équipement cible, mais ce dernier n'en est pas un (c'est un codec de visioconférence de marque Aver).

boisrobe
Arias
Messages : 1
Inscription : 16 janv. 2019, 10:27

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par boisrobe » 16 janv. 2019, 10:30

Bonjour,

Même soucis sur un poste d'un de mes collègues depuis quelques jours.
Il vient d'essayer de desinstaller et reinstaller son FF mais rien a faire les sites HTTPS ne sont pas validés.

Pas de soucis avec IE, edge et chrome.

Nous sommes sur un réseau d'entreprise avec routeur et firewall et proxy.

S'il me faut mettre à jour toutes les briques pour un bug FF ...

Avatar de l’utilisateur
Bob49
Animal mythique
Messages : 19082
Inscription : 10 mars 2006, 17:25
Localisation : L'Anjou en France ;-)

Re: Depuis Firefox 64, erreur HTTPS : "La connexion n’est pas sécurisée"

Message par Bob49 » 16 janv. 2019, 13:13

Salut

@ boisrobe... Ce n'est pas parce que tu lis un titre qui correspond au message d'erreurs que tu as lu, que la source au problème est la même !!! evr a une configuration spéciale que tu n'as sans doute pas !.. Il aurait été préférable que tu ouvres un nouveau fil ! :wink:

D'ailleurs, tu n'expliques pas la configuration du pc de ton collègue et si son pc est sur un réseau d'entreprise ou pas ! :idea: Et s'il est en pc individuel, voir à désactiver la fonction de vérification des connexions sécurisées de son antivirus !..
Bob49 a écrit :
13 janv. 2017, 13:05
En quelques explications...

Voir si l'analyse des connexions sécurisées de votre antivirus ne pose pas problème...
► Aller dans les paramètres de votre antivirus, désactiver la fonction d'analyse des connexions sécurisées (Https, ssl) et voir ce que ça donne !..

Pour les antivirus qui dérangent (les paramètres peuvent ne pas être les bons selon version d'antivirus)...:

Avast ► menu ► Paramètres ► Composants ► Agent Web (activé) ► Personnaliser ► Paramètres principaux → Et décocher "Autoriser l'analyse HTTPS".

Si un site de confiance, le mettre en Exclusions... https://support.avast.com/fr-fr/article/168
Et pour le mieux, prévenir Avast si exès de zèle (si blocage de bien sites https et très connus)... par téléphone ou via le forum

**********
AVG ► Paramètres ► Navigation ► Bouclier Web → cliquez sur le curseur pour le passer sur Désactivé (rouge)

Sinon mettre le site dans les exceptions... https://support.avg.com/SupportArticleV ... tType=home
Et ne pas hésiter à contacter AVG, si trop de sites https bloqués et surtout si des sites très connus... via support_contact (pas de support téléphonique apparemment) ou en anglais ...

**********
Bitdefender ► Paramètres ► Vie Privée ► Antiphishing → Et désactiver la fonctionnalité "Analyse SSL".
Ou Paramètres ► Avancées ► Décocher "Scan SLL"

Si un site de confiance, le mettre en liste blanche... https://www.bitdefender.fr/support/que- ... -1294.html
Et ne pas hésiter à contacter Bitdefender, si trop de sites https bloqués et surtout si des sites très connus... par courrier ou via le forum

**********
Bullguard ► Le tableau de bord ► Paramètres antivirus ► Navigation → Décochez l'option "Afficher les résultats sans risque" pour les sites web qui affichent ce message d'erreur.

Contact au choix, chatter en direct ou via e-mail (le mieux d'après le forum qui est en anglais et quasiment pas en français)...

**********
ESEThttp://support.eset.com/kb3126/?viewlocale=fr_FR

Si c'est un site de confiance, l'exclure du blocage ...
Et ne pas hésiter à contacter AVG, si trop de sites https bloqués et surtout si des sites très connus... contact ou via forum en anglais

**********
Kaspersky ► Paramètres ► Section Avancé ►Réseau → Et choisir "ne pas analyser les connexions sécurisées" (HTTPS).

Ou peut-être ceci pour Kaspersky 2018 (merci de confirmer) https://support.kaspersky.com/fr/13629#block4

Si c'est un site de confiance, l'exclure du blocage...
Et ne pas hésiter à contacter Kaspersky, si trop de sites https bloqués et surtout si des sites très connus... https://www.kaspersky.fr/about/contact? ... ly_prodmen ou via le forum
boisrobe a écrit :
16 janv. 2019, 10:30
S'il me faut mettre à jour toutes les briques pour un bug FF ...
De là a évoquer un quelconque bug, il y à encore des vérifications a effectuer et du temps...
.
.
******************************
Juste comme cela, pour tout le monde...
Firefox : Rumeurs et news sur le développement
Sauvegardez le profil de votre Firefox , avant d'y faire des modifications(install, etc..) ;-)
"Le bonheur est souvent la seule chose qu'on puisse donner sans l'avoir, et c'est en le donnant qu'on l'acquiert." Voltaire
Image

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 2 invités