[RESOLU] Histoire de barre d'état

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

Répondre
Gloops
Tyrannosaurus Rex
Messages : 2355
Enregistré le : 22 mai 2006, 11:55

[RESOLU] Histoire de barre d'état

Message par Gloops » 29 déc. 2018, 21:05

Bonjour tout le monde,

Je ne sais pas exactement ce qu'on a trafiqué dans la version 64 de Firefox, toujours est-il qu'elle semble incapable d'afficher la barre d'état au bon endroit, elle l'affiche par-dessus la page, alors qu'un emplacement lui est réservé en bas de la fenêtre.

Pour les gens qui auraient le même problème, je me rends compte qu'il faut impérativement suivre les étapes suivantes :
  1. désinstaller Firefox
  2. installer la version 60
  3. désactiver la mise à jour automatique
  4. réinitialiser Firefox (menu d'aide, redémarrer avec les modules désactivés, réinitialiser)
  5. fermer le message "Votre version de Firefox est sérieusement obsolète" (un comble)
  6. récupérer le userChrome.css (depuis les "Anciennes données de Firefox" sur le bureau)
  7. redémarrer Firefox
Procéder autrement (par exemple installer la version 60 par-dessus la 64) donne un résultat instable.

Si quelqu'un peut me prévenir quand les nouvelles versions ne posent plus ce problème ...
Modifié en dernier par Gloops le 01 janv. 2019, 08:03, modifié 1 fois.

Avatar du membre
lool_lauris
Tyrannosaurus Rex
Messages : 4761
Enregistré le : 14 mars 2008, 22:51

Re: Histoire de barre d'état

Message par lool_lauris » 30 déc. 2018, 10:50

Salut,

Il me semble qu'il y a déjà pas mal de temps que ce comportement subsiste dans FFX, contrairement à TBird qui lui possède toujours un emplacement désactivable d'une barre d'état. D'ailleurs, dans les options d'affichage de FFX, sous "Affichage" > "Barres d'outils", la barre d'état n'est pas présente.

Ce comportement "par dessus" me parait beaucoup plus optimum en terme de gain d'espace de visualisation (surtout dans la hauteur). En effet, cela n'occulte pas une bande systématiquement affichée et donc une perte permanente sur la visualisation de la page. De plus, l'information d'état n'est pas figée en bas à gauche; en effet, si l'on y amène le curseur de souris (pour une information d'état qui resterait suffisamment longtemps et masquerait ainsi la zone superposée) l'information d'état passe à droite.
.
Soutenez le Libre !

Image

Gloops
Tyrannosaurus Rex
Messages : 2355
Enregistré le : 22 mai 2006, 11:55

Re: Histoire de barre d'état

Message par Gloops » 30 déc. 2018, 11:04

Bonjour,
Par défaut en effet ça se pratique depuis un moment, mais jusqu'à la version 60 la barre d'état se trouve dans le #browser-bottombox, c'est juste que par défaut celui-ci n'est pas visible.
Donc, par une feuille de style appropriée on peut empêcher la barre d'état de rogner sur la page.
Avec les versions suivantes, les deux s'affichent séparément, donc si on affiche le #browser-bottombox il ne sert à rien, puisque la barre d'état vient par dessus, et recouvre une partie de la page.
***
11:40
Ah, quelqu'un me propose une feuille de style qui fonctionne paraît-il avec la version 64.
J'essaie ça demain soir, j'aurai une connexion forfaitaire.

Gloops
Tyrannosaurus Rex
Messages : 2355
Enregistré le : 22 mai 2006, 11:55

Re: Histoire de barre d'état

Message par Gloops » 01 janv. 2019, 08:00

En effet, il y a eu un faux départ mais ceci dans le userChrome.css donne une barre d'état OK dans Firefox 64.0 (64 bits) sur Windows 10 :

Code : Tout sélectionner

#browser-bottombox {
    height: 30px; border-top: solid 1px #505050;
    background-color:red!important;
}
.browserContainer > #statuspanel { /* was .browserContainer>statuspanel */
    left: 4px !important; bottom: 0px;
    transition-duration: 0s !important;
    transition-delay: 0s !important;
}
label#statuspanel-label { /* was label.statuspanel-label */
    margin-left: 0px !important;
    border: none !important;
    padding: 0px !important;
    background-image: none !important;
    background-color: #cedaeb !important;
    color: #000000 !important;
    font-size:20px ! important;
}
Au passage il y a une chose que je ne m'explique pas, c'est que j'avais désactivé les mises à jour, et que lorsque j'ai lancé Firefox il a commencé par ... se mettre à jour.
Ça tombait bien c'était le bon moment, mais ... Il ne pouvait pas le savoir.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 13 invités