[sync server] update error 134

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

Répondre
petrusko
Lézard vert
Messages : 120
Enregistré le : 11 déc. 2013, 13:07

[sync server] update error 134

Message par petrusko » 06 oct. 2016, 12:28

Salut,

Tentative de mise à jour du serveur Sync sur une Raspbian Jessie 8,
en suivant le mode d'emploi ici : http://docs.services.mozilla.com/howtos ... the-server

Et après la commande make build, ca donne :

Code : Tout sélectionner

#make build
virtualenv --python=`which python2 python | head -n 1` --no-site-packages ./local
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Aborted
Makefile:22: recipe for target 'local/COMPLETE' failed
make: *** [local/COMPLETE] Error 134
Et là j'avoue être relativement très perdu !!!
Merci d'avance pour le coup de main ;)
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

Avatar du membre
Bob49
Animal mythique
Messages : 20775
Enregistré le : 10 mars 2006, 17:25

Re: [sync server] update error 134

Message par Bob49 » 06 oct. 2016, 13:04

Bonjour

Est-ce bien en rapport avec l'utilisation de Firefox ? :idea:
Si oui, as-tu vérifié en mode sans échec et\ou avec un nouveau profile ?
.
.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0(version pour développement)

********************************************************************************************************************
Supplément à ma signature…
Notes :
:arrow: Pour les personnes ayant un problème avec un logiciel de Mozilla, autre que Firefox, veuillez poster sur le bon forum ! Cela sera bien mieux pour tout le monde et surtout pour vous-même, pour avoir des réponses plus rapidement… suivre l'accueil du forum
:arrow: Pour navigateur sur téléphone et tablette sous Android, c’est en haut de celui de Firefox viewforum.php?f=32
:arrow: Après utilisation de la fonction de recherches du forum, ouvrez votre propre nouveau fil (sujet) pour votre problème. Un internaute et son(ses) problème(s) = un fil.
Sauvegardez le profil de votre Firefox , avant d'y faire des modifications(install, etc..) ;-)
"Le bonheur est souvent la seule chose qu'on puisse donner sans l'avoir, et c'est en le donnant qu'on l'acquiert." Voltaire
Image

petrusko
Lézard vert
Messages : 120
Enregistré le : 11 déc. 2013, 13:07

Re: [sync server] update error 134

Message par petrusko » 06 oct. 2016, 13:30

Bob49 a écrit : Est-ce bien en rapport avec l'utilisation de Firefox ? :idea:
Salut, merci pour ta réponse!
Effectivement le rapport avec l'utilisation de "Firefox" est un peu éloigné, mais il n'y a malheureusement aucun sous-forum/catégorie qui corresponde à leur "serveur sync" par ici... Je me suis donc permis de venir pointer le bout de mon nez dans ce coin ;)

Sinon pour éventuellement apporter qq petites infos complémentaires, il y aurait un souci du coté de virtualenv...?

# python --version
Python 2.7.9

# virtualenv --version
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Abandon

petrusko
Lézard vert
Messages : 120
Enregistré le : 11 déc. 2013, 13:07

Re: [sync server] update error 134

Message par petrusko » 14 déc. 2016, 20:37

Bon, la solution a été de réinstaller totalement le serveur sync en clonant le git...

Du coup, petit bug avec les dernières MAJ de Firefox ou je ne sais quoi...?
Bref, étant reparti à 0, il faut maintenant créer un script de lancement automatique au boot du serveur... car l'ancien script n'est plus ok pour cette nouvelle version... mais là je pense qu'il est plus judicieux d'ouvrir un nouveau post ;)
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

viewtopic.php?f=5&t=131895

.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 23 invités