Pages lentes à apparaître... F5

Vos requêtes concernant Mozilla Firefox, le navigateur Gecko alternatif, ne trouvèrent point de réponses lorsque vous cherchâtes ? Toute l'équipe Geckozone est prête à vous aider.

Modérateurs : Mori, myahoo, jpj, nico@nc

Répondre
Gaétan

Pages lentes à apparaître... F5

Message par Gaétan » 15 oct. 2012, 21:48

Salut,
Dernièrement, j'ai un souci avec Firefox 16.0.1
Certains sites (pages) s'affichent lentement.
Je dois pour que la page s'affiche peser sur F5.
Quand je pèse sur F5, la page s'affiche.

Solutions !

Merci

Avatar du membre
jpj
Animal mythique
Messages : 25243
Enregistré le : 01 août 2005, 15:38

Re: Pages lentes à apparaître... F5

Message par jpj » 15 oct. 2012, 22:04

Bonsoir,

Dans ton pare-feu, il faut autoriser tous les exécutables de Firefox qui sont dans C:\Program Files (x86)\Mozilla Firefox\ :
crashreporter.exe ;
firefox.exe (indispensable) ;
maintenanceservice.exe ;
maintenanceservice_installer.exe ;
plugin-container.exe (indispensable) ;
updater.exe.

Éventuellement, supprime les autorisations pour ces exécutables et redonne-les.


Vérifie aussi en mode sans échec de Firefox (sans réinitialiser pour l'instant) :
http://support.mozilla.org/fr/kb/resoud ... sans-echec
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

Gaétan

Pages lentes à apparaître... F5

Message par Gaétan » 15 oct. 2012, 22:15

crashreporter.exe ;
firefox.exe (indispensable) ;
maintenanceservice.exe ;
maintenanceservice_installer.exe ;
plugin-container.exe (indispensable) ;
updater.exe.

J'ai fait cette 1re partie de la solution
Aucun des ces fichiers n'apparaissent dans le Parefeu de Windows 7
Je vais voir à l'usage si votre solution a fonctionnée
Merci.

Gaétan

Pages lentes à apparaître... F5

Message par Gaétan » 15 oct. 2012, 22:20

Pour le moment rien n'a changé.
Je dois toujours peser sur F5 pour que la page apparaisse, sinon le curseur tourne et tourne.
Dans le Parefeu de Windows, il y a deux colonnes: Domestique/entreprise(privé) et Public

J'ai coché les cases dans les 2 colonnes; est-ce judicieux ?

Dois-je re-démarrer Windows ?

scoobidiver
Animal mythique
Messages : 6402
Enregistré le : 01 avr. 2011, 19:26

Re: Pages lentes à apparaître... F5

Message par scoobidiver » 16 oct. 2012, 00:18

Commence par effacer le cache et les cookies :
https://support.mozilla.org/fr/kb/diagn ... otre-cache

Essaie également le mode sans échec comme indiqué par jpj.

Black Winny
Gecko
Messages : 70
Enregistré le : 18 nov. 2004, 12:43

Re: Pages lentes à apparaître... F5

Message par Black Winny » 16 oct. 2012, 15:02

J'ai eu le même problème pendant plusieurs jours jusqu'à ce matin : lenteur désespérante du téléchargement des pages, parfois plusieurs minutes de patience avec le message classique [Firefox ne répond pas] dans la barre de titre.

J'ai fait pas mal d'essais.

Désactivation de tous les modules complémentaires et redémarrage : le problème subsistait.

Installation de Firefox 17 beta en ayant tous les modules complémentaires désactivés : le problème subsistait.

Installation de la précédente version de Firefox (la 15) en ayant tous les modules complémentaires désactivés : le problème subsistait.

Installation d'une version encore plus ancienne (la 14) en ayant tous les modules complémentaires désactivés : le problème subsistait.

Alors là j'ai commencé à vraiment penser que le problème n'a absolument rien à voir avec la version de Firefox (ni bien sûr avec un des modules complémentaires puisqu'ils sont tous désactivés).

Restait à voir trois problèmes possibles :
1. La connexion elle-même
2. Le fournisseur d'accès
3. Autre chose perturbant en interne le fonctionnement de Firefox

Pour tester la connexion elle-même il suffit de voir si les e-mails se chargent normalement dans Thunderbird. Ils se chargent normalement, la connexion n'est donc pas en cause. De plus l'affichage des mêmes pages (celles qui posent problèmes) dans Internet Explorer se passe bien. La connexion n'est donc résolument pas en cause.

De plus, le fournisseur d'accès n'est pas en cause non plus puisque Internet Explorer affiche bien les pages qui me posent problème dans Firefox.

Le problème est donc la présence de quelque chose qui perturbe le fonctionnement de Firefox... y compris des anciennes versions de Firefox puisque j'en suis à une étape de mes tests où la version actuellement installée est la 14.

Qu'est-ce qui peut être étranger à Firefox mais installé dans Firefox et pouvant agir sur le fonctionnement de Firefox tout en n'étant pas un module complémentaire ? Grattons-nous la tête. Eh bien... pourquoi pas un plugin ?!

Hop, je suis allé voir ma liste des plug-ins installés. Pour rappel, il suffit d'ouvrir la liste des modules complémentaires et de cliquer sur Plugins (la brique de Lego dans la barre verticale à gauche de la page des modules complémentaires).

Je décide de tester mes pages à problèmes en désactivant un par un mes plugins. Et pour commencer je vais tester avec Flash désactivé. Je désactive Shockwave Flash (11.4.402.287), je relance mon Firefox 14 qui n'a aucun module complémentaire activé. Et je teste une des mes pages à problème. Oh !!! Ca marche !!!

Je teste mes autres pages à problème... Oh !!! Toutes fonctionnent !!!

Bon. J'ai compris, le coupable est une fois de plus ce foutu Flash qui pose d'innombrables problèmes les plus divers depuis des années.

J'ai jeté un coup d'oeil à la page de mise à jour de Flash... Ma 11.4.402.287 est bien la dernière version pour le moment. Donc en l'attente d'une nouvelle version je vais la laisser désactivée.

Je réinstalle la version 16.0.1 de Firefox (mais je laisse tous les modules complémentaires désactivés et je laisse Flash désactivé). Je refais un test sur mes pages à problème : elles marchent toutes sans le moindre problème.

Je réactive tous mes modules complémentaires et redémarre Firefox. Je refais mes tests : toutes mes pages à problèmes marchent sans problème.

Bilan : je suis revenu à la situation de départ (Firefox 16.0.1 et tous mes modules complémentaires activés) à la seule différence que Flash est désactivé. Et tout marche désormais sans problème.

Conclusion : tout simplement désactiver Flash. Il est bien possible que cela résolve aussi votre problème.
Modifié en dernier par Black Winny le 16 oct. 2012, 15:07, modifié 2 fois.
Win 10 - Modem Netgear DGN2200v4 (RJ45 sur un poste, Wi-fi sur l'autre) - Mamadoo ADSL - Avast - FF dernière V - TB dernière V - Notepad++ - Total Commander - Un oreiller - Un zozio attentif - Une théière à boire - une épouse à croquer

Gaétan

Pages lentes à apparaître... F5

Message par Gaétan » 16 oct. 2012, 15:06

Cool,
Merci pour cette réponse.
Je vais l'essayer.

scoobidiver
Animal mythique
Messages : 6402
Enregistré le : 01 avr. 2011, 19:26

Re: Pages lentes à apparaître... F5

Message par scoobidiver » 16 oct. 2012, 15:47

Black Winny a écrit :Conclusion : tout simplement désactiver Flash. Il est bien possible que cela résolve aussi votre problème.
Même si Flash est en cause, le désactiver n'est pas une solution compte tenu de sa présence dans la majorité des sites Web, et pas que pour les pubs.

As-tu désactivé l'accélération matérielle de Flash ?
https://support.mozilla.org/fr/kb/video ... e-de-flash
Si c'est OK, mets à jour tes pilotes graphiques :
https://support.mozilla.org/fr/kb/mettr ... graphiques
et réactive-la pour tester.

Avatar du membre
jpj
Animal mythique
Messages : 25243
Enregistré le : 01 août 2005, 15:38

Re: Pages lentes à apparaître... F5

Message par jpj » 16 oct. 2012, 18:03

Bonjour,

[Hors sujet.]
Black Winny a écrit :… Pour tester la connexion elle-même il suffit de voir si les e-mails se chargent normalement dans Thunderbird. Ils se chargent normalement, la connexion n'est donc pas en cause. De plus l'affichage des mêmes pages (celles qui posent problèmes) dans Internet Explorer se passe bien. La connexion n'est donc résolument pas en cause.
Pas obligatoirement. Les courriels et la navigation internet n'utilisent pas les même protocoles. Il y a des cas (rares) où les courriels sont reçus alors que les connexions http et https sont dans les choux.

Pour tester la bande passante, tu peux par exemple utiliser ça : http://www.speedzilla.net/
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

Black Winny
Gecko
Messages : 70
Enregistré le : 18 nov. 2004, 12:43

Re: Pages lentes à apparaître... F5

Message par Black Winny » 23 oct. 2012, 20:41

Il y a du nouveau en ce qui me concerne : dans mon cas le problème est maintenant totalement résolu, et je vais expliquer pourquoi on a ce problème (du moins si la cause est la même) et donc... comment j'ai résolu le problème.

La raison d'abord : j'ai fini par la trouver sur différents sites web américains (vous les trouverez aisément, et même Mozilla en parle). La raison c'est tout simplement que sur les machines tournant en Windows 64 bits, les nouvelles versions de Firefox (qui n'existe pour le moment qu'en 32 bits) et de Flash (qui existe en 32 et 64 bits) deviennent de plus en plus incompatibles entre elles. En fait, au sens large c'est encore plus simple : les développeurs de Flash, qu'il soit en 32 ou en 64 bits, ont été devant un choix à faire : continuer à jongler entre les codes pour navigateurs 32 bits et les codes pour les navigateurs 64 bits et donc entretenir encore et encore une usine à gaz... ou délibérément laisser tomber le 32 bits et se concentrer dans du code propre pour l'avenir, c'est à dire faire avant tout du 64 bits et "tant pis pour les développeurs de navigateurs qui trainent depuis des années pour sortir une version 64 bits alors que les systèmes d'exploitation Windows qui tournent aujourd'hui sont maintenant majoritairement des Windows 64 bits... sur des cartes mères 64 bits".

Bref, continuer à trainer le boulet 32 bits pendant encore des années... ou se tourner de façon radicale vers le 64 bits qui n'est même plus l'avenir mais qui est quasiment partout déjà le présent !

Pour les machines tournant sous Windows 64 bits il faut donc passer à un navigateur 64 bits. ("Point barre !" ont du mentalement penser très fort les décideurs chez Adobe)

Or à l'heure actuelle il n'y a que Internet Explorer qui soit disponible en release 64 bits, c'est à dire en version publique, ayant passé les tests de validation et mise à disposition de tout le monde.
- Chrome est encore en 32 bits (une version 64 bits est bientôt disponible),
- Safari est encore en 32 bits (et je n'ai aucune information sur un portage en 64 bits)
- et Firefox est encore en 32 bits (mais plusieurs versions 64 bits sont en phase de test, et certaines d'entre elles sont quasiment prêtes).

Pour moi, en ce qui concerne l'utilisation de Chrome (dont je suis les évolutions depuis longtemps comme beaucoup d'entre nous), bien que ce soit un outil populaire je le trouve loin, très loin derrière Firefox pour ce qui est de la personnalisation, la richesse des extensions, et même les possibilités permises aux développeurs d'extensions.

J'ai préféré chercher une solution valable en restant dans le monde de Mozilla.

Et la solution chez Mozilla... elle existe !
Et je précise : elle existe dans la mesure où on est prudent et où on utilisera le navigateur chez soi et pas en contexte professionnel.

Comme je l'ai écrit plus haut, il y a plusieurs projets en cours concernant le développement de Firefox en 64 bits. Et certaines sont quasiment prêtes.


Je récapitule les points que j'ai effectués, dans l'ordre, pour arriver au résultat final où désormais tout marche impeccable sur ma machine :

1.
J'ai complètement désinstallé Flash (avec le classique "Ajout/Suppression de programmes" de Windows). Si plusieurs versions de Flash sont installées, désinstaller toutes les versions.

2.
Puis j'ai téléchargé (sans installer !) la toute dernière mouture de la Nightly pour Windows 64 bits :
http://ftp.mozilla.org/pub/mozilla.org/ ... a-central/

3.
Puis bien entendu j'ai fermé Firefox (attention à bien fermer toutes les fenêtres de Firefox s'il y en a plusieurs !)

4
Puis j'ai fait une sauvegarde de mon profil Firefox :
- On va dans le répertoire C:\Users\[xxxx]\AppData\Roaming\Mozilla\Firefox\Profiles
Et on fait une copie du répertoire qui s'y trouve. C'est tout.

5.
Puis j'ai installé Nightly (le programme que j'ai téléchargé ci-dessus au point 2). Il n'y a aucun piège, il suffit d'installer sans rien changer à ce qu'il propose par défaut.

6.
Et Nightly démarre (sur le Bureau Windows c'est une icône montrant un ciel de nuit dans un cercle).
Je retrouve instantanément mes extensions, mes marque-pages, et tout et tout.

7.
Evidemment c'est en anglais puisque c'est une version de Firefox en cours de test, mais si on connait bien Firefox (ou l'anglais) il n'y a absolument aucune difficulté.

Parmi mes premiers tests, bien sûr je suis allé sur Youtube. Evidemment Nightly me propose alors d'installer le plugin Flash. J'installe sans me poser de questions. Et la vidéo apparait sans problème.


Et je n'ai plus aucun problème. Tout fonctionne parfaitement, aussi bien les vidéos... que les pages ordinaires qui étaient auparavant si lentes à ouvrir.

Bien entendu, il ne faut pas oublier que Nightly c'est Firefox en test de ses futures versions. Donc à éviter en contexte professionnel en raison de possibles bugs affectant notre activité ou notre profil Firefox (d'où la sauvegarde au point 4 ci-dessus). Mais depuis deux jours que je l'utilise très intensivement et sur deux machines... je n'ai pas encore rencontré le moindre bug partout où je suis passé ! Toutes mes extensions fonctionnent parfaitement (y compris TabMix Plus et TreeStyle Tab, qui sont deux extensions pourtant très sensibles), mes marque-pages s'ouvrent sans aucun problème, mon historique a été conservé, mes mots de passe n'ont pas été perdus, Java fonctionne, Flash aussi, Silverlight aussi, Zotero aussi, mon SQlite Manager aussi, etc. Bref, pas le moindre problème depuis l'installation il y a 48 heures.

Dernier détail : c'est en anglais je l'ai dit. Et... le dictionnaire qui accompagne Nightly est uniquement en anglais. J'ai alors voulu télécharger le dictionnaire en français (ici). Manque de bol... il n'est pas installable sur la version 19 de Firefox. Alors... je l'ai téléchargé puis modifié pour qu'il soit installable jusqu'à la version 20 de Firefox. J'ai tenté de le mettre en pièce jointe à ce post mais je n'ai pas pu ("L'extension xpi n'est pas autorisée"). Si l'administrateur de Geckozone peut me donner le tuyau pour que je puisse partager ce fichier...
Win 10 - Modem Netgear DGN2200v4 (RJ45 sur un poste, Wi-fi sur l'autre) - Mamadoo ADSL - Avast - FF dernière V - TB dernière V - Notepad++ - Total Commander - Un oreiller - Un zozio attentif - Une théière à boire - une épouse à croquer

scoobidiver
Animal mythique
Messages : 6402
Enregistré le : 01 avr. 2011, 19:26

Re: Pages lentes à apparaître... F5

Message par scoobidiver » 23 oct. 2012, 22:59

Le plugin Flash en 64 bits est pourri dixit Mozilla.

Il n'est pas prévu de Firefox 64 bits, même si Mozilla en est techniquement capable. En voici les raisons :
http://www.geckozone.org/forum/viewtopi ... 38#p681438

Nightly existe en français et en pas mal de langues :
http://ftp.mozilla.org/pub/mozilla.org/ ... tral-l10n/

On te propose des solutions simples et stables et tu ne les testes même pas.

Avatar du membre
jpj
Animal mythique
Messages : 25243
Enregistré le : 01 août 2005, 15:38

Re: Pages lentes à apparaître... F5

Message par jpj » 24 oct. 2012, 06:17

Black Winny a écrit :… Or à l'heure actuelle il n'y a que Internet Explorer qui soit disponible en release 64 bits, c'est à dire en version publique, ayant passé les tests de validation et mise à disposition de tout le monde.…
Il semble qu'il y ait aussi Opera : http://www.opera.com/browser/download/ mais il faut cliquer sur "Plus d'options" car ce n''est pas proposé par défaut. Ils ne doivent pas juger ça trop prioritaire non plus.

PS. Je suis sous Seven x64 et je n'ai jamais eu de problème avec Flash, même en version 11.3. J'ai quelques problèmes de lenteur de chargement de page mais je soupçonne très fortement mon FAI (Orange) d'y être pour quelque chose (problème identique avec tous les navigateurs et avec un netbook sous Linux, donc c'est ou le FAI, ou le modem-routeur mais je voie mal ce dernier faire de la discrimination uniquement sur certains sites et toujours les mêmes).
► Si votre problème est [Résolu], svp, marquez-le.
► Pas de support par mp, l’aide se fait sur le forum.

Tsensei
Iguane
Messages : 715
Enregistré le : 08 nov. 2011, 19:48

Re: Pages lentes à apparaître... F5

Message par Tsensei » 24 oct. 2012, 12:29

Black Winny a écrit :La raison d'abord : j'ai fini par la trouver sur différents sites web américains (vous les trouverez aisément, et même Mozilla en parle). La raison c'est tout simplement que sur les machines tournant en Windows 64 bits, les nouvelles versions de Firefox (qui n'existe pour le moment qu'en 32 bits) et de Flash (qui existe en 32 et 64 bits) deviennent de plus en plus incompatibles entre elles. En fait, au sens large c'est encore plus simple : les développeurs de Flash, qu'il soit en 32 ou en 64 bits, ont été devant un choix à faire : continuer à jongler entre les codes pour navigateurs 32 bits et les codes pour les navigateurs 64 bits et donc entretenir encore et encore une usine à gaz... ou délibérément laisser tomber le 32 bits et se concentrer dans du code propre pour l'avenir, c'est à dire faire avant tout du 64 bits et "tant pis pour les développeurs de navigateurs qui trainent depuis des années pour sortir une version 64 bits alors que les systèmes d'exploitation Windows qui tournent aujourd'hui sont maintenant majoritairement des Windows 64 bits... sur des cartes mères 64 bits".
etc...
Je ne sais pas où tu as trouvé ces infos, mais il y a un sacré paquet d'âneries dedans. Flash 64 bits fonctionne très mal, et les navigateurs 64 bits sont quasiment inutiles et ne sont pas une priorité pour les développeurs. Flash (32 bits) fonctionne sans problème avec Firefox (32 bits) sous Win7 64, les bugs qui ont jalonné la version 11.3 sont dus à l'incompétence des développeurs Adobe et à la nouvelle sandbox qu'ils ont mis en place sans consulter les développeurs Mozilla. La majorité des problèmes sont résolus maintenant.

Avatar du membre
galoupia
Tyrannosaurus Rex
Messages : 2101
Enregistré le : 19 nov. 2008, 22:56

Re: Pages lentes à apparaître... F5

Message par galoupia » 24 oct. 2012, 13:10

Bonjour
j'ai eu le même problèmes la solution pour moi suppression d'adobe flash ('uniquement shockwave Flash)remis les plugins et laisser les inutiles en déactiver
Tout est ok

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 12 invités