Encodage caractères : pas de solution trouvée-[Résolu]

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

Répondre
RDLAF

Encodage caractères : pas de solution trouvée-[Résolu]

Message par RDLAF » 26 oct. 2011, 11:15

Bonjour,

je me résigne à déposer un message d'appel au secours car j'ai cherché sur les forums y compris celui-ci et sur le web et je ne trouve décidément pas de solution au problème d'encodage des caractères que je rencontre sur ThunderBird.

Ma configuration est Windows XP pro, à jour, et ThunderBird 7.0.1, à jour.

Mon problème est que certains des emails que je reçois sont composés de caractères indésirables comme un losange avec point d'interrogation à l'intérieur ou des € ou des é etc.

Je sais bien que le problème vient de l'encodage des caractères car quand je reçois un message avec ces caractères fâcheux, il suffit que je clique sur AFFICHAGE / ENCODAGE DES CARACTERES / UNICODE (UTF-8) ou AFFICHAGE / ENCODAGE DES CARACTERES / OCCIDENTAL (ISO-8859-1) ou AFFICHAGE / ENCODAGE DES CARACTERES / OCCIDENTAL (EURO) (ISO-8859-15), suivant les cas, pour que le message soit parfaitement lisible.

Pourtant, bien que j'aie essayé de modifier
AFFICHAGE / ENCODAGE DES CARACTERES / DETECTION AUTOMATIQUE / (DESACTIVEE) ou UNIVERSEL
clic droit sur COURRIER ENTRANT ou ENVOYES, PROPRIETES... / CODAGE PAR DEFAUT DES CARACTERES et APPLIQUER PAR DEFAUT...
OUTILS / OPTIONS / AFFICHAGE / FORMATAGE / AVANCEE... / AUTORISER LES MESSAGES A... , COURRIER ENTRANT:, COURRIER SORTANT:, QUAND C'EST POSSIBLE...
rien n'y fait, de toutes façons, certains messages restent entachés de ces caractères mal codés, ce ne sont pas toujours les mêmes messages qui sont touchés, ça dépend des modifications de paramétrages que je fait, mais il y en a toujours certains, disons 20 %, qui sont mal codés.

Idéalement, je voudrais que Thunderbird choisisse lui-même quel encodage, UTF-8, ISO-8859-1, etc., appliquer et l'applique automatiquement. Je me dis que c'est ce que le paramétrage AFFICHAGE / ENCODAGE DES CARACTERES / DETECTION AUTOMATIQUE / UNIVERSEL est censé faire mais le fait est que ça ne produit rien de bon.

Donc SVP sauriez-vous comment résoudre ce problème ?

merci par avance.

Avatar du membre
Demot
Animal mythique
Messages : 16955
Enregistré le : 28 juin 2008, 18:07

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Demot » 26 oct. 2011, 11:37

Bonjour → Pas trouvé mieux depuis TB2 et dans les versions successives
Quand un message est en UFT-8 ou l'iso la page s'ouvre avec l'encodage approprié et pas de Pb avec les clic droit.

Dans Options > Affichage > Formatage > Avancé : sélectionner :
occidental (iso-8859-1)
occidental (iso-8859-1)
Cocher ✔ Autoriser les messages à utiliser d'autres polices
Décocher ❑ Quand c'est possible utiliser l'encodage par défaut dans les réponses

Dans la barre de menu sélectionner :
Affichage / Encodage des caractères > Détection automatique > ● Universel

Sur les dossiers (exemple Courrier entrant)
Clic droit > Propriété • Décocher ❒ Appliquer par défaut à tous les messages du dossier (Ignorer l'autodétection ainsi que l'encodage spécifique par message)
❒ une vraie réponse doit avoir pour but premier d'aider, pas celui de se montrer pour palier à un manque.
Je ne lis pas les sarcasmes, c'est inutile de m'en écrire Pas confondre Pigeon et On Pige

RDLAF

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par RDLAF » 26 oct. 2011, 13:49

Bonjour Demot,
je vous remercie pour votre réponse rapide,
je pense que j'ai déjà essayé, sans succès, ces paramétrages
mais je viens de les remettre en place, éteindre, puis rallumer TB, et vais les tester pendant 24 h.
je vous tiens au courant. merci encore.

RDLAF

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par RDLAF » 27 oct. 2011, 09:15

Bonjour,

malheureusement
comme je le craignais

ces paramétrages, ci-dessus, ne suppriment pas le problème,
par exemple, extrait d'un email reçu ce matin : "... préparer l’expédition ...". :(

si je paramètre AFFICHAGE / ENCODAGE DES CARACTERES / UNICODE (UTF-8), j'obtiens "... préparer l’expédition ..." et la vie est belle ! :)

si je paramètre AFFICHAGE / ENCODAGE DES CARACTERES / OCCIDENTAL (EURO) (ISO-8859-15), j'obtiens "... préparer l’expédition ..." :(

j'ai l'impression que TB ne détecte absolument pas l'encodage de son propre chef. et pourtant j'ai bien AFFICHAGE / ENCODAGE DES CARACTERES / DETECTION AUTOMATIQUE / UNIVERSEL.
ce qui est bizarre en plus c'est que le copier / coller des messages TB vers ce présent message Firefox se fait authentiquement, sans transformation de l'encodage, des caractères.

à part utiliser un autre logiciel emails, auriez-vous SVP une solution ?

d'avance merci.

Avatar du membre
Demot
Animal mythique
Messages : 16955
Enregistré le : 28 juin 2008, 18:07

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Demot » 27 oct. 2011, 11:08

Bonjour ... STP : plus facile à lire quand écriture minuscule.

Oui mais encore quand tu reçois un message et que tu fais
Affichage > Encodage des caractères > il y a quoi de sélectionné ?
Chez moi c'est l'encodage détecté automatiquement qui est affiché
Occidental (iso-8859-1) ou Unicode (UFT-8)

En vrac : dans l'editeur de configuration : (filtre : charset)
intl.charset.detector → valeur : universal_charset_detector ?
mailnews.force_charset_override → false ?

HS : Pourquoi ce occidental (euro) (iso-8859-15) ?
❒ une vraie réponse doit avoir pour but premier d'aider, pas celui de se montrer pour palier à un manque.
Je ne lis pas les sarcasmes, c'est inutile de m'en écrire Pas confondre Pigeon et On Pige

Teraoctet
Iguane
Messages : 769
Enregistré le : 08 sept. 2011, 00:44

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Teraoctet » 29 oct. 2011, 12:43

Demot a écrit :Bonjour ... STP : plus facile à lire quand écriture minuscule.

Oui mais encore quand tu reçois un message et que tu fais
Affichage > Encodage des caractères > il y a quoi de sélectionné ?
Chez moi c'est l'encodage détecté automatiquement qui est affiché
Occidental (iso-8859-1) ou Unicode (UFT-8)

En vrac : dans l'editeur de configuration : (filtre : charset)
intl.charset.detector → valeur : universal_charset_detector ?
mailnews.force_charset_override → false ?

HS : Pourquoi ce occidental (euro) (iso-8859-15) ?
Bonjour une possible explication de cet iso-8859-15
L'encodage iso-8859-1 correspond à l'encodage de l'Europe de l'Ouest. L'iso-8859-15 comprend quelques caractères en plus, dont le signe de l'euro €

Donc cela signifie que l'iso-8859-15 est la "nouvelle version" de l'iso-8859-1 ? Si oui, alors pourquoi tant de site continue d'utiliser l'iso-8859-1 (par exemple Alsacréations) ?

Et pourquoi même en iso-8859-1 j'arrive à afficher le symbole de l'euro (alors que techniquement, il n'aurait pas dû bien s'afficher) ? Serait-ce à cause de la configuration de mon navigateur (qui prend le dessus sur l'encodage définit dans la page) ?

Si oui, comment faire pour les navigateurs ayant des paramètres différents des miens ?

Concernant l'UTF-8, je sais que c'est pour afficher n'importe quel caractères de n'importe quelle langue. De plus, il n'utilise qu'1 octet pour les caractères n'en nécessitant qu'1 (donc il est "intelligent").

Sachant également que je ne compte pas (à priori) mettre des caractères d'autres langues que celles d'Europe occidentales ?

Mais malgré tout, l'utf-8 a une bonne réputation (enfin il me semble), et on dirait qu'il prend de l'importance. Serait-donc "la solution" ?

Je sais que si l'on code en utf-8, il faut encoder également le fichier, cela est un peu plus chiant, mais est-ce le prix à payer pour se voir afficher tous ses caractères convenablement sur tous les navigateurs du monde entier (enfin navigateur récent, quoi) ?

Le XML utilise déjà l'utf-8 comme "the" encodage, doit-on s'attendre de même avec le XHTML ? Même si c'est pas pour tout de suite, est-ce que c'est ce qui va se passer ?

En bref :

Quel encodage choisir ? Pourquoi ? Quels sont les "sacrifices" à faire (par ex. encoder un fichier en plus de spécifier un encodage) ? Qui en bénéficie ? Et qui n'en bénéficie pas ?
Bonne journée :mrgreen:
Préférez Kompozer 0.8b3(20100301)

RDLAF

[RESOLU]Encodage caractères : pas de solution trouvée, help

Message par RDLAF » 03 nov. 2011, 11:53

Bonjour,

Demot, merci à vous ! mille fois merci ! : ça marche !

(désolé pour l'écriture majuscule de mon précédent email.)

vous avez touché juste :
bien que changer les paramétrages par les menus n'ait rien changer,
c'est l'éditeur de configuration qui a tout changé ! mailnews.force_charset_override était sur true.
changé en false, je n'ai plus jamais eu de problème d'encodage ! et ça dure depuis 1 semaine ! je peux considérer que c'est résolu car, statistiquement, j'aurais du en recevoir au mois 1 de "problématique".

l'ISO-8859-15 c'est simplement moi qui avais décidé de l'essayer, comme d'autres encodages, et je l'ai gardé au cas où ça résoudrait mon problème. mais ça n'a rien résolu.




ce qui est rigolo c'est que je vois, en bas à droite, arriver des messages avec des encodages de caractères "mal" décodés (en bas à droite dans la fenêtre furtive) mais qu'une fois "à leur place" dans TB, ils sont parfaitement lisibles.



je pense que vous devriez publier votre solution sur les forums car j'ai pu observer plusieurs cas non-résolus. et l'aide de TB n'apporte absolument aucune aide à ce sujet.

grand merci à vous !

cordialement

Teraoctet
Iguane
Messages : 769
Enregistré le : 08 sept. 2011, 00:44

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Teraoctet » 03 nov. 2011, 21:19

Bonsoir RDLAF,
Le publier sur d'autres forums que neni les internautes n'ont qu'à faire le...déplacement jusque Geckozone :lol:
Maintenant s'il t'es possible, tu peux clore le sujet en revenant dans ton premier message > éditer et dans la barre du titre écrire: [RESOLU]
Bonne fin de soirée :mrgreen:
Préférez Kompozer 0.8b3(20100301)

Avatar du membre
Demot
Animal mythique
Messages : 16955
Enregistré le : 28 juin 2008, 18:07

Message par Demot » 04 nov. 2011, 08:42

Image De quoi je me mêle
Si je voulais l’écrire ailleurs ce serait mon droit
RDLF est en invité il ne peut pas clore le fil

filtre ABP ||img4.hostingpics.net/pics/402560Teraoctet.gif
❒ une vraie réponse doit avoir pour but premier d'aider, pas celui de se montrer pour palier à un manque.
Je ne lis pas les sarcasmes, c'est inutile de m'en écrire Pas confondre Pigeon et On Pige

Teraoctet
Iguane
Messages : 769
Enregistré le : 08 sept. 2011, 00:44

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Teraoctet » 04 nov. 2011, 08:45

Image?....
Pour Invité je n'avais pas lu désolé
bonne journé
Préférez Kompozer 0.8b3(20100301)

FF_Olivier
Iguane
Messages : 979
Enregistré le : 09 juil. 2004, 15:41

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par FF_Olivier » 04 nov. 2011, 14:03

Demot/Teraoctet a écrit :filtre ABP ||img4.hostingpics.net/pics/402560Teraoctet.gif
Image?....
:wink: Je pense que ce que Demot cherche à te dire, c'est que ton avatar animé est insupportable, d'où direction poubelle ABP (AdBlock Plus).

Edit : et je viens seulement de découvrir qu'appuyer sur la touche [Esc] interrompait les animations GIF sur la page courante : pratique !
openSUSE 12.2 - FF v24.0 FR - TB v24.0 FR ma config en détails - Décrivez la vôtre ici ;)
userContent.css : modifiez l'apparence et le contenu des sites visités !

mpl75
Varan
Messages : 1671
Enregistré le : 14 nov. 2009, 00:28

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par mpl75 » 05 nov. 2011, 20:01

Bonsoir,
[Esc] interrompait les animations GIF sur la page courante : pratique !
excellent :D

Irat56410
Arias
Messages : 1
Enregistré le : 16 nov. 2013, 17:54

Re: Encodage caractères : pas de solution trouvée, help SVP.

Message par Irat56410 » 21 déc. 2014, 10:13

Merci RDLAF!
Votre solution :"c'est l'éditeur de configuration qui a tout changé ! mailnews.force_charset_override était sur true.
changé en false, je n'ai plus jamais eu de problème d'encodage" fonctionne parfaitement sur Thunderbird 31.3.0 sur Mac10.8.
TB est maintenant parfait en ce qui me concerne!
Bonnes fêtes de fin d'année!
Votre Navigateur : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:34.0) Gecko/20100101 Firefox/34.0

Avatar du membre
Demot
Animal mythique
Messages : 16955
Enregistré le : 28 juin 2008, 18:07

Re: Encodage caractères : pas de solution trouvée-[Résolu]

Message par Demot » 21 déc. 2014, 11:47

Pourquoi déterrer un fil de 2011 ?!

A savoir pour activer la détection automatique de l'encodage y compris dans Tb 31.3.0
Dans l’éditeur de configuration
  • intl.charset.detector ➜ universal_charset_detector
.....
❒ une vraie réponse doit avoir pour but premier d'aider, pas celui de se montrer pour palier à un manque.
Je ne lis pas les sarcasmes, c'est inutile de m'en écrire Pas confondre Pigeon et On Pige

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot], REDG et 10 invités