l'incompatibilité des modules change d'un jours à l'autre

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

Répondre
KooK_dev
Arias
Messages : 7
Enregistré le : 16 mai 2011, 15:21

l'incompatibilité des modules change d'un jours à l'autre

Message par KooK_dev » 20 sept. 2011, 09:12

Bonjour,

Depuis la mise à jour en version 5 de TB, j'avais perdu mon agenda (extension lightning).
Ce matin sans rien avoir changé (à ma connaissance), sans avoir fait de mise à jour, j'ai retrouvé un agenda (youpi), mais presque tous mes autres modules sont maintenant marqués incompatibles.

Je me demandais si quelqu'un avait déjà eu un comportement similaire et si les extensions sont chargés dans TB selon un ordre pouvant changer d'un jour à l'autre (ce qui pourrait expliquer le pb par une interaction entre modules) ?

TB : 6.02 portable ( framabird )
modules ok :
Enigmail 1.3.2
Ligthning 1.0b5

modules fonctionnant encore hier soir, mais plus ce matin
Display Quota 0.3.3.1
Extra Folder Columns 1.1.3
LightningButton 1.5.1
Signal Spam 0.6
ThunderBirthDay 0.5.0

Windows 7 et XP (le même profil est utilisé pour thunderbird dans Ubuntu pas utilisé entre hier soir et ce matin).

KooK
KooK

phocas
Tyrannosaurus Rex
Messages : 2488
Enregistré le : 15 déc. 2004, 11:31

Re: l'incompatibilité des modules change d'un jours à l'autr

Message par phocas » 22 sept. 2011, 12:58

Salut

c'est tout simplement le développeur de chaque extension qui est responsable de son portage vers TB
D'ou les délais variables dans les mises à jour

chaques fois que tu ouvres TB il vérifie si des modules n'ont pas été mis à jour et les récupére
ils sont ensuite activés au démarrage suivant

J2m06
Administrateur
Messages : 21454
Enregistré le : 05 déc. 2005, 10:46

Re: l'incompatibilité des modules change d'un jours à l'autr

Message par J2m06 » 22 sept. 2011, 14:30

bonjour

A savoir certaines extensions peuvent étre " bumper"
Voir cette FAQ sur les extensions http://j2m-06.pagesperso-orange.fr/faq_ ... sions.html

et j'ai aussi mis en téléchargements des extensions modifiées pour TB6 :wink:
https://sites.google.com/site/j2m06cote ... ements/dow

.
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

KooK_dev
Arias
Messages : 7
Enregistré le : 16 mai 2011, 15:21

Re: l'incompatibilité des modules change d'un jours à l'autr

Message par KooK_dev » 22 sept. 2011, 14:59

Salut,

Merci d'avoir répondu.
C'est bien l'idée qui m'était venue, mais je reste sceptique.
Pourquoi un développeur (5 dans mon cas) ferait une mise à jour qui briserait la compatibilité ?
...
Je pense plutôt pour l'interaction entre module.
Je viens de lancer "à la main" la mise à jour des extensions.
Toutes mes extensions sont marquées comme actives, mais je n'ai plus le calendrier.

Je vais les désactiver une par une pour voir.
...
Bon, c'est le plus logique : LightningButton 1.5.1 est incompatible avec Lightning 1.0b5.
Je vais rapporter le problème aux développeurs de ces extensions, ainsi qu'au service informatique qui demande de les installer sur nos machines.

[nouvelle édition]
En fait, sous XP, je n'ai plus de calendrier. C'est donc aussi lié à la version du SE.
[/nouvelle édition]
KooK

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 11 invités