Suppression des extensions des pièces jointes

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

Répondre
carthae
Gecko
Messages : 64
Enregistré le : 29 déc. 2006, 19:27

Suppression des extensions des pièces jointes

Message par carthae » 10 oct. 2008, 14:40

Bonjour, il y a un bug avec mon TB. On m'avertit que les fichiers que j'envoie (de différents formats) n'ont pas d'extension et ne peuvent pas être ouverts directement.

Quelqu'un saurait-il pourquoi ?

Merci de votre aide.

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Fabrice.Tres.Net
Tyrannosaurus Rex
Messages : 2390
Enregistré le : 26 juin 2006, 12:50

Message par Fabrice.Tres.Net » 10 oct. 2008, 15:09

Je ne sais pas pourquoi.

Mais un fichier n'est pas obligé d'avoir une extension. Un bon courrielleur ne devrait jamais ouvrir un fichier en se basant sur le nom de son extension.
Cela doit se faire sur le type mime transmis conjointement avec le fichier.

Question: es-tu sûr que les fichiers envoyés ont une extension?

carthae
Gecko
Messages : 64
Enregistré le : 29 déc. 2006, 19:27

Message par carthae » 10 oct. 2008, 16:23

Merci pour la réponse, même si elle ne m'aide guère. Oui, j'en suis sûre.

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Fabrice.Tres.Net
Tyrannosaurus Rex
Messages : 2390
Enregistré le : 26 juin 2006, 12:50

Message par Fabrice.Tres.Net » 10 oct. 2008, 17:28

Tu peux jeter un coup d'oeil dans le source d'un de tes messages envoyés.
(Pour voir le source CTRL U dans le message ou par le menu Affichage > Source du message)
Tu devrais trouver quelque chose comme cela pour la pièce jointe excel:
--------------030509050701010605050802
Content-Type: application/vnd.ms-excel;
name="Simulation.xls"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="Simulation.xls"

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7/CQAGAAAAAAAAAAAAAAABAAAAIAAAAAAA
(ce charabia c'est le contenu du fichier encodé)
Peux-tu en faire une copie similaire et la postée?
Modifié en dernier par Fabrice.Tres.Net le 09 déc. 2008, 11:41, modifié 1 fois.

carthae
Gecko
Messages : 64
Enregistré le : 29 déc. 2006, 19:27

Message par carthae » 31 oct. 2008, 18:59

Ca donne ca:

--------------000600030904010405010608
Content-Type: application/msword;
name="Compte-rendu de la =?UTF-8?B?csOpdW5pb24gZHUgamV1ZGkgMzAgb2N0b2JyZSAyMDA4?==?UTF-8?B?IGF2ZWMgTS4gRnJpdHNjaC5kb2M=?="
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename*0*=UTF-8''%43%6F%6D%70%74%65%2D%72%65%6E%64%75%20%64%65%20%6C%61;
filename*1*=%20%72%C3%A9%75%6E%69%6F%6E%20%64%75%20%6A%65%75%64%69%20%33;
filename*2*=%30%20%6F%63%74%6F%62%72%65%20%32%30%30%38%20%61%76%65%63%20;
filename*3*=%4D%2E%20%46%72%69%74%73%63%68%2E%64%6F%63

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7/CQAGAAAAAAAAAAAAAAABAAAALQAAAAAA
AAAAEAAALwAAAAEAAAD+////AAAAACwAAAD

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

caméléon
Animal mythique
Messages : 9526
Enregistré le : 08 nov. 2004, 17:54

Message par caméléon » 01 nov. 2008, 08:13

On dirais que ta PJ word est transmise en ligne (cf: Content-Disposition: inline; ).
Il faudrait avoir plutôt ceci: Content-Disposition: attachment;
Essais la solution 1 de ce post pour voir si ça règle le problème: http://www.geckozone.org/forum/viewtopi ... 187#332187

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

archeboc
Iguane
Messages : 776
Enregistré le : 15 nov. 2004, 19:03

Message par archeboc » 01 nov. 2008, 08:31

Salut et bon week-end

Ne serait-ce pas le programme anti-virus qui masque l'extension ?
Du temps où j'utilisais Kaspersky, celui-ci modifiait systématiquement les extensions des fichiers Word (susceptibles de contenir des macro..douteuses)

Pour cette raison je ne transmets que des *.rtf ou *.pdf pour les courriers.


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Ne faites jamais savoir à un ordinateur combien vous êtes pressé(e)

carthae
Gecko
Messages : 64
Enregistré le : 29 déc. 2006, 19:27

Message par carthae » 01 nov. 2008, 12:11

Je ne saurais trop dire,j'utilise AVG free et je n'ai presque pas d'options. Si c'est bien là que réside le problème, je ne vois aucun moyen pour changer cela...

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

J2m06
Administrateur
Messages : 21450
Enregistré le : 05 déc. 2005, 10:46

Message par J2m06 » 01 nov. 2008, 14:01

Bonjour


As-tu essayé de t'envoyer des Pj pour voir :?:
carthae a écrit : je ne vois aucun moyen pour changer cela...
Tu peux le désactiver provisoirement pour les essais :!:
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

caméléon
Animal mythique
Messages : 9526
Enregistré le : 08 nov. 2004, 17:54

Message par caméléon » 01 nov. 2008, 18:24

Et ma solution, ça donne quoi :?:

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 36 invités