[RESOLU] impossible desinstaller/reinstaller extensions v1.5

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

[RESOLU] impossible desinstaller/reinstaller extensions v1.5

Message par gilles6975 » 01 déc. 2005, 09:18

Bonjour a tous.
Voila mon probleme j'avais Minimize to tray sur la version precedente de Tb. Apres passage a la 1.5 je voulais enlever cette extension pour installer celle en développement compatible.

Or par l'interface des extensions je n'arrive pas a l'enlever il me dit systematiquement que l'extension sera mise a jour ou desinstaller au prochain demarrage de Tb.

Une capture ci dessous :
Image

Bref si vous savez comment enlever une extension sans passer par le gestionnaire des extensions cela me rendrait service.

Au passage utilisez vous la beta de Minimize to tray et cela marche t il ?

Merci par avance de vos réponses.


[edit] d'ailleurs je viens de me rendre compte que cela me fait la même chose avec toutes les extensions grisées sur la capture. Mon profil est il corrompu. POurtant j'ai réinstallé Tb 1.5 RC1 pour voir mais cela n'a rien changé
Modifié en dernier par gilles6975 le 09 déc. 2005, 14:42, modifié 1 fois.

asap29
Animal mythique
Messages : 12088
Enregistré le : 30 oct. 2003, 00:34

Message par asap29 » 01 déc. 2005, 10:08

apparemment toutes tes extensionssont dans le meme cas
2 solutions
1) tu vas dans ton profil et supprime les dossiers chromes et extensions et la touts tes themes et extensions vont etre supprimés

2)toujours dans ton ptofil dans le dossier extension ouvre chaque dossier l'un après l'autre du genre 8514762846231
ouvre le chrome et cherche le nom de l'extension que tu veux supprimer
une fois identifier tu supprime tout le dossier <chiffres>

http://www.geckozone.org/articles/2005/ ... -le-profil

3)minimize pas utuilisé
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 01 déc. 2005, 11:22

J'ai suivi la première methode proposée.
J'ai donc supprimé le dossier chrome et extensions ansi que les fichiers extensions *.cache, *.rdf et *.ini de même que component.ini (dans lequel il y'a avait des liens vers les dossiers extensions).

J'ai desinstallé et réinstallé TB 1.5.

La liste des extensions a été complétement nettoyée.

J'ai réinstallé mon thème : pas de probleme
J'ai réinstallé les extensions : et là toujours le même probleme : "l'extension machin sera installé lors du prochain démarrage de TB". J'ai beau redémarrer TB rien y fait !


Nota : j'ai essayé en enlevant les thèmes et cela ne donne rien.

Je remarque aussi que dans mon profile dans le dossier extensions j'ai des dossiers de ce type {28BA62BF-022B-44a3-88BC-D2112DDB7D} mais qui ne contiennent aucun fichier (sauf celui contenant le thème). Cela me fait penser que l'installation ne doit pas se faire.

De même toujours dans le dossier extension j'ai un dossier staged-xpis qui contient les *.xpi (je ne sais pas si c'est normal je n'avais jamais remarqué ce dossier).

Voila donc visiblement impossible d'installer des extensions.

Je ne sais plus trop quoi faire :-(

asap29
Animal mythique
Messages : 12088
Enregistré le : 30 oct. 2003, 00:34

Message par asap29 » 01 déc. 2005, 12:23

gilles6975 a écrit :J'ai suivi la première methode proposée.
J'ai donc supprimé le dossier chrome et extensions ansi que les fichiers extensions *.cache, *.rdf et *.ini de même que component.ini (dans lequel il y'a avait des liens vers les dossiers extensions).

ou as tu trouvé ces fichiers.cache......
Je remarque aussi que dans mon profile dans le dossier extensions j'ai des dossiers de ce type {28BA62BF-022B-44a3-88BC-D2112DDB7D}
supprime les
De même toujours dans le dossier extension j'ai un dossier staged-xpis qui contient les *.xpi
connais pas non plus
cela le fait uniquement avec minimize tout tray

il te serait peut etre plus facil de creer un nouveau profil pour tester l'install des extensions
Modifié en dernier par asap29 le 01 déc. 2005, 12:56, modifié 1 fois.
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 01 déc. 2005, 12:47

Je vais essayer avec un nouveau profil.

Je mets les captures qui montrent les dossiers dont je parle. Ca me parait bizarre tout cela. Aurais je une extension qui a foutu le bazarre ?
Nota: je suis sous W98SE

Je te tiens au courant avec le nouveau profil.

Image ou on voit le staged-xpis (le chemin relatif est dans la barre d'adresse)

Image

Image ou on voit le fichier *.cache

Image

asap29
Animal mythique
Messages : 12088
Enregistré le : 30 oct. 2003, 00:34

Message par asap29 » 01 déc. 2005, 14:31

je pense avoir une explication a ton pb

tu as certainement copié les fichiers .xpi dans le dossier extension du profil(comme pour FF1.5 maintenant) pensant qu'ils allaient s'installer tous seuls-->he ben non ça marche pas comme ça->pas savoir pourquoi

essai la methode classique
ouvre la fenetre extension-->installer-->pointe sur le fichier.xpi
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 01 déc. 2005, 16:23

J'ai bien essayé d'installer mes extensions via outils--> extensions -->installer mais cela m'a donné le résultat ci dessus.

J'ai essayé en créant un autre profil : même résultat

J'ai essayé en installant une autre extension : même résultat


bref je crois que c'est le bazard dans mon profil faudrait que je trouve la liste des fichiers normaux et que j'arrive a isoler les pas normaux.

C'est toujours la mer..

Je ne sais pas ce qui s'est passé avant tout marchait bien :cry:

jmg
Lézard à collerette
Messages : 211
Enregistré le : 10 oct. 2005, 15:34

Message par jmg » 01 déc. 2005, 16:31

Sinon la solution un peu radical est de recréer un nouveau profil et glisser tous tes dossiers de mails sans extensions (voir le lien du profil sous ma signature pour savoir comment ca fonctionne).

Comme cela tu reparts avec d'une part un profil propre et tes mails préservé :)

j'espére t'avoir aidé ! ++++
Guéro Jean-Marie
Planète Sciences
www.planete-sciences.org
Clic sur Comprendre le Profil
Compacter c'est quoi ?

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 01 déc. 2005, 16:54

jmg a écrit :Sinon la solution un peu radical est de recréer un nouveau profil et glisser tous tes dossiers de mails sans extensions (voir le lien du profil sous ma signature pour savoir comment ca fonctionne).

Comme cela tu reparts avec d'une part un profil propre et tes mails préservé :)

j'espére t'avoir aidé ! ++++

Je crois que cette solution que je vais choisir en esperant que cela marche et qu'il n'y ait pas de bug !!

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 01 déc. 2005, 18:20

Suite de mes peripeties.

J'ai créé un profil vierge. Je n'ai recupéré que mes mails et j'ai tenté d'installer une extension.

Malheureusement cela s'est conclue par un echec flagrant. Toujours la même chose. "l'extensions xyxyx sera installée au prochain démarrage de TB" ce qui evidemment ne se produit pas :(

Heureusement que cela ne me fait pas ca sous FF ou les extensions sont plus indispensables !!


Peut être quelqu'un a t il encor eune idée :?

jmg
Lézard à collerette
Messages : 211
Enregistré le : 10 oct. 2005, 15:34

Message par jmg » 01 déc. 2005, 19:35

C'est quelle extension que tu essayes d'installer ?

Peut être un probléme de droit ! Es tu l'admin de ton ordinateur ?
Guéro Jean-Marie
Planète Sciences
www.planete-sciences.org
Clic sur Comprendre le Profil
Compacter c'est quoi ?

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 02 déc. 2005, 08:29

Je suis sous 98 donc les problemes d'admin ne se posent pas (de toute facon il n'y a un qu'un seul profil sur mon pc).

En ce qui concerne les extensions cela me le fait avec toutes !! J'ai bien fait atention a ne prendre que celle compatibles avec TB 1.5.

Le probleme a commencé pour l'installation de Minimize to tray et apres impossible d'installer correctement ou de desinstaller n'importe quelle extension.

Est ce qu'on peut trouver une liste des fichiers types qui doivent être dans le profil. Ca me permettrait de checker ceux qui sont en plus et peut être trouver l'origine du probleme !

Il y a deja ceux que jai trouvé dans comprendre e profil mais y en a t il d'autres ?

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 09 déc. 2005, 14:17

Je m'auto répond parceque je continue a chercher !!!

J'ai vu le post de Flore ici :
http://www.geckozone.org/forum/viewtopic.php?t=32654
a propos de Firefox.

Je me suis dit ca doit être pareil sur TH. C'est effectivement pareil mais j'etais deja à true pour la valeur xpi.enabled

Cependant vous noterez que j'ai le même probleme que celui que décrit Flore sauf que moi c'est pour TH.

En parcourant le about:config je me suis rend compte qu'un truc que j'avais supprimé est resté et je pense que c'est lui qui interfere.

Il s'agit de Yamb qui permettait sur les veilles versions de Th de changerle notifieur. Je n'ai pas regardé tout mon about: config mais je me demande comment s'en faire un "viergeé ou comment vraieent desnstaller certains plugin.

Voila si quelqu'un a de l'inspiration ce serait cool :o

Je rajoute que dans le dossier chrome de mon profil il n'y a aucun fichier !!

gilles6975
Salamandre
Messages : 35
Enregistré le : 23 juin 2005, 08:36

Message par gilles6975 » 09 déc. 2005, 14:39

YESSSSSSSSS J'AI TROUVE........

Bon alors comme tout probleme compliqué a une solution simple j'ai cherché longtemps des trucs ultra compliqués.

J'avais deja fait une desinstallation/reinstallation sans aucun resultat. Le fait de voire des trucs que j'avais viré être encore dans le about:config m'a mis sur la piste. (cf post precedent).


J'ai desinstallé une nouvelle fois TH mais cette mois ci je suis allé voir ce qu'il restait dans le dossier C:\Program Files\Mozilla Thunderbird et là oh surprise plein de merdouilles qui dataient de veilles version ou d'anciennes extensions dont je n'avais plus besoin. Pourquoi cela c'est mis la et pourquoi ce ne part pas a la desinstallation : mystère.;

Bref je supprime le dossier C:\Program Files\Mozilla Thunderbird et je refais mon installation.

Je me lance dans l'installation d'un xpi et oh miracle cela marche..


En esperant ne pas avoir trop cassé les pieds a ceux qui ont tenté de m'aider : ca marche ;)

jmg
Lézard à collerette
Messages : 211
Enregistré le : 10 oct. 2005, 15:34

Message par jmg » 09 déc. 2005, 14:45

En y réfléchissant ca parait simple en effet car pourquoi un logiciel supprimerait des fichiers qu'il n'a pas crée ! C'est le cas avec Thunderbird et ses extensions. Thunderbird ne connait pas forcément les extensions donc ne supprime pas les fichiers crée par les extensions ;)

Bon à savoir je note dans ma mémoire ;)
Guéro Jean-Marie
Planète Sciences
www.planete-sciences.org
Clic sur Comprendre le Profil
Compacter c'est quoi ?

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 7 invités