[RÉSOLU] "Sécurité Windows" ?!

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

Almohan
Salamandre
Messages : 21
Enregistré le : 01 août 2013, 14:58

[RÉSOLU] "Sécurité Windows" ?!

Message par Almohan » 14 sept. 2020, 21:05

Bonsoir.

Recevant de Yahoo une nouvelle flopée d'"Avis de sécurité important concernant votre compte Yahoo", je veux vérifier que j'ai déjà effectué la manipulation pour chacun des comptes la dernière fois que Yahoo m'y a incité, donc je vais dans Outils > Options > Mots de passe enregistrés... > Afficher les mots de passe -- et là, pour la première fois, je vois surgir une boîte de dialogue intitulée "Sécurité Windows" où je lis : "Mozilla Thunderbird - Confirmez votre identité pour révéler les mots de passe enregistrés." Problème (s) :
1. je n'ai pas le souvenir d'avoir crée quoi que ce soit de ce genre !
2. pourquoi cette boîte de dialogue s'appelle-t-elle "Sécurité Windows" ?

J'ai tenté "Autre choix", mais le système m'impose une adresse email (qui n'est même pas mon adresse principale par défaut dans Thunderbird) pour laquelle rien de ce que j'entre dans les champs ne le satisfait.
La boîte de dialogue indique que je peux "réinitialiser [mon] code confidentiel en accédant à Paramètres > Comptes > Options de connexion, mais je ne trouve nulle part ces "Options de connexion".
Je suis également passé par Mots de passe > Utiliser un mot de passe principal, mais ça me ramène à l'étape "Sécurité Windows".

Les questions que je me pose sont donc :
1. pourquoi cette nouvelle complication (qui semble concerner Thunderbird et pas Yahoo) ?
2. comment accéder à "Afficher les mots de passe" ?
3. (et accessoirement) pourquoi cette "Sécurité Windows" dans une interface Thunderbird ?

Grand merci à qui saura m'éclairer...!

Almohan

P.-S. Je ne peux pas être le seul à qui ça tombe soudain dessus, mais je n'ai pas trouvé de sujet déjà crée.
Modifié en dernier par Almohan le 15 sept. 2020, 13:17, modifié 1 fois.

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 4164
Enregistré le : 02 avr. 2006, 03:24

Re: "Sécurité Windows" ?!

Message par Jean-Claude » 15 sept. 2020, 01:04

Bonjour,

Pour info :

C'est une nouveauté de la version 78 de Thunderbird. Voir ici https://translate.google.be/translate?h ... senotes%2F
https://translate.google.be/translate?hl=fr&sl=en&tl=fr&u=https%3A%2F%2Fwww.thunderbird.net%2Fen-US%2Fthunderbird%2F78.0%2Freleasenotes%2F a écrit : MODIFIÉ Thunderbird demandera maintenant le mot de passe du compte OS avant d'afficher les mots de passe enregistrés
Note : compte OS = compte operating system. Il s'agit du compte utilisateur lié au système d'exploitation.

Comme je n'ai pas encore installé la version 78, je ne sais pas s'il y a moyen de désactiver cette demande. Je n'ai pas trouvé d'informations en rapport sur Internet.

A+

En ligne
Agent virtuel
Tyrannosaurus Rex
Messages : 3130
Enregistré le : 29 janv. 2018, 12:06

Re: "Sécurité Windows" ?!

Message par Agent virtuel » 15 sept. 2020, 05:14

Bonjour
Almohan a écrit :
14 sept. 2020, 21:05
P.-S. Je ne peux pas être le seul à qui ça tombe soudain dessus, mais je n'ai pas trouvé de sujet déjà crée.
viewtopic.php?p=905048#p905048

Almohan
Salamandre
Messages : 21
Enregistré le : 01 août 2013, 14:58

Re: "Sécurité Windows" ?!

Message par Almohan » 15 sept. 2020, 09:03

Grand merci à vous deux !
En effet, après quelques tâtonnements, j'ai enfin pu accéder aux mots de passe en entrant mes identifiants MS (encore faut-il avoir créé un compte), attendu que par "nom d'utilisateur" il fallait comprendre l'adresse email.
...Ouf !

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: "Sécurité Windows" ?!

Message par Rolandin » 27 oct. 2020, 15:13

Almohan a écrit :
15 sept. 2020, 09:03
Grand merci à vous deux !
En effet, après quelques tâtonnements, j'ai enfin pu accéder aux mots de passe en entrant mes identifiants MS (encore faut-il avoir créé un compte), attendu que par "nom d'utilisateur" il fallait comprendre l'adresse email.
...Ouf !
Bonjour à vous tous, :wink:
J'ai le même problème sur 3 PCs, c'est la galère la plus complète. J'ai bien créé un compte Microsoft, pour chacun, mais je ne me souviens d'aucun. Je mélange les codes demandé à l'installation de Windows 10, ou là aussi il faut créer un compte "gmail", mais depuis mon compte "gmail" a changer de MDP car oublié, c'est bien de celui là dont il est question pour accéder aux mots de passe depuis quelques mois :idea: . Quand je vais pour réinitialiser mon passe gmail, il me propose mon adresse, je la sélectionne, une dizaine de point apparaissent, et en cliquant sur l'icône en forme d'oeil je vois ce passe en clair.
Mais quand il faut le rentrer pour voir les mots de passes de TB, adresse et mot de passe non sont pas valable.
C'est quoi cette histoire. Je suis prisonnier de mon propre matériel, c'est injuste, surtout sans moyen de changer ces infos oubliées.
Vous les sp&spécialistes que me conseillez vous s.v.p

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 4164
Enregistré le : 02 avr. 2006, 03:24

Re: "Sécurité Windows" ?!

Message par Jean-Claude » 27 oct. 2020, 17:52

Rolandin a écrit :
27 oct. 2020, 15:13
J'ai bien créé un compte Microsoft, pour chacun, mais je ne me souviens d'aucun.
Bonjour,

Plutôt que de créer un compte Microsoft, tu peux créer un compte local, indépendant de toute boîte mails.
Voir ici https://lecrabeinfo.net/creer-un-compte ... ws-10.html

A+

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: [RÉSOLU] "Sécurité Windows" ?!

Message par Rolandin » 27 oct. 2020, 20:00

Merci Jean Claude, je vais testé cela demain à tête reposé, je reviendrais.

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: "Sécurité Windows" ?!

Message par Rolandin » 28 oct. 2020, 10:47

Jean-Claude a écrit :
27 oct. 2020, 17:52

Plutôt que de créer un compte Microsoft, tu peux créer un compte local, indépendant de toute boîte mails.
Voir ici https://lecrabeinfo.net/creer-un-compte ... ws-10.html
A+
Bonjour Jean Claude, j'ai créé ce compte utilisateur local, mais quand je demande d'afficher les mots de passe, j'ai toujours cette fenêtre qui s'ouvre, je rendre le nom et passe de d'utilisateur local, et celà ne fonctionne toujours pas.

C'est le code "confidentiel" (ou code PIN) qu'il demande, ou le compte Windows, ou compte "utilisateur", ou le "session", je n'y comprends plus rien avec tous ces codes pour accéder "CHEZ MOI" :evil:

Si tu peux me venir en aide car à prêt de 80 ans je suis perdu, merci d'avance.

PS: Toujours pas de réponse qui arrivent dans ma boite :idea:

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 4164
Enregistré le : 02 avr. 2006, 03:24

Re: "Sécurité Windows" ?!

Message par Jean-Claude » 28 oct. 2020, 13:57

Rolandin a écrit :
28 oct. 2020, 10:47
C'est le code "confidentiel" (ou code PIN) qu'il demande, ou le compte Windows, ou compte "utilisateur", ou le "session",
Bonjour,

C'est bien le nom de l'utilisateur local qu'il faut encoder, plus son mot de passe.
Cela fonctionne comme cela aussi sur mon PC.

Mais se pose une question :

Est-ce bien cet utilisateur local (+ mot de passe) que tu utilises pour démarrer ton PC, et ouvrir ta session Windows, et ensuite démarrer Thunderbird ?
Car sous Windows, chaque l'utilisateur a son propre espace applicatif, et Thunderbird installe son profil par défaut dans l'espace applicatif propre à l'utilisateur qui effectue l'installation.
Comment faisais-tu auparavant pour t'identifier au démarrage de Windows ?
Comme ton utilisateur local est récent, as-tu déplacé le profil de Thunderbird dans son espace applicatif propre, sous %appdata%, c-à-d dans le répertoire
c:\users (traduit "utilisateurs")\[utilisateur Windows]\appdata\roaming\ ?

De mon côté, je vais faire des recherches pour voir s'il est possible de faire sauter cette demande d'un nom d'utilisateur Windows, avec son mot de passe, lors de l'accès aux mots de passe sauvegardés dans Thunderbird. Cette nouvelle fonctionnalité dans Thunderbird semble poser pas mal de soucis.

A+

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: [RÉSOLU] "Sécurité Windows" ?!

Message par Rolandin » 28 oct. 2020, 15:06

Merci Jean Claude de t'occuper de mon cas, je doit m'absenter, pour rechercher mes lunettes, et passer chez l'audio prothésiste. Je répondrais (si je le peux) à tes questions, merci encore @+

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: "Sécurité Windows" ?!

Message par Rolandin » 28 oct. 2020, 18:25

Jean-Claude a écrit :
28 oct. 2020, 13:57
Est-ce bien cet utilisateur local (+ mot de passe) que tu utilises pour démarrer ton PC, et ouvrir ta session Windows, et ensuite démarrer Thunderbird ?
Non, c'est celui du compte Microsoft
Jean-Claude a écrit :
28 oct. 2020, 13:57
Car sous Windows, chaque l'utilisateur a son propre espace applicatif, et Thunderbird installe son profil par défaut dans l'espace applicatif propre à l'utilisateur qui effectue l'installation.
Comment faisais-tu auparavant pour t'identifier au démarrage de Windows ?
Avant comme maintenant c'est le compte Microsoft avec l'adresse "gmail" plus son mot de passe; ensuite pour ne pas à avoir à le rentrer à chaque allumage (ou comme il est dit "session") j'ai ét dans le compte utilisateur pour décocher la case "Les utilisateurs doivent rentrer.....etc, etc
Jean-Claude a écrit :
28 oct. 2020, 13:57
Comme ton utilisateur local est récent, as-tu déplacé le profil de Thunderbird dans son espace applicatif propre, sous %appdata%, c-à-d dans le répertoire
c:\users (traduit "utilisateurs")\[utilisateur Windows]\appdata\roaming\ ?
Je sais aller jusque là, mais je fais quoi à cet endroit (il y a le dossoer "Thunderbird"

Ok merci encore, c'est pénible ce truc, il y a déjà tellement de truc à se rappeler, à chaque connexion sur les différents forums ou autres :oops:

[modération]
@rolandin
Pour rendre compréhensible le message, les balises de citation ont été retouchées. Merci d'en prendre note.
lool-lauris
[/modération]

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 4164
Enregistré le : 02 avr. 2006, 03:24

Re: "Sécurité Windows" ?!

Message par Jean-Claude » 28 oct. 2020, 23:25

Rolandin a écrit :
28 oct. 2020, 10:47

C'est le code "confidentiel" (ou code PIN) qu'il demande, ou le compte Windows, ou compte "utilisateur", ou le "session", je n'y comprends plus rien avec tous ces codes pour accéder "CHEZ MOI" :evil:
Bonjour,

J'ai trouvé le moyen de faire sauter cette demande de mot de passe du compte utilisateur Windows lors de l'affichage des mots de passe sauvegardés.
Il suffit de passer le paramètre "security.osreauthenticator.blank_password" à TRUE dans l'éditeur de configuration de Thunderbird.
Pour cela : menu / outils / Options / général / tout en bas du volet droit : éditeur de configuration / je prends le risque / dans le champ "Recherche", tape "security.osreauthenticator.blank_password", double-clique sur la ligne résultat pour faire passer sa valeur à TRUE / ferme la fenêtre en cliquant sur le X.

L'effet est immédiat. On retrouve donc après cela la gestion des mots de passe telle qu'elle était dans les versions antérieures à la version 78.
Ce sera à toi de gérer la protection de tes mots de passe, soit en utilisant un mot de passe principal, soit en protégeant ta session Windows au démarrage du PC.

A+

Rolandin
Iguane
Messages : 867
Enregistré le : 09 oct. 2005, 16:03

Re: [RÉSOLU] "Sécurité Windows" ?!

Message par Rolandin » 29 oct. 2020, 09:44

Bonjour et un grand merci Jean Claude

Tu vas faire des heureux. J'ai eu un moment de frayeur. Je suis ta ligne de commande, je passe la valeur "FALSE" à la valeur "TRUE", et je vais voir mes mot de passe. Horreur même fenêtre demandant de confirmer mon identité.

Je redémarre le PC, je retourne pour voir si "TRUE" est bien pris comme modif, et je vois qu'à la place il y a "FALSE", je corrige en "TRUE", et là, miracle mes mots de passe apparaissent comme avant la version "78"

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 4164
Enregistré le : 02 avr. 2006, 03:24

Re: [RÉSOLU] "Sécurité Windows" ?!

Message par Jean-Claude » 29 oct. 2020, 21:12

Rolandin a écrit :
29 oct. 2020, 09:44
Je redémarre le PC, je retourne pour voir si "TRUE" est bien pris comme modif, et je vois qu'à la place il y a "FALSE"
Bonjour,

Je viens de me rendre compte du problème.
La valeur de security.osreauthenticator.blank_password repasse automatiquement à sa valeur par défaut, c-à-d. FALSE, après un redémarrage du PC, voire en cours de session après un certain délai.
Embêtant :cry:

EDIT
La solution qui a l'air de tenir la route, est de placer ce paramètre dans un fichier user.js.
Pour cela, copier les lignes suivantes :

Code : Tout sélectionner

user_pref("security.osreauthenticator.blank_password", true);
user_pref("security.osreauthenticator.password_last_changed_hi", 99999999);
user_pref("security.osreauthenticator.password_last_changed_lo", 99999999);
dans un fichier texte, et sauver ce fichier sous le nom "user.js" dans le profil, à côté du prefs.js qui contient la configuration standard.
Les paramètres dans user.js sont activés après ceux de prefs.js, et écrasent les paramètres identiques contenus dans prefs.js.

A+

En ligne
Agent virtuel
Tyrannosaurus Rex
Messages : 3130
Enregistré le : 29 janv. 2018, 12:06

Re: [RÉSOLU] "Sécurité Windows" ?!

Message par Agent virtuel » 30 oct. 2020, 05:58

Bonjour

Autre essai

Verrouiller security.osreauthenticator.blank_password true c'est possible via un fichier mozilla.cfg

autoconfig.js

Code : Tout sélectionner

//
pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);
Enregistrer votre fichier
Type : Tous les fichiers
autoconfig.js

mozilla.cfg

Code : Tout sélectionner

//
lockPref("security.osreauthenticator.blank_password", true);
Enregistrer votre fichier
Type : Tous les fichiers
mozilla.cfg

autoconfig.js à placer dans le dossier pref

Thunderbird (64 bits)
C:\Program Files\Mozilla Thunderbird\defaults\pref
Thunderbird (32 bits)
C:\Program Files (x86)\Mozilla Thunderbird\defaults\pref

mozilla.cfg à placer dans le dossier Mozilla Thunderbird

Thunderbird (64 bits)
C:\Program Files\Mozilla Thunderbird
Thunderbird (32 bits)
C:\Program Files (x86)\Mozilla Thunderbird

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Agent virtuel et 18 invités