Police de signature disparaît à l'envoi

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

Répondre
damienSerres
Arias
Messages : 1
Enregistré le : 24 juin 2019, 12:15

Police de signature disparaît à l'envoi

Message par damienSerres » 24 juin 2019, 16:31

Bonjour à tous,

J'utilise une signature html dans Thunderbird et j'ai noté un souci.

C'est sans doute une astuce dans les menus de Thunderbird, mais j'ai changé toutes les polices vers celle que je veux (Fira Mono) et rien n'y fait.
- Lorsque j'ouvre un nouveau mail ma signature se place bien avec la bonne police
https://drive.google.com/file/d/1txDUgx ... sp=sharing

- Lorsque le mail est reçu la police change (probablement en police par défaut)
https://drive.google.com/file/d/1Fk7Gbc ... sp=sharing

Je l'ai testé chez un ami qui a un Mac et il reçoit pareillement cassé.


Code : Tout sélectionner

<!doctype html>
<html>
<head>
<meta charset="UTF-8">
<title>Signature de Damien pour Yahoo</title>
<style type="text/css">

a:link {
	text-decoration:none;
	color: #ff7275;
}
a:visited {
	color: #ff7275;
}
a:hover {
	color: #000000;
}
a:active {
	color: #ff7275;
}
</style>
</head>

<body style="font-family: 'Fira Mono'; color:#ff7275;">
<table style="color: #ff7275;" width="400" height:"100" border="0" cellspacing="0" cellpadding="0">
  <tbody>
    <tr>
      <td width="100"><img src="http://formations.design/signatures-mail/logo-mail.png" width="100" height="100" alt=""/></td>
      <td width="300"style="padding:10px;"><span style="font-weight:bold;">Damien Serres</span><br />
      <a href="tel:+33621786853">06 21 78 68 53</a>
	  <p style="font-size:9pt;">&gt; <a href="https://institut.design" target="blank">institut.design</a></p>
	  </td>
    </tr>
  </tbody>
</table>
</body>
</html>

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 3318
Enregistré le : 02 avr. 2006, 03:24

Re: Police de signature disparaît à l'envoi

Message par Jean-Claude » 24 juin 2019, 18:41

Bonjour,

Quand tu rédiges ton mail, et insères du HTML, tu n'es pas en mode "Preview", mais en mode rédaction. Tu vois donc, par exemple, la délimitation de ta table pour la signature, qui ne sera plus visible en mode "preview" puisque dans ton HTML la propriété "Border" est à 0 pour ta table.

Toutes les caractéristiques HTML de ta signature doivent être incluses dans le code HTML, et indépendantes de tes propres paramètres Thunderbird, puisque ton mail sera lu, sur d'autres PC, dans d'autres logiciels de messagerie.

Je te conseille de rédiger ta signature HTML dans un éditeur HTML (gratuit) comme Kompozer. Disponible ici https://sourceforge.net/projects/kompozer/.
Il a un onglet "Source" où on peut voir et modifier directement le code HTML, un onglet "Design" où on peut dessiner le résultat voulu, et un mode "Preview" (en bas à droite de l'écran) où on peut voir le résultat final. Il y a pas mal de tutoriels sur internet pour Kompozer. Il y a même une section du forum de Geckozone qui lui est dédié.

Lorsque je copie ton code HTML dans l'onglet "Source" de Kompozer, et que je vérifie le résultat dans l'onglet "Design" en mode "Preview", j'obtiens le même résultat que celui que tu qualifies de "mauvais" (pour ma part, je le trouve pas mal :D ) .

Dans Thunderbird, pour être en mode "Preview", il suffit de sauvegarder son mail dans les "Brouillons", et de l'afficher à partir de ce dossier.

A+

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 6 invités