Bug au démarrage avec Non Lus et Dossiers Unifiés

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 23 déc. 2018, 16:06

Bonjour,

Après création d'un nouveau profil le problème est identique avec celui-ci :mrgreen: .

Si vous appliquez le filtre "Non lus" sur Courrier Entrant de tous les Dossiers unifiés (voir image plus haut) le filtre saute au redémarrage avec les modules désactivés vu que l'affichage revient en mode normal (donc plus de Courrier Entrant comprenant tous les dossiers unifiés). Si vous appliquez le filtre sur une adresse unique (ce que vous avez du faire), alors oui il reste actif.

Pour préciser encore plus, le problème intervient si un filtre est appliqué sur les dossiers unifiés suivants : Courrier Entrant, Envoyés, Indésirables et Corbeille.

Le problème reste entier...

J2m06
Administrateur
Messages : 21424
Enregistré le : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par J2m06 » 23 déc. 2018, 17:25

FutMan a écrit :
23 déc. 2018, 16:06
Après création d'un nouveau profil le problème est identique avec celui-ci :mrgreen: .
aie c'est plus embetant :( - surtout que l'on arrive pas à reproduire facilement ce souci
Si vous appliquez le filtre sur une adresse unique (ce que vous avez du faire), alors oui il reste actif.
adresse unique ! pas compris :(
Je ne peux pas mettre ce filtre rapide (non lus) sur plusieurs comptes en même temps
Pour préciser encore plus, le problème intervient si un filtre est appliqué sur les dossiers unifiés suivants : Courrier Entrant, Envoyés, Indésirables et Corbeille.
j'ai essayé sur ces dossiers - avec plusieurs non lus à des dates différentes de plusieurs mois
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 23 déc. 2018, 19:04

Je pense que tu n'as pas du bien comprendre mon problème. Relis depuis le début et regarde l'image que j'ai posté. Mon soucis intervient lorsque j'affiche en dossiers unifiés et que j'applique un filtre, par exemple, sur "Courrier Entrant" qui regroupe toute mes adresses et que je ferme et re-ouvre Thunderbird.

J2m06
Administrateur
Messages : 21424
Enregistré le : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par J2m06 » 23 déc. 2018, 19:08

FutMan a écrit :
23 déc. 2018, 19:04
, sur "Courrier Entrant" qui regroupe toute mes adresses et que je ferme et re-ouvre Thunderbird.
[edit] ah je viens de comprendre :lol:
Tu parles de Courrier entrant qui regroupe TOUS les courriers entrants des différents comptes :wink:
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 23 déc. 2018, 19:09

Image

Tu appliques bien ton filtre sur la flèche rouge ?
Donc on peut bien mettre un filtre sur plusieurs comptes en même temps.

Effectivement si cela regroupe tous mes adresses, ca regroupe tous les messages...

Lorsque tu es en mode Dossiers unifiés et que tu redémarres en mode sans extensions. On est bien d'accord que tu te retrouves en affichage normal ?
Modifié en dernier par FutMan le 23 déc. 2018, 19:18, modifié 1 fois.

J2m06
Administrateur
Messages : 21424
Enregistré le : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par J2m06 » 23 déc. 2018, 19:17

FutMan a écrit :
23 déc. 2018, 19:09
Donc on peut bien mettre un filtre sur plusieurs comptes en même temps
.ah je viens de comprendre :lol:
Tu parles de Courrier entrant qui regroupe TOUS les courriers entrants des différents comptes :wink:
Malgré cela je n'arrive à reproduire ton souci

Lorsque tu es en mode Dossiers unifiés et que tu redémarres en mode sans extensions. On est bien d'accord que tu te retrouves en affichage normal ?
dans ce cas oui


Image
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 23 déc. 2018, 19:25

une fois le filtre appliqué (toujours sur Courrier entrant qui regroupe toutes les adresses) tu as fermé et ré ouvert Thunderbird plusieurs fois sans toucher le filtre ? car souvent la 1ère fois cela fonctionne. A l'instant cela a planté à la 4ème fois mais c'est une exception.

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 23 déc. 2018, 21:23

Bonjour,
FutMan a écrit :
23 déc. 2018, 16:06

Après création d'un nouveau profil le problème est identique avec celui-ci :mrgreen: .
J'ai passé une bonne partie de la matinée à reproduire ce que j'appellerai désormais un bug, ceci dans un nouveau profil et avec la version en-US de Thunderbird.
Pour préciser encore plus, le problème intervient si un filtre est appliqué sur les dossiers unifiés suivants : Courrier Entrant, Envoyés, Indésirables et Corbeille.
Avec la combinaison "dossiers unifiés" activé plus un dossier unifié sélectionné (par exemple Courrier entrant) plus un filtre rapide activé (par exemple "non lus") j'observe au redémarrage les deux message d'erreur consécutifs :

Image

Image

L'affichage de ces deux messages au (re)démarrage n'est pas constant, il ne semble d'ailleurs ne pas empêcher le téléchargement de nouveaux messages.
En revanche chaque fois que je quitte Thunderbird dans cette configuration, il ne répond pas pendant une minute (roue colorée) puis finit par planter.
J'ai fabriqué une bonne douzaine de rapports de plantage depuis ce matin, entre autres

bp-ad823d46-0c66-469e-b9d7-df2d10181223
bp-41df38ca-0d56-4ed3-affe-3d2130181223
bp-9ee97f7b-dc0e-4fa4-b624-0ff2f0181223
bp-e46d0f54-1805-460f-8b11-45bd60181222
bp-96ea816b-db67-4d94-bcbc-908d10181223
bp-35fc976f-814c-42e3-ad95-e95e80181223


Pour l'instant je n'ai pas encore trouvé un rapport de bug sur Bugzilla qui correspondrait à ce problème.

J2m06
Administrateur
Messages : 21424
Enregistré le : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par J2m06 » 24 déc. 2018, 09:02

Bonjour
FutMan a écrit :
23 déc. 2018, 19:25
une fois le filtre appliqué (toujours sur Courrier entrant qui regroupe toutes les adresses) tu as fermé et ré ouvert Thunderbird plusieurs fois sans toucher le filtre ? car souvent la 1ère fois cela fonctionne. A l'instant cela a planté à la 4ème fois mais c'est une exception.
bon j'ai essayé près de 10 arrêts/redémarrage avec TB60.3.3 (et TB60.4.0) + Win10 sans obtenir ton message (ni eux de Mapenzi)

Par contre , et c'est peut-être une piste :!: .
j'ai remarqué qu'après plusieurs arrêt/démarrage avec le filtre rapide non lus+dossier unifiés d'activés ,
j'ai un message comme quoi le profil est en cours d'utilisation....Veuillez le fermer.... :!:
(J'ai fais les essais avec démarrage sur gestionnaire de profis de TB)
Si je vais dans le gestionnaire des tache il y a bien un autre instance de TB en arrière-plan
Si je l’arrête je peux démarrer TB sans souci (il s'ouvre bien avec le filtre non lus activé et pas de message d'erreur)
  • [edit] avec TB60.4.0 mis à jour à l'instant-
    Si j'insiste sans arrêter la tache en arrière-plan-TB se ferme avec un rapport de plantage
2/. Je refais un autre essai en ne démarrant TB directement (sans utiliser le gestionnaire de profils)
  • Et là j'ai un autre message ->TB est en utilisation , voulez vous le fermer ?
    Je fais oui et TB démarre sans souci (il s'ouvre bien avec le filtre non lus activé et sans message)
3/. Autre essai- Je désactive le filtre avant de fermer TB
  • Dans ce cas pas de TB en tache de fond et TB démarre normalement
4/. Dernier essai - Je réactive le filtre
  • et à la troisième fermeture/ouverture ->message comme quoi le profil est inaccessible ou manquant :!:
    (Mais toujours pas ton message, ni ceux de Mapenzi)
Pourquoi Windows 10 ne ferme pas correctement TB après 3/4 fermetures avec le filtre activé :?:

Vérifie avant d'ouvrir TB qu'il n'y ai pas une instance qui tourne en arrière-plan :!:
via le gestionnaire des taches de windows

bonne lecture (si vous savez pas quoi faire ce soir :lol: )- si cela peut faire avancer les choses :D

Image
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 24 déc. 2018, 10:15

Bonjour,
J2m06 a écrit :
24 déc. 2018, 09:02
  • [edit] avec TB60.4.0 mis à jour à l'instant-
    Si j'insiste sans arrêter la tache en arrière-plan-TB se ferme avec un rapport de plantage
Ça correspond à ce que j'ai décrit dans ma réponse d'hier soir. Au début j'avais forcé TB à quitter quand je voyais qu'il ne répondait plus suite à (menu) Thunderbird > Quitter Thunderbird (ou Cmd + Q).
Dans mes essais d'hier après chaque fermeture j'ai observé la roue colorée et/ou le moniteur d'activité pendant environ 60 sec jusqu'à ce que TB plante et envoie un rapport de plantage à Mozilla

Image

Image

Ce matin, je peux reproduire la séquence à l'infini.
Dossiers unifiés + dossier Courrier entrant (unifié) sélectionné + filtre "Étiquettes" activé
=> à la fermeture "Thunderbird ne répond pas" puis plantage au bout d'environ une minute
=> au démarrage les deux messages d'erreur successifs

Ce qui m'étonne c'est que notre ami FutMan n'ait pas observé cette impossibilité de fermer (quitter) Thunderbird normalement.
J'ai également fait un test avec la version TB 52.9.1 dans son propre profil mais ne n'ai pu reproduire ce problème dans cette version.

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 24 déc. 2018, 11:32

Bonjour,

Je vous remercie d'avoir pris le temps de chercher à reproduire ce problème. Il s'agit donc bien d'un bug :mrgreen: et je sais maintenant que mon installation n'est pas corrompu :wink:. Par contre chez moi effectivement, je n'ai pas de soucis de fermeture et de plantage. J'allais dire surement une différence Mac vs Windows mais comme cela se produit aussi avec J2m06... Après vérification, une fois TB fermé, je n'ai aucun processus le concernant qui tourne en tache de fond. Il n'y a plus qu'a attendre que cela soit résolu dans une future MAJ, encore faut-il que le problème soit remonté.

Merci et bon réveillon.

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 24 déc. 2018, 20:30

FutMan a écrit :
24 déc. 2018, 11:32
Il n'y a plus qu'a attendre que cela soit résolu dans une future MAJ, encore faut-il que le problème soit remonté.
Je suis en train de m'en occuper mais bugzilla.mozilla.org m'a encore bloqué mon compte ! Chaque fois que Bugzilla n'arrive pas à m'envoyer un émail - et avec un compte chez Laposte.net ça arrive fréquemment - mon compte est bloqué automatiquement et je dois demander de le débloquer, ce qui prendra certainement quelques jours à cause des fêtes.
Merci et bon réveillon.
Merci et bonnes fêtes de fin d'année.

Gloops
Tyrannosaurus Rex
Messages : 2320
Enregistré le : 22 mai 2006, 11:55

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Gloops » 25 déc. 2018, 03:36

Bonjour,
Les messages d'erreur reproduits en tête de fil laissent supposer un problème de communication avec le serveur. Il peut y avoir un problème de ligne, mais que ça apparaisse avec une nouvelle version fait plutôt penser à une corruption du profil.
Elle peut être due à une extension qui a un problème avec la version 60, mais si ça a corrompu le profil, la résolution peut être plus lourde que juste désactiver l'extension.
Quelles sont les extensions installées, au fait ?
Si il y en a en commun sur les machines où le problème s'est posé, ça fera déjà une piste.
Comme on est quand même pas mal dans le brouillard, on peut en profiter, en plus du système, pour noter les logiciels de sécurité.

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 25 déc. 2018, 10:04

Gloops a écrit :
25 déc. 2018, 03:36

Elle peut être due à une extension qui a un problème avec la version 60, mais si ça a corrompu le profil, la résolution peut être plus lourde que juste désactiver l'extension.
Je pense que tu n'as pas assez dormi ;)
Je reproduis le problème des deux messages d'erreur et du crash à la fermeture avec TB 60 dans plusieurs profils dont un que j'ai créé exprès pour ces tests et où j'ai désactivé Lightning.
Le bug ne se produit que quand un dossier unifié est sélectionné lors de la fermeture de TB, pas quand il s'agit d'un dossier individuel comme par exemple du "Courrier entrant" de l'adresse duschmol@machin.com.
Ce même problème n'apparait pas dans un autre profil avec TB 52.9.1.

Le bug est reproduisible à l'identique dans la version bêta TB 64.0b4 :

Image

Image

Gloops
Tyrannosaurus Rex
Messages : 2320
Enregistré le : 22 mai 2006, 11:55

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Gloops » 25 déc. 2018, 13:33

Cela étant, on n'a pas fait le tour, avec ça.
J'ai souvent un dossier unifié sélectionné à la fermeture de Thunderbird, et ça ne plante pas pour autant.
À la réouverture Thunderbird sélectionne le dernier ouvert dedans.

Ah, pardon, on a dit la troisième fois ...
Alors quatre fois d'affilée :
  • je sélectionne Courrier Entrant
  • je ferme Thunderbird
  • j'ouvre Thunderbird
  • dans Courrier Entrant je me retrouve avec le dossier Gloops de sélectionné
et aucun message d'erreur.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 7 invités