Bug au démarrage avec Non Lus et Dossiers Unifiés

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 11:59

Bonjour :) ,

Depuis le passage a la Version 64, j'ai un problème lors de la récupération des mails dans une certaine configuration. En effet, je dispose de plusieurs adresses que j'affiche en Dossiers Unifiés. Je sélectionne Courrier entrant et je clique sur Non lus. Si je démarre Thunderbird dans cette configuration j'ai ce message qui apparaît sur une adresse aléatoire :

Image

et ensuite

Image

Cela se produit uniquement si non lu est sélectionné pour un dossier unifié (Courriers Entrant, Envoyés, Indésirables ou corbeillle).

Vous avez ce bug aussi, sinon une idée pour résoudre cela ?

Merci pour vos lumières.
Modifié en dernier par FutMan le 22 déc. 2018, 13:58, modifié 2 fois.

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 22 déc. 2018, 12:25

Bonjour,

s'agit-il vraiment de la version 64 de Thunderbird qui est une version bêta (actuellement 64.0b4) ?
Ou plutôt de la version 60.4.0 qui est l'actuelle version "release" ?
J'ai fait un test avec la version 60.4.0 et n'ai pas pu reproduire ton problème.

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 13:06

Je me suis trompé, il s'agit de la version 60.4.0.

Tu as essayé dans cette confuguration ?

Image

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 22 déc. 2018, 13:34

FutMan a écrit :
22 déc. 2018, 13:06
Je me suis trompé, il s'agit de la version 60.4.0.
OK, je m'en doutais un peu ...
Tu as essayé dans cette confuguration ?
Non. Puisque ce n'était pas précisé j'ai fait mon test avec le bouton "Afficher" => "Non lus" (en fait, il s'appelle "Vues de courrier" dans la fenêtre de personnalisation) car je n'utilise que très rarement le "filtre rapide" :

Image

Mais toujours en "Dossiers unifiés" et en activant l'affichage "Non lus" du filtre rapide je n'arrive pas non plus à reproduire ce problème.

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 13:38

Effectivement, je n'ai pas précisé qu'il s'agissait du filtre rapide "Non Lus".

J'ai l'impression que tu as un Mac sous IOS non ?

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 22 déc. 2018, 13:58

FutMan a écrit :
22 déc. 2018, 13:38

J'ai l'impression que tu as un Mac sous IOS non ?
Sous macOS, 10.13.6 (High Sierra) plus précisément.
iOS est pour les iPhone et iPad.
Malheureusement le macOS ressemble de plus en plus à iOS :(

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 14:05

Désolé je ne connais pas beaucoup le monde Apple. En tout cas merci de ton intervention mais on ne peux pas se baser sur ton résultat car nous n’évoluons pas au sein du même OS. Un bug sous Windows n’existe pas forcément sous Mac et vice versa.

Quelqu'un d'autre pourrait tester SVP ?

Merci d'avance.

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 3188
Enregistré le : 02 avr. 2006, 03:24

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Jean-Claude » 22 déc. 2018, 16:38

Bonjour,

Pas de soucis chez moi, sous Windows 10; avec Thunderbird 60.4.0 / Dossiers unifiés et filtres "non lus".
J'ai des comptes GMAIL, Hotmail, GMX, Yahoo, Laposte, tous en IMAP. Un seul compte POP, celui de mon FAI (Telenet).

Vois ce que cela donne en réinitialisant les dossiers unifiés. Avec le temps, ils se dégradent, car ce ne sont que des filtres. Je viens de le constater chez moi, et je viens de les réinitialiser.

Pour cela :

1. Ferme TB.
2. Supprime le fichier virtualsFolders.dat dans le profil de Thunderbird.
Cela devrait réinitialiser la liste des dossiers virtuels. Un nouveau fichier "VirtualFolders.dat" sera créé à la prochaine fermeture de TB

Pour accéder au profil, tape %appdata%\thunderbird dans la barre adresse de l'explorateur de Windows + presse "Enter". Déploie ensuite l'arborescence du répertoire Thunderbird vers \profiles\(xxxxxx).default.
C'est là que se trouve le fichier VirtualFolders.dat
Il est possible que tu doives aussi au préalable sélectionner l'option "Afficher les dossiers et fichiers cachés" dans les options de l'explorateur.

3. Ensuite, il faut en plus supprimer le dossier "smart mailboxes" qui se trouve sous %appdata%\thunderbird\profiles\(xxxx).default\mail
Le répertoire sera aussi recréé automatiquement par TB.

4. Redémarre TB

A+
Modifié en dernier par Jean-Claude le 22 déc. 2018, 22:27, modifié 1 fois.

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 18:51

Bonsoir Jean-Claude,

Tout d'abord merci pour ton intervention. Malheureusement ta manip ne règle pas le soucis. Ce que je ne comprend pas c'est que cela est intervenu suite au passage en version 60. Mais si cela ne le fait pas chez toi... alors la c'est la mouise. Tu mets bien le filtre non lu sur courrier entrant unifiés et tu redémarres Thunderbird ?

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 22 déc. 2018, 20:10

Il y a du nouveau ! Finalement, à force de répéter les essais dans un profil test j'ai réussi à reproduire les mêmes messages que tu montres dans ton premier post mais une seule fois. Maintenant le problème c'est que quand je veux quitter Thunderbird pour le redémarrer il se bloque ("ne répond plus") et il faut que je le force à quitter.

Image

Dans mon profil de travail c'est pareil sauf que je n'ai pas eu les deux messages. Mais dès que je veux quitter TB il ne répond plus et j'ai la roue colorée qui tourne et tourne .... Dans ces conditions je préfère m'arrêter pour ne pas prendre le risque d'endommager ces profils.

Si j'ai le temps demain je ferai d'autres tests dans un nouveau profil sans modules complémentaires.

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 22 déc. 2018, 20:20

Aie désolé pour toi. Tu as raison, ne vas pas endommager tes profils. Me concernant je réalise une image Acronis chaque semaine. Il m'est donc facile de restaurer ce que je veux.

D'ailleur avec la manip de Jean-Claude le problème étant toujours présent. J'ai restauré le fichier "VirtualFolders.dat" et le dossier "smart mailboxes" car ma personnalisation avait disparue.

Mapenzi
Varan
Messages : 1900
Enregistré le : 18 mars 2015, 20:17

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Mapenzi » 22 déc. 2018, 21:20

FutMan a écrit :
22 déc. 2018, 20:20
Aie désolé pour toi. Tu as raison, ne vas pas endommager tes profils.
Ça serait récupérable car je fais tous les jours une copie automatique du dossier "Thunderbird" avec tous les profils. Ce qui m'embête surtout c'est les "ne répond pas". Probablement il s'agit d'un bug de la version 60 mais est-ce qu'il est déjà répertorié ?

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 3188
Enregistré le : 02 avr. 2006, 03:24

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par Jean-Claude » 22 déc. 2018, 23:35

FutMan a écrit :
22 déc. 2018, 18:51
Tu mets bien le filtre non lu sur courrier entrant unifiés et tu redémarres Thunderbird ?
Je confirme. Dossiers unifiés + filtre rapide "non lus" + "Conserver les filtres lors du changement de dossiers" + redémarrage sur courrier entrant au plus haut niveau.
FutMan a écrit :
22 déc. 2018, 20:20
J'ai restauré le fichier "VirtualFolders.dat" et le dossier "smart mailboxes" car ma personnalisation avait disparue.
De quelle personnalisation s'agit-il ? Je m'étonne que cela ait causé un souci, car la réinitialisation tient compte de tous les filtres existant.

NB
Ton problème pourrait-il être dû à un module complémentaire défaillant ? As-tu essayé de voir ce qu'il en était en redémarrant Thunderbird avec les modules désactivés (mode sans échec) ? Pour cela : menu / ? / redémarrer avec les modules désactivés.

A+

FutMan
Arias
Messages : 16
Enregistré le : 22 déc. 2018, 00:57

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par FutMan » 23 déc. 2018, 01:23

Je parle de la personnalisation des colonnes (Intitulé et Dimension).

Par contre je viens de m'apercevoir que le problème est présent avec n'importe quel filtre appliqué. Que ce soit Non lus, Suivis, Contacts, Étiquettes ou Pièces jointes. A partir du moment où un filtre est appliqué et que je redémarre... Bing un message d'erreur et ensuite d’échec apparaît.

Concernant les modules complémentaires, je n'en ai aucun. La seul chose que j'ai rajouté sont des thèmes dont un seul est activé. Ceci dit, on ne peut pas voir si le problème vient d'un module complémentaire car lors d'un redémarrage avec les modules désactivés, l'affichage des dossiers revient en mode "normal" et les filtres ne sont plus appliqué.

Je comprends vraiment pas d'ou ça peut provenir et encore une fois cela est intervenu à la MAJ en Version 60.

J2m06
Administrateur
Messages : 21424
Enregistré le : 05 déc. 2005, 10:46
Localisation : Tout en bas à droite au bord de la mer !
Contact :

Re: Bug au démarrage avec Non Lus et Dossiers Unifiés

Message par J2m06 » 23 déc. 2018, 15:21

Bonjour
FutMan a écrit :
23 déc. 2018, 01:23
Par contre je viens de m'apercevoir que le problème est présent avec n'importe quel filtre appliqué. Que ce soit Non lus, Suivis, Contacts, Étiquettes ou Pièces jointes. A partir du moment où un filtre est appliqué et que je redémarre... Bing un message d'erreur et ensuite d’échec apparaît.
malgré de nombreux essais je n'ai pas pu reproduire ton souci (compte pop ou imap)

Essaie de créer un nouveau profil avec TB - clic ici , ou ici
Ceci dit, on ne peut pas voir si le problème vient d'un module complémentaire car lors d'un redémarrage avec les modules désactivés, l'affichage des dossiers revient en mode "normal" et les filtres ne sont plus appliqué.
chez moi le filtre Non lus reste activé même avec les modules désactivés. Seul est désactivé l'affichage de la barre d'outils du panneau des dossiers (+ colonne panneau des dossiers)
Un conseil: Faire 2 sauvegardes à 2 endroits différents = Tranquillité :wink:
FAQ Thunderbird/Firefox (avec + de 2700 captures écran )

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Patclash et 4 invités