Transférer par un filtre

Vous cherchez une alternative viable et sécurisée pour votre courrier ? Une conjuration s'est abattue sur vous et vous ne réussissez pas à trouver réponse satisfaisante à propos de Mozilla Thunderbird ? Cliquez donc par là…

Modérateurs : J2m06, Blogus, caméléon

PatDeff
Arias
Messages : 7
Enregistré le : 02 mai 2019, 17:36

Transférer par un filtre

Message par PatDeff » 09 juil. 2019, 09:43

Ma configuration:
W10, Thunderbird 60.7.2, Serveur de messagerie : laposte.net
Définition Thunderbird du compte de messagerie standard (Smtp / pop3)
Fonctionnement de ce compte : normal - aucun souci, tout est OK, tant en réception qu'en envoi de mails.

J'ai voulu créer un filtre pour transférer certains mails, répondant à certains critères, directement vers une autre adresse de messagerie.
Ce filtre est correctement activé: la première action (déplacer le mail entrant vers un dossier) est correctement réalisée.
La deuxième action (transfert vers une autre adresse de messagerie) est probablement déclenchée, mais après 2 minutes je reçois une pop-up : L’envoi du message a échoué.
Le message n’a pas pu être envoyé car la connexion au serveur sortant (SMTP) « smtp.laposte.net » a expiré. Veuillez essayer à nouveau. connexion perdue avec le serveur SMTP.

Comment résoudre ce problème ?
Merci pour vos idées….

Agent virtuel
Varan
Messages : 1093
Enregistré le : 29 janv. 2018, 12:06

Re: Transférer par un filtre

Message par Agent virtuel » 09 juil. 2019, 09:53

Bonjour

Éventuellement

(ex) http://kb.mozillazine.org/Can_not_send_ ... ttachments

En préalable ? essayez mailnews.tcptimeout
Outils->Options->Avancé->Général->Éditeur de configuration
Image
Modification mailnews.tcptimeout
+ OK + arrêt/démarrer Thunderbird

Essayez (et pour voir si) différentes valeur de mailnews.tcptimeout
+ OK + arrêt/démarrer Thunderbird

PatDeff
Arias
Messages : 7
Enregistré le : 02 mai 2019, 17:36

Re: Transférer par un filtre

Message par PatDeff » 09 juil. 2019, 11:55

Ce n'est pas une question de dimension du message à transférer:
Pour mes tests, le message fait moins de 1 Ko …

J'ai essayé la modification du tcptimeout.
le résultat n'a été qu'un simple allongement du délai avant d'obtenir la pop-up ...

Agent virtuel
Varan
Messages : 1093
Enregistré le : 29 janv. 2018, 12:06

Re: Transférer par un filtre

Message par Agent virtuel » 09 juil. 2019, 12:45

Ne suis pas actuellement au domicile
Ne peut donc pas actuellement expérimenter filtre

Sinon
mailnews.tcptimeout
Cela peut-être éventuellement utile
Illustration viewtopic.php?f=4&t=141649

Avatar du membre
Jean-Claude
Tyrannosaurus Rex
Messages : 3186
Enregistré le : 02 avr. 2006, 03:24

Re: Transférer par un filtre

Message par Jean-Claude » 09 juil. 2019, 13:10

Bonjour,

Si le déplacement s'exécute avant le transfert, le mail n'est plus disponible (dans courrier entrant) pour un transfert. Le filtre ne suivant pas le mail déplacé, mais le mail dans le dossier courrier entrant.
Le transfert doit donc s'exécuter en premier.
Pour cela, et bizarrement, dans l'écran des filtres, dans la liste des actions, poser d'abord le déplacement et en-dessous le transfert. Une note apparaitra dans l'écran "Voir l'ordre d'exécution" où cet ordre sera précisé.

Image

A+

PatDeff
Arias
Messages : 7
Enregistré le : 02 mai 2019, 17:36

Re: Transférer par un filtre

Message par PatDeff » 09 juil. 2019, 14:12

Bonjour Jean-Claude, et merci de t'intéresser à mon souci.

Le coup de l'ordre d'exécution: Bien vu !
Cependant, après vérification, cette dualité est bien prévue dans Thunderbird, et l'application ordonnance toute seul la succession des actions dans la "bonne" séquence".
Dans ma mailbox, j'ai défini deux filtres pour réaliser des transferts

Pour la première règle, l'ordre présenté est correct (transfert avant déplacement)
(Désolé: pas de serveur d'image pour en insérer une dans mon mail)

Pour la deuxième, l'ordre d'écriture des règles ne correspond pas à l'ordre du traitement de ces règles, et ce qui est réalisé par Thunderbird correspond à ce qui doit être : transfert avant déplacement.

Dans les deux cas, je récupère le message qui est censé avoir été transféré dans le classeur où je voulais le faire archiver : Correct.
La deuxième action a donc été réalisée correctement .
Mais dans les deux cas, les transfert de messages ne sont pas réalisés, avec toujours cette même pop-up de TCP time out…

Ce qui me surprend, c'est que lors d'envoi manuel de message, la connexion vers le serveur SMTP s'établit tout à fait normalement, et les mails (envoyés manuellement) sont correctement traités - dans des délais tout à fait raisonnables (1 à 2 secondes).
Par contre, pour le transfert de message par les règles, ce n'est pas du tout la même chose : rien ne part, avec cette erreur TCP connection time out ..

Agent virtuel
Varan
Messages : 1093
Enregistré le : 29 janv. 2018, 12:06

Re: Transférer par un filtre

Message par Agent virtuel » 09 juil. 2019, 18:24

Bonsoir

Selon
Constat
À instant
Pour ma part c'est ok

Un retour brut d'information (nb) informations personnelles modifiées dans la citation

msgFilterRules.dat
version="9"
logging="no"
name="Corps contient : constat09072019"
enabled="yes"
type="17"
action="Move to folder"
actionValue="mailbox://xxxxxxxxxx@pop.laposte.net/Verification1"
action="Forward"
actionValue="xxxxxxxxxx@gmail.com"
condition="AND (body,contains,constat09072019)"
https://drive.google.com/file/d/1sXiugs ... sp=sharing

PatDeff
Arias
Messages : 7
Enregistré le : 02 mai 2019, 17:36

Re: Transférer par un filtre

Message par PatDeff » 10 juil. 2019, 16:06

Merci pour le retour.
(au fait .. configuration équivalente ?)
Mais … pas glop !

Je constate que la définition du compte dans Thunderbird est correcte, et que les paramétrages associés sont bons : La messagerie fonctionne normalement, les messages entrants sont bien livrés chez moi, les messages sortants (méthode normale) arrivent correctement chez leur(s) destinataire(s).
Je constate aussi que les filtres sont définis correctement, et activés quand justifié.

Par contre, les messages transférés par application d'un filtre ne sont pas envoyés, et je récupère toujours ce fichu message de connexion SMTP en time out…

Si quelqu'un a une idée ….
Merci d'avance.

landsteph
Arias
Messages : 6
Enregistré le : 11 juil. 2019, 10:07

Re: Transférer par un filtre

Message par landsteph » 11 juil. 2019, 10:15

salut,
j'ai le meme probleme, et je compléterai qu'au vu des log SMTP, tout semble (presque) bien se passer :

Via Filtre :

Code : Tout sélectionner

...
2019-07-11 07:52:28.667000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 235 2.7.0 Authentication successful
2019-07-11 07:52:28.667000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 18
2019-07-11 07:52:28.667000 UTC - [7132:Main Thread]: D/SMTP SMTP Login response, code 235
2019-07-11 07:52:28.667000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 3
2019-07-11 07:52:28.667000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: MAIL FROM:<xxx.xxx@outlook.fr> BODY=8BITMIME SIZE=1308

2019-07-11 07:52:28.715000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 07:52:28.715000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 250 2.1.0 Sender OK
2019-07-11 07:52:28.715000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 5
2019-07-11 07:52:28.715000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: RCPT TO:<yyy.yyy@outlook.fr>

2019-07-11 07:52:28.760000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 07:52:28.760000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 250 2.1.5 Recipient OK
2019-07-11 07:52:28.760000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 6
2019-07-11 07:52:28.760000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: DATA

2019-07-11 07:52:28.804000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 07:52:28.804000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 354 Start mail input; end with <CRLF>.<CRLF>
2019-07-11 07:52:28.804000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 7
2019-07-11 07:52:28.804000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 8
2019-07-11 07:52:28.804000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: .
via envoi standard :

Code : Tout sélectionner

...
2019-07-11 08:11:42.158000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 235 2.7.0 Authentication successful
2019-07-11 08:11:42.158000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 18
2019-07-11 08:11:42.158000 UTC - [7132:Main Thread]: D/SMTP SMTP Login response, code 235
2019-07-11 08:11:42.158000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 3
2019-07-11 08:11:42.159000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: MAIL FROM:<xxx.xxx@outlook.fr> BODY=8BITMIME SIZE=435

2019-07-11 08:11:42.206000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.206000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 250 2.1.0 Sender OK
2019-07-11 08:11:42.206000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 5
2019-07-11 08:11:42.206000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: RCPT TO:<yyy.yyy@outlook.fr>

2019-07-11 08:11:42.250000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.250000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 250 2.1.5 Recipient OK
2019-07-11 08:11:42.250000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 6
2019-07-11 08:11:42.250000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: DATA

2019-07-11 08:11:42.295000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.295000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 354 Start mail input; end with <CRLF>.<CRLF>
2019-07-11 08:11:42.295000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 7
2019-07-11 08:11:42.295000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 8
2019-07-11 08:11:42.295000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: .

2019-07-11 08:11:42.600000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.600000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 250 2.0.0 OK <zzz@AM0PR02MB5651.eurprd02.prod.outlook.com> [Hostname=AM0PR02MB5651.eurprd02.prod.outlook.com]
2019-07-11 08:11:42.600000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 9
2019-07-11 08:11:42.600000 UTC - [7132:Main Thread]: I/SMTP SMTP Send: QUIT

2019-07-11 08:11:42.600000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.649000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 0
2019-07-11 08:11:42.649000 UTC - [7132:Main Thread]: I/SMTP SMTP Response: 221 2.0.0 Service closing transmission channel
2019-07-11 08:11:42.649000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 10
2019-07-11 08:11:42.653000 UTC - [7132:Main Thread]: I/SMTP SMTP entering state: 12
2019-07-11 08:11:42.653000 UTC - [7132:Main Thread]: I/SMTP SMTP connection error quitting 804b0002, ignoring 
obtenu en suivant les instructions sur le site :
https://wiki.mozilla.org/MailNews:Logging#Windows

La différence va se situé apres

Code : Tout sélectionner

I/SMTP SMTP Send: .
. dans le cas du filtre, rien ne se passe (timeout)
Peut etre le CRLF ? je n'ai pas testé la version beta

landsteph
Arias
Messages : 6
Enregistré le : 11 juil. 2019, 10:07

Re: Transférer par un filtre

Message par landsteph » 11 juil. 2019, 10:26

en version beta (du jour), le probleme persiste.

Agent virtuel
Varan
Messages : 1093
Enregistré le : 29 janv. 2018, 12:06

Re: Transférer par un filtre

Message par Agent virtuel » 11 juil. 2019, 12:57

Bonjour

Hypothèse ?

https://support.mozilla.org/fr/kb/impos ... s-messages

Éventuellement

Effectuez un essai avec votre logiciel antivirus protection de l’ordinateur ? complétement stoppé

Un vpn ?

PatDeff
Arias
Messages : 7
Enregistré le : 02 mai 2019, 17:36

Re: Transférer par un filtre

Message par PatDeff » 11 juil. 2019, 20:29

Bonjour à tous,
et merci pour votre aide: je commençais à perdre espoir …
Un merci tout particulier à Landsteph pour ses recherches et ses tests, même sur le bêta. Personnellement, je suis incapable d'aller aussi loin.
Ce qui me rassure, c'est que tu as constaté le même souci. Ce qui pourrait induire qu'il y a réellement un souci dans l'application.

J'ai lu avec attention l'article proposé par Agent virtuel.
Je ne suis pas suffisamment expert, mais j'ai une difficulté à comprendre pourquoi une action - envoi d'un mail - fonctionnerait lorsqu'elle est initialisée manuellement, mais ne fonctionnerait pas dans le cas d'un envoi par un filtre: Les notions de serveur SMTP, mot de passe, etc, ne devraient pas intervenir à ce niveau. Idem pour l'antivirus.
Pour l'anecdote: Lors de la dernière mise à jour de Thunderbird (18/06/2019), ma messagerie s'est brusquement arrêtée de fonctionner.
Après plein de recherches, j'en suis arrivé à supprimer la règles "Thunderbird" que MacAffee avait intégrée il y a deux ans, et comme par miracle, MacAffee a recréé une nouvelle règle avec le même nom, et tout s'est remis à fonctionner.
C'était binaire: rien … ou tout.

Dans le cas présent, l'envoi (manuel) fonctionne … Seul l'envoi par filtre ne passe pas …
Je suis prêt à faire d'autres tests, si on me précise quoi tester - et comment ..

landsteph
Arias
Messages : 6
Enregistré le : 11 juil. 2019, 10:07

Re: Transférer par un filtre

Message par landsteph » 12 juil. 2019, 11:16

Antivirus et pare feu désactivés : pas de changement. Transfert/Envoi standard OK, Transfert via Filtres NOK

landsteph
Arias
Messages : 6
Enregistré le : 11 juil. 2019, 10:07

Re: Transférer par un filtre

Message par landsteph » 12 juil. 2019, 11:59


landsteph
Arias
Messages : 6
Enregistré le : 11 juil. 2019, 10:07

Re: Transférer par un filtre

Message par landsteph » 12 juil. 2019, 12:16

Finalement, j'ai trouvé l'astuce. c'est tout con.

En lien avec les bugs suivants :
https://bugzilla.mozilla.org/show_bug.cgi?id=161806
https://bugzilla.mozilla.org/show_bug.cgi?id=1222046

En effet, la conversion des CRLF fait que ca bug... et c'est bien un bug.

Il faut envoyer le mail (qui sera forwardé) en version évoluée (HTML).
Appliquer une couleur sur le texte suffit par exemple.

Ca reste quand meme un bug.

L'astuce, c''est d'aller dans option > avancé > Editeur de config et modifier la valeur suivante :
mail.forward_message_mode = 0
Modifié en dernier par landsteph le 12 juil. 2019, 14:04, modifié 1 fois.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 7 invités