Passage à une build communautaire ?

Firefox OS a été un nouveau système d'exploitation destiné aux appareils mobiles. Ce forum traite des problèmes rencontrés sur les branches 1.4+ et 2.0+.
Ainsi que des téléphones et tablettes de développement (Flame...)

Modérateurs : Monique, genma

bartleby
Salamandre
Messages : 42
Inscription : 12 août 2015, 15:19

Passage à une build communautaire ?

Message par bartleby » 12 août 2015, 15:40

Bonjour à tous,
j'ai acheté un ZTE Open C sur ebay pour 70 € il y a un an (version 1.3.0.0). La dernière mise à jour envoyée par ZTE date je crois de l'automne dernier (FF0S_EU_EBAY_OPENCV1.0.0B6). De plus j'ai eu récemment deux plantages en décrochant des appels (et je n'arrive plus à lire le contenu de mes emails, juste le sujet), ce qui est quand même gênant pour un téléphone. Il paraît qu'il faut réinitialiser le téléphone pour résoudre le problème.
Tant qu'à faire j'envisage donc de franchir le pas : installer une build communautaire ! Je sollicite donc votre avis en posant quelques questions :
- quels sont les risques ? Concrètement l'un d'entre vous a-t-il déjà bousillé sont ZTE en faisant cela ?
- Sachant que c'est mon seul portable (pas un portable de test), est-ce que ces builds sont suffisamment fiables pour une utilisation courante ?
- Et enfin, me conseillez-vous d'installer la 2.1 ou la 2.2 ?

Merci de votre aide. Si je franchis le pas, j'essaierai de donner des retours à la communauté.
ZTE Open C (EU eBay), Boot2Gecko 2.1.0.0-prerelease, Free Mobile

Avatar de l’utilisateur
tchevalier
Lézard à collerette
Messages : 330
Inscription : 13 janv. 2013, 05:45
Localisation : Londres
Contact :

Re: Passage à une build communautaire ?

Message par tchevalier » 13 août 2015, 00:21

Bonjour,

- quels sont les risques ?
-> Aucun si tu suis les étapes du Wiki.

- est-ce que ces builds sont suffisamment fiables pour une utilisation courante ?
-> Oui car des tests sont effectués avant chaque mise à jour, donc une mise à jour ne devrait jamais casser des fonctionnalités importantes comme la téléphonie, les messages, etc. Bien sûr, aucun système n'est infaillible, mais les mesures de base ont été prises.

- Et enfin, me conseillez-vous d'installer la 2.1 ou la 2.2 ?
-> 2.1 voire 2.0. Il arrive encore que des choses cassent en 2.2.
N'hésite pas si tu as d'autres questions et bon test à toi :)

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 13 août 2015, 07:04

Salut bartleby,

Je rejoins ce que t'a écrit tchevalier.
Le passage à une build communautaire est simple et sans risque, si tu suis à la lettre la procédure :) .

Voici un petit retour que j'ai fait il y a quelques mois, après mon passage de la v1.3 à la v2.1 (canal bêta):
viewtopic.php?f=35&t=123116&start=105#p788846

Petits changements depuis:
- Le problème d'heure et de date a pu être corrigé en suivant les indications ici: viewtopic.php?f=33&t=122227&start=75#p792481
- Le deuxième ZTE Open C que j'ai passé de 1.3 à 2.1 dont je parle dans mon retour était lui aussi bien concerné par ce problème

Autre retour depuis:
- Dans le journal d'appel, quand tu cherches à sélectionner des appels entrants/sortants, on constate un défaut de traduction de deux boutons. On peut y lire "Delete" et "Deselect all".

En tout cas, au jour d'aujourd'hui, je ne peux que recommander la 2.1, que j'apprécie beaucoup.

Et à choisir entre la 2.1 et la 2.2, je te conseillerai, comme tchevalier, la 2.1, car elle est plus stable.
++
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

Avatar de l’utilisateur
tchevalier
Lézard à collerette
Messages : 330
Inscription : 13 janv. 2013, 05:45
Localisation : Londres
Contact :

Re: Passage à une build communautaire ?

Message par tchevalier » 13 août 2015, 07:09

Salut BiiO,
BiiO a écrit : Autre retour depuis:
- Dans le journal d'appel, quand tu cherches à sélectionner des appels entrants/sortants, on constate un défaut de traduction de deux boutons. On peut y lire "Delete" et "Deselect all".
Dans quelle version constates-tu ça ? Ce n'est pas normal.
Sur 2.1 ? Je vais vérifier demain au bureau sur un Flame.

P.S. quand tu vois des choses comme ça, ouvre un bug stp ;)

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 13 août 2015, 07:33

tchevalier a écrit :Salut BiiO,
BiiO a écrit : Autre retour depuis:
- Dans le journal d'appel, quand tu cherches à sélectionner des appels entrants/sortants, on constate un défaut de traduction de deux boutons. On peut y lire "Delete" et "Deselect all".
Dans quelle version constates-tu ça ? Ce n'est pas normal.
Sur 2.1 ? Je vais vérifier demain au bureau sur un Flame.

P.S. quand tu vois des choses comme ça, ouvre un bug stp ;)
Sur 2.1 oui (Commit Gits: 2015-05-21 14:40:33 0d34f49).
Le bugzilla me rebute un peu je dois dire. L'anglais et moi ça fait deux... Mais je compte me repencher sur la question prochainement ! :P :wink: .
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

Avatar de l’utilisateur
tchevalier
Lézard à collerette
Messages : 330
Inscription : 13 janv. 2013, 05:45
Localisation : Londres
Contact :

Re: Passage à une build communautaire ?

Message par tchevalier » 13 août 2015, 09:20

BiiO a écrit : Sur 2.1 oui (Commit Gits: 2015-05-21 14:40:33 0d34f49).
Le bugzilla me rebute un peu je dois dire. L'anglais et moi ça fait deux... Mais je compte me repencher sur la question prochainement ! :P :wink: .
Ok, merci, je vais regarder. À mon avis ce sont les restes du bug du script de Dattaz pour mettre à jour les traductions, mais je vais vérifier quand même.
Pour la prochaine fois, on a une instance de Bugzilla où tu peux signaler ça en français : https://bugzilla.frenchmozilla.fr/enter ... =FirefoxOS

bartleby
Salamandre
Messages : 42
Inscription : 12 août 2015, 15:19

Re: Passage à une build communautaire ?

Message par bartleby » 13 août 2015, 14:52

Merci BiiO et tchevalier pour vos encouragements qui m'ont incité à franchir le pas. J'ai choisi la 2.1 comme vous me l'avez conseillé. Si j'ai bien compris, quand la 2.2 passera dans le canal Beta, et sera alors à peu près stable, je pourrai en bénéficier automatiquement en faisant la mise à jour par le WiFi.

Au final, après 2h de travail je suis en 2.1 ! Mais j'ai quand même eu quelques soucis :-? :

1) Lors du passage en "root", je n'avais pas installé le pilote Windows 7 du ZTE, le logiciel m'ayant indiqué que le ZTE était "Connected". J'ai donc lancé la mise à jour qui a échoué à 3 % alors que Windows m'indiquait "Installation de pilote de périphérique". J'enlève la batterie, je redémarre le ZTE, j'essaie à nouveau, le tout plusieurs fois. Puis ça a fini par fonctionner ! Probablement que j'aurais dû attendre quelques minutes que Windows ait terminé d'installer le pilote.

2) Je passe sous Linux pour installer la 2.1. Tout se passe bien. J'éteins, je remets ma carte SIM, je redémarre, j'entre le code PIN de la SIM. Et là le comportement est assez étrange : notification "Aucune carte SIM insérée", l'icône réseau en haut finit par indiquer qu'il y a du réseau mais pas possible d'appeler ou de recevoir des appels. Dans les paramètres du ZTE : "Etat carte SIM inconnu". Pourtant je reçois un message de la messagerie vocale ! et un SMS ! (mais réponse SMS impossible : "carte SIM manquante"). Après avoir plusieurs fois essayé de réinsérer ma carte SIM, je décide de tenter une réinitialisation du téléphone : je redémarre et là, miracle, message "nouvelle carte SIM insérée" et ça marche ! :P

Ma première impression de la 2.1 est très bonne :D : on a vraiment l'impression d'avoir un nouvel OS que ce soit au niveau visuel ou au niveau fonctionnalités ! Et les applis se mettent à jour ! Je remercie donc la communauté et je signalerai les éventuels problèmes rencontrés au fur et à mesure.

Pour l'instant je peux dire que fonctionnent :
- le téléphone (émission/réception),
- les SMS (émission/réception),
- l'appareil photo,
- le GPS,
- la diode de mise en charge,
- le Wifi (navigateur, MarketPlace),
- la capture d'écran.
ZTE Open C (EU eBay), Boot2Gecko 2.1.0.0-prerelease, Free Mobile

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 13 août 2015, 17:57

tchevalier a écrit :Pour la prochaine fois, on a une instance de Bugzilla où tu peux signaler ça en français : https://bugzilla.frenchmozilla.fr/enter ... =FirefoxOS
C'est noté, merci ! Je m'en servirai à coup sûr :wink: .
bartleby a écrit :Merci BiiO et tchevalier pour vos encouragements qui m'ont incité à franchir le pas. J'ai choisi la 2.1 comme vous me l'avez conseillé. Si j'ai bien compris, quand la 2.2 passera dans le canal Beta, et sera alors à peu près stable, je pourrai en bénéficier automatiquement en faisant la mise à jour par le WiFi.

Au final, après 2h de travail je suis en 2.1 ! Mais j'ai quand même eu quelques soucis :-? :
C'est bien ça oui.

Tu as du avoir quelques sueurs froides... :roll: . En tout cas, j'espère qu'à la longue, tu ne regretteras pas ton choix. J'ai fait le même choix il y a quelques mois et j'en suis ravi. Et puis en cas de pépin, y'a toujours quelqu'un ici pour aider :D .
Merci encore à tous ceux qui contribuent au développement des builds communautaires !
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

bartleby
Salamandre
Messages : 42
Inscription : 12 août 2015, 15:19

Re: Passage à une build communautaire ?

Message par bartleby » 13 août 2015, 18:29

BiiO a écrit : C'est bien ça oui.
Super, c'est pour ça que j'avais acheté ce téléphone. Alors j'étais déçu de ne plus avoir aucune mise à jour trois mois après l'avoir acheté ! Et d'être bloqué sous la 1.3 !
BiiO a écrit : Tu as du avoir quelques sueurs froides... :roll: .
C'est sûr que si je l'avais acheté 700 €, comme certains smartphones à la pomme, je n'aurais pas pris le risque...

Enfin libre... :lol:
ZTE Open C (EU eBay), Boot2Gecko 2.1.0.0-prerelease, Free Mobile

bartleby
Salamandre
Messages : 42
Inscription : 12 août 2015, 15:19

Re: Passage à une build communautaire ?

Message par bartleby » 13 août 2015, 21:39

A noter que pour importer les contacts que j'avais sauvegardés avec PC Sync et Firefox OS Assistant, j'ai dû mettre à jour le module de l'assistant dans Firefox (je suis passé de la version 1.3.3 je crois à la 2.3.0). Avec l'ancienne version, pas moyen de récupérer les contacts (il y a bien connexion, mais ça mouline ensuite dans le vide).

J'ai pu à l'occasion tester le nouveau mode de connexion par WiFi avec code, au lieu de l'USB.
ZTE Open C (EU eBay), Boot2Gecko 2.1.0.0-prerelease, Free Mobile

Avatar de l’utilisateur
tchevalier
Lézard à collerette
Messages : 330
Inscription : 13 janv. 2013, 05:45
Localisation : Londres
Contact :

Re: Passage à une build communautaire ?

Message par tchevalier » 15 août 2015, 21:00

tchevalier a écrit :
BiiO a écrit : Sur 2.1 oui (Commit Gits: 2015-05-21 14:40:33 0d34f49).
Le bugzilla me rebute un peu je dois dire. L'anglais et moi ça fait deux... Mais je compte me repencher sur la question prochainement ! :P :wink: .
Ok, merci, je vais regarder. À mon avis ce sont les restes du bug du script de Dattaz pour mettre à jour les traductions, mais je vais vérifier quand même.
Pour la prochaine fois, on a une instance de Bugzilla où tu peux signaler ça en français : https://bugzilla.frenchmozilla.fr/enter ... =FirefoxOS
J'ai vérifié sur la dernière build 2.1 du Flame, je n'ai pas le problème, tout est traduit. C'est donc probablement que les traductions utilisées pour compiler les build communautaires 2.1 sont obsolètes, j'en toucherais deux mots à dattaz quand il reviendra. C'est vraiment dommage que ce genre de problème ne soit pas signalé plus tôt.

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 16 août 2015, 11:32

Merci d'avoir verifié.

Effectivement, c'est bête que ce genre de défaut traîne encore après plusieurs mois... J'ouvre l'oeil et signalerai tout autre problème constaté le plus vite possible ;-).
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

Avatar de l’utilisateur
tchevalier
Lézard à collerette
Messages : 330
Inscription : 13 janv. 2013, 05:45
Localisation : Londres
Contact :

Re: Passage à une build communautaire ?

Message par tchevalier » 18 août 2015, 03:44

Salut Biio,

Pourrais-tu regarder à nouveau ce problème de traduction stp ? Car je viens de regarder dans la dernière archive .zip pour la 2.1 (2015-05-21), et les traductions sont tout à fait à jour. À mon avis tu as vu le problème avant cette mise à jour et il est maintenant corrigé. Mais je préfèrerais avoir confirmation :)

Merci !

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 18 août 2015, 07:29

Salut tchevalier,

Bien qu'ayant la dernière version (celle que tu cites), voici ce que j'ai:
Image

Par rapport à la version d'origine (2.1 du 2015-05-21) je n'ai effectué qu'une modification: j'ai corrigé le problème d'heure et de date après un reboot, à l'aide du sujet suivant: viewtopic.php?f=33&t=122227&start=75#p792481. Qui sait, peut être que ça te mettra sur une piste ?...

Tiens-moi au courant :wink: . Merci !
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

BiiO
Lézard à collerette
Messages : 259
Inscription : 15 nov. 2014, 17:42

Re: Passage à une build communautaire ?

Message par BiiO » 27 sept. 2015, 08:21

Coucou tous!

@tchevalier: as-tu des news concernant le souci de traduction qu'on évoque plus haut?
Depuis, j'ai fait un reset de mon téléphone (qui commençait à buguer de tous les côtés) et le problème de traduction persiste.

Merci!
++
ZTE Open C - Boot2Gecko 2.2
BQ Aquaris E5 HD - Ubuntu Touch

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités