Firefox 2.1, 2.2, Problème d'heures

Firefox OS a été un nouveau système d'exploitation destiné aux appareils mobiles. Ce forum traite des problèmes rencontrés sur les branches 1.4+ et 2.0+.
Ainsi que des téléphones et tablettes de développement (Flame...)

Modérateurs : Monique, genma

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 28 mars 2015, 20:11

Ah ! peut-être une piste alors :)

Essaies d'envoyer le dossier sur le tel avec les commandes suivantes (ton-backup-flame = chemin vers dossier backup-flame, bien entendu) :

Code : Tout sélectionner

adb push ton-backup-flame/system/b2g/distribution/bundles /system/b2g/distribution/bundles &&
adb shell find /system/b2g/distribution/bundles/ -type d -exec chmod 755 {} + &&
adb shell find /system/b2g/distribution/bundles/ -type f -exec chmod 644 {} +
Tiens-moi au courant.

Edit : A vrai dire, le dossier distribution est resté pour moi (et l'heure fonctionnait), donc aucune action à effectuer. Par ailleurs, c'est en essayant de trouver des infos que je suis tombé sur le bug.
Dernière édition par micgeri971 le 28 mars 2015, 21:44, édité 1 fois.

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 28 mars 2015, 20:36

ça n'a pas marché sur mon tel normal. Je ferai le test demain ou après demain sur mon tel à l'écran abimé pour voir.

Après sur la mailing list de b2g, il me semble qu'ils disaient que les versions des composants xpcom, ril (et d'autre composant dont le nom m'effraie) n'était pas compatible entre différentes versions/compilations.

Je te tiens au courant dès que j'ai fait les vérif sur mon autre tél.

EDIT: Pour la recherche d'info, je fais pareil ;-). Le bugzilla de mozfr conclu sur le fait qu'il y a des blob binaires de qualcom intégré par ZTE. Je t'invite aussi à lire les explications dans les messages de Fabrice Desré dans la conversation sur la mailing list dont je parlais (https://groups.google.com/forum/#!topic ... tXL7Myn7To). Est-ce que tu as compris comment sont chargées ces ressources dans distributions/bundles (script init ; ajout au variables d’environnement; symlink ...)?

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 29 mars 2015, 16:37

bon bah, j'ai ré-essayer à partir de zéro et ça ne marche toujours pas (mais en utilisant ton script le dossier distribution reste sur le téléphone - j'imagine par contre qu'il n'est pas pris en compte si gecko se construit s'en le remettre dans le dossier out).
J'ai cru comprendre que le problème d'heure semblait résolu pour le flame en nightly donc je testerai surement d'aller sur une build nightly bientôt pour voir ce que ça donne.
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 29 mars 2015, 18:20

fabbox a écrit :EDIT: Pour la recherche d'info, je fais pareil ;-). Le bugzilla de mozfr conclu sur le fait qu'il y a des blob binaires de qualcom intégré par ZTE. Je t'invite aussi à lire les explications dans les messages de Fabrice Desré dans la conversation sur la mailing list dont je parlais (https://groups.google.com/forum/#!topic ... tXL7Myn7To). Est-ce que tu as compris comment sont chargées ces ressources dans distributions/bundles (script init ; ajout au variables d’environnement; symlink ...)?
Non, je n'ai pas encore compris. Je pensais que c'était une forme de détection automatique du dossier, mais apparemment non. Il faudra que je fasse des recherches supplémentaires pour comprendre.

fabbox a écrit :bon bah, j'ai ré-essayer à partir de zéro et ça ne marche toujours pas (mais en utilisant ton script le dossier distribution reste sur le téléphone - j'imagine par contre qu'il n'est pas pris en compte si gecko se construit s'en le remettre dans le dossier out).
J'ai cru comprendre que le problème d'heure semblait résolu pour le flame en nightly donc je testerai surement d'aller sur une build nightly bientôt pour voir ce que ça donne.
J'ai refait le test et c'est un peu plus précis.
En ré-exécutant l'outil de root de ZTE avec les fichiers correspondant, et en utilisant par la suite uniquement le script, l'heure reste après les redémarrages. (Et je suis quasi-certain que c'est le résultat que j'obtenais avec les B02/B03 unroot). Si j'applique la procédure normale (./flash gecko et make install/reset-gaia) ne serait ce qu'une fois, l'heure ne reste plus par la suite, et il me faut soit réutiliser le pack root, soit réutiliser la recovery avec la B02 unroot).

Quand tu es reparti de zéro, as-tu utilisé uniquement le script, ou as-tu utilisé ./flash gecko et make install/reset-gaia ?
Aussi, Comment es-tu reparti de zéro (pack root, B02/B03 unroot) ?

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 29 mars 2015, 18:43

Je suis reparti de zéro en utilisant le pack root puis uniquement ton script.
(J'ai mis à jours mon dépot (config.sh flame openc.xml) puis construit en faisant ./build.sh tout court avant en partant d'un backup_flame de téléphone fraichement avec le pack root).

Là je suis passé en 3.0. l'heure ne se conserve toujours pas (ça ne m'étonne pas trop vu que le flame est en kitkat maintenant, il y avait peu de chance que ça marche sur l'openc) mais je n'ai pas l'air d'avoir de bug particulier.

Du coup, sauf si tu as fait des modifs au fichier openc.xml (à l'exception des 3 lignes pour changer master à 2.0), je crois que je vais laisser tomber pour l'instant (tant de RAZ en une semaine sans un poil d'avance commence à me lasser :-D).
Bien sur, si tu as des idées, je suis toujours preneur !
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 29 mars 2015, 18:50

A part t'envoyer mon dossier backup-flame pour tester, je suis à court d'idée moi-aussi.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 29 mars 2015, 19:07

j'y avais pensé également mais en fait ce dossier n'est qu'une copie de ce qu'il y a dans /system sur le téléphone juste après le root donc on devrait avoir le même...
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 30 mars 2015, 17:32

Salut fabbox,

J'ai fait quelques recherches supplémentaires, et j'ai peut-être une dernière option. Peux-tu tester la chose suivante stp ?
Récupères l'archive test_horloge.tar à l'adresse suivante : http://1drv.ms/1Mo3PcX

Extraits l'archive, branches ton téléphone, et exécutes le script présent (Il va effacer le dossier /data/time de ton open C, le remplacer par le mien, puis redémarrer le téléphone).
Suite à cela, dis-moi si au redémarrage, tu gardes une date et une heure correcte (effectues plusieurs redémarrages, arrêt/démarrage de ton téléphone).

Si ça fonctionne, cette bidouille pourrait temporairement servir de "correctif", le temps que le bug soit vraiment corrigé.

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 30 mars 2015, 18:38

Salut micgeri971,

Tu m'as propulsé dans le futur (11 avril 2015) ! Dès que je règle l'heure et redémarre, ça revient au 11 avril 2015.
Il te reste à m'envoyer ton dossier "out" pour que je teste :-D
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 30 mars 2015, 18:59

:o Je dois dire que je ne m'attendais à tout, sauf ça. Je fais l'archive et j’éditerai ce message pour mettre un lien comme précédemment. Deux choses :
  • - C'est une 2.0
    - Tu vas constater "miraculeusement" :D que le bouton home s'allume, mais c'est parce que j'ai modifié avant hier le fichier gecko/hal/gonk/GonkHal.cpp, mais une fois de plus ça reste de la bidouille. De plus, il arrive parfois que le bouton refuse de s'éteindre. Enfin, c'est pas pratique, car il faudrait à chaque mise à jour des dépôts modifier le fichier (maintenant que j'y pense, ça pourrait s'arranger :) ).
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 30 mars 2015, 20:34

Bien reçu, merci !
Je teste ça demain et je te dirais si je réclame d'autres choses :-D (comme la build de gaia....)
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 30 mars 2015, 21:20

Petit oubli.
Je t'ai envoyé le lien pour gaia également.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

micgeri971
Lézard vert
Messages : 129
Inscription : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: Firefox 2.1, 2.2, Problème d'heures

Message par micgeri971 » 31 mars 2015, 02:47

@MatadorXV3 : Salut,
Rencontres-tu toujours le problème d'heure ?
Si tel est le cas, pourrais-tu faire le même test que fabbox avec l'archive test_horloge.tar, et nous dire quel impact cela à sur ton téléphone stp ?
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

Avatar de l’utilisateur
MatadorXV3
Lézard vert
Messages : 170
Inscription : 17 oct. 2014, 11:39

Re: Firefox 2.1, 2.2, Problème d'heures

Message par MatadorXV3 » 31 mars 2015, 07:26

coucou

je ne peux le faire maintenant, mais, je testerais aujourd'hui c'est promis!
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

fabbox
Lézard à collerette
Messages : 357
Inscription : 16 oct. 2014, 20:20

Re: Firefox 2.1, 2.2, Problème d'heures

Message par fabbox » 31 mars 2015, 08:09

micgeri971 Je ne croyais plus pouvoir dire ça mais ça marche \o/ J'ai flasher gecko et gaia avec tes versions (et ton script) et je confirme que l'heure s'est maintenue (à partir du 3ième démarrage je crois. il a fallu que ça retombe dans les années 70, je l'ai re-réglée et maintenant \o/).

Je dirai donc que ça vient de la build mais je n'explique pas pourquoi.
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités