[RÉSOLU] ZTE Open C Brické - besoin d'un coup de main

Firefox OS a été un nouveau système d'exploitation destiné aux appareils mobiles. Ce forum traite des problèmes rencontrés sur les branches 1.4+ et 2.0+.
Ainsi que des téléphones et tablettes de développement (Flame...)

Modérateurs : Monique, genma

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 28 déc. 2014, 12:05

Hello Micger971,

Je suis toujours bloqué devant le renard de feu en boucle. Je n'arrive pas à passer ce cap. :|

J'ai essayé d'installer la build communautaire 2.1 de mozfr, mais lorsque je fais Install update from zip file avec le Recovery de FFOS_FR_ZTE_OPENCV1.0.0B02,
j'ai le message d'erreur suivant:

Code : Tout sélectionner

E:failed to verify whole-file signature
E:signature verification failed
Installation from sdcard aborted
Avec la recovery de Vampirefo, j'ai l'erreur suivante:

Code : Tout sélectionner

Starting B2G FOTA : partial file_getprop: failed to stat "/system/build.prop: No such file or directory
E:Error in /external_sd_update.zip (Status 7) 
Installation aborted
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 28 déc. 2014, 13:54

Bonjour YackYack,

L'erreur avec la recovery de Vampireinfo est dû au fait qu'il ne trouve pas le fichier build.prop, car la partition /system n'est pas monté. Il faut que tu la montes via le menu mount and storage, et que tu retente d'installer la mise à jour. Cependant, il se pourrait que même avec cette recovery ça ne fonctionne pas.

Ce que tu pourrais faire, c'est de retenter le root avec l'utilitaire de ZTE (fr). Pour cela, il faut que tu laisses ton téléphone démarrer (avec le renard de feu en boucle), que tu le branches à ton PC, et que tu lances l'utilitaire. S'il trouve le téléphone, tu pourras alors relancer le root.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 28 déc. 2014, 14:09

ENFIN!

C'est bon il fonctionne! :D

Encore un grand merci à vous tous!
Spécialement à micgeri971, fabbox, MatadorXV3!

Je suis finalement passé par la recovery de FFOS_FR_ZTE_OPENCV1.0.0B02 pour installer le .zip
de FFOS_FR_ZTE_OPENCV1.0.0B02(SD card software) téléchargé sur le site de ZTE.

Merci de m'avoir consacré autant de temps! 8-)

A+

Y.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 28 déc. 2014, 14:16

Il n'y a pas de quoi. Content de voir que ton Open C fonctionne à nouveau.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 28 déc. 2014, 14:26

Juste une petite précision : le fait que l'installation de la build communautaire aie échoué, et que celle du site de ZTE soit passé, signifie que ton téléphone n'est pas rooté.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 29 déc. 2014, 09:59

Hello,

C'est une super nouvelle que tu ai enfin pu remettre en route ton OpenC.
J'étais un peu loin de la civilisation ces derniers jours ^^

En ce qui me concerne je suis passé sur la build communautaire de MozFr, en version nightly, ce qui est bien pratique, ça évite de compiler.
Amuse toi bien maintenant avec ton OpenC (:
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 29 déc. 2014, 11:25

@micgeri971
C'est étrange, je pensais l'avoir Rooté. C'est pour cela que la Recovery de Vampirefo me le demandait à chaque fois.

@MatadorXV3 Merci. C'est aussi ce que je vais faire. La version 1.3 est quand même ultra limitée!
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 29 déc. 2014, 12:00

je dirais, que c'est limité oui et non, tout dépend de l'utilisation.
Mais quand on a gouté à la 2.0 et +, la rechute est dure, ça c'est sûr ! (:
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 29 déc. 2014, 15:03

@YackYack : C'est possible. Si tu veux le faire, il faudrait l'effectuer depuis une machine Windows (avec l'utilitaire que tu as dans le pack root ZTE FR)

@MatadorXV3 : Vraiment très dur cette rechute, je confirme. Mais bon, je suis obligé de rester en 1.3, car je n'arrive plus à compiler la version 2.0 comme je le faisais jusqu'ici.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 29 déc. 2014, 15:28

micgeri971 a écrit :@YackYack : C'est possible. Si tu veux le faire, il faudrait l'effectuer depuis une machine Windows (avec l'utilitaire que tu as dans le pack root ZTE FR)
ou passer par une machine virtuelle, si c'est possible?!
@MatadorXV3 : Vraiment très dur cette rechute, je confirme. Mais bon, je suis obligé de rester en 1.3, car je n'arrive plus à compiler la version 2.0 comme je le faisais jusqu'ici.
et oui, c'est la croix et la banière en ce moment la compilation.
Je suis passé par les builds communautaires de mon coté! Je gagne un temps fou.
Plus besoin de compiler, et la mise à jour passe en FOTA maintenant.
En plus, j'ai gagné 16GB d'espace disque \o/
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 29 déc. 2014, 16:01

Pour la VM, je lui en avait parlé quelques pages avant, mais comme j'avais vu quelques messages sur ce site https://framasphere.org/tags/zte, disant que la compilation sur VM via VirtualBox ne fonctionnait pas, j'ai hésité. Mais il se peut qu'avec VMware, ça passe.

Je suis d'accord avec toi, elles sont beaucoup plus pratiques, et je les ai déjà utilisé.
Pour moi, pas vraiment de problème d'espace (j'arrive à gérer). De plus, mon environnement de compilation/installation se trouve dans une Machine Virtuelle sous VMware.

Malheureusement mon problème n'est toujours pas résolu, même dans la version master (2.2 actuellement) : Je ne peux pas regarder la TV de mon opérateur (Orange Caraïbe), mais c'est une autre histoire (live streaming non pris en charge).
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 29 déc. 2014, 16:14

micgeri971 a écrit :Pour la VM, je lui en avait parlé quelques pages avant, mais comme j'avais vu quelques messages sur ce site https://framasphere.org/tags/zte, disant que la compilation sur VM via VirtualBox ne fonctionnait pas, j'ai hésité. Mais il se peut qu'avec VMware, ça passe.
oui, compiler FxOS via une VM ça déconne pas mal (j'ai jamais réussi à le faire non plus) mais je parlais seulement de rooter les terminal ZTE avec l'outil fournit par le fabricant via une VM si ça marche (je n'en sais rien), si on a pas de machine Windaube sous la main.

Je suis d'accord avec toi, elles sont beaucoup plus pratiques, et je les ai déjà utilisé.
Pour moi, pas vraiment de problème d'espace (j'arrive à gérer). De plus, mon environnement de compilation/installation se trouve dans une Machine Virtuelle sous VMware.
Ce n'est pas ce queleques GB maintenant ... mais le temps, c'est autre chose ... le Père Noël ne m'en a pas apporté cette année encore (:

Malheureusement mon problème n'est toujours pas résolu, même dans la version master (2.2 actuellement) : Je ne peux pas regarder la TV de mon opérateur (Orange Caraïbe), mais c'est une autre histoire (live streaming non pris en charge).
Je pense ne pas pouvoir t'aider là dessus ! ):
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 29 déc. 2014, 17:01

MatadorXV3 a écrit :oui, compiler FxOS via une VM ça déconne pas mal (j'ai jamais réussi à le faire non plus) mais je parlais seulement de rooter les terminal ZTE avec l'outil fournit par le fabricant via une VM si ça marche (je n'en sais rien), si on a pas de machine Windaube sous la main.
Rassures-toi, je parlais bien du root, moi-aussi. Je ne l'ai jamais tenté en VM, vu que j'ai Windows.
Comme je te le disais, je faisais jusqu'ici mes manipulations (compilation/installation) depuis ma machine virtuelle sous Debian Wheezy, et jusqu'à la semaine dernière ça fonctionnait super bien, donc pas trop de soucis.
MatadorXV3 a écrit :Ce n'est pas ce queleques GB maintenant ... mais le temps, c'est autre chose ... le Père Noël ne m'en a pas apporté cette année encore (:
Aïe, pas de bol :(
MatadorXV3 a écrit :Je pense ne pas pouvoir t'aider là dessus ! ):
Ne t'inquiète pas. D'après mes quelques recherches, c'est un problème connu des développeurs. Mais il me semble avoir vu que ça ne sera résolu ni en 2.0, ni en 2.1 (peut-être en 2.2). Espérons que je me sois trompé.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 29 déc. 2014, 18:57

ok pour tout.
;)
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

fabbox
Lézard à collerette
Messages : 357
Enregistré le : 16 oct. 2014, 20:20

Re: ZTE Open C Brické - besoin d'un coup de main

Message par fabbox » 30 déc. 2014, 00:52

Chapeau YackYack pour cette persévérance :D , !

Pour le root, il ne faut pas se casser la tête, il suffit d'avoir le Pack_root_du_ZTE_Open_C.zip de chez zte. Tu extrais l'archive P821A10_FR_ENG_20140806.zip et tu vas dans le dossier extrait. Il te suffit alors de démarrer ton téléphone en fastboot et de flasher le boot par le boot du root (pas besoin de windows) :

Code : Tout sélectionner

fastboot flash boot boot.img

Code : Tout sélectionner

fastboot reboot
et voilà, le téléphone est rooté.

Tu peux vérifier avec la commande :

Code : Tout sélectionner

adb shell getprop ro.secure
qui doit renvoyer 0.

source : https://developer.mozilla.org/en-US/Fir ... ZTE_OPEN_C
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité