[RÉSOLU] ZTE Open C Brické - besoin d'un coup de main

Firefox OS a été un nouveau système d'exploitation destiné aux appareils mobiles. Ce forum traite des problèmes rencontrés sur les branches 1.4+ et 2.0+.
Ainsi que des téléphones et tablettes de développement (Flame...)

Modérateurs : Monique, genma

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

[RÉSOLU] ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 14 déc. 2014, 14:50

Bonjour à tous,

Je viens chercher un peu d'aide ou/et du réconfort.

Je viens d'acheter un Open C sur LDLC. j'ai fait mumuse avec l'appareil et il est blocké sur l'écran de boot.
Je précise que je suis sur Ubuntu (Xubuntu 12.04). J'ai suivi le tutoriel pour le rooter et passer à la version 2.0.
Je n'ai pas réussi à finir la procédure de Frédéric Blanc. Je suis bloqué car le md5 n'était pas identique. J'ai essayé de retéléchargé
le zip, mais rien à faire. Et tout à coup... c'est le drame.
J'ai tenté un peu tout et surtout n'importe quoi.
La, je n'arrive plus à connecter mon open C avec mon ordi (adb devices : liste vide)
J'ai accès au recovery de FFS, mais impossible d'installer quoi que ce soit, l'installation foire (FFOS_FR_ZTE_OPENCV1.0.0B02(SD card software) ou le pack root).

Bref, je patauge dans la semoule.

Auriez-vous une idée ou une piste de ce que je pourrais faire pour faire avancer mon schmilblick pour soit reconnecter mon open c avec l'ordi soit pour remettre à niveau via la carte SD.

Merci d'avoir lu tout ça. :-)

Y.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0
Modifié en dernier par YackYack le 07 janv. 2015, 14:38, modifié 1 fois.

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 14 déc. 2014, 15:27

Bonjour YackYack,

Quand tu dis que tu es bloqué sur l'écran de boot, tu parles de celui avec le renard de feu ? Si tel est le cas, tu devrais pouvoir réinstaller le FXOS de ZTE avec le logiciel de root, car ce dernier arrive à trouver le téléphone (pour moi ça avait marché). Pour ce faire, il faudrait que tu aies un Windows sous la main. A la limite, si tu peux installer une machine virtuelle sous windows, qui peut accéder à tes ports USB, ça devrait passer.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 14 déc. 2014, 15:33

Hello micgeri971,

Merci pour ta réponse. Je vais essayer ça demain chez mes parents. Ca m'attriste de devoir passer par Windows pour rooter un téléphone...

A+

Y.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 14 déc. 2014, 22:36

Hello.

Tu peux lancer le téléphone en mode recovery?
Mais c'est le recovery de ZTE hyper bridé j'imagine...
Je ne vois pas mieux qu'installer la ROM ZTE avec l'outil de root.

Perso, j'ai remplacé le recovery ZTE par celui de Vampirefo.
Si mon téléphone ne boot pas, je fais une restauration facilement.
Votre Navigateur : Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 15 déc. 2014, 11:19

Merci pour vos conseils.

Arrg! Je deviens fou. Ca fait 5x que je télécharge le pack root depuis le site ztefrance.com et à chaque fois le zip n'est pas valide.

@ MatadorXV3 Tu as rooté avec le pack et ensuite tu as installé la recovery de Vampirefo? Tu as aussi installé la dernière version de FFX (2.1)?

A+

Y.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 15 déc. 2014, 11:33

étrange pour le zip du RootPack.
Tu n'essaye pas de le décompresser avec WinRAR par hasard? (c'est parfois pas hyper compatible).

De mon coté, j'avais rooté mon téléphone en restant sous FxOS byZTE root 1.3b02.
Lorsque la B03 est sortie je suis passée dessus grâce à Furious-Therapy.
Mais vu ce que ça apportait en plus, j'ai réutilisé le RootPack pour rooter le mobile et compiler FxOS moi même pour passer directement FxOS2.2.

Parallèlement, j'ai flashé le Recovery byZTE (qui ne sert pas a grand chose si on veut bidouiller) pour installer le Recovery de Vampirefo.
ça permet, entre-autres, de lancer le Recovery sans le charger via la connexion USB et le poste Linux (ou autre OS?!), il est toujours dans le téléphone.
Si mon téléphone n'arrive pas à boot après une update/bidouille, le démarrage en mode Recovery se fait en maintenant [power]+[Vol+] pendant 10 secondes environ, et le recovery se lance.

Regarde ce tuto
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

micgeri971
Lézard vert
Messages : 129
Enregistré le : 14 déc. 2014, 02:15
Localisation : Guadeloupe

Re: ZTE Open C Brické - besoin d'un coup de main

Message par micgeri971 » 15 déc. 2014, 13:40

Bonjour à vous deux,

@YackYack : Ca m'est arrivé aussi. Il vaut mieux que tu utilises un gestionnaire de téléchargement, tel que Free Download Manager, ou l'extension DownThemAll! pour Firefox.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 15 déc. 2014, 15:48

Bon, ben... c'est la cac, comme on dit chez moi.

@ micgeri971 Merci du conseil, mais avec DownThemAll! ça n'a pas marché.
Du coup, je suis bloqué. Je vais essayé avec un autre navigateur.
Peut-être qu'avec IE je pourrai enfin installer FFX os. :o


@MatadorXV3
Merci!. Je garde tout ça sous le coude.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 16 déc. 2014, 10:23

Bonjour à tous,

J'ai finalement réussi à télécharger une bonne archive du Pack Root avec un autre navigateur.
J'ai installé le tout sous Win 7.
Et malheureusement, l’outil de mise à jour ne parvient pas à trouver mon téléphone et il n'est pas dans les périphériques.
J'ai réinstaller les drivers, mais rien n'y fait.

Une petite idée?

Merci pour le coup de main!

A+

Y.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 16 déc. 2014, 11:51

hello,

c'est bien ce que je pensais, le téléphone ne boot pas vraiment, donc difficile pour l'utilitaire de root de le trouver...
C'est compliquer de le récupérer mais pas impossible je pense.

Il faudrait que tu récupères l'archive zte-openc-rootkit-master.zip avec ce lien.
Il y a un README.md à ouvrir avec un éditeur de texte pour la marche à suivre.
Il y a des scripts pour :
  • débricker et remettre une ROM FxOS officielle (EBAY ou FR?! je pencherais plus pour EBAY)
    rooter le téléphone
En revanche, je n'ai jamais utilisé ces scripts, donc je ne garanti rien.
Je te conseille quand même d'utiliser les scripts du unbrick et install, ensuite si tu arrives à ré-utiliser ton téléphone, rooter avec le RootPack byZTE.

Code : Tout sélectionner

sudo apt-get update;
sudo apt-get install android-tools-adb android-tools-fastboot;
Démarrer l'Open C en Fastboot [Power]+[Vol-] (10 sec.)
Connecter en USB
Vérifier que le téléphone soit reconnu :

Code : Tout sélectionner

fastboot devices
Doit répondre

Code : Tout sélectionner

9a19590fastboot
Ensuite, changer le répertoire pour le répertoire du unbrick

Code : Tout sélectionner

cd ~/zte-openc-rootkit-master/01-unbrick
./01-unbrick.sh
Après que le script se soit exécuté, le téléphone redémarre en Recovery Mode
Lancer le script :

Code : Tout sélectionner

./02-install.sh
Je l'ai récupéré je ne sais plus où, et je me suis dit que ça vaudrait le coup que je le conserve, au cas où j'ai une cou***e avec mon OpenC.

Tiens moi au courant :)
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

fabbox
Lézard à collerette
Messages : 357
Enregistré le : 16 oct. 2014, 20:20

Re: ZTE Open C Brické - besoin d'un coup de main

Message par fabbox » 16 déc. 2014, 14:06

Bonjour,

j'ai eut un problème équivalent il y a deux ou trois semaines quand fxos 2.2 a commencé à ne plus se lancer suite au dernier changement. J'ai paniqué et fini par tout foutre en l'air.
La bonne nouvelle est que j'ai finalement réussi à tout retrouver, la mauvaise est que ce n'est pas aussi direct que le logiciel que te propose de télécharger MatadorXV3 (d'ailleurs il y a une version sur github https://github.com/qunxyz/zte-openc-rootkit). En effet, la version installée dans le lien est la version openc_Ebay et tu risques de ne pas pouvoir faire une mise à jours vers une openc_FR directement ensuite. Si le logiciel de root windows par zte ne fonctionne pas, je pourrai te détailler la méthode que j'ai suivi.

A noter que les commandes fastboot ne passaient pas chez moi sans ajouter une règle udev supplémentaire (en fastboot mon openc est reconnu comme étant google et non zte) ou en faisant un sudo (ce que je ne conseilles pas).

Bon courage
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0

MatadorXV3
Lézard vert
Messages : 170
Enregistré le : 17 oct. 2014, 11:39

Re: ZTE Open C Brické - besoin d'un coup de main

Message par MatadorXV3 » 16 déc. 2014, 14:36

fabbox a écrit :Bonjour,

j'ai eut un problème équivalent il y a deux ou trois semaines quand fxos 2.2 a commencé à ne plus se lancer suite au dernier changement. J'ai paniqué et fini par tout foutre en l'air.
La bonne nouvelle est que j'ai finalement réussi à tout retrouver, la mauvaise est que ce n'est pas aussi direct que le logiciel que te propose de télécharger MatadorXV3 (d'ailleurs il y a une version sur github https://github.com/qunxyz/zte-openc-rootkit). En effet, la version installée dans le lien est la version openc_Ebay et tu risques de ne pas pouvoir faire une mise à jours vers une openc_FR directement ensuite. Si le logiciel de root windows par zte ne fonctionne pas, je pourrai te détailler la méthode que j'ai suivi.

A noter que les commandes fastboot ne passaient pas chez moi sans ajouter une règle udev supplémentaire (en fastboot mon openc est reconnu comme étant google et non zte) ou en faisant un sudo (ce que je ne conseilles pas).

Bon courage
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
ah ben mon "unbrick pack" vient de GitHub donc!
Je pensais bien que ça installait une version de Open C Ebay (plus répandu à l'international).
effectivement, en général, il faut ajouter le règle avec :

Code : Tout sélectionner

sudo gedit /lib/udev/rules.d/91-permissions.rules
Dans le fichier, ajouter la ligne :

Code : Tout sélectionner

SUBSYSTEM=="usb", MODE="0666", GROUP="plugdev"
Sauvegarder et quitter.

Et comme tu le soulignes fabbox, ce n'est pas dit qu'avec une rom ebay tu pourras installer la rom root byZTE dans son RootPack.
Mais, il sera possible de restaurer une backup grâce au clockworkmod de Vampirefo peut être.

C'est également mon cas concernant la reconnaissance du terminal ZTE en mode Fastboot comme étant un terminal Google.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
ZTE OpenC_FR - FFOS2.1 HomeBuild

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 16 déc. 2014, 21:41

Hello à tous,

Merci beaucoup pour votre aide. C'est vraiment sympa!

@Fabbox J'ai exactement le même souci que tu as eu. J'ai mon Open C (de chez LDLC F) qui est reconnu comme étant chez Google et je n'arrive pas à le connecter.
Peux-tu me donner le lien du tutoriel que tu as utilisé? :P

@ MatadorXV3 J'ai bien rajouter la règle que tu mentionnes, mais quand je fait

Code : Tout sélectionner

adb devices 
j'ai ma liste of devices attached qui est vide. :cry:

A+

Y.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

YackYack
Salamandre
Messages : 25
Enregistré le : 14 déc. 2014, 14:33

Re: ZTE Open C Brické - besoin d'un coup de main

Message par YackYack » 16 déc. 2014, 22:16

@ MatadorXV3 J'ai suivi ton mini tutoriel et je suis bloqué à l'install.

Code : Tout sélectionner

y@y:~$ fastboot devices
1a14ea7	fastboot
y@y:~/Bureau/zte-openc-rootkit-master/01-unbrick$ ./01-unbrick.sh
target reported max download size of 1073741824 bytes
erasing 'system'...
OKAY [  0.826s]
sending 'system' (61440 KB)...
OKAY [  2.473s]
writing 'system'...
OKAY [  4.541s]
finished. total time: 7.840s
downloading 'boot.img'...
OKAY [  0.345s]
booting...
OKAY [  0.281s]
finished. total time: 0.627s
y@y:~/Bureau/zte-openc-rootkit-master/01-unbrick$ ./02-install.sh
error: device not found
Je n'ai pas eu de reboot après le 01-unbrick et je n'arrive plus à rebooter en Recovery Mode en manuel. :(
Je vais retenter le coup, j'ai peut-être oublié qqch.

Y.
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

fabbox
Lézard à collerette
Messages : 357
Enregistré le : 16 oct. 2014, 20:20

Re: ZTE Open C Brické - besoin d'un coup de main

Message par fabbox » 16 déc. 2014, 22:26

La procédure que j'ai suivi est la meme que celle de matadorXV3 (mais en customisant les fichiers du script pour avoir les fihcier du zte openc_FR). je me suis inspiré de https://support.mozilla.org/en-US/questions/1003136 en utilisant les fichiers sur le site de zte france (http://www.ztefrance.com/downloads/FFOS ... tware).zip).

Pour là où tu en es, tu dois attendre que le téléphone reboot tout seul après avoir rentré la commande unbrick. il affichera un recovery. il te faut alors cliquer (sur le téléphone) sur "update by adb" puis tu peux lancer le second script (./install.sh). Essaie de continuer de suivre la piste de matadorXV3 avant de t'embrouiller avec le poste pour la version customisée fr.

Bon courage
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité