4.0b9pre en français ?

Courageux ou téméraire, vous testez des versions nocturnes, Aurora ou Bêta de Firefox ? Partagez vos expériences avec les autres membres du forum.

Modérateurs : nico@nc, teoli2003

Répondre
helenic
Lézard à collerette
Messages : 381
Inscription : 25 mai 2007, 12:53

4.0b9pre en français ?

Message par helenic » 09 janv. 2011, 21:11

Bonjour,

Je fais le yoyo entre 3.6 et 4.0etc depuis un moment déjà et je voudrais bien savoir s'il est possible de passer la 4.0b9pre en français d'une manière ou d'une autre ?

commando
Lézard à collerette
Messages : 304
Inscription : 05 janv. 2009, 15:23
Localisation : Dans l'internet.

Re: 4.0b9pre en français ?

Message par commando » 09 janv. 2011, 21:20

Oui, plusieurs façons.
La plus simple est de télécharger le fichier d'installation incluant directement le français, et de l'installer par dessus la version 4 déjà installée (ça passera en mise à jour normalement).
Voici le lien direct sur ce fichier: ftp://ftp.mozilla.org/pub/firefox/night ... taller.exe

helenic
Lézard à collerette
Messages : 381
Inscription : 25 mai 2007, 12:53

Re: 4.0b9pre en français ?

Message par helenic » 09 janv. 2011, 21:41

Ah ben oui.. C'est mieux comme ça ! Merci beaucoup.. Les MAJ se feront en français aussi donc ?

Eone

Re: 4.0b9pre en français ?

Message par Eone » 09 janv. 2011, 22:08

Il n'y a pas de 64 bits sur windows dans cette liste, c'est normal?
On ne peut pas avoir en français et en 64 bits?

vulcain
Varan
Messages : 1732
Inscription : 20 juil. 2010, 08:41

Re: 4.0b9pre en français ?

Message par vulcain » 09 janv. 2011, 23:31

Il existe une version 64 bit pour windows mais mais à ma connaissance c'est plus pour des tests. Un des soucis majeurs de cette versions est l'absence de plugins en 64 bits: celui d'adobe est en phase expérimental, java, itunes n'en propose pas (c'est les plugins les plus courants) et la gestion de plugins 32 bits est un soucis d'après ce que j'ai compris.

Pour ceux qui ont un windows 64 bits et aiment les sensations fortes: http://wiki.mozilla-x86-64.com/Firefox:Download
This is UNOFFICIAL BINARY, so you DON'T report a bug to https://bugzila.mozilla.org/
-->Même pas de suivis des bugs par Mozilla.

Eone

Re: 4.0b9pre en français ?

Message par Eone » 09 janv. 2011, 23:45

C'est bizarre, la, je tourne sur une version anglaise 64 bits, et elle vient des nightly.

commando
Lézard à collerette
Messages : 304
Inscription : 05 janv. 2009, 15:23
Localisation : Dans l'internet.

Re: 4.0b9pre en français ?

Message par commando » 10 janv. 2011, 10:46

Si, Java existe en version stable en 64 bits natifs.
Je suis en train de concocter la procédure complète pour avoir Firefox 4 en 64 bits natifs sous Windows, et dans sa langue, car j'ai très bien réussi, et avec flash et java 64 bits opérationnels (voir le lien de ma signature, puis dernière section), et que je mettrai sur mon blog. Donc là maintenant, ce ne sera peut être pas bien formulé, et un peu à la va-vite:

- Installer la dernière nocturne de Firefox 64 bits en anglais, pour Windows dans le dossier suivant: ftp://ftp.mozilla.org/pub/firefox/night ... a-central/. Ca doit se terminer par ".win64-x86_64.installer.exe".

- Ensuite on s'occupe des 2 principaux plugins (flash et java), car c'est plus simple que de mettre Firefox 64 bits dans sa langue, parfois (ça dépend de la compatibilité annoncée de l'addon Quick Locale Switcher):
=> Flash en 64 bits: Installer la dernière version avancée de la version Plugin 64 bits de Flash à cette adresse: http://labs.adobe.com/downloads/flashpl ... quare.html
=> Pour Java: se rendre à cette adresse fourre-tout: https://cds.sun.com/is-bin/INTERSHOP.en ... _Developer. Puis mettre dans le menu déroulant Windows x64... Puis le reste de la procédure est très explicite même si c'est en anglais.

- Ensuite, télécharger et installer en addon la version adéquate du pack de langue en français au même endroit que pour télécharger la nocturne en 32 bits dans sa langue: ftp://ftp.mozilla.org/pub/firefox/night ... tral-l10n/. Pour le français, ça doit se terminer par ".fr.langpack.xpi". A ce stade, c'est toujours pas en français, et c'est normal, il manque une dernière étape. Et elle est juste en dessous.

- Se rendre sur la page AMO de Quick Locale Switcher: https://addons.mozilla.org/fr/firefox/addon/1333/.
=> Si c'est compatible avec la nocturne installée: l'installer directement depuis AMO. Et on passe directement redémarrage de Firefox!
=> Si ce n'est pas compatible avec la nocturne installé: aller sur le lien en bas de page "Voir toutes les versions", puis cliquer droit sur le bouton d'installation/téléchargement (selon la traduction en cours sur AMO, mais c'est de toute façon pour installer, d'où le clic droit), puis "enregistrer la cible du lien sous..", pour le mettre où vous voulez sur votre disque. On change son extension en zip, et dire OK au message, le dézipper, et ouvrir l'install.rdf. A un endroit dans ce fichier, il doit y avoir un bout de code qui ressemble à ceci:

Code : Tout sélectionner

<!-- Mozilla Firefox -->
<em:targetApplication>
<Description>
	<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
	<em:minVersion>1.0</em:minVersion>
	<em:maxVersion>4.0b9pre</em:maxVersion>
</Description>
Remplacer la valeur de maxVersion, par celle de votre nocturne. [ATTENTION: ici ça fonctionne bien, mais ne le faites pas pour tous les addons si vous n'êtes pas sûr de ce que vous faites!!]
Ensuite on enregistre l'install.rdf, on ferme l'appli qui a servi à le modifier (notepad++ ou notepad.exe, par exemples). Et on fait clic droit sur l'install.rdf pour le "rajouter à l'archive...". Dans la nouvelle fenêtre, on sélectionne l'archive de l'addon QLS, on met qu'on veut "remplacer", puis c'est partit en cliquant sur OK. On revient à l'explorer pour voir l'archive, et on rechange l'extension pour remettre comme avant (normalement c'est xpi pour cet addon). Et là on l'installe à partir de la nocturne (soit en faisant cliquer-déposer du xpi dans l'onglet des modules complémentaires, soit en cliquant sur la petite icône de paramètres dans ce même onglet et faire une install "à partir d'un fichier" pour choisir ce xpi).

- On redémarre Firefox 64 bits, et vous choisissez le français dans les options de QLS. :D

PS: pour aller plus loin en 64 bits, j'ai fait un sujet: http://www.geckozone.org/forum/viewtopi ... 24&t=88727

EDIT: reformulation sur l'existence de java en 64 bits pour Windows. Java étant une application, non une entité (pas réveillé quand je mettais que Java propose telle ou telle version^^).
Je mettrai la procédure sur mon blog ET l'autre sujet quand ce sera mieux écrit, avec les quelques corrections sur les imprécisions. Mais la procédure conduit tout de même au but recherché, à l'état actuel.
Dernière édition par commando le 10 janv. 2011, 12:04, édité 1 fois.

Eone

Re: 4.0b9pre en français ?

Message par Eone » 10 janv. 2011, 11:20

Pfiou, merci beaucoup :wink:

commando
Lézard à collerette
Messages : 304
Inscription : 05 janv. 2009, 15:23
Localisation : Dans l'internet.

Re: 4.0b9pre en français ?

Message par commando » 10 janv. 2011, 12:14

Il n'y a pas de quoi.
L'inconvénient du support de niveau 2, c'est qu'il faut mettre à jour (d'une façon ou d'une autre...) QLS et le pack de langue à chaque changement de numérotation de la nocturne... Et il n'y a que des nocturnes. C'est à dire que dès que la branche passe en RC pre, la nocturne de la branche de support de niveau 2 passe directement dans la version suivante en a1pre (de mémoire)... Reste que les 1° alpha mettent plusieurs mois à sortir généralement, donc un peu de répis :lol: .
Le niveau de support plus faible c'est pas de support officiel, et le mieux c'est ce que l'on connait tous: des nocturnes, des alphas, des betas, des RC, et enfin du officiellement stable.

Mais il est prévu de mettre Firefox 64 bits pour Windows en stable, un jour. Peut être dans une mise à jour du 4.0.x, ou alors dans la version suivante.

commando
Lézard à collerette
Messages : 304
Inscription : 05 janv. 2009, 15:23
Localisation : Dans l'internet.

Re: 4.0b9pre en français ?

Message par commando » 28 mars 2011, 22:21

Voilà, déterrage de ce sujet, car comme promis, j'ai mis la procédure sur mon blog.
Je l'ai revue, corrigée, et complétée.
La version finale de la procédure étant assez longue, je met donc le lien vers celle-ci: http://aidesetastuces.fr.nf/v2/?p=161.
En prime, le lien vers l'autre sujet de ce forum, pour parler plus généralement de la version 64 bits pour Windows: http://www.geckozone.org/forum/viewtopi ... 24&t=88727.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités