Firefox 3 beta 2 et extensions

Courageux ou téméraire, vous testez des versions nocturnes, Aurora ou Bêta de Firefox ? Partagez vos expériences avec les autres membres du forum.

Modérateurs : nico@nc, teoli2003

Répondre
Michel38
Arias
Messages : 6
Inscription : 16 déc. 2007, 09:19

Firefox 3 beta 2 et extensions

Message par Michel38 » 29 déc. 2007, 09:13

Bonjour et bon bout d'an à tous,
Sous Linux/Ubuntu Gutsy Gibbon je teste cette version. Pour la compatibilité des extensions, j'ai essayé extensions.checkCompatibility avec la valeur booléenne false pour récupérer mes extensions ff 2 .... je ne peux plus démarrer ff 3.
Merci pour vos conseils concernant l'activation des extensions
[/code]

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Dernière édition par Michel38 le 29 déc. 2007, 10:30, édité 1 fois.

La Luciole
Iguane
Messages : 549
Inscription : 25 déc. 2005, 21:58
Localisation : Golfe-Juan (Alpes-Maritimes-06)

Message par La Luciole » 29 déc. 2007, 10:05

Beaucoup d'extensions ne fonctionnent pas "en l'état" avec FF3 et le fait de désactiver la vérification de la compatibilité ne va pas les rendre compatibles...


Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11

Michel38
Arias
Messages : 6
Inscription : 16 déc. 2007, 09:19

Message par Michel38 » 29 déc. 2007, 10:11

La Luciole a écrit :Beaucoup d'extensions ne fonctionnent pas "en l'état" avec FF3 et le fait de désactiver la vérification de la compatibilité ne va pas les rendre compatibles...


Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11
Bonjour et merci pour ta réponse mais j'avais lu le contraire:
http://www.korben.info/faire-fonctionne ... fox-3.html

Avatar de l’utilisateur
asap29
Animal mythique
Messages : 12088
Inscription : 30 oct. 2003, 00:34
Localisation : Entre l'ordi et la chaise ou a la plage

Message par asap29 » 29 déc. 2007, 10:21

Salut
essaie avec
https://addons.mozilla.org/fr/firefox/addon/1391

autre solution c'est de "bumper" les extensions et de les installer a tes risques et perils
c'est quoi le "bump":
il faut telecharger le fichier.xpi de l'extension en question
ouvrir avec un dezippeur
ouvrir avec un editeur de texte le fichier install.rdf
changer la valeur du em:max (dans cet exemple 1.6+)en 3.0+
enregistrer la modif du fichier install.rdf
autoriser ensuite la modif du fichier .xpi lors de la fermeture du dezippeur
installation de l'extension en croisant les doigts pour que cela fonctionne

<Description>
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
<em:minVersion>0.8</em:minVersion>
<em:maxVersion>1.6+</em:maxVersion>
</Description>
</em:targetApplication>


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

Michel38
Arias
Messages : 6
Inscription : 16 déc. 2007, 09:19

Message par Michel38 » 29 déc. 2007, 10:29

asap29 a écrit :Salut
essaie avec
https://addons.mozilla.org/fr/firefox/addon/1391

Marche pas

autre solution c'est de "bumper" les extensions et de les installer a tes risques et perils

Je me risque pas .... j'attendrai bien sagement ....

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Avatar de l’utilisateur
nico@nc
Animal mythique
Messages : 7799
Inscription : 21 août 2005, 08:04
Localisation : fr-FR
Contact :

Message par nico@nc » 29 déc. 2007, 10:37

asap29 a écrit :Salut
essaie avec
https://addons.mozilla.org/fr/firefox/addon/1391

autre solution c'est de "bumper" les extensions et de les installer a tes risques et perils
c'est quoi le "bump":
il faut telecharger le fichier.xpi de l'extension en question
ouvrir avec un dezippeur
ouvrir avec un editeur de texte le fichier install.rdf
changer la valeur du em:max (dans cet exemple 1.6+)en 3.0+
enregistrer la modif du fichier install.rdf
autoriser ensuite la modif du fichier .xpi lors de la fermeture du dezippeur
installation de l'extension en croisant les doigts pour que cela fonctionne

<Description>
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
<em:minVersion>0.8</em:minVersion>
<em:maxVersion>1.6+</em:maxVersion>
</Description>
</em:targetApplication>


Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Ça donnera exactement le même résultat que ce qu'a fait Michel38, en plus compliqué.


Comme le dit la Luciole, ce n'est pas parce que tu force Firefox à accepter tes extensions qu'elles peuvent fonctionner avec Firefox 3 (sinon, il n'y aurait pas à spécifier dans les extensions avec quelles versions de Firefox elles sont compatibles).

Je teste également Firefox 3 sous Gutsy avec la même méthode que toi, et si je ne désactive pas certaines extensions (repérées par les erreurs qu'elles générent dans la console d'erreur), Firefox freeze au bout de quelques minutes. Sans parler de celles qui ne fonctionnent pas correctement (il y en a qui ne fonctionnent tout simplement pas, mais d'autres qui font par exemple disparaître une partie du menu contextuel).

Pour redémarrer Firefox, essaie le mode sans échec : ferme toute fenêtre de Firefox, vérifie qu'il ne reste pas de processus firefox et firefox-bin dans le moniteur système (Système > Administration) et lance firefox -safe-mode. Tes extensions sont désactivées, tu pourra donc en désinstaller, ou repasser la ligne du about:config à true pour désactiver les extensions par la suite.

[Modération] On s'occupe dans cette section uniquement des versions "stables" de Firefox, je déplace donc dans Nouvelle, rumeurs, comme pour tous les sujets traitant de Firefox 3.
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

Avatar de l’utilisateur
asap29
Animal mythique
Messages : 12088
Inscription : 30 oct. 2003, 00:34
Localisation : Entre l'ordi et la chaise ou a la plage

Message par asap29 » 29 déc. 2007, 10:58

essai avec cette autre version de nigtly qui fonctionne pour certaines extensions mais pas toutes
http://www.oxymoronical.com/web/firefox/nightly

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

Avatar de l’utilisateur
nico@nc
Animal mythique
Messages : 7799
Inscription : 21 août 2005, 08:04
Localisation : fr-FR
Contact :

Message par nico@nc » 29 déc. 2007, 11:04

asap29 a écrit :essai avec cette autre version de nigtly qui fonctionne pour certaines extensions mais pas toutes
http://www.oxymoronical.com/web/firefox/nightly

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Je n'ai toujours pas compris pourquoi tu veux utiliser cette extension alors que extensions.checkCompatibility fait exactement la même chose... :?
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

Avatar de l’utilisateur
asap29
Animal mythique
Messages : 12088
Inscription : 30 oct. 2003, 00:34
Localisation : Entre l'ordi et la chaise ou a la plage

Message par asap29 » 29 déc. 2007, 11:11

tout simplement par ce que je ne connais pas l'autre extension et que je suis resté bloqué sur mon idée :oops:
je suis vieux , borné et j'ai le poile terne en ce moment

bonne fêtes de fin d'années

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
si votre pb est résolu modifiez votre premier sujet en ajoutant "resolu"-merci
n'oubliez pas de consulter le portail et ses articles

Avatar de l’utilisateur
nico@nc
Animal mythique
Messages : 7799
Inscription : 21 août 2005, 08:04
Localisation : fr-FR
Contact :

Message par nico@nc » 29 déc. 2007, 11:31

http://kb.mozillazine.org/Extensions.checkCompatibility

Je signale au passage qu'il peut être nécessaire d'utiliser également extensions.checkUpdateSecurity car Firefox 3 demande aux extensions de fournir des mises à jour sécurisées, et pour l'instant (à part pour celles sur AMO), peu le proposent.
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

Zephir
Arias
Messages : 2
Inscription : 20 janv. 2008, 17:26

Message par Zephir » 20 janv. 2008, 17:31

vous dites qu'il y a peu d'extensions compatible FF3.. où sont-elles ?
J'ai un peu regardé sur le site officiel et je n'ai vu aucune option de filtre permettant d'isoler ces extensions.

Et puis, pourquoi les dev ne portent pas leur modules ? FF3 nécessite un nouveau SDK qui n'est pas encore sorti ?

Message envoyé avec : Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

Avatar de l’utilisateur
Benoit
Administrateur
Messages : 4894
Inscription : 19 juil. 2003, 10:59
Localisation : Bruxelles, Belgique
Contact :

Message par Benoit » 20 janv. 2008, 23:00

Le seul « SDK » en ce qui concerne les extensions c'est Firefox 3 lui-même, et effectivement il n'est pas encore sorti :)
♫ Li tens s'en veit, je n'ai riens fais ;
Li tens revient, je ne fais riens. ♪

Zephir
Arias
Messages : 2
Inscription : 20 janv. 2008, 17:26

Message par Zephir » 21 janv. 2008, 09:54

ok chef !
Je vais attendre la fin de la beta alors parce que là Camino/safari reste quand même bcp plus rapide ;-)

Message envoyé avec : Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités