Page 1 sur 1

[RESOLU] Test Pilot

Publié : 24 févr. 2017, 10:29
par JCD59
Bonjour,

Il m'est impossible d'installer le module "Test Pilot"

Je reste figé sur 'installation" sur la page d'accueil de Test Pilot quand je valide "installez le module test pilot"

En bas d'écran j'ai l'info : envoi d'une requête à testpilot.firefox.com..

Je suis sur la version 52.0b8 (32 bits)
Votre Navigateur : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Re: Test Pilot

Publié : 24 févr. 2017, 13:37
par totof_nouveau
bonjour
je viens d'essayer avec la 53.0 pas de pbs, peut etre reessayer?
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Re: Test Pilot

Publié : 24 févr. 2017, 17:51
par JCD59
Ma version est passée à 52.0b9
Le problème subsiste
J'ai été cherché le module Legacy Test Pilote 1.2.3.8
L'installation semble correcte , j'ai bien le message Test Pilote a été installé avec succés
J'ai ensuite un onglet qui s'ouvre avec un texte en anglais qui me félicite etc..., mais qui me propose qu'une seule option : Check out Test Pilot, si je ferme l'onglet cela revient au même, l'extension sera absente !
Quand je consulte ma config, j'ai une ligne
extensions.testpilot@labs.mozilla.com.install-event-fired;true
Dans mon dossier profil, j'ai plusieurs fichiers testpilote avec un suffixe SQLITE, ils sont anciens et ont été modifiés ce jour.
Comment rétablir correctement ce module ?
Votre Navigateur : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Re: Test Pilot

Publié : 24 févr. 2017, 18:24
par pascal
"The legacy Test Pilot program has been replaced, and this add-on is no longer useful. If you're interested in testing new features in Firefox please join the new program at https://testpilot.firefox.com"

C'est l'ancienne version d'il y a plusieurs années, pourquoi tu as installé ça plutôt que le nouveau Test Pilot ?
https://testpilot.firefox.com/
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0

Re: Test Pilot

Publié : 25 févr. 2017, 09:02
par JCD59
pascal a écrit :"The legacy Test Pilot program has been replaced, and this add-on is no longer useful. If you're interested in testing new features in Firefox please join the new program at https://testpilot.firefox.com"
C'est l'ancienne version d'il y a plusieurs années, pourquoi tu as installé ça plutôt que le nouveau Test Pilot ?
https://testpilot.firefox.com/
Votre Navigateur : Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Bonjour,

J'ai tenté cette solution car en utilisant le nouveau test Pilot, quand je valide "Installer le module Test Pilot", je reste figé sur l'étape suivante " installation..." , si longtemps que je suis contraint de stopper la procédure. On dirait que la requête ne part pas ! Antivirus ? J'ai Kaspersky KIS2017, pourtant j'ai mis le site testpilot dans les exceptions pour la collecte des données.

Ne serait-ce pas une très ancienne installation qui bloquerait, car j'avais déjà contribué en 2014, j'ai dans mon dossier profiles un dossier TestpilotExprementFiles ?

Bref je tourne en rond.

Voici ce que me donne la console du navigateur, onglet sécurité ( en mode developpement)
1488025862495 addons.xpi WARN Download of https://testpilot.firefox.com/static/addon/addon.xpi failed: [Exception... "Certificate issuer is not built-in." nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 171" data: no] Stack trace: checkCert()@resource://gre/modules/CertUtils.jsm:171 < onStopRequest()@resource://gre/modules/addons/XPIProvider.jsm:6474 < openModalWindow()@resource://gre/components/nsPrompter.js:364 < ModalPrompter.prototype.openPrompt()@resource://gre/components/nsPrompter.js:554 < ModalPrompter.prototype.confirmEx()@resource://gre/components/nsPrompter.js:695 < Prompter.prototype.confirmEx()@resource://gre/components/nsPrompter.js:79 < Server.defaultAllowConnection()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/security/prompt.js:138 < authenticate()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/security/auth.js:209 < ServerSocketConnection.prototype._authenticate<()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/security/socket.js:727 < TaskImpl.prototype._run()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311 < TaskImpl()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:273 < createAsyncFunction/asyncFunction()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:247 < _handle/<()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/security/socket.js:634 < TaskImpl.prototype._run()@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/task.js:311 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:932 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813 < this.PromiseWalker.scheduleWalkerLoop/<()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747

Voici le code erreur sur l'onglet Js, quand je vais sur la page https://testpilot.firefox.com/

13:34:57,474 Error calling WebSocket::close: InvalidAccessError: A parameter or an operation is not supported by the underlying object 1 sandbox.js:340

J'ai aussi cette erreur
13:38:51,953 Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à self (« style-src https://testpilot.firefox.com https://code.cdn.mozilla.net »). Source: #A9AdsMiddleBoxTop,#A9AdsOutOfStockWidge.... 1 testpilot.firefox.com:1


Votre Navigateur : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Re: Test Pilot

Publié : 25 févr. 2017, 13:59
par JCD59
J'ai trouvé un début de solution,

J'ai du désactiver complément mon antivirus Kasperky ! Ennuyeux !
Votre Navigateur : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Re: Test Pilot

Publié : 25 févr. 2017, 19:11
par totof_nouveau
et la fin? tu l'as trouvée?
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Re: Test Pilot

Publié : 26 févr. 2017, 09:49
par JCD59
Bonjour,

Oui, c'est bien Kaspersky (KIS 2017) qui me bloquait. Le module est intégré, comme un test ( Pour le moment)

J'ai rétabli, bien sur l'antivirus depuis.
Votre Navigateur : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0