Page 1 sur 1

[résolu] Détection de navigateur sur EUR-Lex

Posté : 18 déc. 2008, 17:31
par calimo
Hello,
Je veux utiliser la recherche avancée sur EUR-Lex : http://eur-lex.europa.eu/expert/sg/sga_ ... SE=bas-clx
Je clique donc sur le lien "service de recherche avancée" en bas de la page, et j'obtiens le message suivant :
The version of your browser is too old !
To use the expert interface, please upgrade to a browser running JAVA 1.1.4 or higher.
J'utilise Firefox 3.0.5 sous Ubuntu 8.10 "Intrepid Ibex" avec le plugin IcedTea 6b12-0ubuntu5
Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5

Quelqu'un pour confirmer ?

Posté : 18 déc. 2008, 17:44
par jpbardiau
Salut,
ça fonctionne avec le Java 1.6.0.10 de chez Sun.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-Be; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Posté : 18 déc. 2008, 18:02
par Patclash
Bonjour,
pas de soucis avec le plugin Java SE6 U11

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Posté : 18 déc. 2008, 18:16
par jpj
Avec ton lien, j'a un superbe écran bleu avec
FATAL ERROR

Invalid request (url) - requestName: sga_cnct, action: , application: , mode: prod, sessionId: , contextId: , transitScreen: , uniqueId: at /ec/prod/server/expert/SG/SGV3/lib/SG/Handler.pm line 173.
En passant par cette page (lien direct impossible pour cause de BBcode et phpBB 2), cela fonctionne avec XP et Java 6u11, ainsi qu'avec cet UA : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5 mais sous XP (pas de Linux sous le mulot).

Posté : 18 déc. 2008, 23:45
par myahoo
jpj > Pense à copier-coller le lien en entier, et tu verras qu'une adresse pas copiée entièrement n'est pas la même adresse :mrgreen:

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Posté : 19 déc. 2008, 00:25
par jpj
Arf, zut, crotte !

Bon, essai fait avec Ubuntu 8.04 LTS Hardy Heron plus Java et le site fonctionne. L'idiotie de la fenêtre est dans la référence au navigateur au lieu de ne parler uniquement que de Java.

Posté : 19 déc. 2008, 08:36
par calimo
Alors ça c'est très bizarre !
Effectivement ça fonctionne aujourd'hui. Je marque comme résolu même s'il y a toujours cette détection stupide... :roll:

(je n'avais pas vu que le lien ne s'était pas fait correctement, désolé :oops: )