Site topgratuit

Des problèmes qui n'en sont plus
uzul
Iguane
Messages : 694
Enregistré le : 23 mars 2004, 17:31

Site topgratuit

Message par uzul » 29 mai 2004, 19:37

Bonjour,
Qq'un ayant Firefox peut-il cliquer sur ce lien, fermer la boîte de dialogue qui s'ouvre, puis attendre le chargement de la page?
http://www.topgratuit.com
Que se passe-t-il chez vous?
Merci!

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 29 mai 2004, 21:22

Ben la page se charge... mis à part que ça clignotte partout et qu'elle n'est donc pas restée ouverte plus de 10 secondes, je vois pas :roll:

jv2759
Tyrannosaurus Rex
Messages : 4161
Enregistré le : 12 févr. 2004, 14:29

Message par jv2759 » 29 mai 2004, 21:28

Je vien d'essayer, et effectivement il semble bien qu'il y est un bug...

Quand je clic sur anuler j'ai une page d'erreure de windows et ff s'arrete. Par contre le plus drole, c'est que maintenant cela semble marchais..

Le plus bizard c'est quand regardant le code de la page, il ne semble pas y avoir de chose particuliére qui ce passe si on répond oui ou non, si c'est oui il ouvre un pop up et continut, si c'est non il s'arrete là et continut...

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 29 mai 2004, 21:29

Je suis sûr que le fait que j'aie TBE fausse la donne :roll:

EDIT : avec une 0.9 sans TBE, j'ai effectivement un plantage en rêgle. Mais seulement la première fois :shock:
Aucun problème avec Moz 1.6

Ça vaudrait la peine de soumettre un bug pour firefox je pense.

uzul
Iguane
Messages : 694
Enregistré le : 23 mars 2004, 17:31

Message par uzul » 29 mai 2004, 21:38

Eh oui, c'est curieux. Si on clique "Ok" dans la boîte, la page s'affiche.
Si on annule ou qu'on ferme la boîte, FF rencontre un pb et windows le ferme.
Bizarre....

jv2759
Tyrannosaurus Rex
Messages : 4161
Enregistré le : 12 févr. 2004, 14:29

Message par jv2759 » 29 mai 2004, 22:11

J'ai encore regarder pour mieux comprendre comment ce passer l'erreure.

1er execusion, cela plante.
2ed execusion, cela marche.
puis cela continut à marchais.

Pour reproduire l'erreure il faut que je suprime les cookie lier au site topgratuit et que je vide le cache.

Si je ne fait qu'une seul des opération cela marche toujours.

Donc le bug doit venir de la gestion des cookie. En plus en regardant la source j'ai vue que la gestion des cookie en javascrpt ce faisait en plein milieux de la page, et si je me souvien bien, je crois qu'il faut commencer par la gestion des cookie avant tout autre chose. Quoique je ne sais plus si c'est pas pour le php cela...

chBok
Iguane
Messages : 990
Enregistré le : 17 oct. 2003, 19:17

Message par chBok » 29 mai 2004, 23:09

uzul a écrit :Eh oui, c'est curieux. Si on clique "Ok" dans la boîte, la page s'affiche.
Si on annule ou qu'on ferme la boîte, FF rencontre un pb et windows le ferme.
Bizarre....
:arrow: Je confirme que 'Annuler' m'a fait une erreur fatale de mon Mozilla 1.5-fr sous Win Meuh.

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 30 mai 2004, 08:17

Sous WinXP, ni Moz 1.6-fr ni la 1.7-rc.2 ne plantent, même après supression des cookies.
Par contre le bug est reproductible en supprimant les cookies sur FF-0.8-fr sans TBE comme sur les dernières nightlies (sans TBE aussi).
Et le plus étrange c'est donc TBE qui semble empêcher le plantage :shock:

SB
Varan
Messages : 1095
Enregistré le : 05 mars 2004, 18:38

Message par SB » 30 mai 2004, 15:34

Ben moi j'ai pas de boite de dialogue et le site marche très bien. :o

Kropotkine
Iguane
Messages : 693
Enregistré le : 20 févr. 2004, 20:46

Message par Kropotkine » 30 mai 2004, 15:40

Sous FF 0.8 et Win 2003 Server, plantage la première fois après avoir cliqué sur Annuler.

PS : Je n'arrive pas à faire plus français ... :? :?
Xpower ! Image
Vive les Mac, MacOS X Panther et Safari, les logiciels libres et les mises à jour !

SB
Varan
Messages : 1095
Enregistré le : 05 mars 2004, 18:38

Message par SB » 30 mai 2004, 15:59

Bon sang, où est-ce qu'elle est cte boite de dialogue.

jv2759
Tyrannosaurus Rex
Messages : 4161
Enregistré le : 12 févr. 2004, 14:29

Message par jv2759 » 30 mai 2004, 16:23

Normalement le scripte dit que la boite doit s'afficher, la premiére, la troisiéme et la sixiéme fois (et c'est stocker dans un cookie). si les cookie son bien actiber suprime les si tu les a déjà...

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 31 mai 2004, 17:26

Je viens de regarder sur Bugzilla parmi les 745 bugs provoquant un crash, je n'ai rien trouvé de semblable.
Je pense que ça vaudrait la peine de soumettre un bug, mais il faudrait commencer par trouver où il est exactement, et surtout dans quelles conditions il se déclanche. Chez moi, Moz 1.6fr semble vacciné, et le problème ne se pose pas sur Firefox + TBE.
J'aimerais bien l'avis d'autres utilisateurs de la suite et de TBE avant de le lancer.
À moins que quelqu'un d'autre ne veuille s'y mettre.

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 03 juin 2004, 16:41

Personne qui a TBE ne veut essayer ?

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 04 juin 2004, 17:27

Pour suivre le développement, voir le bug 245570

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités