Points bloquants pour KompoZer 0.8

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, bobo

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Points bloquants pour KompoZer 0.8

Message par Kazé » 04 janv. 2010, 19:46

Bonsoir, bonanétoussa,

la beta2 va naître dans la douleur, avec plus de 8000 lignes de code modifiées depuis la beta1. Il faut que je mette un grand coup d’accélérateur pour livrer une 0.8 finale pour la prochaine Ubuntu LTS…

Je voudrais en profiter pour faire le point avec vous des bugs bloquants dans KompoZer 0.8b1 : on ne parle plus des (nombreux) bugs d’interface, mais uniquement des bugs qui vous contraindraient à rester sur KompoZer 0.7.10. Autrement dit, quels sont les bugs qu’il faudrait corriger en priorité maintenant que le code commence à être stable ?

Attention : je ne cherche pas ici à avoir une liste de 500 bugs à traiter, j’ai déjà ça sur le tracker SourceForge. Je voudrais juste avoir une idée précise des bugs les plus pénibles, qu’il faut donc impérativement corriger pour la 0.8 finale.

Merci d’avance !
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: Points bloquants pour KompoZer 0.8

Message par Ymai » 04 janv. 2010, 23:34

Bonjour Kazé
Dans mon top des flops...
- L'impossibilité de créer un paragraphe nouveau en frappant simplement "Enter" dans un paragraphe (soit le fonctionnement classique d'un traitement de texte et de KpZ 0.7.10).
- L'impossibilité de passer derrière un bloc (<div>, par exemple) avec les touches fléchées. Sous 0.7.10, on sélectionne le bloc dans la barre d'état, puis flèche droite.
- la visualisation dans le navigateur qui ne fonctionne pas
Dans la console Javascript, j'obtiens un message du type suivant:
FileIO: failed to open file 'file:///home/yves/www/sio2/cours/info/index.php'
Trois soucis dont la résolution n'est pas intuitive pour le public cible de KpZ. Pour les deux premiers, je n'ai trouvé que le passage par l'onglet "split" et l'encodage manuel.
Dès que ça fonctionne, je passe mes cours en version 0.8 (bonne résolution de début d'année).
Mais, nonobstant, toute mon admiration pour le travail fourni.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 05 janv. 2010, 00:56

J’ajoute aussi la question du sérialiseur (x)HTML, vu qu’il est loin d’être certain que Laurent Jouanneau puisse me proposer un patch pour le sérialiseur HTML :
  • application des options d’encodage
  • compatibilité HandCoder/Tidy ou intégration de Tidy dans KompoZer 0.8
Tant que j’y pense, il y a aussi le problème de l’éditeur CSS qui rajoute des « *| » dans les sélecteurs CSS quand on clique sur « Annuler », ce qui pose un tas de soucis tant qu’on ne recharge pas la page HTML courante. J’ai avancé sur la question mais je n’ai pas de solution en vue pour l’instant.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

rfr23

Re: Points bloquants pour KompoZer 0.8

Message par rfr23 » 05 janv. 2010, 12:48

Bonjour,

Dans la 0.8b1, "/script" sont remplacés par des "/" .
J'ai été obligé de revenir à la 0.7 à cause de ca.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: Points bloquants pour KompoZer 0.8

Message par Ymai » 05 janv. 2010, 14:35

Bonjour
rfr23 a écrit :Dans la 0.8b1, "/script" sont remplacés par des "/" .
J'ai été obligé de revenir à la 0.7 à cause de ca.
Merci de préciser le contexte. Pour ma part, aucun souci avec

Code : Tout sélectionner

<html>
<head>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
<script type="text/javascript">
alert("test");
</script>
<title>test</title>
</head>
<body>
<br>
<br>
</body>
</html>
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 05 janv. 2010, 15:47

rfr23 fait peut-être allusion à un problème qui se produit sur des documents XHTML sauvegardés avec l’extension *.html, contenant un script du type :

Code : Tout sélectionner

<script type="text/javascript" src="monScript.js />
Du coup, le script n’est plus chargé par le navigateur (notamment Firefox). Le problème n’est pas vraiment du fait de KompoZer, mais du fait que les utilisateurs font des documents XHTML qui sont envoyés en text/html (et non application/xhtml+xml) au navigateur.

KompoZer 0.7.10 contournait le problème en sérialisant cette balise <script> de la façon suivante :

Code : Tout sélectionner

<script type="text/javascript" src="monScript.js></script>
qui fonctionne même sur un document XHTML envoyé en text/html (ou portant l’extension *.html), puisque cette écriture est valide à la fois en XHTML et en HTML.

Là encore, c’est un problème lié au sérialiseur. Une façon simple de contourner ce problème serait de sauvegarder le document XHTML avec une extension *.xhtml (à vérifier sur les autres navigateurs).
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: Points bloquants pour KompoZer 0.8

Message par Ymai » 05 janv. 2010, 15:52

Kazé a écrit :

Code : Tout sélectionner

<script type="text/javascript" src="monScript.js />
Je présume qu'il faut lire

Code : Tout sélectionner

<script type="text/javascript" src="monScript.js" />
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

rfr23

Re: Points bloquants pour KompoZer 0.8

Message par rfr23 » 05 janv. 2010, 20:38

Je vais essayer de reinstaller la 0.8b1 pour regarder de plus près et je vous tiens au courant.

Je ne suis pas un grand connaisseur donc je peux pas repondre en etant sure a 100% mais il me semble bien que ca remplacait le "/script" par "/". Je precise que ce site contient des images en .swf .

Je ne crois pas que ca soit un probleme avec firefox, parce que le seul fait de passer sur la 0.8b1 ( et d'enregistrer au moin une fois ma page ) fait que je perd toute ma page, autant sur firefox que sur IE et meme dans kompozer je ne vois plus rien qui s'affiche.

rfr23

Re: Points bloquants pour KompoZer 0.8

Message par rfr23 » 05 janv. 2010, 21:04

Je viens de réessayer, et c'est exactement ce que dit kazé. Donc désolé, j'ai parlé un peu trop vite...
Pour ma part, je suis en train de me debarrasser de ce genre de scripts, donc je vais bientot utiliser la 0.8b1.

J'ai essayé avec l'extension *.xhtml, et ca fonctionne pour firefox. Sur IE, je n'arrive pas a charger les pages xhtml, je ne sais pas si c'est normal.

Sinon, j'en profite pour remercier et feliciter Kazé et tout ceux qui travaillent sur kompozer, je le trouve vraiment bien.

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 05 janv. 2010, 21:31

Ymai a écrit :Je présume qu'il faut lire

Code : Tout sélectionner

<script type="text/javascript" src="monScript.js" />
Tu présumes bien, j’ai oublié un guillemet. :oops:
rfr23 a écrit :J'ai essayé avec l'extension *.xhtml, et ca fonctionne pour firefox. Sur IE, je n'arrive pas a charger les pages xhtml, je ne sais pas si c'est normal.
C’est « normal » dans la mesure où IE ne supporte pas le « vrai » XHTML, i.e. celui envoyé en XML. C’était le cas pour IE6, visiblement c’est toujours le cas avec IE7 et 8.
Je n’ai rien contre le XHTML (je l’utilise abondamment pour mes documentations), mais vu qu’il n’est pas supporté par IE je ne vois pas l’intérêt de son utilisation pour des pages web…
rfr23 a écrit :Sinon, j'en profite pour remercier et feliciter Kazé et tout ceux qui travaillent sur kompozer, je le trouve vraiment bien.
Merci. :-)
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

photo-expo
Arias
Messages : 3
Enregistré le : 06 janv. 2010, 00:02

Re: Points bloquants pour KompoZer 0.8

Message par photo-expo » 06 janv. 2010, 00:13

Bonjour Kz

J'utilise KompoZer depuis maintenant 2 ans et j'ai créé 2 sites complets.
Pour ma part, le point le plus ennuyeux de cette version, c'est l'enregistrement ou la perte de la feuille de style lorsqu'on l'ouvre plusieurs fois de suite.
Pour palier à cela je fais ma modif, je ferme la page et je l'ouvre à nouveau. Ceci fonctionne mais c'est pénible.

Bon courage pour la version finale,

Michel

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 08 janv. 2010, 00:36

Oui, c’est ce que je signalais plus haut :
Kazé a écrit : il y a aussi le problème de l’éditeur CSS qui rajoute des « *| » dans les sélecteurs CSS quand on clique sur « Annuler », ce qui pose un tas de soucis tant qu’on ne recharge pas la page HTML courante.
Je viens tout juste de trouver une façon de contourner ce bug… du moins, je crois. On vérifiera ça avec la beta2.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 10 janv. 2010, 21:43

Un autre bug (régression) qui me paraît bloquant, c’est le nettoyeur de balises qui plante sur les listes imbriquées — provoquant la perte de toute le document HTML courant.

[EDIT1] semble désormais corrigé sur ma version de travail, à vérifier avec la future beta2.

[EDIT2] tant qu’on y est (et même si ce n’est pas vraiment bloquant), il faudrait voir également s’il n’y aurait pas moyen de virer les « style="vertical-align: top;" » qui sont ajoutés dans les cellules de tableau — soit dans le nettoyeur de balises, soit directement dans le bouton « Tableau ».
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: Points bloquants pour KompoZer 0.8

Message par Kazé » 11 janv. 2010, 02:59

Ymai a écrit : - L'impossibilité de passer derrière un bloc (<div>, par exemple) avec les touches fléchées. Sous 0.7.10, on sélectionne le bloc dans la barre d'état, puis flèche droite.
Je n’ai pas de solution simple pour celui-là, c’est assez tordu. À défaut, je peux implémenter deux raccourcis clavier pour contourner ce bug :
  • Ctrl+Entrée ajouterait un <br> après le bloc courant
  • Ctrl+Maj+Entrée ajouterait un <br> avant le bloc courant
…en espérant que ces raccourcis soient utilisables sur toutes les plate-formes (je m’attends au pire avec MacOSX) — et si vous avez de meilleures idées pour les raccourcis clavier, ne vous gênez pas (Ctrl + flèche haut/bas ?).
J'ai restreint ces raccourcis à une liste d’éléments potentiellement pénibles (div, table, ul, ol, dl, object). Si vous voyez d’autres éléments à inclure dans la liste, merci de me le signaler.

Quoiqu’il en soit : une fois que le <br> est créé, KompoZer peut y placer automatiquement le curseur. J’ai mis ça en œuvre sur ma version de travail, ça fonctionne bien.

Évidemment, on pourra m’objecter le fait que ça crée encore des <br> en trop ; je répondrais que si Gecko crée ces <br>, c’est justement pour y placer le curseur… et le nettoyeur de balises est là pour y remédier. Par ailleurs, un raccourci clavier me semble plus facile à utiliser que la manip « clic dans la barre d’état + flèche » (à condition toutefois que les raccourcis soient suffisamment intuitifs). Et de toute façon, je n’ai pas d’autre solution sous la main pour l’instant.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

pascal
Administrateur
Messages : 1222
Enregistré le : 28 juil. 2003, 15:13

Re: Points bloquants pour KompoZer 0.8

Message par pascal » 11 janv. 2010, 06:55

une suggestion, est-ce que le raccourci clavier pourrait créer un <br class="forcedbreak" /> plutôt qu'un <br /> et avoir le nettoyage de ceux-ci automatiquement dès qu'on enregistre un document ? ça éviterait d'avoir des <br/> légitimes potentiellement supprimés et ça éviterait aussi à l'utilisateur d'avoir à faire une action de nettoyage manuel.

Si l'insertion d'un <br/> correspond au besoin d'insérer tout simplement un nœud dans le DOM et que n'importe quel nœud pourrait marcher, peut être qu'un span vide serait plus utile parce qu'un break peut avoir un impact sur la mise en page et un span vide non (sauf si on le style en CSS).
Modifié en dernier par pascal le 11 janv. 2010, 07:38, modifié 1 fois.
Mozilla
Mes opinions n'engagent que moi et pas mon employeur

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité