KompoZer 0.8 alpha4

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, bobo

Répondre
Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: KompoZer 0.8 alpha4

Message par Kazé » 08 oct. 2009, 14:30

Do-IT a écrit :Rev178.
Sur 5 comptes ftp, un seul fonctionne. Je ne sais pas pourquoi. La console ftp n'est pas assez detaillée. T'as eu aucun soucis ?
Non, pas de souci de mon coté, mais tous mes sites sont chez OVH… Contacte-moi sur IRC ou par MP pour me donner plus de détails STP.

En théorie, tout ce qui est supporté par Firefox 2 et FireFTP 0.97 devrait être supporté par KompoZer 0.8 rev.178. Si ce n’est pas le cas, c’est que j’ai fait une erreur quelque part.
Do-IT a écrit :Le sftp via ssh est absolument indispensable, c'est prévu ?
Pas avant la branche 0.9, malheureusement.
Le problème est que le noyau Gecko ne sait pas faire de SSH ; implémenter SFTP n’est donc pas simple. J’ai une petite lueur d’espoir, puisque FireFTP commence à bosser sur la question (en utilisant une bibliothèque GPL compilée) et que Komodo supporte déjà le SCP. Dans le pire des cas, il faudrait lier la bibliothèque de FileZilla à KompoZer. Dans tous les cas, je n’aurai pas le temps de voir ça avant KompoZer 0.9.
Do-IT a écrit :Un bouton de test de connexion serait le bienvenu dans le gestionnaire de site. Et éventuellement la possibilité en décochant une case de voir le mot de passe qu'on tape en clair.
Ah oui, tiens…
Il faudrait aussi que je permette d’exporter un fichier XML contenant les paramètres des sites FTP, qui soit compatible avec FileZilla.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

chinon37
Animal mythique
Messages : 5318
Enregistré le : 21 mars 2005, 10:17

Re: KompoZer 0.8 alpha4

Message par chinon37 » 08 oct. 2009, 21:25

Salut,
Un bogue que je ne suis pas sûr d'avoir vu passer:
KpZ 0.8a4:
une image de fond est attribuée à un H1 par style interne. > l'adresse de l'image est absolue et pointe donc vers mon disque dur (malgré une page enregistrée et une image dans l'arborescence classique - dossier image du répertoire "site")

Code : Tout sélectionner

<h1
style="background-image: url(file:///D:/Papou/Bureau/cyclo/7clochers/images/bandeaubilan09.jpg);"
id="header">RONDE DES 7 CLOCHERS<br>
</h1>
Je passe donc par le nettoyeur de balise pour relativiser l'adresse: résultat des courses

Code : Tout sélectionner

<h1 style="" id="header">RONDE DES 7 CLOCHERS<br>
</h1>
Pour un nettoyage, c'est un nettoyage!!! Elle est où, ma belle z'image? :(
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: KompoZer 0.8 alpha4

Message par Kazé » 08 oct. 2009, 23:53

Oui, je crois que le bug a été signalé un jour… quelque part…
Soit je résous ce bug dans les heures qui viennent, soit je renomme le « nettoyeur de balises » en « destructeur de balises ». Zou !

Accessoirement, je crois que le problème de l’URL absolue a aussi une influence sur la boite de propriétés des images. Y’a encore du chemin à parcourir avant la 0.8 finale. -_-'

EDIT1: et le pire, c’est qu’il te laisse un <br> à la fin… :oops:
EDIT2: je viens de reproduire ce bug avec KompoZer 0.7.10, ce n’est donc pas une régression.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Do-IT
Iguane
Messages : 537
Enregistré le : 03 juil. 2005, 09:46

Re: KompoZer 0.8 alpha4

Message par Do-IT » 09 oct. 2009, 10:35

rev178. Suppression du .kompozer.net
Ouvrir kz > Edit > Publishing Site Settings (*1) (*2) > Select site directory... (ah bon ?, vu le résultat il falait choisir le dossier de son site web)

*1) Majusculite aigue dans tous les termes de kompozer
*2) Le bouton dans la panneau latéral s'appelle 'Edit site list...'

Apparemment les problèmes de connexion ne sont pas liés au serveur mais c'est plutôt aléatoire comme ici (comparaison filezilla et kp). Ou ici. Encore ailleurs
Je ne fais rien de méchant à part un petit Publish..., des fois ça passe pas. Après un échec de connexion il se contante de faire des NOOP au lieu de retrouver ces billes.

Y'a pas une vue distante ? Comme dans le temps ?

Code : Tout sélectionner

Error: lastLineOfBuffer has no properties
Source File: chrome://editor/content/ftpControlSocket.js
Line: 537
Comme je le disais déjà ici, il y a 3 chiffrements TLS/SSL, l'absent étant SFTP (j'ai quand même plus de 40 comptes ftp accessibles uniquement via ssh). (Filezilla propose 3 chiffrements : SFTP / FTPS / FTPES)

Y'a rien a faire j'arrive pas à me connecter en FTPES sur mon NAS perso, j'ai tout essayé Best/Better/Actif/Passif. (ok avec Filezilla)

Bon WE, je vais aller bosser là.
Redhat, CentOs, Mandriva, Ubuntu au boulot. Ubuntu à la maison. Vista et Xp grâce à la vente liée.
Soutenir KompoZer

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: KompoZer 0.8 alpha4

Message par Kazé » 10 oct. 2009, 18:03

Galère de dernière minute : quand on ferme le gestionnaire de sites, puis qu’on le rouvre (F9 deux fois), on perd la connexion FTP et on ne la récupère jamais. Ça risque de repousser la sortie de la 0.8b1.
Do-IT a écrit : Select site directory... (ah bon ?, vu le résultat il falait choisir le dossier de son site web)
Oui : pour la 0.8, on va imposer d’avoir un dossier local. On en aura besoin pour HandCoder, entre autres.
J’ai donc fait en sorte que lorsqu’on crée un nouveau site ouèbe dans KompoZer, ça demande d’abord un répertoire local.
Do-IT a écrit :Y'a pas une vue distante ? Comme dans le temps ?
Pour l’instant, y’a pas. Y’aura peut-être plus tard.
Do-IT a écrit : Majusculite aigue dans tous les termes de kompozer
Si tu fais allusion au fait que tous les noms communs commencent par une majuscule, c’est normal : en anglais, les titres doivent être formatés comme ça, paraît-il.
Dans la version francisée, ça ne se produira pas.
Do-IT a écrit : Le bouton dans la panneau latéral s'appelle 'Edit site list...'
Vu.
Do-IT a écrit : Comme je le disais déjà ici, il y a 3 chiffrements TLS/SSL, l'absent étant SFTP (j'ai quand même plus de 40 comptes ftp accessibles uniquement via ssh). (Filezilla propose 3 chiffrements : SFTP / FTPS / FTPES)
Désolé, mais il n’y a pas moyen d’avoir du SSH dans Mozilla, d’où l’absence de support SFTP dans KompoZer 0.8. Ça me gêne aussi pour mettre à jour le site sur SourceForge, qui n’accepte que du SFTP.
Pour la version 0.9 je verrai si je peux récupérer les routines SCP d’OpenKomodo, ou si on pourra embarquer le backend de FileZilla. Je n’ai pas de solution miracle à court terme. :-/
Do-IT a écrit : Y'a rien a faire j'arrive pas à me connecter en FTPES sur mon NAS perso, j'ai tout essayé Best/Better/Actif/Passif. (ok avec Filezilla)
Aïe, FTP(e)S devrait fonctionner pourtant, en choisissant « security: SSL / TLS » dans les paramètres du gestionnaire de site.
Ce qui serait sympa, ça serait de tester avec Firefox 2 et FireFTP 0.97.3, pour voir si l’erreur est de mon fait ou si c’est une limitation du code FireFTP que j’utilise.
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Do-IT
Iguane
Messages : 537
Enregistré le : 03 juil. 2005, 09:46

Re: KompoZer 0.8 alpha4

Message par Do-IT » 12 oct. 2009, 13:31

b1 idem.
Kazé a écrit :Aïe, FTP(e)S devrait fonctionner pourtant, en choisissant « security: SSL / TLS » dans les paramètres du gestionnaire de site.
Ce qui serait sympa, ça serait de tester avec Firefox 2 et FireFTP 0.97.3, pour voir si l’erreur est de mon fait ou si c’est une limitation du code FireFTP que j’utilise.
Firefox 2.0.0.20. Fireftp arrive à s'authentifier mais après il n'affiche pas le dossier distant. Il doit pas aimer traverser mon routeur. (Avec filezilla aucun soucis). Faut que j'essaye fireftp en local.
Redhat, CentOs, Mandriva, Ubuntu au boulot. Ubuntu à la maison. Vista et Xp grâce à la vente liée.
Soutenir KompoZer

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 01 nov. 2009, 20:31

Bonjour
Dans la version 0.8a4 des dépôts Ubuntu (Karmic), je n'arrive pas à éditer le texte dans l'onglet "split".
alt+Enter => la zone "split" semble se vider. Impossible d'y écrire.

Autre chose: aucune icône ne semble affectée à KpZ.
Rien dans le "windows switcher" et en haut et à gauche de la fenêtre de KpZ (enfin, si... un rectangle noir contenant un panneau d'interdiction), rien dans la barre des applications en cours (enfin, si... juste l'icône d'une fenêtre générique)
Image

Quelqu'un peut confirmer tout cela?
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

pascal
Administrateur
Messages : 1222
Enregistré le : 28 juil. 2003, 15:13

Re: KompoZer 0.8 alpha4

Message par pascal » 01 nov. 2009, 22:01

Pour tes 3 problèmes, sur karmic:

- l'édition en mode split fonctionne chez moi
- j'ai bien un lanceur pour kompozer, il est dans le menu Internet
- par contre je n'ai effectivement pas d'icône pour l'application dans le coin supérieur gauche.
Mozilla
Mes opinions n'engagent que moi et pas mon employeur

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 01 nov. 2009, 22:50

pascal a écrit :- j'ai bien un lanceur pour kompozer, il est dans le menu Internet
Dans "Programmation", chez moi. Mais c'est dans une Netbook Remix.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

jpbardiau
Tyrannosaurus Rex
Messages : 2709
Enregistré le : 05 avr. 2004, 17:34

Re: KompoZer 0.8 alpha4

Message par jpbardiau » 01 nov. 2009, 23:00

Chez moi, c'est dans "Programmation" et "Internet".
JP
Image
Image

pascal
Administrateur
Messages : 1222
Enregistré le : 28 juil. 2003, 15:13

Re: KompoZer 0.8 alpha4

Message par pascal » 01 nov. 2009, 23:03

ah oui effectivement, je l'ai aussi dans programmation :) manque plus que de le mettre dans Bureautique et on aura le grand chelem :)
Mozilla
Mes opinions n'engagent que moi et pas mon employeur

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 01 nov. 2009, 23:29

pascal a écrit :ah oui effectivement, je l'ai aussi dans programmation :) manque plus que de le mettre dans Bureautique et on aura le grand chelem :)
De fait...

Et pour le mode "split", après un redémarrage de l'OS, c'est maintenant OK.
Mais d'icône, pourtant si élégante, point.
Cela ne justifierait-il pas un rapport de bug?
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

pascal
Administrateur
Messages : 1222
Enregistré le : 28 juil. 2003, 15:13

Re: KompoZer 0.8 alpha4

Message par pascal » 01 nov. 2009, 23:37

pour l'icône, kaze est au courant, j'en discutais tout à l'heure avec lui sur IRC, je sais pas si un bug est déjà ouvert ceci dit.
Mozilla
Mes opinions n'engagent que moi et pas mon employeur

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: KompoZer 0.8 alpha4

Message par Kazé » 02 nov. 2009, 10:09

Oui, pour l’icône manquante je suis au courant — d’ailleurs, je crois qu’on a le même problème avec la version get-deb de la 0.8b1.
De toute façon, l’icône n’a été que partiellement mise à jour dans la 0.8b1, il faut que je reprenne ça de façon plus stricte pour la bêta2.
pascal a écrit :ah oui effectivement, je l'ai aussi dans programmation :) manque plus que de le mettre dans Bureautique et on aura le grand chelem :)
C’est prévu, mais pour la branche 0.9 seulement. :P
Blague à part, je vais tâcher de demander au mainteneur Debian de ne garder que le menu « Internet », d’autant que KompoZer 0.8 est tout sauf un éditeur de code…

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 18 avr. 2010, 17:44

chinon37 a écrit :Salut,
Un bogue que je ne suis pas sûr d'avoir vu passer:
KpZ 0.8a4:
une image de fond est attribuée à un H1 par style interne. > l'adresse de l'image est absolue et pointe donc vers mon disque dur (malgré une page enregistrée et une image dans l'arborescence classique - dossier image du répertoire "site")

Code : Tout sélectionner

<h1
style="background-image: url(file:///D:/Papou/Bureau/cyclo/7clochers/images/bandeaubilan09.jpg);"
id="header">RONDE DES 7 CLOCHERS<br>
</h1>
Je passe donc par le nettoyeur de balise pour relativiser l'adresse: résultat des courses

Code : Tout sélectionner

<h1 style="" id="header">RONDE DES 7 CLOCHERS<br>
</h1>
Pour un nettoyage, c'est un nettoyage!!! Elle est où, ma belle z'image? :(
Aaahhhh!!! C'est donc cela qui m'est arrivé hier. Je me sens moins seul du coup. Textuellement le même problème.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité