KompoZer 0.8 alpha4

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, bobo

Zefling
Tyrannosaurus Rex
Messages : 2577
Enregistré le : 21 déc. 2004, 03:45

Re: Problème Komposer

Message par Zefling » 15 août 2009, 17:30

Kazé a écrit :J’ai mis cet onglet « Source » justement parce que j’en avais marre de recevoir 50 mails par jour me demandant de le remettre.
Vous l’avez voulu, vous l’avez ! :twisted:
Pfff... Sadique. :P

Bon, je vais arrêter de me plaindre pour truc. :D Enfin, je n'utilise toujours pas le 0.8 pour mes articles, parce que sans Tidy, c'est la mort. :cry: (Oui, je copie/colle le source, j'aime pas les éditeurs WYSIWYG en javascript)

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Mon blog de dév web ― Thème pour le forum Geckozone ― Le clavier Latin-9 fr sous Windows ― Raccourcis clavier pour Firefox
Debian 8 KDE avec Firefox & Nightly

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Message par Kazé » 15 août 2009, 20:14

Pour KompoZer 0.8 et HandCoder il y a un topic ici : http://www.geckozone.org/forum/viewtopic.php?t=74996
Et il y a une version installable de HandCoder là : :arrow: http://kompozer.net/xpi/HandCoder-20090515.xpi

Ce n’est pas parfait (loin s’en faut) mais c’est un début et ça fonctionne chez moi avec KompoZer 0.8 — sur des fichiers HTML essentiellement.
Il y a pas mal de choses qui devront être repensées, voire être incluses dans KompoZer 0.8, pour avoir un comportement satisfaisant sur les fichiers PHP.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Message par Kazé » 16 août 2009, 00:12

Ioustone, we got a problem… :-(

Avec Firefox (testé avec les versions 1.0 à 3.5), quand on lit une page *.html contenant :

Code : Tout sélectionner

<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="content-type">
<title></title>
</head>
<body>
<?php
$MonMail = "toto@mail.com";
$sujet = "Mon sujet";
$envoi = "Le texte du mail";
$zorglub = "zorglub@mail.com
mail ($MonMail, $sujet, $envoi, "From: $nom <$zorglub>");
?>
</body>
</html>
on s’aperçoit que la coloration syntaxique plante lamentablement sur le crochet fermant de <$zorglub> :
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="content-type">
<title></title>
</head>
<body>
<?php
$MonMail = "toto@mail.com";
$sujet = "Mon sujet";
$envoi = "Le texte du mail";
$zorglub = "zorglub@mail.com
mail ($MonMail, $sujet, $envoi, "From: $nom <$zorglub>
");
?>
</body>
</html>
là où j’aurais préféré voir :
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="content-type">
<title></title>
</head>
<body>
<?php
$MonMail = "toto@mail.com";
$sujet = "Mon sujet";
$envoi = "Le texte du mail";
$zorglub = "zorglub@mail.com
mail ($MonMail, $sujet, $envoi, "From: $nom <$zorglub>");
?>

</body>
</html>
Autrement dit : ce n’est pas KompoZer qui est en cause pour le code PHP, mais le parser HTML du tronc Mozilla. Du coup ça va être moins simple à débugger.
Pour Nvu, Glazou a probablement dû modifier le tronc Mozilla pour ça, pour l’instant je ne trouve pas où… à creuser.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 16 août 2009, 09:43

Ne serait-ce pas une régression du tronc Mozilla.
Auquel cas, la patate chaude doit être passée plus loin.
Question idiote: les fichiers XML, par exemple, sont lus correctement? A moins qu'il n'y ait pas de rapport?
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

galad
Lézard à collerette
Messages : 346
Enregistré le : 19 déc. 2005, 12:23

Re: KompoZer 0.8 alpha4

Message par galad » 16 août 2009, 12:12

Bonjour,
il y a un truc qui me gêne dans Kpz, c'est de ne pas pouvoir ouvrir directement les pages en php. J'ouvre souvent mes pages pour les modifier, et le fait de cliquer à chaque fois sur "tous les fichiers" pour voir les pages en php est assez ... pénible.
Y a t-il un moyen de configurer Kpz au départ pour qu'il ouvre tous les fichiers ou des préférences ? Ou y penser pour la prochaine version ? Merciiiiiiiiiiiiiiiiii

Sinon pour répondre à un post plus haut, je suis vos conseils et n'utilise plus le code source. Alors Kaze, pour ma part tu peux le supprimer :wink:
Galad, avec kpz 0.8b1 ...

Kazé
Varan
Messages : 1743
Enregistré le : 10 févr. 2005, 10:26

Re: KompoZer 0.8 alpha4

Message par Kazé » 16 août 2009, 12:53

galad a écrit :il y a un truc qui me gêne dans Kpz, c'est de ne pas pouvoir ouvrir directement les pages en php. J'ouvre souvent mes pages pour les modifier, et le fait de cliquer à chaque fois sur "tous les fichiers" pour voir les pages en php est assez ... pénible.
Y a t-il un moyen de configurer Kpz au départ pour qu'il ouvre tous les fichiers ou des préférences ? Ou y penser pour la prochaine version ? Merciiiiiiiiiiiiiiiiii
Y’a pas moyen de configurer KompoZer pour ça, mais je vais essayer de résoudre ce problème pour la prochaine version.
Ymai a écrit :Question idiote: les fichiers XML, par exemple, sont lus correctement? A moins qu'il n'y ait pas de rapport?
La question est tout sauf idiote !
Effectivement, avec un fichier XML ça marche bien — tant avec KompoZer 0.8 que Firefox : il suffit de renommer le fichier précédent en *.xhtml (après avoir ajouté un « / » à la balise <meta>), et le code PHP est bien interprété. Il faudrait donc plutôt chercher du coté du xhtml…

galad
Lézard à collerette
Messages : 346
Enregistré le : 19 déc. 2005, 12:23

Re: KompoZer 0.8 alpha4

Message par galad » 18 août 2009, 10:53

Kazé a écrit :
galad a écrit :il y a un truc qui me gêne dans Kpz, c'est de ne pas pouvoir ouvrir directement les pages en php. J'ouvre souvent mes pages pour les modifier, et le fait de cliquer à chaque fois sur "tous les fichiers" pour voir les pages en php est assez ... pénible.
Y a t-il un moyen de configurer Kpz au départ pour qu'il ouvre tous les fichiers ou des préférences ? Ou y penser pour la prochaine version ? Merciiiiiiiiiiiiiiiiii
Y’a pas moyen de configurer KompoZer pour ça, mais je vais essayer de résoudre ce problème pour la prochaine version.
Merci Kaze
Galad, avec kpz 0.8b1 ...

chinon37
Animal mythique
Messages : 5318
Enregistré le : 21 mars 2005, 10:17

Re: KompoZer 0.8 alpha4

Message par chinon37 » 11 sept. 2009, 11:40

Bouh! je ne retrouve plus le topic qui référençait les bogues ... y'en avait bien un, non?

celui-ci est-il répertorié?:
soit ce menu déroulant (je mets la page complète):

Code : Tout sélectionner

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
  
  <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
  <title>essaimenu</title>

  
  
  <style type="text/css">
#menuDeroulant {
  border:  none;
  margin: 0 auto;
  padding: 0;
  width: 600px;
  text-align: center;
  list-style-type: none;
  position: relative;
}
#menuDeroulant li {
  border:  none;
  margin: 0;
  padding: 0;
  float: left;
}
#menuDeroulant .sousMenu {
  border:  none;
  margin: 0;
  padding: 0;
  display: none;
  list-style-type: none;
  background-color: #cccccc;
}
#menuDeroulant .sousMenu li {
  border:  none;
  margin: 0;
  padding: 0;
  float: none;
}
#menuDeroulant li {
  border:  none;
  margin: 0;
  padding: 0;
  float: left;
  width: 150px;
}
#menuDeroulant li a:link, #menuDeroulant li a:visited {
  border-right: 1px solid #ffffff;
  margin: 0;
  padding: 4px 8px;
  background: #3b4e77 none repeat scroll 0% 50%;
  display: block;
  height: 1%;
  color: #ffffff;
  text-decoration: none;
}
#menuDeroulant li a:hover {
  background-color: #f2462e;
}
#menuDeroulant li a:active {
  background-color: #5f879d;
}
#menuDeroulant .sousMenu li a:link, #menuDeroulant .sousMenu li a:visited {
  border:  none;
  margin: 0;
  background: transparent url(fondTR.png) repeat scroll 0% 50%;
  display: block;
  color: #ffffff;
  text-decoration: none;
}
#menuDeroulant .sousMenu li a:hover {
  background-image: none;
  background-color: #f2462e;
}
#menuDeroulant .sousMenu li {
  border-style: solid solid none none;
  border-color: transparent transparent -moz-use-text-color -moz-use-text-color;
  border-width: 1px 1px 0 0;
  margin: 0;
  padding: 0;
  float: none;
  width: 149px;
}
#menuDeroulant li:hover > .sousMenu {
  display: block;
}

  </style>
</head><body>
<ul id="menuDeroulant">

  <li> <a href="#">club</a>
    <ul class="sousMenu">
      <li><a href="#">lien1</a>
</li>
      <li><a href="#">lien2</a>
</li>
      <li><a href="#">lien3</a>
</li>
    </ul>
  </li>
  <li> <a href="#">téléchargements</a>
    <ul class="sousMenu">
      <li><a href="#">lien1</a>
</li>
      <li><a href="#">lien2</a>
</li>
      <li><a href="#">lien3</a>
</li>
      <li><a href="#">lien4</a>
</li>
      <li><a href="#">lien5</a>
</li>
    </ul>
  </li>
  <li> <a href="#">liens</a>
    <ul class="sousMenu">
      <li><a href="#">lien1</a>
      </li>
      <li><a href="#">lien2</a>
      </li>
      <li><a href="#">lien3</a> </li>
    </ul>
  </li>
  <li> <a href="#">album photos</a>
    <ul class="sousMenu">
      <li><a href="#">ien1</a>
      </li>
      <li><a href="#">lien2</a>
      </li>
      <li><a href="#">lien3</a>
      </li>
      <li><a href="#">lien4</a>
      </li>
      <li><a href="#">lien5</a></li>
    </ul>
  </li>
</ul>


</body></html>
si je fais un passage par l'onglet "source", il est ajouté un <br> après chauqe balise fermante </a>, ce qui donne:

Code : Tout sélectionner

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="content-type">
<title>essaimenu</title>
<style type="text/css">
#menuDeroulant {
border: none;
margin: 0 auto;
padding: 0;
width: 600px;
text-align: center;
list-style-type: none;
position: relative;
}
#menuDeroulant li {
border: none;
margin: 0;
padding: 0;
float: left;
}
#menuDeroulant .sousMenu {
border: none;
margin: 0;
padding: 0;
display: none;
list-style-type: none;
background-color: #cccccc;
}
#menuDeroulant .sousMenu li {
border: none;
margin: 0;
padding: 0;
float: none;
}
#menuDeroulant li {
border: none;
margin: 0;
padding: 0;
float: left;
width: 150px;
}
#menuDeroulant li a:link, #menuDeroulant li a:visited {
border-right: 1px solid #ffffff;
margin: 0;
padding: 4px 8px;
background: #3b4e77 none repeat scroll 0% 50%;
display: block;
height: 1%;
color: #ffffff;
text-decoration: none;
}
#menuDeroulant li a:hover {
background-color: #f2462e;
}
#menuDeroulant li a:active {
background-color: #5f879d;
}
#menuDeroulant .sousMenu li a:link, #menuDeroulant .sousMenu li a:visited {
border: none;
margin: 0;
background: transparent url(fondTR.png) repeat scroll 0% 50%;
display: block;
color: #ffffff;
text-decoration: none;
}
#menuDeroulant .sousMenu li a:hover {
background-image: none;
background-color: #f2462e;
}
#menuDeroulant .sousMenu li {
border-style: solid solid none none;
border-color: transparent transparent -moz-use-text-color -moz-use-text-color;
border-width: 1px 1px 0 0;
margin: 0;
padding: 0;
float: none;
width: 149px;
}
#menuDeroulant li:hover > .sousMenu {
display: block;
}

</style>
</head>
<body>
<ul id="menuDeroulant">
<li> <a href="#">club</a>
<ul class="sousMenu">
<li><a href="#">lien1</a>
<br>
</li>
<li><a href="#">lien2</a>
<br>
</li>
<li><a href="#">lien3</a>
<br>
</li>
</ul>
</li>
<li> <a href="#">téléchargements</a>
<ul class="sousMenu">
<li><a href="#">lien1</a>
<br>
</li>
<li><a href="#">lien2</a>
<br>
</li>
<li><a href="#">lien3</a>
<br>
</li>
<li><a href="#">lien4</a>
<br>
</li>
<li><a href="#">lien5</a>
<br>
</li>
</ul>
</li>
<li> <a href="#">liens</a>
<ul class="sousMenu">
<li><a href="#">lien1</a> <br>
</li>
<li><a href="#">lien2</a> <br>
</li>
<li><a href="#">lien3</a> <br>
</li>
</ul>
</li>
<li> <a href="#">album photos</a>
<ul class="sousMenu">
<li><a href="#">ien1</a> <br>
</li>
<li><a href="#">lien2</a> <br>
</li>
<li><a href="#">lien3</a> <br>
</li>
<li><a href="#">lien4</a> <br>
</li>
<li><a href="#">lien5</a><br>
</li>
</ul>
</li>
</ul>
</body>
</html>


je n'arrive pas à reproduire, mais tout à l'heure, j'ai même eu un 2eme <br> qui est venu à la suite du premier pour chaque item du menu.
Why?
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 12 sept. 2009, 12:42

Bonjour
Je ne puis que confirmer et regretter cette intrusion de <br>.
Dans le même ordre d'idées, il semble impossible de démarrer un nouveau paragraphe quand on est dans une structure de paragraphe.
A la place, on a... deux <br> pour le passage à la ligne.
Cela oblige à passer en code juste pour démarrer un nouveau paragraphe: supprimer les <br>, fermer la balise </p> et ouvrir une nouvelle balise <p>.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 12 sept. 2009, 13:11

Couper/copier/coller/ Delete dans la vue split

Dans la vue split, je sélectionne une structure (un tableau, par exemple).
Ctrl+x (ou même Delete) => la structure disparaît de la vue split mais reste visible dans la vue Normale (le haut de l'écran)
Ctrl+Enter pour confirmer les modifications, la structure revient dans la vue split
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 12 sept. 2009, 17:21

Fin de ligne fantôme ?

Dans une page (onglet split ou code), je colle -par hasard- le code suivant:

Code : Tout sélectionner

<p>Quel serait le plus grand nombre qu'il serait possible de déposer dans <strong>une
série de deux octets</strong>?</p
Placer le curseur en début de ligne: touche "Home". Bien sûr.
Placer le curseur en fin de ligne: touche "End". Pensez-vous?
Ou bien si ce n'est que chez moi que le curseur s'arrête devant le point d'interrogation final?

Encore un coup d'une vraie fausse balise XML ?
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 12 sept. 2009, 17:49

Bloc actif

Sympa, la fonction qui permet de voir le bloc actuellement actif, entouré par un filet pointillé.
Mais sans que je puisse reproduire le phénomène, il arrive assez fréquemment que le texte HTML se trouve muni des directives de style correspondantes

Code : Tout sélectionner

outline-color: navy ! important;
outline-style: dashed ! important;
outline-width: 2px ! important;
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Ymai
Tyrannosaurus Rex
Messages : 4212
Enregistré le : 12 mars 2005, 11:36

Re: KompoZer 0.8 alpha4

Message par Ymai » 30 sept. 2009, 12:35

Document de base

Code : Tout sélectionner

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="content-type">
<title></title>
</head>
<body>
<p>petit test</p>
</body>
</html>
Alt+Enter pour entrer dans le dock.
Je sélectionne l'ensemble du code du document (qui se résume à une ligne) et je le supprime (Delete).
Alt+Enter pour sortir de l'édition du bloc et, miracle, le texte effacé revient...
Seule solution: laisser quelque chose dans le dock.

Deuxième découverte du jour, aucun rapport avec la première
Code source de départ:

Code : Tout sélectionner

<p>1. petit test</p>
<br>
<p>2. petit test</p>
Dans l'onglet "Design":
Effacer la premier ligne. Tout va bien
Effacer le <br />. Tout semble aller bien, mais... la dernière ligne a perdu son statut de <paragraphe>.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Do-IT
Iguane
Messages : 537
Enregistré le : 03 juil. 2005, 09:46

Re: KompoZer 0.8 alpha4

Message par Do-IT » 07 oct. 2009, 21:24

Rev178.
Sur 5 comptes ftp, un seul fonctionne. Je ne sais pas pourquoi. La console ftp n'est pas assez detaillée. T'as eu aucun soucis ?
Le sftp via ssh est absolument indispensable, c'est prévu ?
Un bouton de test de connexion serait le bienvenu dans le gestionnaire de site. Et éventuellement la possibilité en décochant une case de voir le mot de passe qu'on tape en clair.
Redhat, CentOs, Mandriva, Ubuntu au boulot. Ubuntu à la maison. Vista et Xp grâce à la vente liée.
Soutenir KompoZer

buddleia
Arias
Messages : 1
Enregistré le : 08 oct. 2009, 10:29

Re: KompoZer 0.8 alpha4

Message par buddleia » 08 oct. 2009, 11:14

bonjour,
Je suis nouveau sur ce forum.
ma config dell inspiron 9300 1 go de ram
ubuntu 9.04
kompozer 1:0.8~alpha4+dfsg+svm163-2
Je lance kompozer dans un teminal, pas d'erreur, mais il ne lance pas.
Avec sudo kompozer j'ai le message suivant : Alerte, le fichier /res/hiddenWindow.html n'a pu être trouvé etc..
Après vérification ce fichier il est bien présent.
Si dans le path du profile.ini (./kompozer) j'indique le chemin de ce fichier, l'arlerte disparait mais kompozer ne se lance tujours pas.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités