Les gens ne voient pas les images sur mon site web

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, bobo

Avatar de l’utilisateur
Flore
Administratrice
Messages : 3556
Inscription : 19 nov. 2003, 23:04
Localisation : Lyon

Message par Flore » 21 juin 2005, 09:53

Anonymous a écrit :ce que je ne comprends pas, c'est qu'avec ma premiere methode, ça marchait dans internet explorer et pas avec mozilla :?: :?: :?:
Parce qu'IE mélange allègrement les contenus locaux et distants... Tu crois que c'est bon et en fait non...
C'est pas le pire de ses bugs, cependant :roll:
Flore
iMac - Mac OSX + Nightly / Laptop Linux Mint + Nightly / Z3C FirefoxOS

Avatar de l’utilisateur
gwenael_2
Arias
Messages : 12
Inscription : 21 juin 2005, 09:17
Contact :

Message par gwenael_2 » 21 juin 2005, 23:47

haaaaaa!!!!!! ok, ou les tricheurs alors !!!! bon de toute façon je me suis acharnée car je suis tetue, faut que ça marche !!!!! apres multes recherches et essais, j'ai enfin compris une chose.

j'heberge mes images sur image shack, ensuite dans nvu, dans "emplacement de l'image", je mets l'adresse de l'url de mon image hebergée.
CA MARCHE!!!! :P et comme ça je n'est meme plus besoin d'importer mes images avec ma page html, et je vois toutes mes images :D c'est cool :wink:

voila j'ai trouvé comment faire :lol: suis contente :lol:

a bientôt :wink:

PS: au fait c'etait moi l'invitée du dessus, j'avais oublié de m'inscrire !!! :oops: j'ai pas de tete lol :D

merci pour tout et bonne journée :D

Invité

Message par Invité » 26 juin 2005, 17:27

On les voie mes images :?: j'aimerais !! lien : http://trucsastucesmsn.ifrance.com

Avatar de l’utilisateur
Humpfff
Tyrannosaurus Rex
Messages : 2451
Inscription : 05 avr. 2004, 13:23
Localisation : Paris même

Message par Humpfff » 26 juin 2005, 17:41

On ne les voit pas parce ce chemin ne doit pas être le bon.
../../Mes%20documents/Mes%20images/dd.gif"

Invité

Message par Invité » 26 juin 2005, 20:17

et je vais ou pour modifier le chemin ??

Avatar de l’utilisateur
Humpfff
Tyrannosaurus Rex
Messages : 2451
Inscription : 05 avr. 2004, 13:23
Localisation : Paris même

Message par Humpfff » 26 juin 2005, 21:07

lis ou relis attentivement les premiers messages de ce sujet.

Invité

Message par Invité » 26 juin 2005, 21:11

ok je vais le faire mais c'est jsute pour te dire que limage " dd " je lai téléchargé sur internet et que la case " L'url est relative a l'emplacement de la page " est coché. Voila ...

Avatar de l’utilisateur
gwenael_2
Arias
Messages : 12
Inscription : 21 juin 2005, 09:17
Contact :

Message par gwenael_2 » 27 juin 2005, 15:54

ben ????? :?: :?: :?: c'est pas clair ce que j'ai expliqué?? :shock:

au lieu d'aller chercher ton image avec le bouton parcourir sur ton ordi, tu heberge ton image (par ex, chez image shack) et tu met l'url (ou adresse) de l'image.voiloa c'est pas plus compliquer en faite.

tu prends rien dans ton pc, juste des adresse url d'image !!!! et pareil pour le fond, tu met l'adresse url, tu va pas dans ton pc avec le bouton parcourir, voila invité :wink:

clic sur ma banniere en bas et regarde tu vois bien toute les images :wink:
j'ai rien importé de mon pc, juste des adresse url d'image hebergée :wink:
Image

Invité

Message par Invité » 27 juin 2005, 19:29

oko merci , masi ça va prendre du temps !! lol

Avatar de l’utilisateur
gwenael_2
Arias
Messages : 12
Inscription : 21 juin 2005, 09:17
Contact :

Message par gwenael_2 » 27 juin 2005, 20:19

lol, c'est sur, mais faire un site c'est assez long :wink:

a++ :D
Image

este

Message par este » 15 août 2005, 23:34

ou encore mieu tu les héberge sur ton site !
il devrait modifier ce probleme cher N|vu ... c'est vrai que sa m'enbete aussi d'héberger toute les images que j'utilise au lieu de prendre celle qu'il y a sur mon ordi !
...

Avatar de l’utilisateur
gwenael_2
Arias
Messages : 12
Inscription : 21 juin 2005, 09:17
Contact :

Message par gwenael_2 » 16 août 2005, 09:24

ben oui je pourais, c'est ce que j'avais fais au depard, mais j'ai remarqué que les pages s'ouvraient plus vite comme ça ;)
oui c'est vrai ça devrait etre amelioré, mais bon c'est deja bien ;)
Image

Avatar de l’utilisateur
Kazé
Varan
Messages : 1743
Inscription : 10 févr. 2005, 10:26
Localisation : Grenoble
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Kazé » 27 nov. 2005, 18:39

Flore a écrit :Dans Nvu, ai-je bien coché URL relative dans les propriétés de l'image ? Il faut avoir sauvegardé au moins une fois son fichier. Pour vérifier, il suffit de regarder le code de la page (onglet source) et si les balises <img src> sont de type "file:///c:/mes documents/mes images/monimage.jpg". le lien n'est pas bon.
L'éditeur CSS de Nvu (CaScadeS) a un gros bug : il ne propose jamais de case "cette URL est relative à la page", et toutes les URLs des feuilles de style sont transformées en URLs absolues, du style "file:///c:/mes documents/mes images/monimage.jpg".

Un cas typique du problème, c'est quand on utilise CaScadeS pour mettre une image de fond, sur la page ou sur une balise : l'URL de l'image étant convertie en URL absolue, la publication ne fonctionne pas.

Pour contourner le problème, deux solutions :
  • corriger manuellement les URLs dans le code source de la page (affichage "source") ou dans la feuille de style (avec un éditeur texte) ;
  • installer URL Cleaner, qui corrige CaScadeS et ajoute une option "relativiser les URLs locales" dans le nettoyeur de balises :
    • Image
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Jocelyne Sineau

Message par Jocelyne Sineau » 09 déc. 2005, 21:21

Pour que vos images soient vues, il faut qu'elles soient bien nommées, c'est à dire sans utilisation d'accent (Ex: ecole pour école). Les accents sur le web sont, en effet rejetés.

Il faut aussi qu'elles soient enregistrées au bon endroit, que le chemin suivi soit le bon c'est à dire qu'elles soient rangées dans le bon dossier, un dossier "images" situé dans le dossier global du site.

Il faut enfin passer par le système insertion / image. J'ai déjà vu quelqu'un essayer le copier/ coller. Cette façon de procéder ne marche pas parce que le chemin suivi de chaque élément est très important.

Bon courage

Jocelyne
Sites: http://perso.wanadoo.fr/jeunecontinent/
http://www.etab.ac-caen.fr/collegebrassens/

Avatar de l’utilisateur
Kazé
Varan
Messages : 1743
Inscription : 10 févr. 2005, 10:26
Localisation : Grenoble
Contact :

Message par Kazé » 10 déc. 2005, 10:31

Jocelyne Sineau a écrit :Les accents sur le web sont, en effet rejetés.
Plus exactement, ils sont transformés : école.jpg devient %E9cole.jpg, les espaces sont transformés en %20, etc.
Oui, il faut éviter les accents et les espaces (c'est plus joli dans la barre d'adresse, c'est plus simple dans une feuille de style), mais ça n'empêche pas les images d'être vues.
Jocelyne Sineau a écrit :Il faut enfin passer par le système insertion / image. J'ai déjà vu quelqu'un essayer le copier/ coller. Cette façon de procéder ne marche pas parce que le chemin suivi de chaque élément est très important.
:!: :?: Heureusement qu'on peut encore copier une image dans l'explorateur pour la coller dans Nvu !!!
Le copier / coller c'est bon, mangez-en ! :lol:
Evidemment, ça colle une adresse absolue, mais il suffit de double-cliquer sur l'image et de cocher la case magique "l'URL est relative à l'adresse de la page" pour la transformer en adresse relative...
KompoZer lead dev
Ubuntu 10.04 Lucid Lynx — « L'erreur est humaine, mais vraiment foutre la merde nécessite le mot de passe root. »

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités