Les gens ne voient pas les images sur mon site web

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, Ymai, bobo

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4206
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Ymai » 15 oct. 2014, 17:26

Bonjour
Je crains que le code source ci-dessus ne corresponde pas à la page d'accueil.
Dans le code source de la page d'accueil disponible en ligne, on voit que les références des images sont données sur le disque local F:
Exemple: "file:///F:/image%20clim%20modifier%20%21%21%21%21%20forme%20rectangulaire%20encadr%C3%A9e.jpg
Il est donc -heureusement- logique qu'elles n'apparaissent pas en ligne: les visiteurs du site n'ont pas accès au disque dur du PC sur lequel le site a été conçu.
Les pages html sont-elles sur le même disque? Et à la racine du disque? Auquel cas, je pense que le nettoyeur de balises de KompoZer doit pouvoir faire le travail de nettoyage des références absolues => références relatives. Sinon, quelle est la situation sur le terrain?

Une autre souci qui se profile est celui des liens vers d'autres pages. Je vois des choses comme: mentionrgeindex.html.html
La double extension .html est très certainement incorrecte. Il s'agit d'un cadeau de WinChose qui n'affiche pas toujours les extensions quand il considère que l'utilisateur est assez malin pour comprendre qu'il est possible de les cacher. Rien que pour ça déjà, bien content d'avoir rompu avec Bill Gates.
Attention donc: ne pas rajouter l'extension .html à la fin d'un nom de fichier. Elle est déjà là mais astucieusement cachée par les sbires de Mr Bill.
À remarque que cela ne vaut pas pour toutes les extensions; seules celles que Mr Bill a décidé de cacher sont invisibles. Quant à savoir lesquelles???
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 16 oct. 2014, 10:43

bonjour ymai :wink:

ha le vilain gredin de bill ,sacré bill miro ..... je retien donc de ne pas re mentionné le html . quand au file/...... j'avais bien compris ce problème la dans diférent post; tu dis le nettoyeur de balise de kompozer , ou ca ???? :?: , connait pas lui moi :shock: .

j'ai aussi découvert que j'ai mis mon dossier image ou du moins éssayer , mais avec le code image ; il s'avere aprés communication avec le cyber base de bayonne, qu'il faille mettres mes images dedans tout cours :) et non les côdes , bref j'étais partis sur la 1er option et j'aurais du m'écouter lol.

merci de ton aide et de tes réponses appréciables ymai :)
Votre Navigateur : Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.15

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4206
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Ymai » 16 oct. 2014, 12:37

Bonjour
scorames a écrit :bonjour ymai :wink:

ha le vilain gredin de bill ,sacré bill miro ..... je retien donc de ne pas re mentionné le html . quand au file/...... j'avais bien compris ce problème la dans diférent post; tu dis le nettoyeur de balise de kompozer , ou ca ???? :?: , connait pas lui moi :shock: .]
Quelques explications là: http://info.sio2.be/kpz/1/14.php
scorames a écrit : j'ai aussi découvert que j'ai mis mon dossier image ou du moins éssayer , mais avec le code image ; il s'avere aprés communication avec le cyber base de bayonne, qu'il faille mettres mes images dedans tout cours :) et non les côdes , bref j'étais partis sur la 1er option et j'aurais du m'écouter lol.

merci de ton aide et de tes réponses appréciables ymai :)
Votre Navigateur : Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.15
Là, je ne suis pas sûr d'avoir tout compris. Je relirai à tête reposée ce soir...
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 16 oct. 2014, 13:46

et me revoila ymai

j'ai trouver et cliqué sur le nettoyeur de balises, le lien que vous m'avez fournis l'explicite trés bien, lien en file /../ doivent disparaitres , ben dans le code source de ma page exploré il m'en reste, donc voici l'échantillon du dis code en l'état aprés traitement ....<a href="imagesindex.html.html"><img
style="border: 0px solid ; width: 135px; height: 121px;"
alt="MENTION R.G.E" src="file:///F:/logo_805982_web.JPG"></a></h2> :roll:

et le gros du pavé déja mentionné par vous même ymai ; src="file:///F:/image%20clim%20modifier%20%21%21%21%21%20forme%20rectangulaire%20encadr%C3%A9e.jpg"></a>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
</div>
le nettoyeur interne n'est pas extra apparement :o lol ; j'ai essayé de trouver en téléchargement url clenear sans succé cela dis ?.
ha oui aussi j'ai vue les html codé en double dans la page , donc j'ai repassé la page en revue pour éliminer l'édition html de trop .

voili voilou ou j'en suis .
Votre Navigateur : Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.15

Avatar de l’utilisateur
chinon37
Animal mythique
Messages : 5307
Inscription : 21 mars 2005, 10:17
Localisation : Touraine, entre Loire et Vienne
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par chinon37 » 16 oct. 2014, 21:26

Et si on redémarrait sur de bonnes bases?
-
scorames a écrit :euuuu chinon ! escuse la virulence de mes propos de l'autre jrs :roll: , c'était un jrs sans pour moi ,l'enfer quoi lol .
Il en faut plus pour me vexer... Par exemple, me refuser une chimay bleue alors qu'elle est à portée de main, ou une orval à 13°C...

- Pour le site: As-tu, en préalable à toute création de page, créé un dossier sur ton disque dur (nommé par exemple web) où tu enregistres toutes les pages html "fabriquées" avec KompoZer? Dans ce dossier web, as-tu créé un sous-dossier images, dans lequel tu as mis les images que tu comptes insérer dans tes pages html?
Si ce préalable n'a pas été fait, il faut passer par là pour éviter tous ces problèmes de non affichage des images, et permettre à KompoZer de mettre l'adresse relative exacte. Ainsi, ensuite, pour mettre le site en ligne, un simple glissé déposé des dossiers du disque dur vers l'hébergeur via un logiciel ftp sera suffisant. Plus besoin de mettre les mains dans le cambouis :wink:
scorames a écrit :j'ai aussi découvert que j'ai mis mon dossier image ou du moins éssayer , mais avec le code image ; il s'avere aprés communication avec le cyber base de bayonne, qu'il faille mettres mes images dedans tout cours :) et non les côdes , bref j'étais partis sur la 1er option et j'aurais du m'écouter lol.
Pô compris non plus, et trop fatigué pour réfléchir :oops:

Petit rappel: KompoZer est un logiciel wysiwyg, i.e. un logiciel intuitif où on peut presque se passer de mettre les mains dans le code, en se contentant des outils à disposition... dans un premier temps. Ensuite, lorsqu'on a compris la mécanique de ce type de logiciel, on affine.
Votre Navigateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 17 oct. 2014, 10:46

hello :)

que de questions chinon ... ben en fais je craint que non, sur mom bureau j'ai mon dossier images et mes pages html du site (crée et enregistré avec kompozer dans mes documments ) :roll:

tien ma croyance que de facto c'étais enregistré direct sur mon disque dure vole en lambos lol :mrgreen: ....

a partir d'ou je crée mes dossier pour glissées mes pages html ? (je sais je suis un boulé :mrgreen: )

bien a vous deux
Votre Navigateur : Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.15

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 22 oct. 2014, 20:34

tien pas de réponse :roll: , semblerait que vous soyez partis en vacance ! :D
Votre Navigateur : Mozilla/5.0 (Windows NT 4.10; rv:32.0) Gecko/20100101 Firefox/32.0

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 23 oct. 2014, 14:25

bonjour chinon :shock:

alors voila ; suite a ton expliquation ,je peu dire une chose , j'ai crée et nommer un fichier "index html " dans "mes documents" dedans il ya mes 9 pages du site ; es ce bien ce type de dossier dont tu me cause plus haut :?: pour qu'ils se trouvent sur le disque dure :roll: ? , si oui c'est bon, sinon ben j'ai pas compris comment faire :cry:
Votre Navigateur : Mozilla/5.0 (Windows NT 4.10; rv:32.0) Gecko/20100101 Firefox/32.0

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4206
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Ymai » 25 oct. 2014, 13:21

Bonjour
Quelques notions sur la structure que devrait/pourrait avoir un site web, y compris les notions de dossier/répertoire et fichier là:
http://info.sio2.be/kpz/1/3.php
Votre Navigateur : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

scorames
Arias
Messages : 18
Inscription : 27 sept. 2014, 09:43

Re: Les gens ne voient pas les images sur mon site web

Message par scorames » 27 oct. 2014, 20:49

merci ymai :wink:
Votre Navigateur : Mozilla/5.0 (Windows NT 4.10; rv:32.0) Gecko/20100101 Firefox/32.0

kerno
Arias
Messages : 4
Inscription : 29 oct. 2015, 10:41

Re: Les gens ne voient pas les images sur mon site web

Message par kerno » 29 oct. 2015, 11:04

Bonjour
suis nouveau, novice et nul.. je ne comprends le langage informatique bref:
j'ai cree un site avec nvu et je le modifie avec kompzer.
lorsque je veux publier la page que j'ai creee avec photos et tout... j'ai un message d'erreur: " anonymes only."..???
qu'ai mal fait ??? si qqu'un peut m'aider ce serait super...
mais avec des mots simples car je suis vraiment débutant
kerno

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4206
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Ymai » 29 oct. 2015, 11:07

Bonjour
Je pense que le problème n'est pas à chercher du côté de KompoZer ou de NVU.
Pouvons-nous avoir l'adresse à laquelle cette page est publiée?
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

Avatar de l’utilisateur
chinon37
Animal mythique
Messages : 5307
Inscription : 21 mars 2005, 10:17
Localisation : Touraine, entre Loire et Vienne
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par chinon37 » 30 oct. 2015, 15:02

Bonjour,
Pourquoi poser la question ici alors que tu l'as déjà posée dans un autre post? Une seule fois suffit.
Si tu n'as pas encore de réponse, c'est sans doute que nous sommes entrain de mélanger un peu de houblon au brassin... Chaque chose en son temps!
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité