Les gens ne voient pas les images sur mon site web

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, Ymai, bobo

Avatar de l’utilisateur
Flore
Administratrice
Messages : 3555
Inscription : 19 nov. 2003, 23:04
Localisation : Lyon

Les gens ne voient pas les images sur mon site web

Message par Flore » 08 avr. 2005, 12:10

Situation :
Je ne vois pas (ou mes amis ne voient pas) [les images/le fond d'écran] de mon site ?

Résolution :
  • Les images sont elles bien sur le serveur ?
  • Dans Nvu/KompoZer, ai-je bien coché URL relative dans les propriétés de l'image ? Il faut avoir sauvegardé au moins une fois son fichier. Pour vérifier, il suffit de regarder le code de la page (onglet source) et si les balises <img src> sont de type "file:///c:/mes documents/mes images/monimage.jpg". le lien n'est pas bon.
Dernière édition par Flore le 17 avr. 2005, 15:03, édité 1 fois.
Flore
iMac - Mac OSX + Nightly / Laptop Linux Mint + Nightly / Z3C FirefoxOS

Avatar de l’utilisateur
bobo
Iguane
Messages : 764
Inscription : 18 août 2003, 11:04
Localisation : Lyon, France
Contact :

Message par bobo » 08 avr. 2005, 13:37

Autres conseils :
  • Si vous éditez votre site en local d'abord, pensez à créer l'arborescence sur le site distant avant de publier avec les images.
  • Si vous éditez votre site depuis le gestionnnaire de sites, n'insérez pas d'images directement depuis votre disque dur directement !
    En effet, dans cette situation, Nvu utilisera un chemin absolu. Il faut d'abord télécharger l'image sur le serveur, puis glisser l'icône de l'image depuis le gestionnaire de site dans la page.
Les standards c'est bon, mangez en !
Flore & Sébastien
Unité dans la diversité.

jipé

merci de développer

Message par jipé » 24 avr. 2005, 21:06

j'ai compris la première contribution (il faut cocher...), mais pas la deuxième (créer l'arborescence, etc...) : merci, M. Bobo, de développer cette explication pour les nuls (comme moi !).

Avatar de l’utilisateur
chinon37
Animal mythique
Messages : 5307
Inscription : 21 mars 2005, 10:17
Localisation : Touraine, entre Loire et Vienne
Contact :

Message par chinon37 » 25 avr. 2005, 09:16

créer une arborescence consiste à ouvrir, à l'intérieur d'un répertoire, un certain nombre de dossiers qui recevront les fichiers nécessaires au site web:
explication:
soit un répertoire "web". à l'intérieur de ce répertoire, tu peux créer un dossier "images" qui stockera toutes les photos que tu utilises pour ton site. Tu peux aussi créer un dossier "styles" qui contiendra tes feuilles de style.
l'arborescence aura la forme suivante:
web (*répertoire*)
... /images (*dossier*)
... ... /photo.jpg (*fichier*)
... /styles (*dossier*)
... .... /style.css (*fichier*)
par exemple
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

Ludivine
Arias
Messages : 6
Inscription : 22 avr. 2005, 14:37
Contact :

Re: Les gens ne voient pas les images sur mon site web

Message par Ludivine » 26 avr. 2005, 10:23

Flore a écrit : Résolution :
  • Les images sont elles bien sur le serveur ?
  • Dans Nvu, ai-je bien coché URL relative dans les propriétés de l'image ? Il faut avoir sauvegardé au moins une fois son fichier. Pour vérifier, il suffit de regarder le code de la page (onglet source) et si les balises <img src> sont de type "file:///c:/mes documents/mes images/monimage.jpg". le lien n'est pas bon.
Je suis sur NVU j'édite ma page en mode normal j'ai fait un tableau et insérer des images. Mais mes images ne sont pas visibles pour les internautes.
Je fais propriétés de l'image
Emplacement de l'image je fais parcourir
il me met file:///C:/docsweb/gauche.jpg
s'il faut cocher l'url comment fait-on ? il faut donc mettre quoi dans emplacement de l'image ?

Merci pour votre aide
Ludivine

Avatar de l’utilisateur
chinon37
Animal mythique
Messages : 5307
Inscription : 21 mars 2005, 10:17
Localisation : Touraine, entre Loire et Vienne
Contact :

Message par chinon37 » 26 avr. 2005, 11:30

si sur le web, ton image est bien dans le dossier nommé "docsweb", il faut que tu supprime "C:/" afin de créer une adresse relative.
Si ça ne marche pas, donne l'adresse de ton site qu'on jette un coup d'oeil, ce sera plus facile pour t'aider
Préferez Kompozer 0.8 à Nvu
Défendons nos valeurs, adhérons à l'APRIL
La Démocratie, c'est quand on frappe à votre porte à 6h00 du matin, et que c'est le laitier.

Ludivine
Arias
Messages : 6
Inscription : 22 avr. 2005, 14:37
Contact :

Message par Ludivine » 27 avr. 2005, 10:15

chinon37 a écrit :si sur le web, ton image est bien dans le dossier nommé "docsweb", il faut que tu supprime "C:/" afin de créer une adresse relative.
au début il n'y avait que gauche.jpg dans emplacement de l'image mais ça n'allait pas non plus.

j'ai mis donc l'adresse de l'image http://.....gauche.jpg et là ça marche pourtant l'url est relative à l'emplacement de l'image est décoché.

je patoge mais bon !

Existe t-il un livre spécial NVU dans les grandes librairies ? FNAC etc

Merci

Ludivine

Avatar de l’utilisateur
bobo
Iguane
Messages : 764
Inscription : 18 août 2003, 11:04
Localisation : Lyon, France
Contact :

Message par bobo » 27 avr. 2005, 13:54

Ludivine a écrit :Existe t-il un livre spécial NVU dans les grandes librairies ?
Non, un tel livre reste encore à écrire.
Les standards c'est bon, mangez en !
Flore & Sébastien
Unité dans la diversité.

Avatar de l’utilisateur
Eowung
Gecko
Messages : 80
Inscription : 10 juil. 2004, 13:39
Localisation : Pas très loin de Strasbourg...

Re: Les gens ne voient pas les images sur mon site web

Message par Eowung » 27 avr. 2005, 16:47

Flore a écrit :Situation :
Je ne vois pas (ou mes amis ne voient pas) [les images/le fond d'écran] de mon site ?
Autre résolution (Je l'ai appris à mes dépends :evil:) [exclusivement pour windows]:

Verifier que le nom du fichier soit en tout point identique à celui utilisé pour le lien. En effet, si windows se montre peu regardant sur la non concordance des majuscules et des minuscules (ça marche quand je regarde mon site localement), les serveurs utilisés par les fai le sont souvent beaucoup plus. En clair : monimage.png c'est pas la même chose que Monimage.png.

simson

Help me please

Message par simson » 03 juin 2005, 09:50

Bonjours je suis nouveau sur ce forum et la je galere vraiment,cela fait maintenant presque deux mois que j'ai créer mon site avec voila (et Nvu) et les images ne s'affichent toujours pas,j'ai pourtant tout essayer,j'ai chercher sur des sites internet et tous se que l'on ma proposer n'a pas marcher.J'ai bien cocher la case de l'URL,je pense que mes lien sont les bons et je suis sur que les chemins sont les meme sur mon ordi que chez mon hebergeur,pas de majuscule ni tiret etc...
Si vous pouviez m'aider j'apprecierer vraiment.
Mon adressse MSN est disponible dans mon profil et mon site est http://site.voila.fr/powerider
Merci d'avance
Simon

Avatar de l’utilisateur
Bambou
Arias
Messages : 1
Inscription : 27 avr. 2005, 09:36
Localisation : Erezée/Wallonie
Contact :

Message par Bambou » 03 juin 2005, 11:05

Ben il fonctionne bien ton site et je peux te dire que l'on voit les photos.Félicitations, tu as fait du bon boulot, il est bien ton site.

zero prod

Message par zero prod » 04 juin 2005, 03:48

J'ai le même problème d'image... et j'ai d'autre problèmes aussi :wink: je comprend pas vraiment l'arborescence... quelqu'un pourrait-il m'expliquer ce que c'est en gros?


www.zeroprod.qc.tc

Mercurius
Salamandre
Messages : 45
Inscription : 28 mars 2005, 00:10
Localisation : Nord de France

Re: Help me please

Message par Mercurius » 04 juin 2005, 20:50

les images ne s'affichent toujours pas,j'ai pourtant tout essayer,j'ai chercher sur des sites internet et tous se que l'on ma proposer n'a pas marcher.J'ai bien cocher la case de l'URL,je pense que mes lien sont les bons et je suis sur que les chemins sont les meme sur mon ordi que chez mon hebergeur,pas de majuscule ni tiret etc...
Bonjour
J'ai observer des images sur votre site sans probléme.
Et je n'ai pas la réponse a "Pourquoi une personne exterieur arrive a observer les images et pas celle qui a créer le site"
Je profite pour une question au spécialiste.
Nvu a pour base Composeur de Mozilla ???
Merci
Ubuntu

hibou57
Gecko
Messages : 52
Inscription : 13 juin 2005, 16:55
Contact :

Message par hibou57 » 13 juin 2005, 18:09

Comment fait-on pour publier une images ? J'ai essayer avec le gestionnaire de site (copier/coller, glisser/déposer, menu contextuel), je ne vois rien qui semble le permettre. Et Nvu ne publie pas automatiquement les images que je lie à mes pages.

Invité

Message par Invité » 20 juin 2005, 22:19

bonjour a tous, je suis toute nouvelle d'aujourd'hui et j'ai telecharger nvu il y a 5 jours pour construire ma page perso sur voila.fr
j'ai telechargé une interface et c'est niquel. :D

seulement voila, je fais quelque experience car mon but serait de construir le graphisme de ma page web moi meme, malgres que je n'y connais rien :roll: mdr

j'ai donc mis un fond via mes fichier perso et une banniere, mais en les mettant comme j'ai fais pour l'autre site, pas d'image :cry: pourtant avec le avec nvu dans navigateur, j'avais bien les images, j'utilise mozilla et je peux vous dire que par contre mes images se voyais dans IE donc j'ai lu vos post, j'ai essayé de remplacer file...etc par l'adresse url des images que j'avais deja mis sur le site, rien :cry: donc j'ai essayé l'autre methode en faisant glisser les images dans nvu, par contre pour le fond ça marche pas :cry: et toujourd rien, j'ai donc arreté pour le fond, j'ai fais un glissé avec la banniere et la eureka !!! ça marche.

ce que je ne comprends pas, c'est qu'avec ma premiere methode, ça marchait dans internet explorer et pas avec mozilla :?: :?: :?:

comment inserer une image grace a un lien sans devoir modifier dans la page "source" ?

je suis nulle ou plutôt tres novice, et j'avous ne pas tout comprendre dans ce que j'ai lu :shock: :oops:

a bientôt :D

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité