PB installation sous Linux

Le premier forum francophone sur l'éditeur de pages Web multiplateforme (Linux, Mac OS X, Windows) qui monte… KompoZer, héritier de Nvu, permet de créer vos pages Web graphiquement (wysiwyg) sans aucune connaissance du langage HTML.

Modérateurs : chinon37, Kazé, Ymai, bobo

TV
Salamandre
Messages : 27
Inscription : 06 mai 2006, 18:22
Localisation : La Rochelle
Contact :

PB installation sous Linux

Message par TV » 18 nov. 2015, 17:18

Bonjour,

J'ai fait des recherches mais n'ai rien trouvé sauf "on télécharge, on extrait et c'est prêt".
J'ai téléchargé kompozer-0.8b3.fr.gcc4.2-i686.tar.gz
J'ai extrait le paquet.
J'ai bien un fichier Kompozer dans le dossier mais impossible de lancer le programme. Quand je clique le fichier s'ouvre dans Gedit (éditeur de texte), c'est vrai pour toutes les autres applications du dossier. J'ai essayé aussi sh en ligne de commande. Ceci sous Trisquel et sous LinuxMint. Pas de problème sous Windows, c'est rageant.

Si vous avez une idée, merci d'avance
Librement
Thierry Vedel
TV
Sous Trisquel
Membre de l'APRIL
Je soutiens Framasoft.

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4208
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: PB installation sous Linux

Message par Ymai » 20 nov. 2015, 18:26

Bonjour
Le fichier "kompozer" est-il exécutable?

Code : Tout sélectionner

$ chmod u+x kompozer
$ ./kompozer
devrait le faire.
Attention au fait que certaines dépendances sont tout à fait obsolètes. Une refonte complète du programme serait nécessaire pour le rendre à nouveau fonctionnel sur certaines distributions, y compris les plus populaires.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

TV
Salamandre
Messages : 27
Inscription : 06 mai 2006, 18:22
Localisation : La Rochelle
Contact :

Re: PB installation sous Linux

Message par TV » 20 nov. 2015, 19:31

Bonjour Ymai,

Kompozer est exécutable. j'ai fait la manip mais aucun effet.
J'ai extrait Kompozer...tar.gz dans home/logiciels et je pense qu'il devrait être dans etc ou autre. Qu'en pensez-vous ?
TV
Sous Trisquel
Membre de l'APRIL
Je soutiens Framasoft.

Avatar de l’utilisateur
Ymai
Tyrannosaurus Rex
Messages : 4208
Inscription : 12 mars 2005, 11:36
Localisation : Brüsel - Les Cités Obscures
Contact :

Re: PB installation sous Linux

Message par Ymai » 21 nov. 2015, 09:54

Bonjour
TV a écrit : Qu'en pensez-vous ?
Aucune importance.
Et, comme précisé sur https://trisquel.info/fr/forum/pb-insta ... e-kompozer , le paquet libmozjs.so n'existe plus. Donc, peu de chance que Kpz puisse fonctionner.
ymai
« Un enfant de cinq ans comprendrait cela ! Allez me chercher un enfant de cinq ans ! »
Groucho Marx.

TV
Salamandre
Messages : 27
Inscription : 06 mai 2006, 18:22
Localisation : La Rochelle
Contact :

[Résolu] PB installation sous Linux

Message par TV » 21 nov. 2015, 10:49

Bonjour,

J'ai ajouté le dépôt : deb http://fr.archive.trisquel.info/trisquel toutatis main
J'ai rechargé.
J'ai trouvé les paquets kompozer et kompozer-data dans Synaptic.
J'ai installé.
Ca marche.
Je ne sais pas si ce dépôt " fonctionne " pour d'autres distributions autres que Trisquel.

Pour info. Le paquet lbmozjs.so est dans le dossier kompozer si on télécharge et extrait.

Le lien est un fil que j'ai ouvert sur Trisquel.

Merci encore
Thierry
TV
Sous Trisquel
Membre de l'APRIL
Je soutiens Framasoft.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité