[Résolu] Seamonkey n'aime pas les favicônes...

Vous cherchez une solution complète et libre ? La curiosité vous presse de poser des questions sur SeaMonkey (successeur de la suite Mozilla), et vous ne parvenez pas à trouver de réponses ? Venez ici, et trouvez votre bonheur.

Modérateur : Mori

Répondre
La Luciole
Iguane
Messages : 578
Enregistré le : 25 déc. 2005, 21:58
Localisation : Golfe-Juan (Alpes-Maritimes-06)

[Résolu] Seamonkey n'aime pas les favicônes...

Message par La Luciole » 12 juin 2007, 22:08

Bonsoir à tous...
Y a t-il une astuce pour que Seamonkey affiche les favicônes dans les marque-pages et dans la barre d'adresse ?
Merci.


Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2
Modifié en dernier par La Luciole le 13 juil. 2007, 14:03, modifié 1 fois.

myahoo
Animal mythique
Messages : 7946
Enregistré le : 02 sept. 2005, 00:13

Message par myahoo » 13 juin 2007, 00:50

Pour Firefox on a bien Favicon Picker : il semblerait prêt à être accepté par SeaMonkey, mais il faudrait forcer la compatibilité.
Je ne sais plus trop comment cela se règle, mais certainement un histoire de fichier .jar :?

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Philippe-Pierre
Lézard à collerette
Messages : 475
Enregistré le : 29 août 2006, 19:58

Message par Philippe-Pierre » 16 juin 2007, 11:39

Si tu mets les valeurs de :

Code : Tout sélectionner

browser.chrome.favicons
et

Code : Tout sélectionner

browser.chrome.site_icon
à "true", ça n'a pas cet effet ? Je ne me souviens plus au juste, mais il me semble que ça vaut d'être essayé.

(saisir "about:config" dans la barre d'adresse pour accéder à la configuration de SM, puis par exemple "icon" dans la barre de recherche pour trouver les chaînes qui nous intéressent).

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5pre) Gecko/20070604 Firefox/2.0.0.4 Navigator/9.0b1
Cordialement,

Philippe
----
* Dedicated to software which sucks less ... http://suckless.org/

La Luciole
Iguane
Messages : 578
Enregistré le : 25 déc. 2005, 21:58
Localisation : Golfe-Juan (Alpes-Maritimes-06)

Message par La Luciole » 16 juin 2007, 12:52

Philippe-Pierre a écrit :Si tu mets les valeurs de :

Code : Tout sélectionner

browser.chrome.favicons
et

Code : Tout sélectionner

browser.chrome.site_icon
à "true"
ça marche pour la barre d'adresse et l'entête des onglets si les deux valeurs sont à "true".... :)

ça ne marche pas pour les marque-pages... :(

Merci.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2

Mc Gyver
Gecko
Messages : 65
Enregistré le : 16 févr. 2005, 13:03
Localisation : Sud-Ouest

Message par Mc Gyver » 13 juil. 2007, 11:15

Bonjour,

C.f. cette discussion sur le forum de Mozillazine en anglais :
http://forums.mozillazine.org/viewtopic ... 5f9df82f70

Pour faire apparaitre les favicons
taper dans la barre d'adresse

Code : Tout sélectionner

about:config
et mettre la valeur 2 à l'option

Code : Tout sélectionner

browser.chrome.load_toolbar_icons
.

En revanche, il ne faut pas toucher à l'option

Code : Tout sélectionner

browser.chrome.favicons
et la laisser sur

Code : Tout sélectionner

false
.

L'explication est donné dans la discussion citée ci dessus :
Please turn browser.chrome.favicons back off. It enables discouraged behaviour, namely making the browser look for favicon.ico on every site's root directory. Example: www.example.com/favicon.ico

The other setting, browser.chrome.load_toolbar_icons, is all you need.
Bonne journée.

Tchô

Message envoyé avec : Mozilla/5.0 (Windows; U; WinNT4.0; fr-FR; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2
En premier lieu "Rechercher",
Puis le problème envolé,
N'oubliez pas d'éditer,
Afin d'apparaitre "Réglé",
C'est tellement plus gai.
Soyez-en remercié.

La Luciole
Iguane
Messages : 578
Enregistré le : 25 déc. 2005, 21:58
Localisation : Golfe-Juan (Alpes-Maritimes-06)

Message par La Luciole » 13 juil. 2007, 14:02

GENIAL !!
Merci...
:)


Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)

Mc Gyver
Gecko
Messages : 65
Enregistré le : 16 févr. 2005, 13:03
Localisation : Sud-Ouest

Message par Mc Gyver » 13 juil. 2007, 17:26

De rien,

Et merci à toi d'avoir édité ton post.

Par contre si qq'un sait traduire la raison pour laquelle il ne faut pas toucher à browser.chrome.favicons passque j'ai rine compris à l'anglais.


Merci et bonne journée.

Message envoyé avec : Mozilla/5.0 (Windows; U; WinNT4.0; fr-FR; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2
En premier lieu "Rechercher",
Puis le problème envolé,
N'oubliez pas d'éditer,
Afin d'apparaitre "Réglé",
C'est tellement plus gai.
Soyez-en remercié.

Xanthor
Lézard à collerette
Messages : 280
Enregistré le : 29 juil. 2003, 18:36
Localisation : Fr
Contact :

Message par Xanthor » 06 août 2007, 17:22

Car avec cette option, le navigateur va faire une requête inutile pour chaque page que tu ouvriras (entrainant un comportement hautement polluant, aussi bien pour le réseau que pour le serveur).

Avatar du membre
Mori
Animal mythique
Messages : 13293
Enregistré le : 30 avr. 2004, 19:17
Localisation : >:)°

Message par Mori » 07 août 2007, 12:53

salut,

sympa, ces astuces, j'ai désactivé les ~icon~ dans ff ... on peut avoir un gain (théorique) en vitesse de surf sensible ou pas dans ce cas de figure ?
Linux ubuntu MATE 18.04 (x86_64)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités